Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
26.10.2021, 13:53:25

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 759706
  • Themen insgesamt: 61032
  • Heute online: 542
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  vnc Server hört nach Installation nur auf IPV6 Verbindungen und localhost  (Gelesen 720 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo zusammen,

nach einem beherztem,
sudo apt install tigervnc-standalone-serverund dem starten des selben
vncserver...kann ich mich leider nicht von einem VNC Client auf meinen Rechner verbinden.

Der VNC Server läuft -
vncserver -list

TigerVNC server sessions:

X DISPLAY # RFB PORT # PROCESS ID
:1 5901 106233
hört aber wohl nur auf _tcp6_
netstat -ano | grep "5901"
tcp        0      0 127.0.0.1:5901          0.0.0.0:*               LISTEN      aus (0.00/0/0)
tcp6       0      0 ::1:5901                :::*                    LISTEN      aus (0.00/0/0)

Was mache ich den da falsch?

CU Thomas
« Letzte Änderung: 06.09.2021, 16:27:29 von Thomas, DL3NGN »

thebookkeeper

  • aka AnanasDampf
  • *****
Bei Dir Port 5901 für TigerVNC - bei mir Port 5900 für X11VNC. Router-Firewall oder Ufw müssen für diese Ports geöffnet sein:
thebookkeeper@Dell-DV051:~$ sudo ufw status verbose
Status: Aktiv
Protokollierung: on (low)
Voreinstellung: deny (eingehend), allow (abgehend), disabled (gesendet)
Neue Profile: skip

Zu                         Aktion      Von
--                         ------      ---
5060/udp                   ALLOW IN    Anywhere                 
1720/tcp                   ALLOW IN    Anywhere                 
39275/udp                  ALLOW IN    Anywhere                 
5900/tcp                   ALLOW IN    Anywhere                 
22/tcp                     ALLOW IN    Anywhere                 

thebookkeeper@Dell-DV051:~$
https://wiki.ubuntuusers.de/VNC/:
Zitat
... Beim traditionellen Weg lauscht der VNC-Server auf TCP-Port 5900 ...
« Letzte Änderung: 02.09.2021, 22:57:50 von thebookkeeper »

Guten Morgen,

wenn Du noch mal schaust, was ich oben gepostet habe, dann ist das Problem, das der VNC Server auf 127.0.0.1:5901 (nicht 5900 absolut richtig) hört, aber eben sonst nicht auf 192.168.x.y tcp - tcp6 sieht das anders aus.

Die Frage, die sich mir stellt, warum läßt der VNC Server eine externen (nicht localhost) Verbindungen auf tcp zu?

Oder habe ich jetzt Deine Antwort nicht verstanden?

Grüße Thomas

Also so wie ich das sehe, hört dein Service NUR auf localhost. Sowohl der localhost IPv4 als auch localhost IPv6. Er lauscht auf keiner anderen Adresse. Evtl stimmen Regeln in der Firewall nicht oder die config.

Jetzt gehen wir mal davon aus, dass die Config nicht stimmt und oder die Firewall - welche Files müssen wie aussehen?

MfG Thomas

thebookkeeper

  • aka AnanasDampf
  • *****
... wenn Du noch mal schaust, was ich oben gepostet habe, dann ist das Problem, das der VNC Server auf 127.0.0.1:5901 (nicht 5900 absolut richtig) hört, aber eben sonst nicht auf 192.168.x.y tcp - tcp6 sieht das anders aus ...
Ja, das müsste eigentlich so ähnlich aussehen:
thebookkeeper@Dell-DV051:~$ sudo netstat -tulpen | grep "5900"
tcp        0      0 0.0.0.0:5900            0.0.0.0:*               LISTEN      0          35961      1350/x11vnc         
tcp6       0      0 :::5900                 :::*                    LISTEN      0          35962      1350/x11vnc         
thebookkeeper@Dell-DV051:~$

Off-Topic:
Ich hab damals auch andere VNC-Varianten getestet und hatte gute Gründe, warum ich mich für x11vnc entschied. Das war mit etwas Aufwand verbunden, siehe Anleitung per PDF-Anhangdatei. Und dieser Beitrag hat mich daran erinnert, dass SSH-Port22 nicht freigeschaltet war.
« Letzte Änderung: 02.09.2021, 23:01:40 von thebookkeeper »

Hallo und guten Morgen,

danke für das PDF - ich komme leider nur bis zur Stelle:
thomas@Uberuix:~$ sudo x11vnc -storepasswd t8nndhow /etc/x11vnc.pass
stored passwd in file: /etc/x11vnc.pass
thomas@Uberuix:~$ sudo gedit /lib/systemd/system/x11vnc.servicenano
sudo: gedit: Befehl nicht gefunden
thomas@Uberuix:~$ sudo nano /lib/systemd/system/x11vnc.servicenano
thomas@Uberuix:~$ echo „Configure Services“
„Configure Services“
thomas@Uberuix:~$ sudo systemctl enable x11vnc.service
Failed to enable unit: Unit file x11vnc.service does not exist.

...kann es sein, dass ich die Rechte von /lib/systemd/system/x11vnc.servicenano noch anpassen muß?
-rw-r--r-- 1 root root  247 Sep  3 10:11  x11vnc.servicenano
Wenn ich den Zugriff nur lokal machen will, kann ich mir das ssh-Putty-Zeug sparen?

Grüße Thomas

thebookkeeper

  • aka AnanasDampf
  • *****
thebookkeeper@Dell-DV051:~$ cat /lib/systemd/system/x11vnc.service
[Unit]
Description=Start x11vnc at startup.
After=multi-user.target

[Service]
Type=simple
ExecStart=/usr/bin/x11vnc -viewonly -auth guess -forever -loop -noxdamage -repeat -rfbauth /etc/x11vnc.pass -rfbport 5900 -shared

[Install]
WantedBy=multi-user.target
thebookkeeper@Dell-DV051:~$
Die Datei heißt x11vnc.service, aktuell bei mir dort viewonly-Option aktiviert.
SSH ist gut und funktionierte auch per Wlan-Zugriff mit Handy-App.

Off-Topic:
...
thomas@Uberuix:~$ sudo x11vnc -storepasswd t8nndhow /etc/x11vnc.pass
stored passwd in file: /etc/x11vnc.pass
...

Vielleicht sollte man das wiederholen mit nicht-öffentlichen Passwort :-)

Und wenn x11vnc läuft, sieht sein Status beispielsweise so aus:
thebookkeeper@Dell-DV051:~$ sudo systemctl status x11vnc
● x11vnc.service - Start x11vnc at startup.
   Loaded: loaded (/lib/systemd/system/x11vnc.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2021-09-03 23:34:34 CEST; 1h 15min ago
 Main PID: 1290 (x11vnc)
    Tasks: 2 (limit: 4635)
   CGroup: /system.slice/x11vnc.service
           ├─1290 /usr/bin/x11vnc -viewonly -auth guess -forever -loop -noxdamage -repeat -rfbauth /etc/x11vnc.pass -rfbport 5900 -shared
           └─1321 /usr/bin/x11vnc -viewonly -auth guess -forever -loop -noxdamage -repeat -rfbauth /etc/x11vnc.pass -rfbport 5900 -shared
...
« Letzte Änderung: 04.09.2021, 01:39:36 von thebookkeeper »

Danke für den Hinweis, natrürlich sind das exakt die PW die ich auch z.B. hier im Forum zu Anmeldung verwendet habe...

Wie es aussehen soll ist klar, aber was mache ich, wenn es eben, wie oben beschrieben nicht funktioniert? Wie gesagt, ich bin zu doof den Service einzurichten, kannst Du mir da weiterhelfen?

Danke und ein schönes Wochenende!
Grüße Thomas

thebookkeeper

  • aka AnanasDampf
  • *****
Du kannst die Anhang-Datei entpacken nach: /lib/systemd/system/
(in diesem Ordner brauchst Du Root-Rechte)
Danach fehlen noch folgende Terminal-Befehle, nacheinander:
echo „Configure Services“
sudo systemctl enable x11vnc.service
sudo systemctl daemon-reload
sleep 5s
sudo shutdown -r now

Dass die Anleitung doppelt - deutsch und englisch ist, verwirrt evtl.

...habe den Fehler gefunden - bin halt doch doof.

wenn ich einen Service erstelle, der x11vnc.servicenano heißt, ist das wohl ehr deppert den Service mit x11vncservice starten zu wollen :-(

PW sind geändert, vielen Dank! Ich komme wieder wenn ich mich wieder dumm stelle.
Bis dahin,
Grüße Thomas