Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
05.03.2021, 11:39:38

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 719932
  • Themen insgesamt: 58218
  • Heute online: 671
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Linux Mint 12: ATI Treiber lässt sich nicht installieren (Kernel 3.4.0 RC3)  (Gelesen 4214 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Ampel

  • Gast
Hallo Leute

Ich bin seit ein paar  Tagen dran irgendwie den ATI  Treiber  für meine Grafikkarte korrekt ans Laufen zu bekommen ,da ich gerne das eine oder andere Game  Zocken möchte. Leider werden dort Open GL Treiber benötigt ,Jedoch bietet der Standard Treiber für  AMD/ATI Grafikkarten keine an. Der Versuch  den Treiber direkt zu Installieren schlug fehl ,da die Meldung kommt :



In der Datei Jockey.log kann man  schön Nachvollziehen das der Treiber nicht Existiert :

 
2012-04-22 09:49:59,421 WARNING: modinfo for module fglrx failed: ERROR: modinfo: could not find module fglrx

2012-04-22 09:49:59,422 WARNING: /sys/module/fglrx/drivers does not exist, cannot rebind fglrx driver
2012-04-22 09:49:59,423 ERROR: XorgDriverHandler.enable(): package or module not installed, aborting
2012-04-22 09:50:27,398 DEBUG: fglrx.enabled(fglrx): target_alt /usr/lib/fglrx/ld.so.conf current_alt /usr/lib/fglrx/ld.so.conf other target alt /usr/lib/fglrx/alt_ld.so.conf other current alt /usr/lib/fglrx/alt_ld.so.conf
2012-04-22 09:50:27,398 DEBUG: XorgDriverHandler(%s, %s).enabled(): No X.org driver set, not checking
2012-04-22 09:50:27,458 DEBUG: fglrx.enabled(fglrx): target_alt /usr/lib/fglrx/ld.so.conf current_alt /usr/lib/fglrx/ld.so.conf other target alt /usr/lib/fglrx/alt_ld.so.conf other current alt /usr/lib/fglrx/alt_ld.so.conf
2012-04-22 09:50:27,458 DEBUG: XorgDriverHandler(%s, %s).enabled(): No X.org driver set, not checking
2012-04-22 09:53:37,626 DEBUG: fglrx.enabled(fglrx_updates): target_alt None current_alt /usr/lib/fglrx/ld.so.conf other target alt None other current alt /usr/lib/fglrx/alt_ld.so.conf
2012-04-22 09:53:37,626 DEBUG: fglrx_updates is not the alternative in use
2012-04-22 09:53:37,692 DEBUG: fglrx.enabled(fglrx_updates): target_alt None current_alt /usr/lib/fglrx/ld.so.conf other target alt None other current alt /usr/lib/fglrx/alt_ld.so.conf
2012-04-22 09:53:37,693 DEBUG: fglrx_updates is not the alternative in use
2012-04-22 09:53:37,800 DEBUG: fglrx.enabled(fglrx): target_alt /usr/lib/fglrx/ld.so.conf current_alt /usr/lib/fglrx/ld.so.conf other target alt /usr/lib/fglrx/alt_ld.so.conf other current alt /usr/lib/fglrx/alt_ld.so.conf
2012-04-22 09:53:37,801 DEBUG: XorgDriverHandler(%s, %s).enabled(): No X.org driver set, not checking
2012-04-22 09:53:37,859 DEBUG: fglrx.enabled(fglrx): target_alt /usr/lib/fglrx/ld.so.conf current_alt /usr/lib/fglrx/ld.so.conf other target alt /usr/lib/fglrx/alt_ld.so.conf other current alt /usr/lib/fglrx/alt_ld.so.conf
2012-04-22 09:53:37,860 DEBUG: XorgDriverHandler(%s, %s).enabled(): No X.org driver set, not checking
2012-04-22 09:53:37,980 DEBUG: fglrx.enabled(fglrx): target_alt /usr/lib/fglrx/ld.so.conf current_alt /usr/lib/fglrx/ld.so.conf other target alt /usr/lib/fglrx/alt_ld.so.conf other current alt /usr/lib/fglrx/alt_ld.so.conf
2012-04-22 09:53:37,980 DEBUG: XorgDriverHandler(%s, %s).enabled(): No X.org driver set, not checking
2012-04-22 09:53:38,042 DEBUG: fglrx.enabled(fglrx): target_alt /usr/lib/fglrx/ld.so.conf current_alt /usr/lib/fglrx/ld.so.conf other target alt /usr/lib/fglrx/alt_ld.so.conf other current alt /usr/lib/fglrx/alt_ld.so.conf
2012-04-22 09:53:38,042 DEBUG: XorgDriverHandler(%s, %s).enabled(): No X.org driver set, not checking
2012-04-22 09:53:38,197 DEBUG: fglrx.enabled(fglrx_updates): target_alt None current_alt /usr/lib/fglrx/ld.so.conf other target alt None other current alt /usr/lib/fglrx/alt_ld.so.conf
2012-04-22 09:53:38,197 DEBUG: fglrx_updates is not the alternative in use
2012-04-22 09:53:38,258 DEBUG: fglrx.enabled(fglrx_updates): target_alt None current_alt /usr/lib/fglrx/ld.so.conf other target alt None other current alt /usr/lib/fglrx/alt_ld.so.conf
2012-04-22 09:53:38,258 DEBUG: fglrx_updates is not the alternative in use
2012-04-22 09:53:38,354 DEBUG: fglrx.enabled(fglrx): target_alt /usr/lib/fglrx/ld.so.conf current_alt /usr/lib/fglrx/ld.so.conf other target alt /usr/lib/fglrx/alt_ld.so.conf other current alt /usr/lib/fglrx/alt_ld.so.conf
2012-04-22 09:53:38,355 DEBUG: XorgDriverHandler(%s, %s).enabled(): No X.org driver set, not checking
2012-04-22 09:53:38,424 DEBUG: fglrx.enabled(fglrx): target_alt /usr/lib/fglrx/ld.so.conf current_alt /usr/lib/fglrx/ld.so.conf other target alt /usr/lib/fglrx/alt_ld.so.conf other current alt /usr/lib/fglrx/alt_ld.so.conf
2012-04-22 09:53:38,425 DEBUG: XorgDriverHandler(%s, %s).enabled(): No X.org driver set, not checking
2012-04-22 09:53:40,020 DEBUG: Shutting down

Würde gerne den  fglrx nutzen nur wie kriege ich den Ohne Fehlermeldung  Installiert ?

Zur Zeit nutze ich den Kernel 3.4.0.rc3 und auch in diversen Anleitungen (gegoogelt)  hab ich versucht irgendwie den Treiber einzubinden ,es klappt einfach nicht

Was mache ich da falsch  bzw. wie kriegt man den Treiber da richtig rein ?

Auch der Befehl im Terminal  fglrxinfo bringt diese Ausgabe.

X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  138 (ATIFGLEXTENSION)
  Minor opcode of failed request:  66 ()
  Serial number of failed request:  13
  Current serial number in output stream:  13


Auch verständlich  wenn der Treiber nicht korrekt sitzt


Hat da wer vielleicht eine Anleitung oder Lösung dafür ?

 PS:  Die Grafikkarte ist eine HD 6550D  von einer Fusion Lösung (AMD A8-3870)



Re: ATI Treiber macht Probleme
« Antwort #1 am: 22.04.2012, 10:47:50 »
Ich würde dir die händische Installation mittelsaptitude install fglrx-controlempfehlen. Ich trau jockey nciht

Re: ATI Treiber macht Probleme
« Antwort #2 am: 22.04.2012, 11:08:08 »
Ich kann mir gut vorstellen, dass das noch gar nicht geht mit fglrx und dem Mainline-Kernel. Ist ja oft so, dass für solche Kernel noch kein Modul gebaut werden kann von proprietären Treibern.

Re: ATI Treiber macht Probleme
« Antwort #3 am: 22.04.2012, 11:19:57 »
Mir fällt gerade auf:
Wie hast denn du jocley unter LMDE bekommen?

Re: ATI Treiber macht Probleme
« Antwort #4 am: 22.04.2012, 11:21:10 »
Ganz richtig!

Die fglrx-Treiber sind eben nicht Open-Source.
Da kann also auch niemand passende Module für die Mainline-Kernel bauen.
Und AMD/ATI tut es nicht.

Die einzige Chance, an neuere Kernel mit passenden fglrx-Modulen zu kommen, sind Backports.
Und die gibt es bei Ubuntu-basierten Systemen nur in LTS-Versionen.

BTW: Wieso sind wir hier eigentlich unter Linuxmintusers.de » Forum » Linux Mint Debian Edition (LMDE) » Hardware ?


MfG Olav


Edith: Atze hat es auch bemerkt  :D

Re: ATI Treiber macht Probleme
« Antwort #5 am: 22.04.2012, 11:25:32 »
Ich empfehle dir folgende Treiber zu benutzen.

DesktopComputer: http://support.amd.com/de/gpudownload/linux/Pages/radeon_linux.aspx?type=2.4.1&product=2.4.1.3.42&lang=English

Notebook: http://support.amd.com/de/gpudownload/linux/Pages/radeon_linux.aspx

Nach dem dowonload musst du die Datei noch ausführbar machen.

PS.: Bei Lisa funktioniert der Treiber nur unter dem GNOME-Classic Desktop und MATE einwandfrei, unter GNOME3 und Cinnamon gibt es (zumindest bei meinem Laptop) ruckende Bilder bei Filmen und ziemlich schlecht gleitende Fenster.

Gruß Selius

Nachtrag :-)) ja wie die Treiber unter LMDE laufen weis ich leider nicht und sommit musst du mein PS nicht beachten.
« Letzte Änderung: 22.04.2012, 11:30:08 von selius »

Re: ATI Treiber macht Probleme
« Antwort #6 am: 22.04.2012, 11:33:05 »
Hier gehts ja um Lisa, und das ist bei beiden Links der gleiche Treiber (gibt keine unterschiedlichen für Notebooks und Desktops) und man wird vermutlich mit einem Mainline Kernel und dem genauso wenig weit kommen.

Re: ATI Treiber macht Probleme
« Antwort #7 am: 22.04.2012, 11:39:55 »
Ja sorry irgendwie habe ich LMDE übersehen, sonst hätte ich meinen Beitrag ja hier nicht gepostet. ;D

Man könnte natürlich trotzdem die Treiber probieren, wer weis vielleicht gehe die ja. ;)

Re: ATI Treiber macht Probleme
« Antwort #8 am: 22.04.2012, 11:43:00 »
Nochmal, der Beitrag ist im falschen Forum. Das System des TE ist nicht LMDE.

Ampel

  • Gast
Re: ATI Treiber macht Probleme
« Antwort #9 am: 22.04.2012, 15:15:25 »
Mir fällt gerade auf:
Wie hast denn du jocley unter LMDE bekommen?

Ganz normal Linux Mint Installiert. Danch musste ich nur eine Datei ( Mind Lib) Installieren ,danach konnte ich ca. über 390 Updates  ziehen und Installieren. Nach Neustart war der Standard ATI Treiber mit CCC dabei. Das Verwunderliche ist nur alles was ich normal mache. z.B. Videos guggen, Browsergames zocken und all die anderen normalen Desktop Anwendungen arbeiten  Fehlerfrei , kein Ruckeln ,keine Fehlfarben etc. Selbst bei Flash Videos keine Probleme das Darzustellen. Nur wenn ich z.B. das Game Wakfu Installiere , kommt nach  der Installation das Open GL Treiber fehlen.  Im Internet Recherchiert weist dies auf das die Treiber nicht dafür vorhanden sind. Nach überprüfung ( siehe Ersten Text)  stimmte das ja auch .

Ampel

  • Gast
Re: ATI Treiber macht Probleme
« Antwort #10 am: 22.04.2012, 15:19:46 »
Ich empfehle dir folgende Treiber zu benutzen.

DesktopComputer: http://support.amd.com/de/gpudownload/linux/Pages/radeon_linux.aspx?type=2.4.1&product=2.4.1.3.42&lang=English

Notebook: http://support.amd.com/de/gpudownload/linux/Pages/radeon_linux.aspx

Nach dem dowonload musst du die Datei noch ausführbar machen.

PS.: Bei Lisa funktioniert der Treiber nur unter dem GNOME-Classic Desktop und MATE einwandfrei, unter GNOME3 und Cinnamon gibt es (zumindest bei meinem Laptop) ruckende Bilder bei Filmen und ziemlich schlecht gleitende Fenster.

Gruß Selius

Nachtrag :-)) ja wie die Treiber unter LMDE laufen weis ich leider nicht und sommit musst du mein PS nicht beachten.




Diesen Treiber (selbst in englischer version) hab ich ausprobiert und nach der Anleitung die man hier im Forum finden kann ,ausgeführt, brachte nix.

Warscheinlich werde ich noch ein paar Monate warten müssen bis AMD/ATI den passenden Treiber für den passenden Kernel liefert.

Re: ATI Treiber macht Probleme
« Antwort #11 am: 22.04.2012, 15:21:45 »
Ganz normal Linux Mint Installiert.
Es gibt aber nicht ganz einfach nur normal Linux Mint, sondern es gibt Linux Mint Main (das auf Ubuntu basiert) und Linux Mint Debian Edition (LMDE), das auf Debian basiert, und davon jeweils noch mehrere Edititons mit verschiedenen Oberflächen.

Und wie gesagt, mit einem Mainline-Kernel kannst Du das vergessen mit dem proprietären Treiber. Wieso verwendest Du den denn überhaupt und nicht den normalen 3.0.0-17 da aus den Repos?

Ampel

  • Gast
Re: ATI Treiber macht Probleme
« Antwort #12 am: 22.04.2012, 15:28:03 »
Ich würde dir die händische Installation mittelsaptitude install fglrx-controlempfehlen. Ich trau jockey nciht

Ausprobiert und das komische ist das diese Meldung kommt 

Es werden keine Pakete installiert, aktualisiert oder entfernt.
0 Pakete aktualisiert, 0 zusätzlich installiert, 0 werden entfernt und 0 nicht aktualisiert.
Muss 0 B an Archiven herunterladen. Nach dem Entpacken werden 0 B zusätzlich belegt sein.
                                             
Aktueller Status: 40568 Neue [+1].


Vermutlich ist alles drin nur der Kernel scheint "zu neu" zu sein.

 

Ampel

  • Gast
Re: ATI Treiber macht Probleme
« Antwort #13 am: 22.04.2012, 15:31:09 »

Und wie gesagt, mit einem Mainline-Kernel kannst Du das vergessen mit dem proprietären Treiber. Wieso verwendest Du den denn überhaupt und nicht den normalen 3.0.0-17 da aus den Repos?

Der neue soll bessere Unterstützung für neuere Hardware liefern.  Beim 3.0.0.17  habe ich das Problem das wenn ich den Treiber korrekt Installiere ,das mein Desktop komplett in anderer Farbe erscheint , Icons stark Verpixelt sind und ich so nicht mal erkennen kann wo die Verknüpfung  für den Terminal ist. Selbst die Sprache wird dermaßen "verfremdet" , das man nur erahnen kann was da steht.


Das ist ein bekanntes Problem des Treibers aus den Repos mit Gnome 3. Du solltest es, wenn noch nicht geschehen, mit dem 3.0.0-17 und dem Treiber von der ATI-Seite versuchen.