Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
04.04.2020, 23:24:56

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 651268
  • Themen insgesamt: 52727
  • Heute online: 719
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  Gnome 3: Panel und im Notification teilweise chinesisch  (Gelesen 1441 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Gnome 3: Panel und im Notification teilweise chinesisch
« am: 07.04.2012, 13:35:06 »
Hallo Leute

Eine Frage an euch habe Linux Mint 12 mit Gnome 3 neu installiert bin kein anfänger

nun habe ich das Problem das alles in Anwendungen sowie auch im Panel und im Notification teilweise chinesisch angezeigt wird

und alles was ich versucht habe es lässt sich nicht umstellen

kein languageselector und auch sonst nichts

und Firefox wird auch nur in Englisch dargestellt

vielleicht wisst ihr ja rat bevor ich meine sicherung zurückspiele

siehe Bildschirmfotos

gruß und frohe ostern

groni
« Letzte Änderung: 07.04.2012, 14:50:31 von groni »

Re: Gnome 3
« Antwort #1 am: 07.04.2012, 15:12:39 »
Hallo Leute

Mein Problem ist gelöst habe ein bisschen gestöbert und volgendes gefunden:

Wenn ein Benutzer eine andere Kodierung benötigt als systemweit eingerichtet, ist dies in der Datei ~/.profile anzugeben:

Aufzurufen im Terminal mit:sudo gedit ~/.profile ist am einfachsten Passwort eingeben und Voila schont hat man die profile


Die bei mir so aussah und so aussehen muss (änderung unterstrichen)


# ~/.profile: executed by the command interpreter for login shells.
# This file is not read by bash(1), if ~/.bash_profile or ~/.bash_login
# exists.
# see /usr/share/doc/bash/examples/startup-files for examples.
# the files are located in the bash-doc package.

# the default umask is set in /etc/profile; for setting the umask
# for ssh logins, install and configure the libpam-umask package.
#umask 022

# if running bash
if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
   . "$HOME/.bashrc"
    fi
fi

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/bin" ] ; then
    PATH="$HOME/bin:$PATH"
fi

Das war der Bösewicht:
export LANGUAGE="zh_CN:de_DE:en"

und so muss es Wirklich sein:

export LANGUAGE="de_DE:en"
export LC_MESSAGES="de_DE.UTF-8"
export LC_CTYPE="de_DE.UTF-8"
export LC_COLLATE="de_DE.UTF-8"
export LANG="de_DE.UTF-8"

export LANG=de_DE.UTF-8 in meinem Fall es gibt auch verschiedene Varianten der Sprachen

Nach dem nächsten Login wird diese Einstellung dann übernommen. Der Befehl locale sollte etwas in dieser Art ausgeben:

LANG=de_DE.UTF-8
LANGUAGE=de_DE:en
LC_CTYPE=de_DE.UTF-8
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE=de_DE.UTF-8
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES=de_DE.UTF-8
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=

Gibt es Warnungen bei einem "update-initramfs", ausgelöst von einem automatischen oder manuellen Vorgang, bei dem ausgegeben wurde:

Warning: No Support for locale: de_DE.utf8

Und da lag der Hase  Begraben ich hatte Localepurge installiert und nicht die Warnung beachtet

Ja was man nicht im Kopf hat..... na aber es gibt unter Mint nichts was man nicht hinbekommt ja halt Linux

so nun noch der link wo ich es gefunden habe:

http://wiki.ubuntuusers.de/Spracheinstellungen?highlight=language-support-de%20#Systemweite-nderung

So nun aber

Einen lieben Gruß und Frohe Ostern

wünscht euch

groni





Re: Gnome 3
« Antwort #2 am: 07.04.2012, 18:27:05 »
Die $HOME/.profile sollte eigentlich dem Nutzer gehören und sollte auch von diesem bearbeitet werden.

PS.: Benutze doch bitte, der Lesbarkeit wegen, Codeblöcke. (Das Raute-Symbol bei den SMilies)