Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
17.04.2021, 16:55:31

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25504
  • Letzte: Shiro
Statistiken
  • Beiträge insgesamt: 729350
  • Themen insgesamt: 58841
  • Heute online: 599
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  WLAN einmal per Fn-Tastenkombi ausgemacht, lässt sich nun nicht mehr aktivieren  (Gelesen 365 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo zusammen,

ich hatte früher LMDE 3 benutzt, bin aber vor einiger Zeit auf Kernel: 5.4.0-70-generic x86_64 bits: 64 Desktop: MATE 1.24.0/Distro: Linux Mint 20.1 Ulyssa umgestiegen.

Mein Rechner (Lenovo T540p) hat eine Tastenkombi (Fn-F8, Symbol "durchgestrichener Sendemast"), mit der ich unter LMDE das WLAN toggeln konnte (also ein- und ausschalten). Unter dem aktuellen System scheint nur noch Ausschalten vorgesehen zu sein. Wie schalte ich das WLAN wieder ein?

(Ich bin mir einigermaßen sicher, dass ich vor einiger Zeit (vor ein paar Wochen) schonmal vor dem Problem stand, und dann konsterniert "Shift-Fn-F8" ausprobiert habe, und dann ging es wieder. Ist aber eine eher recht vage Erinnerung.)

Auf jeden Fall ist es mir jetzt nicht gelungen, WLAN wieder einzuschalten, auch durch einen neuen Boot nicht.

Ausprobiert habe ich (vor dem neuen Boot):
  • $ rfkill unblock all
    (Bewirkt zwar, dass $ rfkill list nun "Soft blocked: no" anzeigt, aber nicht, dass in der GUI (RJ-Stecker-Symbol in der Taskleiste) etwas anderes als "Funknetzwerk ist deaktiviert" und keine SSID angezeigt würde.)
  • $ sudo xed /var/lib/NetworkManager/NetworkManager.state
    …und dann "WirelessEnabled=false" durch "WirelessEnabled=true" ersetzt. Auch hier kein Effekt auf die GUI-Anzeige ("…deaktiviert" sowie keine SSID).
    (Seit Neustart steht wieder "false" darin.)
  • Neustart, im Bootmenü das alte LMDE (auf anderer Partition noch vorhanden) gebootet – kein Problem. Direkt werden mir SSID angezeigt, kann mich verbinden und die Verbindung auch wieder mit Fn-F8 abbrechen und auch wieder mit nochmals Fn-F8 WLAN wieder aktivieren.

Wer weiß Rat?

Danke und gute Nacht – Peter

PS:
$ inxi -Fz
System:
  Kernel: 5.4.0-70-generic x86_64 bits: 64 Desktop: MATE 1.24.0
  Distro: Linux Mint 20.1 Ulyssa
Machine:
  Type: Laptop System: LENOVO product: 20BFS05L00 v: ThinkPad T540p
  serial: <filter>
  Mobo: LENOVO model: 20BFS05L00 serial: <filter> UEFI: LENOVO
  v: GMET90WW (2.38 ) date: 04/13/2020
Battery:
  ID-1: BAT0 charge: 15.1 Wh condition: 15.9/56.2 Wh (28%)
CPU:
  Topology: Quad Core model: Intel Core i7-4700MQ bits: 64 type: MT MCP
  L2 cache: 6144 KiB
  Speed: 1141 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 1196 2: 1128
  3: 1176 4: 1196 5: 1167 6: 1154 7: 1078 8: 1192
Graphics:
  Device-1: Intel 4th Gen Core Processor Integrated Graphics driver: i915
  v: kernel
  Device-2: NVIDIA GK208M [GeForce GT 730M] driver: nouveau v: kernel
  Display: x11 server: X.Org 1.20.9 driver: modesetting unloaded: fbdev,vesa
  resolution: 2880x1620~60Hz
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2)
  v: 4.5 Mesa 20.2.6
Audio:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
  driver: snd_hda_intel
  Device-2: Intel 8 Series/C220 Series High Definition Audio
  driver: snd_hda_intel
  Sound Server: ALSA v: k5.4.0-70-generic
Network:
  Device-1: Intel Ethernet I217-LM driver: e1000e
  IF: enp0s25 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-2: Intel Wireless 7260 driver: iwlwifi
  IF: wlp4s0 state: down mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
  IF-ID-2: virbr0-nic state: down mac: <filter>
Drives:
  Local Storage: total: 2.05 TiB used: 9.98 GiB (0.5%)
  ID-1: /dev/sda vendor: Seagate model: ST2000LM003 HN-M201RAD
  size: 1.82 TiB
  ID-2: /dev/sdb vendor: Transcend model: TS256GMTS400S size: 238.47 GiB
Partition:
  ID-1: / size: 22.35 GiB used: 9.97 GiB (44.6%) fs: btrfs dev: /dev/sdb4
  ID-2: /home size: 22.35 GiB used: 9.97 GiB (44.6%) fs: btrfs
  dev: /dev/sdb4
  ID-3: swap-1 size: 16.39 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb2
Sensors:
  System Temperatures: cpu: 48.0 C mobo: 0.0 C gpu: nouveau temp: 48 C
  Fan Speeds (RPM): cpu: 2099
Info:
  Processes: 265 Uptime: 29m Memory: 15.52 GiB used: 1.51 GiB (9.7%)
  Shell: bash inxi: 3.0.38
« Letzte Änderung: 08.04.2021, 13:27:18 von Peter0 »

kann mich dunkel dran erinnern sowas ähnliches mal bei einer meiner Latituden gehabt zu haben,
nur kann ich mich ums verrecken nicht mehr erinnern wie ich es wieder hinbekommen habe,
glaube aber schon das dir hier jemand helfen kann

Hallo,
dann zeige doch zunächst bitte mal mehr und genauere Informationen dazu.
iwconfig wlp4s0
rfkill list
iw reg get
lsmod | egrep 'laptop|wmi|acpi|rfkill'

Das Ein/Aus - Schalten funktioniert bei diesem T440p über Fn-F8 ohne Probleme.
Jedoch ist mein UEFI von 04/20/2020.
t440p@t440p-ThinkPad-T440p:~$ inxi -Fz
System:
  Kernel: 5.8.0-48-generic x86_64 bits: 64 Desktop: Cinnamon 4.8.6
  Distro: Linux Mint 20.1 Ulyssa
Machine:
  Type: Laptop System: LENOVO product: 20AN006VGE v: ThinkPad T440p
  serial: <filter>
  Mobo: LENOVO model: 20AN006VGE v: 0B98401 PRO serial: <filter>
  UEFI: LENOVO v: GLETA1WW (2.55 ) date: 04/20/2020
Battery:
  ID-1: BAT0 charge: 39.9 Wh condition: 69.6/73.3 Wh (95%)
CPU:
  Topology: Quad Core model: Intel Core i7-4700MQ bits: 64 type: MT MCP
  L2 cache: 6144 KiB
  Speed: 898 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 953 2: 899
  3: 898 4: 901 5: 898 6: 900 7: 916 8: 902
Graphics:
  Device-1: Intel 4th Gen Core Processor Integrated Graphics driver: i915
  v: kernel
  Device-2: NVIDIA GK208M [GeForce GT 730M] driver: nouveau v: kernel
  Display: x11 server: X.Org 1.20.9 driver: modesetting unloaded: fbdev,vesa
  resolution: 1600x900~60Hz
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2)
  v: 4.5 Mesa 20.2.6
Audio:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
  driver: snd_hda_intel
  Device-2: Intel 8 Series/C220 Series High Definition Audio
  driver: snd_hda_intel
  Sound Server: ALSA v: k5.8.0-48-generic
Network:
  Device-1: Intel Ethernet I217-LM driver: e1000e
  IF: enp0s25 state: down mac: <filter>
  Device-2: Intel Wireless 7260 driver: iwlwifi
  IF: wlp4s0 state: up mac: <filter>
  IF-ID-1: wwan0 state: down mac: <filter>
Drives:
  Local Storage: total: 931.51 GiB used: 12.14 GiB (1.3%)
  ID-1: /dev/sda vendor: SanDisk model: SDSSDH31000G size: 931.51 GiB
Partition:
  ID-1: / size: 45.58 GiB used: 10.91 GiB (23.9%) fs: ext4 dev: /dev/sda5
  ID-2: /home size: 437.50 GiB used: 1.20 GiB (0.3%) fs: ext4 dev: /dev/sda6
Sensors:
  System Temperatures: cpu: 37.0 C mobo: 0.0 C gpu: nouveau temp: 37 C
  Fan Speeds (RPM): cpu: 0
Info:
  Processes: 277 Uptime: 3m Memory: 7.66 GiB used: 1.72 GiB (22.4%)
  Shell: bash inxi: 3.0.38
t440p@t440p-ThinkPad-T440p:~$

sudo xed
Wenn dir dein System lieb ist startest du grafische Programme nie mit nacktem sudo, sondern immer nur sudo -H.

dann zeige doch zunächst bitte mal mehr und genauere Informationen dazu.

Ok.

$ iwconfig wlp4s0
wlp4s0    IEEE 802.11  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on

$ rfkill list
0: tpacpi_bluetooth_sw: Bluetooth
Soft blocked: no
Hard blocked: no
2: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
3: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

Hinweis: Da stand mal beim WLAN "Soft blocked: yes", bevor ich "unblock all" gegeben habe. Siehe OP.

$ iw reg get
global
country 00: DFS-UNSET
(2402 - 2472 @ 40), (N/A, 20), (N/A)
(2457 - 2482 @ 20), (N/A, 20), (N/A), AUTO-BW, PASSIVE-SCAN
(2474 - 2494 @ 20), (N/A, 20), (N/A), NO-OFDM, PASSIVE-SCAN
(5170 - 5250 @ 80), (N/A, 20), (N/A), AUTO-BW, PASSIVE-SCAN
(5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, AUTO-BW, PASSIVE-SCAN
(5490 - 5730 @ 160), (N/A, 20), (0 ms), DFS, PASSIVE-SCAN
(5735 - 5835 @ 80), (N/A, 20), (N/A), PASSIVE-SCAN
(57240 - 63720 @ 2160), (N/A, 0), (N/A)

$ lsmod | egrep 'laptop|wmi|acpi|rfkill'
snd_rawmidi            36864  1 snd_seq_midi
thinkpad_acpi         110592  0
nvram                  16384  1 thinkpad_acpi
wmi_bmof               16384  0
ledtrig_audio          16384  3 snd_hda_codec_generic,snd_hda_codec_realtek,thinkpad_acpi
snd_seq_device         16384  3 snd_seq,snd_seq_midi,snd_rawmidi
snd                    90112  23 snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,thinkpad_acpi,snd_pcm,snd_rawmidi
mxm_wmi                16384  1 nouveau
wmi                    32768  3 wmi_bmof,mxm_wmi,nouveau
video                  49152  3 thinkpad_acpi,i915,nouveau

Danke soweit

sudo xed
Wenn dir dein System lieb ist startest du grafische Programme nie mit nacktem sudo, sondern immer nur sudo -H.

Ok. Jetzt ist es aber bereits passiert – soll ich irgendwelche Kuren machen? Nichts machen, hoffen und in Zukunft aufpassen? Neu installieren? Rechner im Salzbergwerk entsorgen?

Ciao – Peter

Ok, Regionseinstellung ist nicht korrekt, hat mit der abgeschalteten WLAN-Karte aber nicht direkt zu tun. Korrektur:
sudo sed -i "s/REGDOMAIN=/REGDOMAIN=DE/g" /etc/default/crda Übernahme nach Neustart. Test beim Nächsten Start wiederholen.
Rest soweit auch ok.
Tx-Power ist off (0 dBm)
lp4s0    IEEE 802.11  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
...
Teste jetzt ein:
sudo ip link set wlp4s0 up
# und ggf. noch ein
nmcli radio wifi on
# prüfen
iwconfig wlp4s0

Teste jetzt ein: […]

$ sudo ip link set wlp4s0 up
[sudo] Passwort für […]: Hinweis: Geht noch nicht.

$ nmcli radio wifi on
Hinweis: Geht.

$ iwconfig wlp4s0
wlp4s0    IEEE 802.11  ESSID:"Schnucknetz" 
          Mode:Managed  Frequency:2.437 GHz  Access Point: E0:28:6D:1E:5F:2D   
          Bit Rate=57.8 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=31/70  Signal level=-79 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:1  Invalid misc:19   Missed beacon:0


Ok danke. Fn-F8 macht WLAN wieder aus. Shift-Fn-F8 wieder an. Problem scheint erstmal gelöst. Aber warum es mit Shift-Fn-F8 vorher klemmte – keine Ahnung.

Gruß – Peter

OK, prima. Dann bitte noch als "gelöst" markieren.

PS: falsch angewendetes sudo bei grafischen Programmen kann dir die kompletten Zugriffsrechte in deinem Benutzerverzeichnis verbiegen. Kann man reparieren, aber besser aufpassen.
Zitat
Die Option -H bewirkt, dass dann auch die Umgebungsvariabele $HOME auf das Home-Verzeichnis von BENUTZERNAME mit umzieht, was beim Starten von grafische Programme wichtig ist.
- https://wiki.ubuntuusers.de/sudo/#Terminal-Ausfuehrung-durch-Benutzer-mit-Erlaubnis-in-etc-sudoers
« Letzte Änderung: 08.04.2021, 11:50:40 von Flash63 »

Rechner im Salzbergwerk entsorgen?
Wäre leicht übertrieben. ;)
https://www.linuxmintusers.de/index.php?action=wiki;page=Terminalbefehle , hier findest du Befehle um deine Rechte zu kontrollieren und ggf. zu reparieren.

Hm, bei mir gibt es folgendes Verhalten:

$ sudo bash -c 'echo $HOME'
/root
$ sudo -H bash -c 'echo $HOME'
/root
$ sudo -E bash -c 'echo $HOME'
/home/[…]


Daher nehme ich an, dass (wie in der Manpage angedeutet) "-H" Standard ist. Also mache ich mir nun erstmal keine Sorgen.

Ciao – Peter