Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
04.03.2021, 05:06:51

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 719629
  • Themen insgesamt: 58199
  • Heute online: 444
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 2
Gäste: 311
Gesamt: 313

Autor Thema:  Drucker bleibt im Leerlauf (via FritzBox-USB + CUPS Netzwerk) ohne Fehlermeldung  (Gelesen 150 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Ich versuche hier mal noch mein Glück auf Hilfe, nachdem ich hier leider keine Antworten bekommen habe... Ist ggf. ähnlich zu hier, nur dass es bei mir ja schon mal ging.

Ich hatte unter Linux Mint 20.0 erfolgreich einen alten Brother-Drucker HL-2030 über eine FritzBox (USB) als Netzwerkdrucker installiert bekommen und ich konnte problemlos damit aus LM drucken. Im Prinzip bin ich nach der Anleitung der Brother-Homepage vorgegangen: "CUPSwrapper printer driver (deb package)" (cupswrapperhl2030:i386 2.0.1-2) installiert und diesen dann direkt in der Auswahl verwendet (war extra gekennzeichnet) mit:
AppSocket/HP JetDirect / socket://fritz.box:9100 Danach ging der Druck problemlos.
LPR-Treiber habe ich nicht installiert - es ging ja auch ohne (wofür bräuchte ich die denn?)

Leider kann ich allerdings JETZT (wenige Wochen danach) nicht mehr drucken, und ich weiß nicht woran es liegt.
Linux und CUPS berichten, dass das Dokument erfolgreich an den Drucker gesendet wurde - dieser reagiert aber überhaupt nicht und bleibt im Leerlauf.
Zuerst hatte ich diese Fehlermeldung:
error_log states for failed Job18:
W [19/Feb/2021:18:42:14 +0100] [Job 18] Grayscale/monochrome printing requested for this job but Poppler is not able to convert to grayscale/monochrome PostScript.
W [19/Feb/2021:18:42:14 +0100] [Job 18] Use \"pdftops-renderer\" option (see cups-filters README file) to use Ghostscript or MuPDF for the PDF -> PostScript conversion.

Diese sehe ich jedoch nicht mehr, seit ich von hier PDF-Conversion auf GhostScript umgestellt habe (ob das richtig/gut ist, weiß ich nicht):
lpadmin -p <printername> -o pdftops-renderer-default=gs
Über Windows (Dualboot) geht es problemlos, also kein Hardwareproblem.

Zwischen dem Zeitpunkt als es noch ging, und jetzt zu dem es nicht mehr geht, habe ich mehrere Dinge gemacht, von den ich allerdings nicht weiß was konkret die Ursache ist und was eine Lösung wäre. Vielleicht könnt ihr mir Tipps geben, wie ich zu einer Lösung komme?
Geändert habe ich also:
- upgrade LinuxMint 20.0 --> 20.1 Cinnamon/64Bit
(Sicher ist es aber nicht gewollt, dass ein Drucker nach Updates/Upgrades jedes Mal erneut installiert werden muss?)
- alle updates installiert (ob auch z.B. CUPS aktualisiert wurde, weiß ich nicht?
- samba-service (smbd.service) installiert und konfiguriert (file sync)
- Gufw-Firewall 20.04.1 installiert und eingerichtet (+ einige Regeln für samba service erstellt)

Was ich schon - erfolglos - versucht habe:
- Firewall ganz deaktiviern oder Regeln for CUPS-Benutzung anlegen (z.B. Ports 9100, 631 erlauben)
- Druker in CUPS und in LM-Menü neu hinzugefügt (oder sollte ich den CUPS-Wrapper-Treiber noch mal neu installieren müssen? Vorher purge oder so was?)
Keine Änderung.

Was gibt es für Möglichkeiten das Problem zu finden?

Im Prinzip denkt Linux der Drucker hat gedruckt, aber er macht einfach nichts. Wo geht es verloren? Firewall? Falsche Eisntellungen?
Ich bin für jede Hilfe oder Befehle zum Testen dankbar.


VG, Robert
« Letzte Änderung: 23.02.2021, 21:40:22 von therob »

In den Einstellungen => Drucker gibt es einen Haken "aktiviert". Dieser wird durch manche Updates/widrige Umstände deaktiviert. Mein erster Blick wäre also danach und ggfs halt wieder den Haken setzen.

Danke @Bernibär für den schnellen ersten Aufschlag.
Aber leider: keine Lösung. Der Drucker war bereits korrekt aktiviert (sonst wäre mir das sicher auch aufgefallen - aber sicher ist sicher  ;)).
Testweise habe ich den Haken noch mal entfernt -> gedruckt -> Status: "Ausstehend" -> Drucker wieder aktiviert -> Status: "wird gedruckt" und dann wurde der Auftrag laut LM/CUPS auch erfolgreich zum Drucker gesendet - der jedoch natürlich NICHTS gemacht hat.

Noch eine Idee?