Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
03.03.2021, 13:21:47

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 719463
  • Themen insgesamt: 58188
  • Heute online: 648
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  System startet nicht mehr - disk "hd4,gpt2" not found  (Gelesen 216 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] System startet nicht mehr - disk "hd4,gpt2" not found
« am: 22.02.2021, 09:33:18 »
Hallo

Ich habe eine alte SSD welche ich formatieren möchte, davor soll jedoch geprüft werden, ob ich noch Daten darauf habe. Da ich mein Benutzerverzeichnis verschlüssele und der Zugriff darauf aus einem bestehendem System für mich eine große Hürde ist will ich das System einfach mal starten. Daher habe ich die Festplatte ans meinen PC angesteckt, GRUB aktualisiert und nun versucht den neuen GRUB Eintrag zu starten, hier erhalte ich jedoch:

error: no such device: ...abc
error: disk "hd4,gpt2" not found.
error: you need to load kernel first

Über die Festplattenverwaltung konnte ich sehen, dass device "...abc" vorhanden ist.
Also, auf diesem Gerät, also das System welches ich starten will, die fstab angeschaut:
UUID=...GG2  /boot/efi       vfat    umask=0077      0       1
/swapfile                                 none            swap    sw              0       0
Dann unter der Laufwerksverwaltung geschaut, sowohl "...abc" für "/" als auch "...GG2" für "/boot/efi/" existieren.
Wie gehe ich den nun am besten weiter vor. Danke

edit:
ich bin mir recht sicher, dass es mit dem Eintrag "hd4,gpt2" zu tun hat.. Damals war es wohl die 4. Festplatte im System, gerade gibt es nur 3.

« Letzte Änderung: 23.02.2021, 01:11:55 von macromat »

Re: System startet nicht mehr - no such device
« Antwort #1 am: 22.02.2021, 09:37:00 »
Wie wäre es, wenn du ein Live - System nimmst und auf der SSD nachsiehst, was noch an Daten vorhanden ist.

Re: System startet nicht mehr - no such device
« Antwort #2 am: 22.02.2021, 10:03:50 »
Danke für den Hinweis, da das Benutzerverzeichnis verschlüsselt ist, ist das immer eine ziemlich umständliche Prozedur, wie ich finde, wesentlich angenehmer ist es da, das System einfach zu starten. Das ist ein Punkt. Der Andere Punkt ist, dass ich einfach gerne wüsste wie dieses Problem zustande gekommen ist (oder wie es zu lösen ist:-)

Soweit ich das sehen kann, ist das System, welches nicht starten will, ein Linux Mint 20 Cinnamon.

Das selbe Problem habe ich übrigens auch mit einer anderen alten SSD, auf der Linux Mint 19 installiert ist, habe ich eben festgestellt.
« Letzte Änderung: 22.02.2021, 10:10:22 von macromat »

Re: System startet nicht mehr - no such device
« Antwort #3 am: 22.02.2021, 10:13:36 »
Oha, Sorry, bei Verschlüsselung bin ich so wie so raus.

Re: System startet nicht mehr - no such device
« Antwort #4 am: 22.02.2021, 13:39:01 »
Und ich bei EFI.  8)

Zitat
Da ich mein Benutzerverzeichnis verschlüssele und der Zugriff darauf aus einem bestehendem System für mich eine große Hürde ist
Dann hilft nur üben, üben, üben. Ansonsten darf man dem eben nur unwichtige Daten anvertrauen oder man sollte auf eine einfacher zu handhabende Verschlüsselung ausweichen (Oder ganz auf Verschlüsselung verzichten).

Eigentlich muss im laufenden System nur ein Benutzer angelegt werden und dem das alte Benutzerverzeichnis zugeordnet werden. Das geht mit einem Livesystem natürlich einfacher, da standardmäßig der erste Benutzer die Benutzernummer (uid) 1000 erhält, der im Livesystem verwendete aber die uid 999 hat, was Konflikte vermeidet. Ansonsten muss man den Besitz eben ändern.

Relevante Teile des Artikels sind die Absätze:
https://wiki.ubuntuusers.de/ecryptfs/Datenrettung/#Vorbereitungen-fuer-die-manuelle-Datenrettung
https://wiki.ubuntuusers.de/ecryptfs/Datenrettung/#Daten-manuell-auslesen
Wobei „wrapped-passphrase auslesen“ auch überflüssig ist (Außerdem sollte man die eh schon vorliegen haben, schließlich wurde man beim ersten Systemstart dazu aufgefordert, diese sicher zu verwahren). Den Rest des Artikel kann man getost vergessen.
« Letzte Änderung: 22.02.2021, 13:47:26 von get_well(soon) »

Re: System startet nicht mehr - disk "hd4,gpt2" not found
« Antwort #5 am: 22.02.2021, 13:57:51 »
Damals war es wohl die 4. Festplatte im System, gerade gibt es nur 3.
Wenn nur 3 Platten im Rechner sind, wo soll die 4. herkommen. Außerdem beginnt die Zählung der Platten bei Null.

Re: System startet nicht mehr - disk "hd4,gpt2" not found
« Antwort #6 am: 23.02.2021, 01:11:39 »
Über den Live-Stick konnte ich auf die Daten zugreifen. Doch ich wollte dann trotzdem noch von der Platte starten. Das hat schlussendlich auch funktioniert, indem ich mit dem "efibootmgr" einen Eintrag hinzugefügt habe, anschließend tauchte das Laufwerk im "BIOS" im (U)EFI‐Boot-Menüs meines Computers auf und konnte von dort gestartet werden:
https://wiki.ubuntuusers.de/efibootmgr/#Booteintrag-erstellen
sudo efibootmgr --create --disk /dev/sdb --part 1 --label "LM20 - 840SSD" --loader \\EFI\\ubuntu\\grubx64.efi
« Letzte Änderung: 23.02.2021, 01:39:29 von macromat »