Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
04.03.2021, 05:03:37

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 719629
  • Themen insgesamt: 58199
  • Heute online: 444
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 2
Gäste: 312
Gesamt: 314

Autor Thema:  LM 20.1 Xfce: kein Ruhezustand  (Gelesen 247 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

LM 20.1 Xfce: kein Ruhezustand
« am: 21.02.2021, 21:53:10 »
Hi,
ich habe ein ziemlich frisch installiertes Linux Mint 20.1 Xfce. Leider gibt es keinen Ruhezustand (STD), sondern nur Bereitschaft (STR).
Auch per Konsolenbefehl lässt sich der Laptop nicht in den Ruhezustand versetzen, oder besser gesagt: er wacht nicht mehr auf.
mit
sudo pm-hibernateund auch mit
sudo systemctl hibernatefährt er runter und wenn ich ihn wieder einschalte sind alle geöffneten Programme und Fenster weg, so als hätte ich ihn normal runtergefahren.

Re: LM 20.1 Xfce: kein Ruhezustand
« Antwort #1 am: 21.02.2021, 22:03:37 »
Das ist richtig so!
Seit LM 19 ist der Ruhezustand standardmäßig nicht mehr im System vorhanden.
Ruhezustand benötigt eine SWAP - Partition, aber ab LM 19 läuft Linux Mint (Ubuntu 18.04) mit einer SWAP - File.
Also musst du eine SWAP - Partition anlegen und Ruhezustand manuell nachinstallieren.
Wie? Frage Tante Goole.  ;D 

Re: LM 20.1 Xfce: kein Ruhezustand
« Antwort #2 am: 21.02.2021, 22:19:16 »
Eine Swap Partition habe ich.
Funktioniert diese Anleitung für ubuntu auf für Mint?
https://wiki.ubuntuusers.de/Ruhezustand/

Re: LM 20.1 Xfce: kein Ruhezustand
« Antwort #3 am: 21.02.2021, 22:32:16 »
Kann ich nicht mit Gewissheit sagen.
Aber es ist stark zu vermuten.

Re: LM 20.1 Xfce: kein Ruhezustand
« Antwort #4 am: 23.02.2021, 17:54:27 »
Hat funktioniert. Mit
sudo hibernatekann der Ruhezustand aktiviert werden und auch das Aufwachen funktioniert.

Nach dem Aufwachen ist der Bildschirm nicht gesperrt, d.h. ein Zugriff ohne Passworteingabe ist möglich. Kann man das irgendwie umstellen?

Es wäre auch toll, wenn ich den Ruhezustand aus dem Menü heraus starten könnte und ich nicht immer einen root Befehl ausführen müsste.

Re: LM 20.1 Xfce: kein Ruhezustand
« Antwort #5 am: 23.02.2021, 21:00:59 »
Hallo,
Ich verwende kein xfce,
aber das Sperren sollte in den Systemeinstellungen > Sperrbildschirm möglich sein.

Zwecks Aktivierung könnte man dazu einen Starter anlegen...
... oder man löst es durch Hinzufügen des Applet:
"Shutdown Menü with icons"
Re. - Maus Klick auf die Leiste > Applet hinzufügen....
das Applet bietet auch die Möglichkeit die angebotenen Befehle mit eigenen zu ergänzen.
Meine alten Themen dazu: https://www.linuxmintusers.de/index.php?topic=63009.msg

Sollte beim Auswählen des Ruhebetriebes (Hibernate) ein Kennwort verlangt werden fehlt sehr wahrscheinlich die Datei:/etc/polkit-1/localauthority/com.ubuntu.enable-hibernate.pkla dann hilft dir diese Seite weiter:
https://www.ehlertronic.de/linux/tipps-tricks/ruhezustand.html
« Letzte Änderung: 24.02.2021, 09:45:22 von kuehhe1 »

Re: LM 20.1 Xfce: kein Ruhezustand
« Antwort #6 am: 23.02.2021, 21:37:29 »
Shutdown-Timer kann das auch

Re: LM 20.1 Xfce: kein Ruhezustand
« Antwort #7 am: 24.02.2021, 12:59:30 »
Moin,
Shutdown-Timer kann das auch
aber das Applet: "Shutdown Menü with icons"
das Applet bietet auch die Möglichkeit die angebotenen Befehle mit eigenen zu ergänzen.
z.B. mit diesen Befehlen um die Anwendungen sauber zu Beenden und nicht einfach Abzuwürgen:sh -c "pkill thunderbird; pkill chrome; killall conky; sleep 3; systemctl reboot"
Leider sieht man im Screenshot die erweiterten Befehlszeilen nicht vollständig.
« Letzte Änderung: 24.02.2021, 13:11:02 von kuehhe1 »

Re: LM 20.1 Xfce: kein Ruhezustand
« Antwort #8 am: 24.02.2021, 16:49:03 »
@kuehhe1
Shutdown Menü with icons hatte ich auch mal,
da ich aber Ruhezustand kaum benutze, oder nur mal am Leppie
habe ich mich für Shutdown-Timer entschieden,
weil ich dort diese Timer-Funktion mag,
wenn ich irgendwann inne Falle gehe,
höre ich noch oft Hörbücher und dann fährt der Rechner halt runter nach einer gewissen Zeit,
weil ich dann auch auch meist schon im Traumland bin,
ansonsten ist das natürlich gut wie du es schreibst,
iss eben immer die Frage, was brauche ich, was will ich machen  ::)