Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
25.02.2021, 23:52:18

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25306
  • Letzte: phase0
Statistiken
  • Beiträge insgesamt: 718317
  • Themen insgesamt: 58098
  • Heute online: 654
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  Neuinstallation  (Gelesen 374 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Neuinstallation
« am: 16.02.2021, 22:12:16 »
Folgendes Problem hat sich eingestellt. Ich habe auf dem Laptop eine neue SSD-Platte eingebaut und danach LM20 installiert. Die Installation lief ohne Probleme durch.
Nur beim Starten fehlt angeblich die Möglichkeit zu booten. Den Bootloader ist auf der sdb.
Mittels CD SuperGrub 2 konnte ich mein Linux aufrufen. Das Live-System mit CD startet nicht.
Meine Daten sind auf der alten ausgebauten Festplatte vorhanden.
Ich weiss nicht weiter und die Seite musste ich auch schon mal dafür benutzen: https://wiki.ubuntuusers.de/EFI_Problembehebung/#EFI-Partition
inxi -Fz
System:
  Kernel: 5.4.0-40-generic x86_64 bits: 64 Desktop: Cinnamon 4.6.6
  Distro: Linux Mint 20 Ulyana
Machine:
  Type: Laptop System: Acer product: Aspire F5-573 v: V1.12 serial: <filter>
  Mobo: Acer model: Captain_SK v: V1.12 serial: <filter> UEFI: Insyde
  v: 1.12 date: 08/02/2016
Battery:
  ID-1: BAT1 charge: 25.6 Wh condition: 25.6/41.4 Wh (62%)
CPU:
  Topology: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP
  L2 cache: 3072 KiB
  Speed: 500 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 500 2: 500
  3: 500 4: 500
Graphics:
  Device-1: Intel HD Graphics 620 driver: i915 v: kernel
  Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa
  resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.0.8
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
  Sound Server: ALSA v: k5.4.0-40-generic
Network:
  Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
  driver: ath10k_pci
  IF: wlp2s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
  IF: enp3s0f1 state: down mac: <filter>
Drives:
  Local Storage: total: 1.94 TiB used: 8.22 GiB (0.4%)
  ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 2TB size: 1.82 TiB
  ID-2: /dev/sdb vendor: SK Hynix model: HFS128G39TND-N210A size: 119.24 GiB
Partition:
  ID-1: / size: 36.41 GiB used: 8.09 GiB (22.2%) fs: ext4 dev: /dev/sdb1
  ID-2: /home size: 1.79 TiB used: 123.3 MiB (0.0%) fs: ext4 dev: /dev/sda1
Sensors:
  System Temperatures: cpu: 40.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 214 Uptime: 2m Memory: 31.24 GiB used: 1002.8 MiB (3.1%)
  Shell: bash inxi: 3.0.38
sudo parted --list     
Modell: ATA Samsung SSD 860 (scsi)
Festplatte  /dev/sda:  2000GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: gpt
Disk-Flags:

Nummer  Anfang  Ende    Größe   Dateisystem  Name  Flags
 1      1049kB  2000GB  2000GB  ext4


Modell: ATA HFS128G39TND-N21 (scsi)
Festplatte  /dev/sdb:  128GB
Sektorgröße (logisch/physisch): 512B/4096B
Partitionstabelle: gpt
Disk-Flags:

Nummer  Anfang  Ende    Größe   Dateisystem  Name  Flags
 1      1049kB  40,0GB  40,0GB  ext4
 2      40,0GB  40,5GB  500MB   fat32              boot, esp
« Letzte Änderung: 17.02.2021, 01:06:30 von Giovanni »

Re: Neuinstallation
« Antwort #1 am: 16.02.2021, 22:58:18 »
Hallo,
zeige doch bitte mal noch:

[ -d /sys/firmware/efi ] && echo UEFI || echo BIOSefibootmgr

Re: Neuinstallation
« Antwort #2 am: 16.02.2021, 23:03:38 »
[ -d /sys/firmware/efi ] && echo UEFI || echo BIOS
UEFI
efibootmgr
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 2002,0000,2001,2003
Boot0000* a
Boot0001* ATAPI CDROM: Slimtype DVD A  DA8AESH
Boot0002* Unknown Device:
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network

Re: Neuinstallation
« Antwort #3 am: 16.02.2021, 23:12:52 »
Schau bitte mit GParted nach, ob vor der EFI - Partition ein Schlüssel ist.
« Letzte Änderung: 16.02.2021, 23:18:45 von tommix »

Re: Neuinstallation
« Antwort #4 am: 16.02.2021, 23:20:26 »
Ja da ist ein Schlüssel, aber ich bin mittels SG2 CD im Linux.

Re: Neuinstallation
« Antwort #5 am: 16.02.2021, 23:22:11 »
Dann:
sudo grub-installsudo update-grub
Und zeige bitte die Terminalausgaben dazu hier.

Re: Neuinstallation
« Antwort #6 am: 16.02.2021, 23:25:26 »
sudo grub-install       
x86_64-efi wird für Ihre Plattform installiert.
Installation beendet. Keine Fehler aufgetreten.
sudo update-grub
Quelldatei `/etc/default/grub'
Quelldatei `/etc/default/grub.d/50_linuxmint.cfg'
Quelldatei `/etc/default/grub.d/init-select.cfg'
GRUB-Konfigurationsdatei wird erstellt …
Linux-Abbild gefunden: /boot/vmlinuz-5.4.0-40-generic
initrd-Abbild gefunden: /boot/initrd.img-5.4.0-40-generic
Startmenüeintrag für UEFI-Firmware-Einstellungen wird hinzugefügt
erledigt

Re: Neuinstallation
« Antwort #7 am: 16.02.2021, 23:27:00 »
Bitte:

efibootmgr

Re: Neuinstallation
« Antwort #8 am: 16.02.2021, 23:28:15 »
efibootmgr
BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 0003,2002,0000,2001,2003
Boot0000* a
Boot0001* ATAPI CDROM: Slimtype DVD A  DA8AESH
Boot0002* Unknown Device:
Boot0003* ubuntu
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network

Re: Neuinstallation
« Antwort #9 am: 16.02.2021, 23:29:17 »
Bitte:
sudo reboot

Re: Neuinstallation
« Antwort #10 am: 16.02.2021, 23:33:43 »
Kann nur mit der SuperGrub2 DVD starten.

Re: Neuinstallation
« Antwort #11 am: 16.02.2021, 23:34:26 »
efibootmgr

Re: Neuinstallation
« Antwort #12 am: 16.02.2021, 23:35:37 »
efibootmgr
BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 2002,0000,2001,2003
Boot0000* a
Boot0001* Unknown Device:
Boot0002* ATAPI CDROM: Slimtype DVD A  DA8AESH
Boot0003* ubuntu
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network
Muss ich im Bios die Startfolge ändern?

Re: Neuinstallation
« Antwort #13 am: 16.02.2021, 23:40:51 »
Ein "ubuntu" ist aber noch da, das hattest du vorher nicht.
Versuche bitte manuell im UEFI/BIOS "ubuntu" in der Bootreihenfolge nach vorne zu bekommen.
Und versuche noch:
sudo efibootmgr -o 0003,2002,0000,2001,2003

Re: Neuinstallation
« Antwort #14 am: 16.02.2021, 23:55:25 »
Ja bitte.