Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
25.02.2021, 22:22:59

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25303
  • Letzte: MainCoon
Statistiken
  • Beiträge insgesamt: 718298
  • Themen insgesamt: 58097
  • Heute online: 654
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  Nvidia Treiber verursachen rhythmische Aussetzer  (Gelesen 317 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Nvidia Treiber verursachen rhythmische Aussetzer
« am: 16.02.2021, 13:13:57 »
Hallo Zusammen,

wie vermutlich viele hier, bin ich dabei von Windows 10 auf Mint umzusteigen. Zunächst habe ich Mint neben Windows auf einer separaten SSD installiert und alles lief perfekt.
Gestern habe ich meine primäre Platte (NVMe M2) plattgemacht und Mint darauf installiert. Soweit so gut. Allerdings habe ich jetzt ca. alle 500ms einen Ruckler bzw. Aussetzer.
Ich habe relativ schnell festgestellt, dass es irgendwie mit den Nvidia Treibern zusammenhängt, denn mit dem Nouveau tritt es nicht auf.
Allerdings kann ich meine primären Monitor (5120x2160 über DP) nur mit 30Hz nutzen und das System meldet regelmäßig, dass ich meine Grafiktreiber prüfen soll und das es derzeit nur ohne Video-Hardwarebeschleunigung läuft. Wenn der Rechner den Bildschirm wegen Inaktivität ausschaltet, dann geht danach mein primärer Monitor nicht mehr an. Wenn ich ein Bild mit "Pix" bearbeiten will, stürzt das System ab und es kommt eine Meldung die Nouveau und DRAM erwähnt (genauer habe ich es nicht notiert, da dabei der erste Entwurf dieses Posts verloren gegangen ist ;)).

Inzwischen habe ich viele Stunden damit verbracht nach Lösungen zu suchen, aber nichts hilfreiches gefunden.

Ursprünglich hatte ich neben dem Nouveau noch einen 450 und einen 460 Treiber in der Treiberverwaltung zur Auswahl. Mir ist dann aber aufgefallen, dass es auf der Nvidia Webseite bereits eine neuere Version des 460ers gibt. Also habe ich diese heruntergeladen und mit folgender Anleitung installiert: https://www.linuxmintusers.de/index.php?action=wiki;page=Nvidia-Grafiktreiber_installieren_(von_nvidia.de)_in_Mint_17

Es hat eine Weile gedauert, bis ich realisiert habe, dass ich "lightm" und nicht "mdm" stoppen muss, aber habe es dann hinbekommen.

Bei der Installation hat es zum Ende etwas eigenartig ausgesehen, schien dann aber funktioniert zu haben. Ich verstehe leider nicht, was mit der betroffenen Zeile in der local.conf nicht stimmt und ob es relevant ist. Siehe Screenshot.


Leider hat der neueste Treiber das Problem nicht behoben.
Das Ganze sieht dann wie folgt aus (mit allen Treibern außer dem Nouveau): https://youtu.be/YRPn7rjKhBk

Inzwischen bin ich wirklich ratlos. Was könnte ich abrufen und hier posten, das eventuell hilft das Problem ausfindig zu machen?

Ich benötige den Rechner vor allem um mit Davinci Resolve zu arbeiten und dafür muss die Grafikkarte natürlich ordnungsgemäß funktionieren, was bei meinem ersten Test bereits der Fall war.

Besten Dank im Voraus!

Gruß,
Metabob

« Letzte Änderung: 16.02.2021, 21:05:49 von metabob »

Re: Nvidia Treiber verursachen rhythmische Aussetzer
« Antwort #1 am: 16.02.2021, 13:19:45 »
… denn mit dem Nouveau tritt es nicht auf.
Und spricht etwas dagegen, den nouveau-Treiber zu verwenden?

Re: Nvidia Treiber verursachen rhythmische Aussetzer
« Antwort #2 am: 16.02.2021, 13:25:04 »
und das System meldet regelmäßig, dass ich meine Grafiktreiber prüfen soll und das es derzeit nur ohne Video-Hardwarebeschleunigung läuft.
Dann ist der Treiber nicht richtig am Laufen.
Zeige bitte mal
inxi -FzAusgabe bitte zur besseren Lesbarkeit als Text im Codeblock zeigen. Dazu den Text im Editor auswählen und mit der '#' Schaltfläche formatieren. Siehe auch oben im Forums-Menü unter "Hilfe". Kein Foto bitte!

Re: Nvidia Treiber verursachen rhythmische Aussetzer
« Antwort #3 am: 16.02.2021, 13:32:25 »
Und spricht etwas dagegen, den nouveau-Treiber zu verwenden?

Danke für die Antwort. Wie beschrieben, habe ich dann keine Hardwarebeschleunigung, nur 30Hz und Abstürze bei bestimmten Dingen.


Dann ist der Treiber nicht richtig am Laufen.
Zeige bitte mal
inxi -FzAusgabe bitte zur besseren Lesbarkeit als Text im Codeblock zeigen. Dazu den Text im Editor auswählen und mit der '#' Schaltfläche formatieren. Siehe auch oben im Forums-Menü unter "Hilfe". Kein Foto bitte!

Danke dir. Sehr gerne! Das Foto im ersten Post war nur deshalb ein Foto, weil ich den Zwischenspeicher da gerade nicht nutzen konnte, da ich danach neustarten musste.

System:
  Kernel: 5.4.0-65-generic x86_64 bits: 64 Desktop: Cinnamon 4.8.6
  Distro: Linux Mint 20.1 Ulyssa
Machine:
  Type: Desktop System: Micro-Star product: MS-7B86 v: 1.0 serial: <filter>
  Mobo: Micro-Star model: B450 GAMING PLUS (MS-7B86) v: 1.0 serial: <filter>
  UEFI: American Megatrends v: 1.D0 date: 11/08/2019
CPU:
  Topology: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP
  L2 cache: 3072 KiB
  Speed: 3600 MHz min/max: 2200/3600 MHz Core speeds (MHz): 1: 3599 2: 2056
  3: 3594 4: 2053 5: 2058 6: 3600 7: 3598 8: 2057 9: 3599 10: 2057 11: 2056
  12: 3601
Graphics:
  Device-1: NVIDIA TU116 [GeForce GTX 1660 SUPER] driver: nouveau v: kernel
  Display: x11 server: X.Org 1.20.9 driver: modesetting FAILED: nvidia
  unloaded: fbdev,vesa resolution: 1920x1080~60Hz, 5120x2160~30Hz
  OpenGL: renderer: llvmpipe (LLVM 11.0.0 256 bits) v: 4.5 Mesa 20.2.6
Audio:
  Device-1: NVIDIA TU116 High Definition Audio driver: snd_hda_intel
  Device-2: AMD Starship/Matisse HD Audio driver: snd_hda_intel
  Device-3: Elgato Systems Cam Link 4K type: USB
  driver: hid-generic,snd-usb-audio,usbhid,uvcvideo
  Device-4: Focusrite-Novation Focusrite Scarlett 2i2 type: USB
  driver: snd-usb-audio
  Sound Server: ALSA v: k5.4.0-65-generic
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
  IF: enp34s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 1.03 TiB used: 715.57 GiB (68.1%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 1TB size: 931.51 GiB
  ID-2: /dev/sda vendor: Crucial model: M4-CT128M4SSD2 size: 119.24 GiB
Partition:
  ID-1: / size: 915.40 GiB used: 337.46 GiB (36.9%) fs: ext4
  dev: /dev/nvme0n1p2
Sensors:
  System Temperatures: cpu: 57.0 C mobo: N/A gpu: nouveau temp: 25 C
  Fan Speeds (RPM): N/A gpu: nouveau fan: 886
Info:
  Processes: 288 Uptime: 1h 35m Memory: 31.37 GiB used: 2.41 GiB (7.7%)
  Shell: bash inxi: 3.0.38


Re: Nvidia Treiber verursachen rhythmische Aussetzer
« Antwort #4 am: 16.02.2021, 15:09:49 »
Hi :)
wenn nvidia das problem sein sollte, sollte er auch laufen ;)

Zitat
driver: nouveau

Re: Nvidia Treiber verursachen rhythmische Aussetzer
« Antwort #5 am: 16.02.2021, 15:24:36 »
@ehtron Ok, danke! Wobei ich gestehen muss, dass mich das jetzt auch nicht weiterbringt.

Um Missverständnisse vorzubeugen: ich habe jetzt wieder auf den Nouveau umgestellt, da die Aussetzer so nervig sind. Die Peripherie funktioniert auch immer kurz nicht. Dann ist die Bedienung sehr nervig.

Irgend eine Idee was ich versuchen kann?

Besten Dank im Voraus!

@Edit: jetzt kam mir, dass ich inxi -Fz wphl mal mit den Nvidia-Treibern versuchen sollte.

Re: Nvidia Treiber verursachen rhythmische Aussetzer
« Antwort #6 am: 16.02.2021, 15:33:54 »
Tritt das Problem auch mit dem Kernel 5.8 und den verschiedenen Treibern auf?

Re: Nvidia Treiber verursachen rhythmische Aussetzer
« Antwort #7 am: 16.02.2021, 15:33:56 »
Hi :)
evtl. nachträglich installierte applets oder desklets entfernen..

was ist drin in der local.conf?
zeig die mal.
existiert hier auf keiner maschine in dem ordner.


Re: Nvidia Treiber verursachen rhythmische Aussetzer
« Antwort #8 am: 16.02.2021, 15:43:06 »
Hallo, und Willkommen,
was ist drin in der local.conf?
was @ehtron damit sagen möchte ist das Du den Inhalt Deiner im Screenshot gezeigten :/etc/modprobe.d/local.confhier als Codeblock zeigen sollst.

Den Inhalt der: local.conf kannst du dir mit dem Terminal anzeigen lassen:
cat /etc/modprobe.d/local.conf
existiert hier auf keiner maschine in dem ordner.
Hier auf LM20.1 Cin. gibts auch keine: /etc/modprobe.d/local.conf
« Letzte Änderung: 16.02.2021, 18:27:15 von kuehhe1 »

Re: Nvidia Treiber verursachen rhythmische Aussetzer
« Antwort #9 am: 16.02.2021, 15:50:44 »
Tritt das Problem auch mit dem Kernel 5.8 und den verschiedenen Treibern auf?

Soweit, dass ich selbst einen anderen Kernel verwende, geschweige denn wirklich verstehe, von was ich gerade rede, bin ich leider noch nicht in der Materie voran gekommen.

Es ist mit der aktuellsten Version mit allen Treibern die dabei waren, sowie mit den neuesten von der Nvidia-Page gleich. Außer eben mit dem Nouveau.

Sollte ich manuell den Kernel auf 5.8 ändern, sofern das was ich da sage überhaupt richtig ist? ;)

Sorry, bin noch ein ziemlicher Linux-Noob, wie man vermutlich sofort erkennen kann.


Hi :)
evtl. nachträglich installierte applets oder desklets entfernen..

was ist drin in der local.conf?
zeig die mal.
existiert hier auf keiner maschine in dem ordner.

Das Problem trat von Anfang auf bzw. war das erste, mit dem ich mich auseinander gesetzt habe. Anwendungen habe ich erst danach installiert. Ist also eigentlich ausgeschlossen, dass es daran liegt.

Eigentlich fast nichts. Habe auch schon reingeschaut.
In der local.conf ist lediglich:

drm_kms_helper
options drm_kms_helper poll=N





Re: Nvidia Treiber verursachen rhythmische Aussetzer
« Antwort #10 am: 16.02.2021, 15:59:00 »
Hi :)
das ist der komplette inhalt?
bitte die ganze datei brigen.

wenn du nicht genau machst was wir von dir wollen, wird das hier nix..
ein, kann nicht sein und bestimmt nicht, bringt weder uns noch dich in irgend einer weise weiter.

und fang bitte nicht an hier irgendwas unaufgefordert parallel auszuprobieren ...

Re: Nvidia Treiber verursachen rhythmische Aussetzer
« Antwort #11 am: 16.02.2021, 16:07:56 »
Danke auch an @kuehhe1

Es begeistert mich echt sehr, was für eine aktive und hilfsbereite Community es hier gibt. <3

Habe gerade nochmal Nouveau geblacklisted und neugestartet. Jetzt sieht es wie folgt aus:

Graphics:
  Device-1: NVIDIA TU116 [GeForce GTX 1660 SUPER] driver: nvidia v: 460.39
  Display: x11 server: X.Org 1.20.9 driver: nvidia
  resolution: 5120x2160~60Hz, 1920x1080~60Hz
  OpenGL: renderer: GeForce GTX 1660 SUPER/PCIe/SSE2 v: 4.6.0 NVIDIA 460.39

Re: Nvidia Treiber verursachen rhythmische Aussetzer
« Antwort #12 am: 16.02.2021, 16:19:37 »
Hi :)
das ist der komplette inhalt?
bitte die ganze datei brigen.

Das ist tatsächlich der gesamte Inhalt / die gesamte Datei.

Ich weiß auch jetzt wo sie her kommt. Am Anfang dachte ich, dass es nur die Maus bzw. Peripherie ist und habe die in folgende Thread vorgeschlagene Lösung probiert (welche diese Datei beinhaltet):
https://superuser.com/questions/528727/how-do-i-solve-periodic-mouse-lag-on-linux-mint-mate


wenn du nicht genau machst was wir von dir wollen, wird das hier nix..
ein, kann nicht sein und bestimmt nicht, bringt weder uns noch dich in irgend einer weise weiter.

Sorry, falls das so rübergekommen ist. Das war nicht der Sinn. Ich deinstalliere gerne alles. Ich wollte nur darauf hinweisen, dass ich mir recht sicher bin, das Problem direkt nach der Installation von Mint und vor der Installation der Anwendungen bestand.

und fang bitte nicht an hier irgendwas unaufgefordert parallel auszuprobieren ...

Ok ich mache nichts mehr.  :-X

Re: Nvidia Treiber verursachen rhythmische Aussetzer
« Antwort #13 am: 16.02.2021, 18:38:05 »
Das ist tatsächlich der gesamte Inhalt / die gesamte Datei.
Ok, aber damit sich die Helfenden selbst davon überzeugen können benutzt der Hilfesuchende den oder die vorgeschlagenen Befehl(e) und zeigt in seiner Antwort die komplette Terminal Eingabe und Rückmeldung als Codeblock mit dem Raute # Button. Nur so sind deine Aktionen nachvollziehbar. Schau dazu auch mal in die Hilfe Oben im Site-Menü.

Ich weiß auch jetzt wo sie her kommt. Am Anfang dachte ich, dass es nur die Maus bzw. Peripherie ist und habe die in folgende Thread vorgeschlagene Lösung probiert (welche diese Datei beinhaltet):
https://superuser.com/questions/528727/how-do-i-solve-periodic-mouse-lag-on-linux-mint-mate
entweder es wurden nicht alle dort gezeigten Massnahmen befolgt oder wie du sicherlich bemerkt hast ist jenes Thema acht ( 8 ) Jahre alt, betraf die Version LinuxMint 13 / 14 MATE und die Maßnahme führt Heute nicht mehr zur Lösung .

Tip: vor solchen Aktionen ist es immer ratsam einen Timeshift Schnappschuss anzulegen, damit man im Fehlerfall auf den Stand davor zurücksetzen kann.
« Letzte Änderung: 16.02.2021, 19:16:42 von kuehhe1 »

Re: Nvidia Treiber verursachen rhythmische Aussetzer
« Antwort #14 am: 16.02.2021, 18:45:22 »
Soll jetzt echt keine Ausrede sein, aber ich hatte bereits bevor der Post mit dem Befehl kam die Antwort begonnen und über den Dateimanager von Mint in die File geschaut und den Inhalt davon dann per Raute eingefügt.

Hier nochmal korrekt:
metabob@metabob-mint:~$ cat /etc/modprobe.d/local.conf
drm_kms_helper
options drm_kms_helper poll=N
metabob@metabob-mint:~$