Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
25.02.2021, 23:41:10

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25306
  • Letzte: phase0
Statistiken
  • Beiträge insgesamt: 718315
  • Themen insgesamt: 58098
  • Heute online: 654
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  wozu dient in LM20.1Cin. Startprogramme der Starter >im-launch< ?  (Gelesen 112 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo,
mal eine Verständnissfrage.
in Startprogramme befindet der Starter: im-launch, wozu dient der Eintrag überhaupt?
Der Starter war/ist von Anfang an deaktiviert, ein testweises Starten oder Ausführen des Befehls im Terminal bewirkt keine Veränderung aber auch keine Fehlermeldung.

Der Befehl des Starters lautet: sh -c 'if [ "x$XDG_SESSION_TYPE" = "xwayland" ] ; then exec env IM_CONFIG_CHECK_ENV=1 im-launch true; fi'Auch auf meinem nahezu identischen LM20.1 Cin-Produktiv System befindet sich dieser deaktive Starter im-launch mit selben Befehl. Bisher ist mir dieser Starter nicht aufgefallen und scheint erst seit dem Upgrade LM20.1. im System. Könnte mir den Befehl bitte Jemand "übersetzen"...

Laut Synaptic steht Xwayland für den X Server ,
Beschreibung:
Zitat
This package provides an X server running on top of wayland, using wayland
input devices for input and forwarding either the root window or individual
top-level windows as wayland surfaces.
Deepl Übersetzung:
Zitat
Dieses Paket stellt einen X-Server bereit, der auf wayland läuft und wayland
Eingabegeräte für die Eingabe und leitet entweder das Wurzelfenster oder einzelne
Top-Level-Fenster als Wayland-Oberflächen weiter.

Wayland Infos:
PC-Welt: https://www.pcwelt.de/ratgeber/Vorstellung-des-Display-Servers-Wayland-fuer-Linux-Desktop-9903117.html
Wikipedia: https://de.wikipedia.org/wiki/Wayland_(Display-Server-Protokoll)

Wird Xwayland optional als Ersatz für den zukünftigen Standard X Server anstelle x11 grundsätzlich installiert?

Laut Synaptic Verlauf ist xwayland seit dem 12.09.2020 installiert:kuehhe1@LM20-1-Test:~$ dpkg -l *xwayland* | egrep '^ii '
ii  xwayland       2:1.20.9-2ubuntu1.2~20.04.1 amd64        Xwayland X server

Aktiver XServer ist x11:kuehhe1@LM20-1-Produktiv:~$ printenv | grep XDG
XDG_CONFIG_DIRS=/etc/xdg/xdg-cinnamon:/etc/xdg
XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session0
XDG_SEAT=seat0
XDG_SESSION_DESKTOP=cinnamon
XDG_SESSION_TYPE=x11
XDG_GREETER_DATA_DIR=/var/lib/lightdm-data/kuehhe1
XDG_CURRENT_DESKTOP=X-Cinnamon
XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0
XDG_SESSION_CLASS=user
XDG_VTNR=7
XDG_SESSION_ID=c2
XDG_RUNTIME_DIR=/run/user/1000
XDG_DATA_DIRS=/usr/share/cinnamon:/usr/share/gnome:/home/kuehhe1/.local/share/flatpak/exports/share:/var/lib/flatpak/exports/share:/usr/local/share:/usr/share
kuehhe1@LM20-1-Produktiv:~$
kuehhe1@LM20-1-Produktiv:~$ printenv XDG_SESSION_TYPE
x11
kuehhe1@LM20-1-Produktiv:~$
hier ist Xwayland nicht aktiv und auch in der Systemtemüberwachung ist kein Prozess sichtbar.

Mein System: kuehhe1@LM20-1-Test:~$ inxi -Fz
System:    Kernel: 5.4.0-65-generic x86_64 bits: 64 Desktop: Cinnamon 4.8.6 Distro: Linux Mint 20.1 Ulyssa
Machine:   Type: Laptop System: HP product: HP ProBook 470 G5 v: N/A serial: <filter>
           Mobo: HP model: 837F v: KBC Version 02.3E.00 serial: <filter> UEFI: HP v: Q85 Ver. 01.14.01 date: 10/19/2020
Battery:   ID-1: BAT0 charge: 35.9 Wh condition: 36.5/48.0 Wh (76%)
CPU:       Info: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP L2 cache: 6144 KiB
           Speed: 2590 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 2590 2: 2106 3: 2249 4: 2067 5: 2099 6: 2117 7: 1872
           8: 2803
Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
           Device-2: NVIDIA GM108M [GeForce 930MX] driver: nvidia v: 460.32.03
           Device-3: Lite-On HP HD Camera type: USB driver: uvcvideo
           Display: x11 server: X.Org 1.20.9 driver: modesetting,nvidia unloaded: fbdev,nouveau,vesa resolution: 1600x900~60Hz
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.2.6
Audio:     Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
           Sound Server: ALSA v: k5.4.0-65-generic
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
           IF: enp2s0 state: down mac: <filter>
           Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi
           IF: wlp3s0 state: up mac: <filter>
Drives:    Local Storage: total: 1.17 TiB used: 244.25 GiB (20.4%)
           ID-1: /dev/nvme0n1 vendor: SK Hynix model: PC401 HFS256GD9TNG-62A0A size: 238.47 GiB
           ID-2: /dev/sda vendor: Samsung model: SSD 860 EVO 1TB size: 931.51 GiB
           ID-3: /dev/sdb type: USB vendor: Intenso model: Slim Line size: 29.30 GiB
Partition: ID-1: / size: 39.38 GiB used: 16.52 GiB (42.0%) fs: ext4 dev: /dev/nvme0n1p9
Swap:      ID-1: swap-1 type: partition size: 10.00 GiB used: 0 KiB (0.0%) dev: /dev/nvme0n1p7
Sensors:   System Temperatures: cpu: 36.0 C mobo: 34.0 C
           Fan Speeds (RPM): N/A
Info:      Processes: 313 Uptime: 1h 00m Memory: 7.21 GiB used: 1.60 GiB (22.3%) Shell: Bash inxi: 3.1.06
kuehhe1@LM20-1-Test:~$
Kann mir Jemand zum Starter und/oder Xwayland etwas sagen?
« Letzte Änderung: 12.02.2021, 12:10:00 von kuehhe1 »