Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
25.02.2021, 23:51:52

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25306
  • Letzte: phase0
Statistiken
  • Beiträge insgesamt: 718317
  • Themen insgesamt: 58098
  • Heute online: 654
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  Bildschirmauflösung immer wieder falsch  (Gelesen 296 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Bildschirmauflösung immer wieder falsch
« am: 09.02.2021, 22:12:31 »
Hallo und guten Abend,

nach einigen Jahren habe ich mein Linux Mint (mit Cinnamon) mal neu aufgesetzt und habe seit dem Probleme mit der Bildschirmauflösung. Nach jedem Start begrüßt mich der Login-Screen mit einer falschen Auflösung (1024x768), die sich auch nach dem Login nicht ändert. Melde ich mich dann aber ab, schaltet er in die korrekte Auflösung (1600x1050). Grafikkarte ist Nvidia GTX 750, Asus Bildschirm angeschlosen über DVI. Nvidia-Triber 460, der wohl im Moment aktuell ist.
Wenn er in der falschen Auflösung hochgefahren ist, scheint er den Bildschirm nicht korrekt erkannt zu haben.
Hat vielleicht jemand eine Idee und kann mir helfen?

System:
  Kernel: 5.4.0-65-generic x86_64 bits: 64 Desktop: Cinnamon 4.8.6
  Distro: Linux Mint 20.1 Ulyssa
Machine:
  Type: Desktop Mobo: ASUSTeK model: H110-PLUS v: Rev X.0x serial: <filter>
  UEFI: American Megatrends v: 3402 date: 07/05/2017
CPU:
  Topology: Quad Core model: Intel Core i5-6500 bits: 64 type: MCP
  L2 cache: 6144 KiB
  Speed: 801 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 800 2: 800
  3: 800 4: 800
Graphics:
  Device-1: NVIDIA GM107 [GeForce GTX 750] driver: nvidia v: 460.32.03
  Display: x11 server: X.Org 1.20.9 driver: nvidia
  resolution: 1680x1050~60Hz
  OpenGL: renderer: GeForce GTX 750/PCIe/SSE2 v: 4.6.0 NVIDIA 460.32.03
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio
  driver: snd_hda_intel
  Device-2: NVIDIA GM107 High Definition Audio [GeForce 940MX]
  driver: snd_hda_intel
  Device-3: C-Media USB 2.0 Hub type: USB
  driver: hid-generic,snd-usb-audio,usbhid
  Sound Server: ALSA v: k5.4.0-65-generic
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
  IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 3.66 TiB used: 628.44 GiB (16.8%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 PRO 1TB size: 953.87 GiB
  ID-2: /dev/sda vendor: Western Digital model: WD30EZRX-00DC0B0
  size: 2.73 TiB
Partition:
  ID-1: / size: 937.40 GiB used: 628.43 GiB (67.0%) fs: ext4
  dev: /dev/nvme0n1p2
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 46 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 33%
Info:
  Processes: 226 Uptime: N/A Memory: 7.72 GiB used: 1.32 GiB (17.0%)
  Shell: bash inxi: 3.0.38
« Letzte Änderung: 10.02.2021, 20:49:30 von RobertH »

Re: Bildschirmauflösung immer wieder falsch
« Antwort #1 am: 09.02.2021, 22:14:46 »
So sieht inxi aus, wenn er die falsche Auflösung hat:
System:
  Kernel: 5.4.0-65-generic x86_64 bits: 64 Desktop: Cinnamon 4.8.6
  Distro: Linux Mint 20.1 Ulyssa
Machine:
  Type: Desktop Mobo: ASUSTeK model: H110-PLUS v: Rev X.0x serial: <filter>
  UEFI: American Megatrends v: 3402 date: 07/05/2017
CPU:
  Topology: Quad Core model: Intel Core i5-6500 bits: 64 type: MCP
  L2 cache: 6144 KiB
  Speed: 3456 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 3401 2: 3402
  3: 3598 4: 3436
Graphics:
  Device-1: NVIDIA GM107 [GeForce GTX 750] driver: nvidia v: 460.32.03
  Display: x11 server: X.Org 1.20.9 driver: fbdev,modesetting,nouveau
  unloaded: vesa resolution: 1024x768~76Hz
  OpenGL: renderer: llvmpipe (LLVM 11.0.0 256 bits) v: 4.5 Mesa 20.2.6
Audio:
  Device-1: Intel 100 Series/C230 Series Family HD Audio
  driver: snd_hda_intel
  Device-2: NVIDIA GM107 High Definition Audio [GeForce 940MX]
  driver: snd_hda_intel
  Device-3: C-Media USB 2.0 Hub type: USB
  driver: hid-generic,snd-usb-audio,usbhid
  Sound Server: ALSA v: k5.4.0-65-generic
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
  IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 3.66 TiB used: 628.44 GiB (16.8%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 PRO 1TB size: 953.87 GiB
  ID-2: /dev/sda vendor: Western Digital model: WD30EZRX-00DC0B0
  size: 2.73 TiB
Partition:
  ID-1: / size: 937.40 GiB used: 628.43 GiB (67.0%) fs: ext4
  dev: /dev/nvme0n1p2
Sensors:
  System Temperatures: cpu: 29.8 C mobo: 27.8 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 250 Uptime: N/A Memory: 7.72 GiB used: 883.1 MiB (11.2%)
  Shell: bash inxi: 3.0.38

Re: Bildschirmauflösung immer wieder falsch
« Antwort #2 am: 09.02.2021, 22:15:48 »
Und xrandr bei falscher Auflösung:
$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected primary 1024x768+0+0 0mm x 0mm
   1024x768      76.00*

Re: Bildschirmauflösung immer wieder falsch
« Antwort #3 am: 10.02.2021, 09:48:45 »
In so einem Fall sollte man zunächst alle anderen Treiber testen.

Re: Bildschirmauflösung immer wieder falsch
« Antwort #4 am: 10.02.2021, 11:13:12 »
Welche anderen Treiber denn? Andere Nvidia-Treiber? Kann ich machen. Der Nouveau-Treiber kommt für mich allerdings nicht in Frage, da er imho für 3D-Spiele nicht performant genug ist. Und: der Rechner lief mind. 5 Jahre ohne Probleme mit der Grafikkarte mit vielen Mint Versionen bis 19.3.
Meine Vermutung geht Richtung Monitorerkennung: gibt es dazu irgendwelche Log-Files?

Re: Bildschirmauflösung immer wieder falsch
« Antwort #5 am: 10.02.2021, 11:27:54 »
Nein, der Monitor ist nicht das Problem. Wie die inxi Ausgabe im Problemfall zeigt, wird der Nvidia Treiber nicht verwendet.
Graphics:
  Device-1: NVIDIA GM107 [GeForce GTX 750] driver: nvidia v: 460.32.03
  Display: x11 server: X.Org 1.20.9 driver: fbdev,modesetting,nouveau
  unloaded: vesa resolution: 1024x768~76Hz
  OpenGL: renderer: llvmpipe (LLVM 11.0.0 256 bits) v: 4.5 Mesa 20.2.6
Wie skoopy schon sagte, versuch einen anderen Nvidia Treiber. Falls das auch nix bringt, bau die Karte aus und reinige den Slot und die Kontakte der Grafikkarte.

Re: Bildschirmauflösung immer wieder falsch
« Antwort #6 am: 10.02.2021, 11:37:04 »
Hast Du das Setzen von XRANDR in der .Profile Datei?
Damit das bei  jedem Start da ist?

Re: Bildschirmauflösung immer wieder falsch
« Antwort #7 am: 10.02.2021, 15:30:31 »
Hi :)
wie schon soooo oft mittlerweile erlebt...  timing problem
test
https://www.linuxmintusers.de/index.php?topic=63755.msg837813#msg837813



Re: Bildschirmauflösung immer wieder falsch
« Antwort #8 am: 10.02.2021, 20:49:11 »
Ok, also mit Nvidia-Treiber 390 funktioniert alles korrekt.
Und mit dem Nvidia-Treiber 460 klappt es mit dem von ehtron beschriebenem Workaround mit
ExecStartPre=/bin/sleep 5
in /lib/systemd/system/lightdm.service

Vielen Dank für die Hilfe, mit dem Workaround kann ich gut leben!

Re: Bildschirmauflösung immer wieder falsch
« Antwort #9 am: 11.02.2021, 11:22:52 »
Prima, den 450er müsste es auch noch geben.

Re: Bildschirmauflösung immer wieder falsch
« Antwort #10 am: 12.02.2021, 16:25:24 »
Hi :)
hoffe du hast den nachfolgenden post auch beachtet ;)