Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
27.02.2021, 22:54:30

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 718695
  • Themen insgesamt: 58130
  • Heute online: 717
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  TrackPoint funktioniert nicht  (Gelesen 470 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

mgwThreadstarter

  • *
TrackPoint funktioniert nicht
« am: 21.01.2021, 17:42:12 »
Moin zusammen,

ich habe hier zwei weitgehend identische Maschinen vor mir. Es handelt sich um ältere Lenovo Thinkpad Workstations (W530). Eine davon läuft mit "reinem" Ubuntu 20.04 LTS, die andere mit LinuxMint 20.1.

Grundproblem: Der Trackpoint funktioniert mit "reinem" Ubuntu so wie er soll. Auf dem LinuxMint-System wird der Trackpoint und die beiden zugehörigen roten Maustasten nicht erkannt. Dies war schon mit Version 18 so, wurde mit 20 nicht behoben und auch beim letzten system upgrade: nada.

Details:
System:    Kernel: 5.4.0-62-generic x86_64 bits: 64 Desktop: Cinnamon 4.8.6 Distro: Linux Mint 20.1 Ulyssa
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics driver: i915 v: kernel
           Device-2: NVIDIA GF108GLM [Quadro 1000M] driver: nvidia v: 390.141
           Display: x11 server: X.Org 1.20.9 driver: modesetting,nvidia unloaded: fbdev,nouveau,vesa
           resolution: 1920x1080~60Hz

Auffällig ist die Abwesenheit eines Eintrages für "TPPS/2 IBM TrackPoint" bei den virtual core pointer:
xinput
⎡ Virtual core pointer                    id=2 [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              id=4 [slave  pointer  (2)]
⎜   ↳ MOSART Semi. 2.4G Keyboard Mouse Consumer Control id=11 [slave  pointer  (2)]
⎜   ↳ MOSART Semi. 2.4G Keyboard Mouse        id=13 [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad              id=16 [slave  pointer  (2)]
⎣ Virtual core keyboard (...)

Die vorgeschlagene Installation von synaptics tut nix (vgl. https://www.linuxmint.com/rel_ulyssa_cinnamon.php) dito evdev.

/usr/share/X11/xorg.conf.d/ enthält auf beiden Systemen keine separaten Eintrag für den TrackPoint/Touchpad.

Weiterer Unterschied bzw. Auffälligkeit:
user@Ubuntu:~$ ls /sys/devices/platform/i8042/serio1/serio2/
bind_mode    driver       id       mindrag          protocol    resolution   speed      upthresh
description  drvctl       inertia  modalias         rate        resync_time  subsystem  ztime
draghys      ext_dev      input    power            reach       sensitivity  thresh
drift_time   firmware_id  jenks    press_to_select  resetafter  skipback     uevent
und
user@LinuxMint ~ $ ls /sys/devices/platform/i8042/serio1/serio2/
bind_mode  description  drvctl  firmware_id  id  modalias  power  subsystem  uevent

Im Xorg.0.log ist keine Referenz zum TPPS/2 IBM TrackPoint zu finden.

Scheint ein udev-Problem zu sein?

Frage: Wie bekomme ich das Teil unter LM registriert?

Re: TrackPoint funktioniert nicht
« Antwort #1 am: 21.01.2021, 18:17:19 »
eher hardware defekt mint zu 99% ubuntu

Re: TrackPoint funktioniert nicht
« Antwort #2 am: 21.01.2021, 18:38:43 »
Scherzbold, dann würde es unter Ubuntu auch nicht funktionieren! ::)

Re: TrackPoint funktioniert nicht
« Antwort #3 am: 22.01.2021, 02:06:07 »
Probiere doch mal auf dem Thinkpad mit Ubuntu 20.04 den Mint 20.1 Live Stick oder DVD mit dem du auf dem anderen Lenovo installiert hast. Wenn das nicht funktionieren sollte, kann man den Hardwaredefekt ausschliessen.

Re: TrackPoint funktioniert nicht
« Antwort #4 am: 22.01.2021, 07:21:25 »
Moin,
ich hatte das Problem auch mal und bin damals darauf gestoßen: https://forums.linuxmint.com/viewtopic.php?t=273667. Mir hat das damals geholfen, allerdings muss ich sagen das seit LM19.3 - LM20.1 Cinnamon dieses Problem nicht mehr aufgetaucht ist.
Unter LM 19.3 ->Kernel 4.19.x; Lenovo 520 und 420
LM 20.1 Kernel 5.8.x; Lenovo 520
Vielleicht bringt dich das weiter...
Gruß
Wolfgang

mgwThreadstarter

  • *
Re: TrackPoint funktioniert nicht
« Antwort #5 am: 22.01.2021, 18:08:37 »
Moin,
ich hatte das Problem auch mal und bin damals darauf gestoßen: https://forums.linuxmint.com/viewtopic.php?t=273667. Mir hat das damals geholfen, allerdings muss ich sagen das seit LM19.3 - LM20.1 Cinnamon dieses Problem nicht mehr aufgetaucht ist.
Unter LM 19.3 ->Kernel 4.19.x; Lenovo 520 und 420
LM 20.1 Kernel 5.8.x; Lenovo 520
Vielleicht bringt dich das weiter...
Gruß
Wolfgang
Das war leider keine gute Idee und hat nicht funktioniert. :blank: Maustasten vertauscht... Trotzdem Danke für den Tipp.

mgwThreadstarter

  • *
Re: TrackPoint funktioniert nicht
« Antwort #6 am: 22.01.2021, 18:27:02 »
eher hardware defekt mint zu 99% ubuntu
Hmmm... hatte das Teil schon getauscht... ich schraube 'mal und melde mich wieder. Danke.

Re: TrackPoint funktioniert nicht
« Antwort #7 am: 22.01.2021, 18:30:17 »
AW#2 überlesen? Defekt ist eigentlich extremst unwahrscheinlich, wenn er unter Ubuntu funktioniert. ;)

Re: TrackPoint funktioniert nicht
« Antwort #8 am: 23.01.2021, 03:48:47 »
Moin,
ja schade, dass war wohl ein anderes Problem, kennst du dies schon: https://wiki.ubuntuusers.de/Trackpoint/?
Gruß
Wolfgang

mgwThreadstarter

  • *
Re: TrackPoint funktioniert nicht
« Antwort #9 am: 27.01.2021, 14:34:16 »
AW#2 überlesen? Defekt ist eigentlich extremst unwahrscheinlich, wenn er unter Ubuntu funktioniert. ;)
Vorsicht! - das sind zwei verschiedenen Geräte!

Re: TrackPoint funktioniert nicht
« Antwort #10 am: 27.01.2021, 14:36:59 »
Hatte ich miss verstanden. Und? Was war es nun? Defekt?

mgwThreadstarter

  • *
Re: TrackPoint funktioniert nicht
« Antwort #11 am: 27.01.2021, 14:44:28 »

mgwThreadstarter

  • *
Re: TrackPoint funktioniert nicht
« Antwort #12 am: 29.01.2021, 17:44:18 »
Hatte ich miss verstanden. Und? Was war es nun? Defekt?
Don't know yet. Die HW-Diagnose von Lenovo gibt auch nix her.