Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
27.02.2021, 23:47:00

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 718702
  • Themen insgesamt: 58130
  • Heute online: 717
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  AMD Rreiber für Radeon 5600 XT wird nicht verwendet  (Gelesen 809 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo Forum

Weihnachten habe ich für meinen Sohn einen neuen Computer gekauft (Einzelteile) und wir beide haben den zusammengeschraubt. Hat mal wieder viel Spass gemacht.
Da ich im letzten Jahr von Windows auf Linux Mint umgezogen bin hab ich das meinem Sohn auch installiert. Und das hat hervorragend funktioniert.
Einzig die Grafikkarte macht mir Sorgen weil der Treiber nicht funktioniert:
System:
  Kernel: 5.8.0-38-generic x86_64 bits: 64 Desktop: Cinnamon 4.8.6
  Distro: Linux Mint 20.1 Ulyssa
Machine:
  Type: Desktop System: Micro-Star product: MS-7C91 v: 1.0 serial: <filter>
  Mobo: Micro-Star model: MPG B550 GAMING EDGE WIFI (MS-7C91) v: 1.0
  serial: <filter> UEFI: American Megatrends v: 1.00 date: 05/29/2020
CPU:
  Topology: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP
  L2 cache: 3072 KiB
  Speed: 2200 MHz min/max: 2200/3600 MHz Core speeds (MHz): 1: 2194 2: 2197
  3: 2200 4: 2199 5: 2198 6: 2200 7: 2200 8: 2200 9: 2196 10: 2196 11: 2198
  12: 2200
Graphics:
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
  driver: N/A
  Display: x11 server: X.Org 1.20.9 driver: ati,fbdev
  unloaded: modesetting,radeon,vesa resolution: 1920x1080~77Hz
  OpenGL: renderer: llvmpipe (LLVM 10.0.1 256 bits) v: 3.3 Mesa 20.1.6
Audio:
  Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel
  Device-2: AMD Starship/Matisse HD Audio driver: snd_hda_intel
  Sound Server: ALSA v: k5.8.0-38-generic
Network:
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi
  IF: wlo1 state: up mac: <filter>
  Device-2: Realtek RTL8125 2.5GbE driver: N/A
Drives:
  Local Storage: total: 1.36 TiB used: 50.23 GiB (3.6%)
  ID-1: /dev/nvme0n1 vendor: Kingston model: SA2000M8500G size: 465.76 GiB
  ID-2: /dev/sda vendor: HGST (Hitachi) model: HTS721010A9E630
  size: 931.51 GiB
Partition:
  ID-1: / size: 456.96 GiB used: 50.22 GiB (11.0%) fs: ext4
  dev: /dev/nvme0n1p2
Sensors:
  System Temperatures: cpu: 48.2 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 304 Uptime: 7h 17m Memory: 15.65 GiB used: 3.54 GiB (22.6%)
  Shell: bash inxi: 3.0.38

Anfangs brauchte ich scheinbar keinen Treiber. Erst nach einem der letzten Updates bekomme ich immer nach dem Start die Meldung dass die Videobeschleunigung deaktiviert wäre und ich über die Treiberverwaltung nach neuen Treiber suchen soll (die genaue Meldung hab ich grad nicht parat). Wenn ich dann nach einem neuen Treiber suche wird keiner gefunden.
Dann hatte ich nach etlichem Suchen unter anderem hier im Forum die Info gefunden dass man auf einen neueren Kernel umstellen muss. Das habe ich dann auch getan an der Situation hat das aber nichts geändert.
Also wollte ich es mit den dedizierten AMD Treibern versuchen.
Ich habe hier den neuesten Treiber heruntergeladen: https://www.amd.com/de/support
Und dann nach dieser Anleitung versucht zu installieren: https://amdgpu-install.readthedocs.io/en/latest/preamble.html

Die Installation ist dann aber fehlgeschlagen (die Meldung hab ich nicht mehr). Nach meiner Suche hier im Forum hat einer geschrieben dass man die Treiber mit dem Befehl
./amdgpu-install --no-dkmsinstallieren können soll.
Das ist dann auch ohne Fehler durchgelaufen nur leider ohne Erfolg.
Wo und wie mache ich denn nun weiter?

Danke und Grüße
Henri

P.S. meine Kommataste ist kaputt nicht wundern  :D

Re: AMD Rreiber für Radeon 5600 XT wird nicht verwendet
« Antwort #1 am: 16.01.2021, 20:24:42 »
Herzlich willkommen im Grünen! :)

Die schlechte Nachricht lautet: mit topaktueller Hardware tut man sich bei Linux keinen Gefallen, da sind Schwierigkeiten programmiert. Du musst auf alle Fälle die neuesten Kernel haben, die du kriegen kannst. In der AV ist 5.8 der Neueste, aber über das Tool UMKI kannst du auch 5.10 bekommen.
https://www.linuxmintusers.de/index.php?action=wiki;page=Das_PPA_Mainline_mit_UMKI

Re: AMD Rreiber für Radeon 5600 XT wird nicht verwendet
« Antwort #2 am: 16.01.2021, 21:14:19 »
Und schau bitte auch zum Board-Hersteller.
BIOS/UEFI - Update
https://www.msi.com/Motherboard/support/MPG-B550-GAMING-EDGE-WIFI
Da gibt es eine Version vom 29.12.2020.

Sollte der von @toffifee erwähnte 5.10er genau 5.10.7 das Problem nicht lösen sollte, wäre noch der RC - Kernel 5.11-rc3 (ab Montag 5.11-rc4) installierbar.

vnt

  • **
Re: AMD Rreiber für Radeon 5600 XT wird nicht verwendet
« Antwort #3 am: 16.01.2021, 23:09:24 »
Hallo Henri,

mit dem 5.8 Kernel sollte die Graka eigentlich ohne den proprietären AMDGPU-Pro-Treiber laufen ... insbesondere, wenn das Problem erst seit einem Update besteht.
Falls Ihr Timeshift eingerichtet habt, wäre es eventuell möglich das System auf einem früheren Zeitpunkt zurückzusetzen, als noch alles funktioniert hat. Anschließend könntet Ihr selektiv Updates installieren und so der Ursache auf den Grund gehen.

Das letzte BIOS-Update aktualisiert lediglich die AMD-AGESA Version auf ComboAM4PIV2 1.1.9.0, sollte bei Euch noch das BIOS Version 7C91v13 vom 2020-08-31 oder eine Vorgängerversion installiert sein, würde ich mit dem dem AMD Ryzen 5 3600 nicht auf die neueste AMD-AGESA Version aktualisieren - welche im Wesentlichen lediglich die Unterstützung für die neue Ryzen 5000 Generation bringt - und falls zutreffend ein Update auf die vorgenannte BIOS Version durchführen.

Wenn das Problem erst seit einem Update besteht kann die Ursache nicht plötzlich eine fehlende generelle Unterstützung der Graka im Kernel 5.8 sein! ... allerdings könnte mit einem Kernel-Update durch einen Bug eine Inkompatibilität entstanden sein, was Ihr einfach dadurch testen könnt, indem Ihr das System mit einer älteren Version des 5.8 Kernel startet.

Gruß,
vnt
« Letzte Änderung: 16.01.2021, 23:50:50 von vnt »

Re: AMD Rreiber für Radeon 5600 XT wird nicht verwendet
« Antwort #4 am: 16.01.2021, 23:40:02 »
UEFI: American Megatrends v: 1.00 date: 05/29/2020

Ich habe mir das mit dem Update nicht aus den Fingern gesaugt.

vnt

  • **
Re: AMD Rreiber für Radeon 5600 XT wird nicht verwendet
« Antwort #5 am: 16.01.2021, 23:48:41 »
Ich habe mir das mit dem Update nicht aus den Fingern gesaugt.

Sorry, hatte ich überlesen   ;D ... dann gilt trotzdem meine Empfehlung für den Ryzen 5 3600 auf BIOS Version 7C91v13 vom 2020-08-31 zu aktualisieren.  8)


Gruß,
vnt


Nachtrag:
... eine weitere Möglichkeit die Fehlerursache zu suchen, wäre mittels Live-System auf Basis der LM 20.1 Cinnamon Edge ISO. Wenn es damit funktioniert, hat entweder die aktuelle 5.8.0-38 Kernel-Version einen Bug in Zusammenhang mit "Navi 10" oder Ihr habt Euch anderweitig das System zerschossen.

Die Empfehlung für das vorgenannte BIOS-Update gilt natürlich unabhängig davon.
« Letzte Änderung: 17.01.2021, 00:20:07 von vnt »

Re: AMD Rreiber für Radeon 5600 XT wird nicht verwendet
« Antwort #6 am: 17.01.2021, 11:48:01 »
Hallo zusammen,

da habt ihr mir ja erstmal ganz schön was zu tun gegeben. Ich würde das heute mal angehen und berichte gerne meine Erfahrungen. Ich finde es schade, dass es hierbei solche kniffligen Probleme zu lösen gibt, denn ich wollte meinen Sohn (12) gleich an Linux gewöhnen, bevor der Windows Virus ausbricht. Sowas schafft er aber nicht alleine und ich hab auch meine Probleme damit.

Ich freue mich aber, dass ich bei euch so gut aufgehoben bin  ;)

Viele Grüße
Henri

Re: AMD Rreiber für Radeon 5600 XT wird nicht verwendet
« Antwort #7 am: 17.01.2021, 11:55:02 »
Ich finde es schade, dass es hierbei solche kniffligen Probleme zu lösen gibt,
Dass Linux in Treiberdingen oft etwas hinterherhinkt ist ein alter Hut, den man aber kennen sollte. Leider stellen noch immer viele Hersteller keine Linuxtreiber zur Verfügung und manche nicht mal dazu notwendige Informationen. Das erschwert der Community die Arbeit.
Daher fährt man mit etwas älterer Hardware besser, wenn man es einfach haben möchte.

Re: AMD Rreiber für Radeon 5600 XT wird nicht verwendet
« Antwort #8 am: 17.01.2021, 14:00:22 »
Ok. Meine Tests bisher

Schritt 1 - BIOS Update
Und schau bitte auch zum Board-Hersteller.
BIOS/UEFI - Update
https://www.msi.com/Motherboard/support/MPG-B550-GAMING-EDGE-WIFI
Da gibt es eine Version vom 29.12.2020.
Habe ich erfolgreich durchgef[[hrt. Die Fehlermeldung erscheint aber immer noch.

Schritt 2 - Pruefen mit dem Bootstick und einem 20.1 Egde ISO
... eine weitere Möglichkeit die Fehlerursache zu suchen, wäre mittels Live-System auf Basis der LM 20.1 Cinnamon Edge ISO. Wenn es damit funktioniert, hat entweder die aktuelle 5.8.0-38 Kernel-Version einen Bug in Zusammenhang mit "Navi 10" oder Ihr habt Euch anderweitig das System zerschossen.

Hier kommt die Fehlermeldung nicht. Ich hab aber keine Ahnung wie ich die korrekte Funktionsweise der Grafikkarte hier testen soll. Die Ausgabe von inxi -fZ
ist hier nicht so aufschlussreich
CPU:       Topology: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP L2 cache: 3072 KiB
           Speed: 2197 MHz min/max: 2200/3600 MHz Core speeds (MHz): 1: 2200 2: 2200 3: 2199 4: 2198 5: 2198 6: 2200 7: 2199
           8: 2200 9: 2198 10: 2193 11: 2200 12: 2198
           Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 bmi2 bpext cat_l3 cdp_l3 clflush
           clflushopt clwb clzero cmov cmp_legacy constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total cqm_occup_llc
           cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht
           hw_pstate ibpb ibs irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx
           nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq pdpe1gb perfctr_core
           perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse pse36 rdpid rdpru rdrand rdseed rdt_a rdtscp rep_good sep sev
           sha_ni skinit smap smca sme smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce
           topoext tsc tsc_scale umip v_vmsave_vmload vgif vmcb_clean vme vmmcall wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr
           xsaveopt xsaves

Schritt 3 - Kernelupdate
da bin ich grad dran melde mich

Re: AMD Rreiber für Radeon 5600 XT wird nicht verwendet
« Antwort #9 am: 17.01.2021, 14:04:39 »
Die Ausgabe von inxi -fZ
ist hier nicht so aufschlussreich
Kein Wunder, da du den Befehl falsch schreibst! Linux unterscheidet streng Groß- und Kleinschrift!
inxi -FzIm Terminal ist exaktes Arbeiten angesagt. ;)

vnt

  • **
Re: AMD Rreiber für Radeon 5600 XT wird nicht verwendet
« Antwort #10 am: 17.01.2021, 14:07:30 »
Ich finde es schade, dass es hierbei solche kniffligen Probleme zu lösen gibt, denn ich wollte meinen Sohn (12) gleich an Linux gewöhnen, bevor der Windows Virus ausbricht.

Hallo Henri,

aus langjähriger Erfahrung mit der Wartung meines eigenen Windows-PC und von Windows Rechnern in der Familie und von Freunden und Bekannten kann ich Dir sagen, dass die Mär des unproblematischen Windows betreffend "knifflige Problemen" ins Reich der Mythen und Legenden gehört und mit Windows 10, dem "besten Windows aller Zeiten" keinesfalls wahrer geworden ist. Aus diesem Grund bin ich, nachdem ich nach dem Supportende für Windows 7 mit meinem privaten Rechner auf Linux Mint umgestiegen, zunächst LM 19 als Dual-Boot System mit Windows 7 und bin jetzt mit meinem eigenen, neuen PC seit Mitte letzten Jahres mit dem Erscheinen von LM 20 komplett ohne Windows glücklich.

Nur als Beispiel was man mit Windows 10 alleine durch die halbjährlichen Feature Updates so alles an Problemen bekommen kann: ständige WLAN-Abbrüche, die nur durch das komplette Zurücksetzen der Netzwerkkomponenten und die Auswahl eines älteren WLAN-Treibers beseitigt werden können; ein für das Feature-Update notwendiges BIOS-Update führt anschließend auf einem Business-Serien-Laptop zu gelegentlichen BSOD beim Einschalten; Windows aktualisiert Treiber selbständig trotz gegenteiliger Einstellung und erst das Zurückgehen auf die vorherige Treiberversion nach Nachfrage, warum und ob man das wirklich möchte, stoppt diesen Irrsinn. Abgesehen davon sind die monatlichen Windows-Updates im Vergleich zu den Linux-Updates häufig ein gutes Geduldstraining.

Soviel dazu  ;D


Gruß,
vnt
« Letzte Änderung: 17.01.2021, 16:42:28 von vnt »

Re: AMD Rreiber für Radeon 5600 XT wird nicht verwendet
« Antwort #11 am: 17.01.2021, 14:10:56 »
AMD Navi 10 würde prinzipiell schon mit Kernel 5.4 laufen, siehe
https://www.phoronix.com/scan.php?page=article&item=ubuntu-2004-59mesa203&num=1

Kernel 5.8 wäre sicherlich besser.
Falls nicht mehr zu klären ist, welcher Update das Problem verursacht hat, besser neu installieren.


Re: AMD Rreiber für Radeon 5600 XT wird nicht verwendet
« Antwort #12 am: 17.01.2021, 14:11:40 »
vnt kann ich nur zustimmen. Bei Linux gibt es eigentlich nur 2 größere Problemquellen: allzu neue oder exotische Hardware und allzu experimentierfreudige User, die die dabei notwendige Vorsicht vermissen lassen. ;)

Re: AMD Rreiber für Radeon 5600 XT wird nicht verwendet
« Antwort #13 am: 17.01.2021, 14:16:34 »
Kein Wunder, da du den Befehl falsch schreibst! Linux unterscheidet streng Groß- und Kleinschrift!
inxi -FzIm Terminal ist exaktes Arbeiten angesagt. ;)

Du hast natuerlich vollkommen Recht sorry!
Hier die Ausgabe
mint@mint:~$ inxi -Fz
System:    Kernel: 5.8.0-33-generic x86_64 bits: 64 Desktop: Cinnamon 4.8.5 Distro: Linux Mint 20.1 Ulyssa
Machine:   Type: Desktop System: Micro-Star product: MS-7C91 v: 1.0 serial: <filter>
           Mobo: Micro-Star model: MPG B550 GAMING EDGE WIFI (MS-7C91) v: 1.0 serial: <filter> UEFI: American Megatrends LLC.
           v: 1.53 date: 12/24/2020
CPU:       Topology: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP L2 cache: 3072 KiB
           Speed: 2198 MHz min/max: 2200/3600 MHz Core speeds (MHz): 1: 2200 2: 2197 3: 2200 4: 2191 5: 2200 6: 2199 7: 2197
           8: 2200 9: 2199 10: 2193 11: 2200 12: 2192
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] driver: amdgpu
           v: kernel
           Display: x11 server: X.Org 1.20.8 driver: amdgpu,ati unloaded: fbdev,modesetting,radeon,vesa
           resolution: 1920x1080~60Hz
           OpenGL: renderer: AMD Radeon RX 5600 XT (NAVI10 DRM 3.38.0 5.8.0-33-generic LLVM 10.0.0) v: 4.6 Mesa 20.0.8
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Navi 10 HDMI Audio driver: snd_hda_intel
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio driver: snd_hda_intel
           Sound Server: ALSA v: k5.8.0-33-generic
Network:   Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi
           IF: wlo1 state: up mac: <filter>
           Device-2: Realtek RTL8125 2.5GbE driver: N/A
Drives:    Local Storage: total: 1.39 TiB used: 105.6 MiB (0.0%)
           ID-1: /dev/nvme0n1 vendor: Kingston model: SA2000M8500G size: 465.76 GiB
           ID-2: /dev/sda vendor: HGST (Hitachi) model: HTS721010A9E630 size: 931.51 GiB
           ID-3: /dev/sdb type: USB vendor: SanDisk model: Ultra USB 3.0 size: 28.64 GiB
Partition: ID-1: / size: 7.81 GiB used: 60.4 MiB (0.8%) fs: overlay source: ERR-102
           ID-2: /var/log size: 26.03 GiB used: 45.1 MiB (0.2%) fs: ext4 dev: /dev/sdb3
Sensors:   System Temperatures: cpu: 31.9 C mobo: N/A gpu: amdgpu temp: 38 C
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
Info:      Processes: 333 Uptime: 1m Memory: 15.62 GiB used: 1002.8 MiB (6.3%) Shell: bash inxi: 3.0.38

Re: AMD Rreiber für Radeon 5600 XT wird nicht verwendet
« Antwort #14 am: 17.01.2021, 14:18:19 »
Partition: ID-1: / size: 7.81 GiB used: 60.4 MiB (0.8%) fs: overlay source: ERR-102
           ID-2: /var/log size: 26.03 GiB used: 45.1 MiB (0.2%) fs: ext4 dev: /dev/sdb3


Das sieht nicht gut aus! Vergleiche mal mit oben!
Zeige bitte mal
lsblk
« Letzte Änderung: 17.01.2021, 14:22:52 von toffifee »