Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
28.09.2020, 20:56:55

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24570
  • Letzte: sirit
Statistiken
  • Beiträge insgesamt: 685266
  • Themen insgesamt: 55462
  • Heute online: 668
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  keinen Bootloader nach Installation Linux MInt Lisa / Windows 7  (Gelesen 19045 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #45 am: 24.03.2012, 23:27:38 »
Mal ne ganz blöde frage: Ist ev. im bios die option aktiv das der bootsektor geschützt ist?

Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #46 am: 24.03.2012, 23:31:09 »
mint / # grub-install --recheck /dev/sda
Installation finished. No error reported.
mint / # update-grub
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.0.0-12-generic
Found initrd image: /boot/initrd.img-3.0.0-12-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Windows 7 (loader) on /dev/sda1
Found Windows 7 (loader) on /dev/sda2
done
mint / # fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\""
/dev/sda: Kein GRUB a78
/dev/sda1: Kein GRUB 55aa
/dev/sda2: Kein GRUB 55aa
/dev/sda3: Kein GRUB 00
/dev/sda4: Kein GRUB 55aa
/dev/sda5: Kein GRUB 00
/dev/sda6: Kein GRUB 00
/dev/sdc: Kein GRUB 7c66
/dev/sdc1: Kein GRUB 7815
mint / # grub-install --force /dev/sda
Installation finished. No error reported.
mint / # update-grub
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.0.0-12-generic
Found initrd image: /boot/initrd.img-3.0.0-12-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Windows 7 (loader) on /dev/sda1
Found Windows 7 (loader) on /dev/sda2
done
mint / # fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\""
/dev/sda: Kein GRUB a78
/dev/sda1: Kein GRUB 55aa
/dev/sda2: Kein GRUB 55aa
/dev/sda3: Kein GRUB 00
/dev/sda4: Kein GRUB 55aa
/dev/sda5: Kein GRUB 00
/dev/sda6: Kein GRUB 00
/dev/sdc: Kein GRUB 7c66
/dev/sdc1: Kein GRUB 7815
mint / #

inzwischen sind wir weit  ueber meine Kenntnisse raus, aber kann das Problem vielleicht doch noch woanders liegen? Bios? Bootsektor geschuezt?

Frieder108

  • Gast
Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #47 am: 24.03.2012, 23:35:16 »
Hm, mir gehen die Ideen aus - und der Gedanke von Raven hat was.

Womöglich hat es doch was mit der Recovery-Partition zu tun.

Was fürein Lenovo hast du da eigentlich im Einsatz?

Ich hab selber mehrere ThinkPads hier im Haus zu verwalten, aber da gab es noch nie Probleme damit.

Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #48 am: 24.03.2012, 23:36:17 »
Lenovo M91 /  Windows 7 Prof.

Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #49 am: 24.03.2012, 23:37:25 »
Hm, geschützt, kann sein... oder auch nicht sein.  :'(
Aber ich würd jetzt doch mal raus aus der chroot-Umgebung mit
exit/mnt nicht aushängen, sondern die root-directory-Methode jetzt probieren mit
sudo grub-install --root-directory=/mnt /dev/sdasudo update-grub
Dann noch einmal Abfrage mit dem Befehl da. Und dann, was immer das Ergebnis sei, würde ich es drauf ankommen lassen und mal versuchen, neu zu starten. Vielleicht ist es ja auch doch schon gegangen und nur die Abfrage tut grad nicht richtig.

Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #50 am: 24.03.2012, 23:37:37 »
Im bios gibt es bei gewissen geräten eine option. Heisst je nach hersteller immer anders. Von "protect boot sector" bis "virus protection" oder sowas habe ich schon vieles gesehen. Das muss sowas sein, anders kann man das nicht erklären.

Frieder108

  • Gast
Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #51 am: 24.03.2012, 23:46:21 »
so was ähnliches wie leonidas wollte ich auch gerade vorschlagen - ich würds auch mal drauf ankommen lassen.

Also wie empfohlen mit "exit" raus aus chroot  und der Anleitung von leo folgen.

Den Ansatz von Raven sollte man auch mal weiter verfolgen.

@ Dirk, haste mal nen Link zu deinem M91 - die Reihe ist mir nämlich völlig unbekannt.

Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #52 am: 24.03.2012, 23:49:46 »
sorrr / habe gerade mal im Bios nachgeschaut / da ist nix


Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #54 am: 24.03.2012, 23:56:10 »
mint / # exit
exit
mint@mint ~ $ sudo grub-install --root-directory=/mnt /dev/sda
grub-probe: error: cannot find a device for /boot (is /dev mounted?).
Installation finished. No error reported.
mint@mint ~ $

habe euch gegnueber langsam ein schlechtes Gewissen....

Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #55 am: 25.03.2012, 00:00:17 »
Mach erst nochmal
sudo mount --bind /dev/ /mnt/devund dann nochmal
sudo grub-install --root-directory=/mnt /dev/sdasudo update-grub

Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #56 am: 25.03.2012, 00:02:17 »
mint@mint ~ $ sudo mount --bind /dev/ /mnt/dev
mint@mint ~ $ sudo grub-install --root-directory=/mnt /dev/sda
grub-probe: error: cannot find a device for /boot (is /dev mounted?).
Installation finished. No error reported.
mint@mint ~ $ sudo update-grub
/usr/sbin/grub-probe: error: cannot find a device for / (is /dev mounted?).
mint@mint ~ $

Sauron

  • Gast
Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #57 am: 25.03.2012, 00:03:23 »
/dev/sda  :)

Frieder108

  • Gast
Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #58 am: 25.03.2012, 00:03:45 »
habe euch gegnueber langsam ein schlechtes Gewissen....

brauchste nicht zu haben - du machst ja auch super mit  8)

Und wenn wir zu keinem Ergebniss kommen, dann hast du zumindest erfahren, wie man Codeblocks erstellt  ;D

Frieder

Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #59 am: 25.03.2012, 00:05:05 »
wahrscheinlich habe ich nach dem neuboot was falsch gemacht...?

mint@mint ~ $ sudo mount /dev/sda5 /mnt
mint@mint ~ $ sudo mount -o bind /dev /mnt/dev
mint@mint ~ $ sudo mount -o bind /sys /mnt/sys
mint@mint ~ $ sudo mount -t proc /proc /mnt/proc
mint@mint ~ $ sudo cp /proc/mounts /mnt/etc/mtab
mint@mint ~ $ sudo cp /etc/resolv.conf /mnt/etc/resolv.conf
mint@mint ~ $ sudo chroot /mnt /bin/bash
mint / # exit
exit

dies habe ich nach dem Neustart eingegeben....