Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
15.09.2019, 22:53:02

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22539
  • Letzte: KlaSchu58
Statistiken
  • Beiträge insgesamt: 607928
  • Themen insgesamt: 49200
  • Heute online: 573
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema:  keinen Bootloader nach Installation Linux MInt Lisa / Windows 7  (Gelesen 17553 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #30 am: 24.03.2012, 23:03:42 »
Dann ohne sudo wieder!, also nur
for d in $(sed -ne 's/^.*\(sd.*\)/\1/p' /proc/partitions);do echo -e "$d\t ID: $(hexdump -v -s 0x80 -n 2 -e '2/1 "%x" "\n"' /dev/$d)";done;echo -e "\nGRUB 1: 5272/aa75\nGRUB 2: 7c3c/48b4/020"

Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #31 am: 24.03.2012, 23:06:36 »
mint / # for d in $(sed -ne 's/^.*\(sd.*\)/\1/p' /proc/partitions);do echo -e "$d\t ID: $(hexdump -v -s 0x80 -n 2 -e '2/1 "%x" "\n"' /dev/$d)";done;echo -e "\nGRUB 1: 5272/aa75\nGRUB 2: 7c3c/48b4/020"
sda ID: a78
sda1 ID: 55aa
sda2 ID: 55aa
sda3 ID: 00
sda4 ID: 55aa
sda5 ID: 00
sda6 ID: 00
sdc ID: 7c66
sdc1 ID: 7815

GRUB 1: 5272/aa75
GRUB 2: 7c3c/48b4/020
mint / #

Frieder108

  • Gast
Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #32 am: 24.03.2012, 23:09:01 »

schaut, soweit ich das beurteilen kann, doch ganz gut aus - warten wir mal noch leo´s Analyse ab

Sauron

  • Gast
Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #33 am: 24.03.2012, 23:10:49 »
fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\""

Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #34 am: 24.03.2012, 23:12:01 »
mint / # fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\""
/dev/sda: Kein GRUB a78
/dev/sda1: Kein GRUB 55aa
/dev/sda2: Kein GRUB 55aa
/dev/sda3: Kein GRUB 00
/dev/sda4: Kein GRUB 55aa
/dev/sda5: Kein GRUB 00
/dev/sda6: Kein GRUB 00
/dev/sdc: Kein GRUB 7c66
/dev/sdc1: Kein GRUB 7815
mint / #

Sauron

  • Gast
Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #35 am: 24.03.2012, 23:13:15 »
sudo grub-install --root-directory=/mnt /dev/sda

Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #36 am: 24.03.2012, 23:14:35 »
mint / # sudo grub-install --root-directory=/mnt /dev/sda
sudo: unable to resolve host mint
Installation finished. No error reported.
mint / #

ohne sudo ?

Sauron

  • Gast
Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #37 am: 24.03.2012, 23:15:47 »
Nein, ist doch durchgelaufen. Mal noch update-grub und wieder den Befehl  fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\""

Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #38 am: 24.03.2012, 23:17:34 »
mint / # update-grub
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.0.0-12-generic
Found initrd image: /boot/initrd.img-3.0.0-12-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Windows 7 (loader) on /dev/sda1
Found Windows 7 (loader) on /dev/sda2
done
mint / # fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\""
/dev/sda: Kein GRUB a78
/dev/sda1: Kein GRUB 55aa
/dev/sda2: Kein GRUB 55aa
/dev/sda3: Kein GRUB 00
/dev/sda4: Kein GRUB 55aa
/dev/sda5: Kein GRUB 00
/dev/sda6: Kein GRUB 00
/dev/sdc: Kein GRUB 7c66
/dev/sdc1: Kein GRUB 7815
mint / #

Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #39 am: 24.03.2012, 23:18:38 »
nicht gut - oder?

Sauron

  • Gast
Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #40 am: 24.03.2012, 23:19:20 »
OK. Die Abfrage muss angepasst werden.

Zuerst
exitdann die gemounteten Sachen wieder aushängen und neu starten.

Frieder108

  • Gast
Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #41 am: 24.03.2012, 23:20:05 »
also ich hätt jetzt grub-install --recheck /dev/sda und wenn das nicht hilft grub-install --force /dev/sda vorgeschlagen und dann jeweils nochmals den Befehl mit den vielen "kein Grub" durchlaufen lassen.

Grüßle

Frieder

p.s. du darfst die "Chroot-Umgebung" jedenfalls nicht einfach verlassen,( nur so am Rande Bemerkt) jetzt mußt du hier bleiben bis zum (bitteren?) Ende  ;D :P

Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #42 am: 24.03.2012, 23:20:55 »
Ja, hätt ich auch erst noch probiert.
Mach mal
grub-install --recheck /dev/sdaupdate-grub
Er ist ja in der chroot-Umgebung, da kann er nicht /mnt als root-directory nehmen.

Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #43 am: 24.03.2012, 23:24:08 »
mint / # grub-install --recheck /dev/sda
Installation finished. No error reported.
mint / # fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\""
/dev/sda: Kein GRUB a78
/dev/sda1: Kein GRUB 55aa
/dev/sda2: Kein GRUB 55aa
/dev/sda3: Kein GRUB 00
/dev/sda4: Kein GRUB 55aa
/dev/sda5: Kein GRUB 00
/dev/sda6: Kein GRUB 00
/dev/sdc: Kein GRUB 7c66
/dev/sdc1: Kein GRUB 7815
mint / # grub-install --force /dev/sda
Installation finished. No error reported.
mint / # fdisk -l 2>/dev/null | egrep "Disk /|/dev/" | sed "s#^/dev/#Part /dev/#" | awk '{print $2}' | sed 's/://' | xargs -n1 -IX sh -c "hexdump -v -s 0x80 -n  2 -e '2/1 \"%x\" \"\\n\"' X | xargs -n1 -IY sh -c \"case  \"Y\" in '48b4') echo X: GRUB 2 v1.96 ;; 'aa75' | '5272') echo X: GRUB Legacy ;; '7c3c') echo X: GRUB 2 v1.97 oder v1.98 ;; '020') echo X: GRUB 2 v1.99 ;; *) echo X: Kein GRUB Y ;; esac\""
/dev/sda: Kein GRUB a78
/dev/sda1: Kein GRUB 55aa
/dev/sda2: Kein GRUB 55aa
/dev/sda3: Kein GRUB 00
/dev/sda4: Kein GRUB 55aa
/dev/sda5: Kein GRUB 00
/dev/sda6: Kein GRUB 00
/dev/sdc: Kein GRUB 7c66
/dev/sdc1: Kein GRUB 7815
mint / #

habe mich mal dafuer entschieden.... ::)
leider ohne Erfolg.

Frieder108

  • Gast
Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #44 am: 24.03.2012, 23:26:33 »
blödes "update-grub", das vergess ich immer (danke leo) -den mußt du natürlich auch immer machen.

Sorry, mein Fehler