Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
14.11.2019, 01:37:27

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22802
  • Letzte: F7even
Statistiken
  • Beiträge insgesamt: 619066
  • Themen insgesamt: 49963
  • Heute online: 624
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online
Mitglieder: 1
Gäste: 516
Gesamt: 517

Autor Thema:  keinen Bootloader nach Installation Linux MInt Lisa / Windows 7  (Gelesen 17751 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo zusammen,

habe Linux MInt Lisa auf meinem PC neben Windows 7 Prof. installiert. Beim Neustart bekomme ich jedoch keine Auswahlmenü, sondern Windows startet direkt durch. Wie komme ich nun zum Auswahlmenü um das passende Betriebssystem zu wählen?

Herzlichen Dank!

PS: gleicher Installationsvorgang hat bei meinem Laptop problemlos geklappt. Hier kann ich beim starten auswählen welches Betriebssystem startet...

Hallo Dirkschwarz,

normalerweise wirst Du beim Installieren gefragt ob und wohin Du Grub, also den Bootloader von Linux installieren willst.
Standardmäßig landet der dann im Masterboootrecord Deiner Festplatte.

Das Problem schlägt öfter hier auf, schau Dir einfach mal den Lösungsvorschlag von Frieder aus einem anderen Thread an,
der installiert Dir Grub neu: https://www.linuxmintusers.de/index.php?topic=5841.msg49524#msg49524

Du benötigst dafür nur eine beliebige Linux Live CD und schon kann es losgehen.

gruß
gas

klappt leider immer noch nicht....bekomme kein Auswahlmenü von GRUB angezeigt. Windows startet einfach durch!!

SuperGrub Disk erkennt Linux MInt und Windows und ich kann problemlos beide starten!

sudo update-grub
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.0.0-12-generic
Found initrd image: /boot/initrd.img-3.0.0-12-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Windows 7 (loader) on /dev/sda1
Found Windows 7 (loader) on /dev/sda2
done

sudo fdisk -l
Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 Köpfe, 63 Sektoren/Spur, 38913 Zylinder, zusammen 625142448 Sektoren
Einheiten = Sektoren von 1 × 512 = 512 Bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xf4f895e3

   Gerät  boot.     Anfang        Ende     Blöcke   Id  System
/dev/sda1   *        2048     2459647     1228800    7  HPFS/NTFS/exFAT
/dev/sda2         2459648   386662399   192101376    7  HPFS/NTFS/exFAT
/dev/sda3       386664446   604659711   108997633    5  Erweiterte
/dev/sda4       604659712   625139711    10240000    7  HPFS/NTFS/exFAT
/dev/sda5       386664448   592435199   102885376   83  Linux
/dev/sda6       592437248   604659711     6111232   82  Linux Swap / Solaris

Ich finde keine Lösung. Auch das Inet hat mir nicht wirklich weitergeholfen...hat noch jemand eine Idee?

Danke!

Sauron

  • Gast
Wenn Du mit SuperGrubDisk Mint gestartet hast dann probier mal Grub in /sda zu installieren. sudo grub-install /dev/sda und Grub updaten sudo update-grub

Frust!!!!

beide Befehle ohne Fehlermeldung ausgeführt! -> Neustart -> KEIN Grub-Menü, direkter Start von Windows :-((

 - noch jemand eine Idee oder einen Hinweis?

Frieder108

  • Gast
ok, neuer Versuch - hast du eine Live-Version mit der gleichen Architektur (32/64 Bit) wie das installierte System - wenn ja, dann starte die mal und meld dich aus dem Live-System heraus

Greetz

Frieder

Sauron

  • Gast
Und mal zeigen wo Grub installiert ist grub-probe -t device /boot/grub Oder handelt es sich um GPT ?

@Frieder108

bin jetzt mal mit einen Live/-System / Linux Mint drauf...und nu   ;D

Frieder108

  • Gast
...und nu   ;D

nu versuchen wir mal, dein Problem zu lösen.

Als erstes hätte ich jetzt gerne nochmal die sudo fdisk -l haste zwar schon mal weiter vorne gebracht - aber sicher ist sicher ;)

sudo fdisk -l

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xf4f895e3

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048     2459647     1228800    7  HPFS/NTFS/exFAT
/dev/sda2         2459648   386662399   192101376    7  HPFS/NTFS/exFAT
/dev/sda3       386664446   604659711   108997633    5  Extended
/dev/sda4       604659712   625139711    10240000    7  HPFS/NTFS/exFAT
/dev/sda5       386664448   592435199   102885376   83  Linux
/dev/sda6       592437248   604659711     6111232   82  Linux swap / Solaris

Disk /dev/sdc: 4016 MB, 4016046080 bytes
66 heads, 25 sectors/track, 4753 cylinders, total 7843840 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000eefca

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1   *        2048     7843839     3920896    c  W95 FAT32 (LBA)
« Letzte Änderung: 24.03.2012, 21:44:38 von dirkschwarz »

Frieder108

  • Gast
Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #10 am: 24.03.2012, 21:43:55 »
Ok, jetzt tu mir noch den Gefallen, und setz das Ganze in nen Codeblock, das brauchen wir noch ein paar mal und das macht für mich und andere, die mitlesen, die geschichte übersichtlicher.

Geh dazu nochmal auf deinen Beitrg, klicke auf ändern > markiere die Terminalausgabe mit der Maus > klicke auf das #-Symbol oberhalb der Smileys und du bekommst so eine Ausgabe  ;)
Wie gesagt, das macht es übersichtlicher und wir brauchen das noch ein paar mal.

Übrigens, bitte bei den Befehlen und den entsprechenden Ausgaben immer mit Copy+Paste arbeiten, selbst ein Leer-Zeichen ist wichtig.

Bis gleich

Frieder

Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #11 am: 24.03.2012, 21:45:21 »
erledigt...

Frieder108

  • Gast
Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #12 am: 24.03.2012, 21:55:30 »
sauberle, sieht doch gleich viel besser aus ;)

ok, jetzt nacheinander sudo mount /dev/sdxY /mnt sudo mount -o bind /dev /mnt/dev sudo mount -o bind /sys /mnt/sys sudo mount -t proc /proc /mnt/proc sudo cp /proc/mounts /mnt/etc/mtab sudo cp /etc/resolv.conf /mnt/etc/resolv.conf sudo chroot /mnt /bin/bash
wenn bis hierher alles sauber durchläuft, dann befindest du dich in deinem installierten System

viel Erfolg - bis gleich

Frieder

p.s. eventuelle Fehlermeldungen natürlich bitte posten

Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #13 am: 24.03.2012, 22:04:58 »
mint@mint ~ $ sudo mount /dev/sda5 /mnt
mint@mint ~ $ sudo mount -o bind /dev /mnt/dev
mint@mint ~ $ sudo mount -o bind /sys /mnt/sys
mint@mint ~ $ sudo mount -t proc /proc /mnt/proc
mint@mint ~ $ sudo cp /proc/mounts /mnt/etc/mtab
mint@mint ~ $ sudo cp /etc/resolv.conf /mnt/etc/resolv.conf
mint@mint ~ $ sudo chroot /mnt /bin/bash
mint / #

KEINE Fehler bisher... :)

Frieder108

  • Gast
Re: keinen Bootloader nach Installation Linux MInt Lisa / Windows 7
« Antwort #14 am: 24.03.2012, 22:12:13 »
super

jetzt mal das, was Sauron vorher schon mal angefragt hat grub-probe -t device /boot/grub evtl muß da noch ein "sudo" vorne dran.

Mußte einfach kurz durchprobieren, wär ganz interessant, zu sehen, ob und wenn ja, wohin sich Grub verkümmelt hat (ich denke, XP hat den geplättet)

Grüßle

Frieder