Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
22.01.2021, 14:31:29

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25121
  • Letzte: panThomas
Statistiken
  • Beiträge insgesamt: 710106
  • Themen insgesamt: 57405
  • Heute online: 700
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  Libreoffice versendet nach Update keine Mailangänge mehr  (Gelesen 711 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Libreoffice versendet nach Update keine Mailangänge mehr
« am: 13.01.2021, 15:26:30 »
Hallo Linux-Gemeinde,
vor einiger Zeit bin ich auch von Windows auf Linux-Mint umgestiegen und ein zufriedener Nutzer.

Zur Zeit verwende ich Mint 19 Cinammon.

Kürzlich habe ich mein Libreoffice auf die Version 7.0.4.2 aktualisiert. Seitdem kann ich keine Dateien mehr als Mailanhang oder als PDF versenden. Hat bis vor dem Update einwandfrei funktioniert.

Als Standardmailprogramm dient Thunderbird und ist in den Einstellungen auch so festgelegt.

Ich habe schon das Netz und auch dieses Forum durchgesucht, aber die bisher gefundenen vorgeschlagenen Tipps funktionierten bei mir leider nicht:

Ich habe in Libreoffice unter Optionen > Internet > E-Mail verschiedene Sachen eingetragen: thunderbird oder /usr/bin/thunderbird oder noch anderes. Es erfolgt keinerlei Reaktion.

Wenn ich hier das Feld Email leer lasse und dann auf Als-Mail-versenden gehe, kommt ein Popup, indem ich gefragt werde, mit welchem Programm ich die Datei öffnen möchte. Thunderbird ist dabei vorgeschlagen. Klicke ich das an, geht eine neu verfasste Mail auf, als Betreff ist bereits der Dateiname eingetragen, aber der Anhang fehlt und muss händisch hinzugefügt werden.

Hat mir jemand eine Lösung?

Danke im Voraus und

Gruß aus Tuttlingen

Rainer
« Letzte Änderung: 19.01.2021, 18:58:20 von westwaerts »

Re: Libreoffice versendet nach Update keine Mailangänge mehr
« Antwort #1 am: 13.01.2021, 15:54:15 »
Hallo Rainer,
probiere einmal diese Zeile einzugeben:  /etc/thunderbird/syspref.js

Re: Libreoffice versendet nach Update keine Mailangänge mehr
« Antwort #2 am: 13.01.2021, 16:52:43 »
@Antwort 1: Nachdem ich mich durch den langen Thread durchgelesen habe, scheint es demnach ein Problem von Thunderbird 68.xx zu sein, da es wohl mit Thunderbird 78.xxx wieder funktioniert. Also abwarten, bis auch LM das Update installiert?

Ach so, ich hab noch überprüft, ob ich aus Nemo mit Rechtsklick Dateien versenden kann. Das geht auch nicht mehr. Ging früher immer und wurde rege genutzt.

@Antwort 2: Ich gehe davon aus, dass du meinst, ich solle die Zeile in LO bei Optionen > Internet > EMail eintragen. Hab ich gemacht. Effekt ist der gleiche, wie wenn nix drin steht. (Popup mit Vorschlag Thunderbird, dann neue TB-Mail mit Dateiname im Betreff aber ohne Anhang


Vielen Dank mal an euch zwei, vielleicht gibt es ja noch mehr Vorschläge?

Gruß
Rainer

Re: Libreoffice versendet nach Update keine Mailangänge mehr
« Antwort #3 am: 14.01.2021, 10:36:52 »
Hallo Rainer,
bei mir ist Thunderbirdversion 68.10.0 (64-Bit)  installiert und es funktioniert wie von Dir gewünscht. Einstellungen in LibreOffice siehe Anhang.

Re: Libreoffice versendet nach Update keine Mailangänge mehr
« Antwort #4 am: 14.01.2021, 13:55:01 »
...

@Antwort 2: Ich gehe davon aus, dass du meinst, ich solle die Zeile in LO bei Optionen > Internet > EMail eintragen. Hab ich gemacht. Effekt ist der gleiche, wie wenn nix drin steht. (Popup mit Vorschlag Thunderbird, dann neue TB-Mail mit Dateiname im Betreff aber ohne Anhang
...
Bei mir klappt es jetzt auch mit /etc/thunderbird/syspref.js als Eintrag in LO. @mint13 Danke für den Hinweis. Ohne diesen Eintrag hat sich immer nur eine leere eMail ohne Anhang geöffnet, da in den Systemeinstellungen Thunderbird als eMail-Programm eingestellt ist.

Noch ein Rainer

Re: Libreoffice versendet nach Update keine Mailangänge mehr
« Antwort #5 am: 14.01.2021, 21:25:52 »
Rainer 2: Bitte gern geschehen. Ich kann ja sonst wenig helfen.





Re: Libreoffice versendet nach Update keine Mailangänge mehr
« Antwort #6 am: 14.01.2021, 21:43:17 »
Der neue Stand:

Heute hatten wir zufällig Besuch einer Linux-Expertin, die ich dann auch um Rat gefragt habe. Die hat gemeint, dass es wohl daran liegt, dass ich aus Fremdquellen das LO 7.0.4 installiert habe, das vielleicht geänderte Parameter zur Dateiübergabe an Thunderbird drin hat, und dass das alte Thunderbird diese nicht versteht.

Wir haben dann mal das ganze neue Zeug (auch anderes aus Fremdquellen) rausgeworfen und mein Mint in mehreren Schritten von 19 auf 20.1 aktualisiert. Jetzt ist das LO 7.0.4 ganz normal im offiziellen Paket enthalten, Thunderbird ist aber immer noch 68.xxxx.

Wenn ich gar nichts in der Mail-Zeile in den Einstellungen von LO schreibe, startet es wieder eine leere Mail mit Betreff, aber leider ohne Anhang.

Das Problem ist also immer noch da. Eure anderen Tipps habe ich auch mit der neuen LM-Version noch einmal probiert, aber ohne Erfolg.

Tja, vielleicht kommt irgendwann das Update von Thunderbird ins reguläre Paket und dann geht ja vielleicht alles wieder ...

Danke nochmal an alle und
Gruß aus dem verschneiten Tuttlingen
Rainer

Re: Libreoffice versendet nach Update keine Mailangänge mehr
« Antwort #7 am: 14.01.2021, 21:48:03 »
Ach so, noch ein Nachtrag:

Das Versenden von Dateien mit Rechtsklick direkt aus Nemo hat zwischendurch wieder funktioniert, auch MIT Anhang.

Aber jetzt habe ich festgestellt, dass im Nemo des aktuellen 20.1. bei Rechtsklick gar keine Schaltfläche "Senden" mehr auftaucht. Schade. Habe ich gern und oft benutzt.

Re: Libreoffice versendet nach Update keine Mailangänge mehr
« Antwort #8 am: 14.01.2021, 23:01:28 »
Seitdem kann ich keine Dateien mehr als Mailanhang oder als PDF versenden.
Kannst du  die Anhänge tatsächlich gar nicht mehr versenden oder vermisst du nur die Automatik mit dem entsprechende Kontextmenü in Nemo?

Die wurde nämlich kürzlich von den Mintentwicklern aus Sicherheitsgründen bis auf weiteres entfernt.

Re: Libreoffice versendet nach Update keine Mailangänge mehr
« Antwort #9 am: 15.01.2021, 07:56:35 »
Moin,
bei LO kann das an den Schreib-Leserechten des tmp-Verzeichnisses liegen in welchem die Dateien zum versenden zwischengespeichert werden. Ich habe mir unter >/home/DeinUser< einen Ordner ".tmp_lo" angelegt. Dieses Verzeichnis habe ich dann in LO->Optionen->Pfade für die "Temporäre Dateien" angelegt. Danach LO neu starten und es sollte funktionieren, wobei ich mit >Evolution< arbeite.
Unter Optionen->Internet->eMail habe ich den kompletten Pfad zu meinem Mail-Programm eingetragen...
Gruß
Wolfgang
« Letzte Änderung: 15.01.2021, 08:04:42 von Wolfgang58 »

Re: Libreoffice versendet nach Update keine Mailangänge mehr
« Antwort #10 am: 15.01.2021, 15:08:19 »
@parmenides
Ich meinte, dass im Kontextmenü von Nemo keine Schaltfläche mit "Versenden" auftaucht. Mit Thunderbird Anhänge versenden geht schon, aber ich muss sie halt in der geöffneten neuen Mail händisch einfügen.

@Wolfgang 58
Deinen Tipp hab ich grad ausprobiert. Nützt aber leider auch nichts: Die neue Mail wird erstellt, aber der Anhang nicht übergeben. Schade, ich hatte mich schon gefreut...

Gruß
Rainer

Re: Libreoffice versendet nach Update keine Mailangänge mehr
« Antwort #11 am: 15.01.2021, 15:14:34 »
@parmenides
Zum Zeitpunkt von Antwort#2 war die Schaltfläche im Nemo-Kontextmenü noch da, aber es erfolgte keine Reaktion beim Klicken. Jetzt ist die Schaltfläche weg.

Re: Libreoffice versendet nach Update keine Mailangänge mehr
« Antwort #12 am: 15.01.2021, 17:36:50 »
Ich meinte, dass im Kontextmenü von Nemo keine Schaltfläche mit "Versenden" auftaucht. Mit Thunderbird Anhänge versenden geht schon, aber ich muss sie halt in der geöffneten neuen Mail händisch einfügen.
Wie bereits gesagt, wurde diese Funktion wg. Sicherheitsbedenken gestrichen.
https://ubuntu.com/security/notices/USN-4649-1

Das wurde  kürzlich auch hier schon mal ausführlich diskutiert.
https://www.linuxmintusers.de/index.php?topic=65604.0

In AW #17 hat @ZeckeSZ ein Skript vorgestellt, um diese Funktion auf anderem Wege zu dennoch realisieren.

Re: Libreoffice versendet nach Update keine Mailangänge mehr
« Antwort #13 am: 16.01.2021, 05:31:35 »
Moin,
ich habe das bei mir mal nachgestellt LM Cinnamon 20.1, LO 7.0.4.2 und TB 68.10.0 in dieser Kombination hat das auch funktioniert ohne einen neuen TMP-Ordner anzulegen.
In LO unter Extras->Optionen->Internet->eMail habe ich nichts eingetragen. In den Systemeinstellungen->Bevorzugte Programme habe ich Thunderbird ausgewählt.
Wenn es bei dir nicht geht solltest du mal überprüfen ob deine User-Rechte noch in Ordnung sind, dazu:
find ~ -user root -lsdieser Befehl sollte keine Ausgabe erzeugen, wenn doch dann bitte:
sudo chown -cR $USER:$USER /home/$USERGruß
Wolfgang

Re: Libreoffice versendet nach Update keine Mailangänge mehr
« Antwort #14 am: 17.01.2021, 23:48:04 »
Hallo Wolfgang,
deinen Tipp habe ich eben ausprobiert. Der erste Code erzeugt wie gewünscht keine Ausgabe, zur Sicherheit habe ich auch noch den zweiten eingegeben.
Ergebnis mit den auch bei dir eingetragenen Einstellungen ist aber wie vorher: Mail geht auf, aber ohne Anhang.

Gruß
Rainer