Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
07.03.2021, 10:48:36

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 720389
  • Themen insgesamt: 58244
  • Heute online: 697
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Dualboot mit 2 Grafikkarten Intel+Nvidia -> Nvidia lässt sich nicht abschalten  (Gelesen 475 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

  Guten Abend,

Ich nutze seit Jahren Linux Mint aktuell auf einem Fujitsu Esprimo E920 mit Intel® Core i7. Da ich den Desktop nur für  Office, Email, Web etc brauche, reichte mir Intel HD Graphics.
Da mein Sohn nun auch den Computer benutzt läuft außerdem noch Windows 10 im Dualboot. Für die neuen Spiele brauchten wir eine neue Grafikkarte (MSI GeForce GTX 1050 TI 4GT LP).

Die neue Karte wurde auch sofort von beiden Systemen erkannt und funktioniert ohne Probleme.  Allerdings zieht die Karte ordentlich Strom und der Lüfter nervt (das System war vorher im „normalen“ Betrieb geräuschlos).
Ich hatte gehofft die Karten nach der Installation des proprietären Nvidiatreibers mit Primeprofiles ausstellen zu können, aber da es keine Laptopkarte ist gibt es diese Funktion wohl gar nicht. Im Bios die Karte auszuschalten geht auch nicht da mein Sohn sie ja benötigt.
Ich kann zwar (komischerweise?) mit:   sudo prime-select intel die Grafik umstellen und die Ausgabe erfolgt über Intel HD Graphics, allerdings verbraucht die Nvidia Karte weiterhin Strom und der Lüfter läuft auch weiterhin.
Auch mit anderen Um-/Einstellungen die ich im Netz gefunden habe konnte ich bis jetzt die neue Karte in Mint nicht zum Schweigen bringen.
Einen Ansatz habe ich gefunden aber bislang noch nicht durchgeführt und zwar:

There is an easy trick: Reserve you discrete GPU for KVM passthrough without ever actually passing it to a VM:
•   find your PCI vendor and device ID (e.g. 1002:67ef)
•   add vfio-pci.ids=1002:67ef   to your kernel command line via GRUB (of course using the correct IDs)
Wo genau müsste ich diese Zeilen einfügen und ist der Ansatz überhaupt erfolgsversprechend? Die Annahme ist wohl das wenn keine VM da ist, Mint die Grafikkarte „still legt“.
Wenn jemand Erfahrung hiermit hat würde ich mich über Hilfe freuen. Auch anderen Methodeen stehe ich offen gegenüber.

Viele Grüße


Mint-Version und Desktopumgebung: Linux Mint 20 Cinnamon

Hallo,
zeige doch zunächst eindeutige und verwertbare Informationen zur Hardware.
inxi -FProblem dürfte grundsätzlich der Grafikanschluss sein. Auch wenn die Nvidia abgeschaltet würde und nur die Intel-Grafik der CPU verwendet werden soll, müsste der Monitor immer an den entsprechenden Grafikausgang der Nividia (unter Windows) und am Mainboard (unter Linux) umgestöpselt werden. Das wäre nicht praktikabel. Auch wennn Du über Prime umschaltest wird die Nvidia initialisiert und laufen, da dort ja ein Monitor erkannt wird. Auch in der VM.

Sollten Grafikkarten nicht im Office-Betrieb wesentlich weniger Strom ziehen und die Lüfter nicht still stehen? So ist es zumindest bei mir.

Sollten Grafikkarten nicht im Office-Betrieb wesentlich weniger Strom ziehen und die Lüfter nicht still stehen? So ist es zumindest bei mir.
Hier auch, funktioniert aber nicht mit jeder Grafikkarte unter Linux. Unter Win bieten die Graka-Hersteller ja meist ein zusätzliches Tool dafür an. Bei MSI müsste dies MSI Afterburner sein (Übertaktung und Lüftersteuerung). Ich habe bei meiner Graka noch zwei Dioden  in die Stromzuleitung der Lüfter eingebaut, so dass die Lüfter sehr langsam drehen und unter Win/Gaming ist das durch das Tool und temperaturgesteuert anders.

Off-Topic:
Dann habe ich ja Glück mit meiner Karte. Kann man irgendwo zuverlässig herausfinden, ob diese Funktion von Linux unterstützt wird?

Hier sind die Infos zur Hardware
System:
  Host: stephan-ESPRIMO-MINT Kernel: 5.4.0-58-generic x86_64 bits: 64
  Desktop: Cinnamon 4.6.7 Distro: Linux Mint 20 Ulyana
Machine:
  Type: Desktop System: FUJITSU product: ESPRIMO E920 v: N/A
  serial: <superuser/root required>
  Mobo: FUJITSU model: D3222-A1 v: S26361-D3222-A1
  serial: <superuser/root required> UEFI: FUJITSU // American Megatrends
  v: 4.6.5.4 R1.37.0 for D3222-A1x date: 08/06/2015
CPU:
  Topology: Quad Core model: Intel Core i7-4770 bits: 64 type: MT MCP
  L2 cache: 8192 KiB
  Speed: 1097 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 1097 2: 1097
  3: 1097 4: 1097 5: 1097 6: 1097 7: 1098 8: 1098
Graphics:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics
  driver: i915 v: kernel
  Device-2: NVIDIA GP107 [GeForce GTX 1050 Ti] driver: nvidia v: 455.38
  Display: x11 server: X.Org 1.20.8 driver: nvidia
  resolution: 2560x1440~60Hz
  OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 455.38
Audio:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
  driver: snd_hda_intel
  Device-2: Intel 8 Series/C220 Series High Definition Audio
  driver: snd_hda_intel
  Device-3: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel
  Sound Server: ALSA v: k5.4.0-58-generic
Network:
  Device-1: Intel Ethernet I217-LM driver: e1000e
  IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: 90:1b:0e:57:b5:61
Drives:
  Local Storage: total: 2.04 TiB used: 14.20 GiB (0.7%)
  ID-1: /dev/sda vendor: Crucial model: CT240BX500SSD1 size: 223.57 GiB
  ID-2: /dev/sdb vendor: Crucial model: CT2000MX500SSD1 size: 1.82 TiB
Partition:
  ID-1: / size: 72.24 GiB used: 14.17 GiB (19.6%) fs: ext4 dev: /dev/sda5
Sensors:
  System Temperatures: cpu: 54.0 C mobo: 29.8 C gpu: nvidia temp: 31 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 40%
Info:
  Processes: 291 Uptime: 2m Memory: 15.52 GiB used: 1.44 GiB (9.3%)
  Shell: bash inxi: 3.0.38

Hier noch die Ansicht (siehe Anhang)/Ausgabe von nvidia-settings (s:35440): GLib-GObject-CRITICAL **: 21:42:17.354: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
** Message: 21:42:17.524: PRIME: No offloading required. Abort
** Message: 21:42:17.524: PRIME: is it supported? no



Ich hatte eigentlich gehofft unter Powermixer das Performace Level auf 0 festlegen zu können aber wie man sieht ist eigentlich fast immer Level 2 aktiv und festlegen kann ich leider garnix :-(.

Also mein Ziel ist es die Karte entweder unter Mint ganz auszustellen oder wenigstens sie in den maximalen Stromsparmodus zu versetzen damit der Fan aufhört.

@ Flash63: also mein Monitor besitzt 2 Eingänge: derzeit DVI mit Intel HD Graphics und Displayport an der Nvidia. Wenn es wirklich klappen würde, dass die Nvidia schlafen geht wenn ich beim Hochfahren einfach den Displayportstecker entferne dann wäre es auch eine, wenn gleich nicht gerade schöne, Lösung. Muss ich nachher mal probieren.

Nvidia deinstallieren, nouveau sperren und den Monitor am Grafikausgang des Mainboard verwenden.

Dies würde dann ohne Stecker ziehen klappen?

Die Reihenfolge und dann Neustart?

sudo dpkg -P $(dpkg -l | grep nvidia-driver | awk '{print $2}')
 sudo apt autoremove

sudo echo blacklist nouveau > /etc/modprobe.d/blacklist-nvidia-nouveau.conf
Installiert hatte ich den Treiber damals mit
sudo apt-get install nvidia-455





Ja genau so, ob es funktioniert ...?

Wie gesagt , unter Windows muss der Monitor ja an die Nvidia.

Kleine Änderung falls der Sperrbefehl nicht funktioniert:
echo "blacklist nouveau" | sudo tee /etc/modprobe.d/blacklist_mouveau.conf
« Letzte Änderung: 02.01.2021, 23:02:53 von Flash63 »

Dann bleibt leider alle schwarz....

Im gesicherten Modus also nochmal alles zurück auf Los...

Möglicherweise muss im BIOS die Initialisierung der Graka von der ext. im PCIe-Slot auf die int. iGPU umgestellt werden.