Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
05.03.2021, 11:49:03

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 719934
  • Themen insgesamt: 58219
  • Heute online: 671
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  WLAN sehr langsam wird falsch erkannt  (Gelesen 969 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] WLAN sehr langsam wird falsch erkannt
« am: 29.12.2020, 15:47:56 »
Hallo an die Runde,
habe mal wieder ein Problem mit einem Rechner.
Habe mir aus einem Lenovo Think Centre M53 einen Retro Arcade PC gemacht.
Lauf soweit alles Prima, nur das Wlan Netzwerk will nicht so richtig.
Verbau ist eine 300 Mbit Karte (externen Stick mit 300 Mbit habe ich auch probiert) doch verbunden werde ich immer nur mit 72 Mbit.
Router steht 2 Meter entfernt ohne Mauern.

thomas@thomas-ThinkCentre-M53:~$ iwconfig
wlp4s0    IEEE 802.11  ESSID:"A1-Hybride-Gate" 
          Mode:Managed  Frequency:2.462 GHz  Access Point: 8C:EB:C6:83:89:94   
          Bit Rate=72.2 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-40 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:499   Missed beacon:0

lo        no wireless extensions.

enp3s0    no wireless extensions.

thomas@thomas-ThinkCentre-M53:~$


Was mache ich falsch ?

Lg Thomas
« Letzte Änderung: 31.12.2020, 00:03:16 von top50 »

Re: WLAN sehr langsam wir falsch erkannt
« Antwort #1 am: 29.12.2020, 16:12:14 »
Hi :)
und wie immer.. bitte als codeblock
inxi -Fz
testen
echo "options rtl8723be swenc=1 fwlps=0 ips=0 msi=0" | sudo tee /etc/modprobe.d/rtl8723be.confreboot


welche protokoll einstellung im router?
hoffentlich nur n+g
« Letzte Änderung: 29.12.2020, 16:17:46 von ehtron »

Re: WLAN sehr langsam wir falsch erkannt
« Antwort #2 am: 29.12.2020, 16:30:34 »
Hallo,

Router steht auf b+g+n andere Option hat er nicht.

inxi -Fz
System:
  Host: thomas-ThinkCentre-M53 Kernel: 5.4.0-58-generic x86_64 bits: 64
  Desktop: Cinnamon 4.4.8 Distro: Linux Mint 19.3 Tricia
Machine:
  Type: Desktop System: LENOVO product: 10DC0005GE v: ThinkCentre M53
  serial: <filter>
  Mobo: LENOVO model: Aptio CRB v: SDK0E50510 WIN serial: <filter>
  UEFI [Legacy]: LENOVO v: FRKT48AUS date: 01/18/2017
CPU:
  Topology: Quad Core model: Intel Pentium J2900 bits: 64 type: MCP
  L2 cache: 1024 KiB
  Speed: 2325 MHz min/max: 1333/2666 MHz Core speeds (MHz): 1: 1581 2: 1655
  3: 2667 4: 2667
Graphics:
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
  driver: i915 v: kernel
  Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa
  resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa DRI Intel HD Graphics (BYT) v: 4.2 Mesa 20.0.8
Audio:
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio
  driver: snd_hda_intel
  Sound Server: ALSA v: k5.4.0-58-generic
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
  IF: enp3s0 state: down mac: <filter>
  Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter
  driver: rtl8723be
  IF: wlp4s0 state: up mac: <filter>
Drives:
  Local Storage: total: 465.76 GiB used: 17.69 GiB (3.8%)
  ID-1: /dev/sda vendor: Seagate model: ST500LM000-1EJ162 size: 465.76 GiB
Partition:
  ID-1: / size: 457.45 GiB used: 17.69 GiB (3.9%) fs: ext4 dev: /dev/sda1
Sensors:
  System Temperatures: cpu: 56.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 184 Uptime: 5m Memory: 3.30 GiB used: 1.28 GiB (38.9%)
  Shell: bash inxi: 3.0.32


Test ohne erfolg
echo "options rtl8723be swenc=1 fwlps=0 ips=0 msi=0" | sudo tee /etc/modprobe.d/rtl8723be.conf

LG Thomas


Re: WLAN sehr langsam wir falsch erkannt
« Antwort #3 am: 29.12.2020, 16:50:43 »
Hi :)
doch.. b (uralt) muss aus..  kann man garantiert ausschalten.

Re: WLAN sehr langsam wir falsch erkannt
« Antwort #4 am: 29.12.2020, 17:02:20 »
Router A1 Hybrid Box.

4 Möglichkeiten zum einstellen.

2,4 GHz-Frequenzband

- b/g/n
- b/g
- g
- b

5 GHz-Frequenzband


a/n/AC
a

LG Thomas

Re: WLAN sehr langsam wird falsch erkannt
« Antwort #5 am: 29.12.2020, 17:27:06 »
Hallo,
der Realtek rtl8723be  Chipsatz...
 * unterstützt kein Dualband 5GHz und somit auch keinen ac-Modus
 * und auch  nur einen Datenstrom (1x1 MIMO), also max. 150Mb/s brutto und nicht 300MB/s
 * die hier aufgebaute Verbindung mit 72.2 Mb/s netto ist also schon ein guter Wert, mehr geht kaum

Siehe auch https://www.realtek.com/en/products/communications-network-ics/item/rtl8723be

Zitat
(externen Stick mit 300 Mbit habe ich auch probiert)
Was ist das für ein Stick?
lsusb
« Letzte Änderung: 29.12.2020, 17:30:37 von Flash63 »

Re: WLAN sehr langsam wird falsch erkannt
« Antwort #6 am: 29.12.2020, 17:39:41 »
@Flash63

USB Stick CTAgon 300 mbits

Laut Lenovo sollten 300 mbit verbaut sein .. läuft auch unter Windows weitaus schneller.
Ich Glaube die Wlankarte wird falsch erkannt.

Komme auf eine Download Rate von max 500-600 kbits.

LG Thomas

Re: WLAN sehr langsam wird falsch erkannt
« Antwort #7 am: 29.12.2020, 17:56:37 »
Laut Lenovo ist diese Wlan Karte verbaut

Wireless NIC
Intel Wireless-N 7260




Re: WLAN sehr langsam wird falsch erkannt
« Antwort #8 am: 29.12.2020, 18:16:32 »
Laut Lenovo ist diese Wlan Karte verbaut

Wireless NIC
Intel Wireless-N 7260
Nein, die ist optional. Die Karte wird auch nicht falsch erkannt. 500-600kbit sind ja nicht einmal 1Mbit.
Mit der Angabe "USB Stick CTAgon 300 mbits" kann man nichts anfangen. Zeige die Ausgabe von ...
lsusb... mit angeschlossenem Stick.

Siehe https://www.lenovo.com/us/en/desktops/thinkcentre/m-series-tiny/m53/

Connectivity:
entweder ...
2 x 2 802.11 b/g/n combo (WLAN + optional Bluetooth®) ... das dürfte die Intel sein, oder 1 x 1 802.11 b/g/n. Das ist die hier verbaute Realtek.

Re: WLAN sehr langsam wird falsch erkannt
« Antwort #9 am: 29.12.2020, 18:17:22 »
Anbei ein Bild von der Download Rate.

Max. 460 kBits

Theoretisch sollten bei 72mbits knapp 9 mb/s möglich sein.

Da stimmt sicher etwas nicht mit dem Treiber.

Re: WLAN sehr langsam wird falsch erkannt
« Antwort #10 am: 29.12.2020, 18:20:12 »
lsusb

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 04d9:1503 Holtek Semiconductor, Inc. Keyboard
Bus 001 Device 005: ID 0bda:b728 Realtek Semiconductor Corp.
Bus 001 Device 003: ID 0409:005a NEC Corp. HighSpeed Hub
Bus 001 Device 002: ID 1ea7:0066 
Bus 001 Device 006: ID 0bda:8178 Realtek Semiconductor Corp. RTL8192CU 802.11n WLAN Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


Re: WLAN sehr langsam wird falsch erkannt
« Antwort #11 am: 29.12.2020, 18:22:57 »
Ich sehe da keine Downloadrate. Screenshots sind zudem überflüssig. Verwechsele nicht bit und Byte. Die tatsächliche Downloadrate hängt u.a. von deinem Internetanschluss ab, nicht von der Verbindungsgeschwindigkeit zwischen WLAN-Client und Accesspoint.

Download Speed-Test:
curl -o /dev/null http://speedtest.wdc01.softlayer.com/downloads/test100.zipBus 001 Device 006: ID 0bda:8178 Realtek Semiconductor Corp. RTL8192CU 802.11n WLAN AdapterDer Stick mit RTL8192CU-Chipsatz sollte theoretisch bis300Mbit/s können, wird unter Linux aber nur mäßig unterstützt und die max. Übertragungsrate wird i.d.R. nie erreicht. Zudem gibt es eine Treiberkonflikt (es werden zwei Module geladen / rtl8xxxu & rtl8192cu). Das zeigt dir
lsmod | egrep -i 'rtl|mac80|cfg80'
« Letzte Änderung: 29.12.2020, 18:56:51 von Flash63 »

Re: WLAN sehr langsam wird falsch erkannt
« Antwort #12 am: 29.12.2020, 18:50:58 »
@Flash63

Ich verwechsle Bits und Byte nicht.
Bei einer 72 mbit/s Verbindung / 8 bits sind Theoretisch 9 mb/s möglich , ich schaffe nicht mal 1/2 mb/s

Den USB Stick habe ich nur zum Testen vom Reciver genommen.

Lsmod Ausgabe
thomas@thomas-ThinkCentre-M53:~$ lsmod | egrep i 'rtl|mac80|cfg80'
grep: rtl|mac80|cfg80: Datei oder Verzeichnis nicht gefunden
thomas@thomas-ThinkCentre-M53:~$

Den test habe ich nach 10 Min. abgebrochen da war er erst bei  19%

thomas@thomas-ThinkCentre-M53:~$ curl -o /dev/null http://speedtest.wdc01.softlayer.com/downloads/test100.zip
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
 19  100M   19 19.3M    0     0  33843      0  0:51:38  0:10:00  0:41:38 97242^C


Da stimmt definitiv etwas nicht.

Lg Thomas

Re: WLAN sehr langsam wird falsch erkannt
« Antwort #13 am: 29.12.2020, 18:57:16 »
Tippfehler meinerseits:
lsmod | egrep -i 'rtl|mac80|cfg80'
Zitat
Ich verwechsle Bits und Byte nicht.
Bei einer 72 mbit/s Verbindung ..
Na ja, 72 milli-bit/s stimmt jedenfalls nicht ;)

Mit welcher WLAN-Karte war jetzt der Speedtest?
« Letzte Änderung: 29.12.2020, 19:01:03 von Flash63 »

Re: WLAN sehr langsam wird falsch erkannt
« Antwort #14 am: 29.12.2020, 19:25:11 »
@Flash63

Speedtest war mit der Lenovo PCI Card.

Ausgabe lsmod

rtl8xxxu              122880  0
rtl8723be              98304  0
btcoexist             126976  1 rtl8723be
rtl8723_common         24576  1 rtl8723be
rtl_pci                32768  1 rtl8723be
btrtl                  16384  1 btusb
rtl8192cu              73728  0
rtl_usb                20480  1 rtl8192cu
rtl8192c_common        57344  1 rtl8192cu
rtlwifi                77824  7 rtl_pci,rtl8192c_common,rtl_usb,rtl8192cu,rtl8723be,btcoexist,rtl8723_common
mac80211              786432  6 rtl_pci,rtl_usb,rtl8192cu,rtl8723be,rtlwifi,rtl8xxxu
bluetooth             516096  43 btrtl,btintel,btbcm,bnep,btusb,rfcomm
cfg80211              634880  2 rtlwifi,mac80211