Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
07.03.2021, 10:12:21

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25346
  • Letzte: Nahuta
Statistiken
  • Beiträge insgesamt: 720380
  • Themen insgesamt: 58243
  • Heute online: 602
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Upgrade-Check von Linux-MINT 19.3 Cinnamon auf 20 wirft Fehler  (Gelesen 356 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo,
ich würde gerne auf Linux Mint 20 upgraden und habe den upgradecheck laufen lassen.
Leider wirft dieser mir folgende Fehler, die ich nicht wirklich zu interpretieren weiß:

Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fehler!
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libgirepository-1.0-1 : Beschädigt: python-gi (< 3.34.0-4~) aber 3.26.1-2ubuntu1 soll installiert werden
E: Fehler: Unterbrechungen durch pkgProblemResolver::Resolve hervorgerufen; dies könnte durch zurückgehaltene Pakete verursacht worden sein.
Traceback (most recent call last):
  File "/usr/bin/mintupgrade", line 726, in <module>
    upgrader.check()
  File "/usr/bin/mintupgrade", line 498, in check
    cache.upgrade(True)
  File "/usr/lib/python3/dist-packages/apt/cache.py", line 385, in upgrade
    self._depcache.upgrade(dist_upgrade)
apt_pkg.Error: E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/apport_python_hook.py", line 154, in apport_excepthook
    os.O_WRONLY | os.O_CREAT | os.O_EXCL, 0o640), 'wb') as f:
FileNotFoundError: [Errno 2] No such file or directory: '/var/crash/_usr_bin_mintupgrade.1000.crash'

Original exception was:
Traceback (most recent call last):
  File "/usr/bin/mintupgrade", line 726, in <module>
    upgrader.check()
  File "/usr/bin/mintupgrade", line 498, in check
    cache.upgrade(True)
  File "/usr/lib/python3/dist-packages/apt/cache.py", line 385, in upgrade
    self._depcache.upgrade(dist_upgrade)
apt_pkg.Error: E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Was muss ich da tun, damit es mir beim upgrade nichts zerschießt?

Und eine weitere Frage: ich habe Signal-Desktop installiert und hätte das gerne genau so auf dem neuen System. Wird das übernommen, oder muss ich das irgendwie sichern?

Besten Dank.
Grüße
Nrbrt

Re: Upgrade-Check von Linux-MINT 19.3 Cinnamon auf 20 wirft Fehler
« Antwort #1 am: 22.12.2020, 17:40:15 »
Hat soweit schon mal geklappt - besten Dank!

jetzt wirft er mir aber folgenden Fehler:
   + Checking your Linux Mint codename...

  + Checking your Linux Mint edition...

  + Checking your Timeshift configuration...

  + Updating cache...

OK:1 http://archive.ubuntu.com/ubuntu focal InRelease
OK:2 http://archive.canonical.com/ubuntu focal InRelease                                                             
OK:3 http://archive.ubuntu.com/ubuntu focal-updates InRelease                                                       
OK:4 http://archive.ubuntu.com/ubuntu focal-backports InRelease                                                     
OK:5 http://security.ubuntu.com/ubuntu focal-security InRelease                                                     
Ign:6 http://packages.linuxmint.com ulyana InRelease                         
OK:7 http://packages.linuxmint.com ulyana Release   
Paketlisten werden gelesen... Fertig               

  + Checking your APT repositories...

  + Checking your APT packages...

    - linux-generic-hwe-18.04: 5.4.0.58.64~18.04.53, should be 5.4.0.58.61 (from focal-updates)
    - linux-headers-generic-hwe-18.04: 5.4.0.58.64~18.04.53, should be 5.4.0.58.61 (from focal-updates)
    - linux-image-generic-hwe-18.04: 5.4.0.58.64~18.04.53, should be 5.4.0.58.61 (from focal-updates)
    - wine-stable: 4.0~bionic, should be 3.0.1ubuntu1 (from focal)

------------------------------------------------
!!  ERROR: The packages above have incorrect versions. They can be downgraded using 'Software Sources -> Maintenance -> Downgrade Foreign Packages'.
!!  Exiting.
------------------------------------------------

  + Restoring your backed up APT sources...

Wenn ich dann zu den Anwendungspaketquellen gehe und "Fremde Pakete herabstufen" wähle, wird mir nichts mehr zum herabstufen angezeigt. Müssen die dann manuell downgegradet werden? Wenn ja, wie genau mach ich das denn?
Danke!

Grüße
Nrbrt

Re: Upgrade-Check von Linux-MINT 19.3 Cinnamon auf 20 wirft Fehler
« Antwort #2 am: 22.12.2020, 17:50:17 »
Hat soweit schon mal geklappt - besten Dank!
Die Befehle waren eigentlich dazu gedacht, sie mit Ausgabe hier zu zeigen.... ;)

Re: Upgrade-Check von Linux-MINT 19.3 Cinnamon auf 20 wirft Fehler
« Antwort #3 am: 22.12.2020, 18:03:52 »
Hmm,.. hat aber auf jeden Fall schon was gebracht :-D

Hier die Ausgaben:
inxi -r
Repos:     No active apt repos in: /etc/apt/sources.list
           Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
           1: deb http://packages.linuxmint.com ulyana main upstream import backport #id:linuxmint_main
           2: deb http://archive.ubuntu.com/ubuntu focal main restricted universe multiverse
           3: deb http://archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse
           4: deb http://archive.ubuntu.com/ubuntu focal-backports main restricted universe multiverse
           5: deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
           6: deb http://archive.canonical.com/ubuntu/ focal partner

sudo apt-get update && apt-cache policy libgirepository-1.0-1 python-gi
OK:1 http://archive.ubuntu.com/ubuntu focal InRelease
OK:2 http://archive.canonical.com/ubuntu focal InRelease                                                             
Holen:3 http://archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]                                           
Ign:4 http://packages.linuxmint.com ulyana InRelease                                                                 
Holen:5 http://security.ubuntu.com/ubuntu focal-security InRelease [109 kB] 
Holen:6 http://archive.ubuntu.com/ubuntu focal-backports InRelease [101 kB]                                 
OK:7 http://packages.linuxmint.com ulyana Release                                                                   
Holen:8 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 DEP-11 Metadata [263 kB]
Holen:9 http://archive.ubuntu.com/ubuntu focal-updates/universe amd64 DEP-11 Metadata [205 kB]                       
Holen:11 http://archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 DEP-11 Metadata [2.468 B]                   
Holen:12 http://archive.ubuntu.com/ubuntu focal-backports/universe amd64 DEP-11 Metadata [1.768 B]       
Holen:13 http://security.ubuntu.com/ubuntu focal-security/main amd64 DEP-11 Metadata [24,3 kB]           
Holen:14 http://security.ubuntu.com/ubuntu focal-security/universe amd64 DEP-11 Metadata [56,6 kB]
Es wurden 877 kB in 1 s geholt (678 kB/s). 
Paketlisten werden gelesen... Fertig
libgirepository-1.0-1:
  Installiert:           1.56.1-1
  Installationskandidat: 1.64.1-1~ubuntu20.04.1
  Versionstabelle:
     1.64.1-1~ubuntu20.04.1 500
        500 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages
     1.64.0-2 500
        500 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages
 *** 1.56.1-1 100
        100 /var/lib/dpkg/status
python-gi:
  Installiert:           3.26.1-2ubuntu1
  Installationskandidat: 3.36.0-1
  Versionstabelle:
     3.36.0-1 500
        500 http://archive.ubuntu.com/ubuntu focal/universe amd64 Packages
 *** 3.26.1-2ubuntu1 100
        100 /var/lib/dpkg/status

Re: Upgrade-Check von Linux-MINT 19.3 Cinnamon auf 20 wirft Fehler
« Antwort #4 am: 22.12.2020, 18:18:09 »
muss ich das irgendwie sichern?
Auf diese Frage erwartest du doch nicht ernsthaft eine Antwort...

Re: Upgrade-Check von Linux-MINT 19.3 Cinnamon auf 20 wirft Fehler
« Antwort #5 am: 22.12.2020, 18:20:15 »
muss ich das irgendwie sichern?
Auf diese Frage erwartest du doch nicht ernsthaft eine Antwort...

Jaein - etwas blöd ausgedrückt.. natürlich ist es gesichert, aber ist davon auszugehen, dass das nachher ohne Neuinstallation funktioniert, oder wird das beim Upgrade platt gemacht?