Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
05.03.2021, 12:19:48

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 719940
  • Themen insgesamt: 58220
  • Heute online: 671
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Problem: Windows10 utimate und LinuxMin20 multiboot  (Gelesen 1039 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo Experten,
      1. habe Win10 ultimate neu installiert (Kopie von gpartet unten)
      2. dann Linux Mint20 dahinter
Problem: beim ersten Start ist das Grub Menü noch vorhanden (ubuntu und MS Bootloader)
Wenn MS Bootloader gewählt wird startet Win10 und beim nächsten Start startet nur noch Win10 ohne Auswahl

was läuft da schief?
Danke für Hilfe!


Hier die Systemdaten:
mint@mint:~$ inxi -Fz
System:
  Kernel: 5.4.0-40-generic x86_64 bits: 64 Desktop: Cinnamon 4.6.6
  Distro: Linux Mint 20 Ulyana
Machine:
  Type: Desktop Mobo: ASRock model: B75 Pro3 serial: <filter> UEFI: American Megatrends
  v: P1.90 date: 12/20/2013
CPU:
  Topology: Quad Core model: Intel Core i5-3470 bits: 64 type: MCP L2 cache: 6144 KiB
  Speed: 1597 MHz min/max: 1600/3600 MHz Core speeds (MHz): 1: 1596 2: 1597 3: 1597
  4: 1597
Graphics:
  Device-1: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics driver: i915
  v: kernel
  Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa
  resolution: 1680x1050~60Hz
  OpenGL: renderer: Mesa DRI Intel HD Graphics 2500 (IVB GT1) v: 4.2 Mesa 20.0.8
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio driver: snd_hda_intel
  Sound Server: ALSA v: k5.4.0-40-generic
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 974.83 GiB used: 11.61 GiB (1.2%)
  ID-1: /dev/sda type: USB vendor: Kingston model: DataTraveler 3.0 size: 14.41 GiB
  ID-2: /dev/sdb vendor: Seagate model: ST1000DM003-9YN162 size: 931.51 GiB
  ID-3: /dev/sdc type: USB vendor: Verbatim model: STORE N GO size: 28.91 GiB
Partition:
  ID-1: / size: 3.73 GiB used: 213.1 MiB (5.6%) fs: overlay source: ERR-102
  ID-2: /var/log size: 12.35 GiB used: 1.08 GiB (8.7%) fs: ext4 dev: /dev/sda3
Sensors:
  System Temperatures: cpu: 31.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 219 Uptime: 1h 03m Memory: 7.47 GiB used: 1.71 GiB (22.8%) Shell: bash
  inxi: 3.0.38
mint@mint:~$
-------------------------------------------------------------------------
sudo parted --list
Modell: Kingston DataTraveler 3.0 (scsi)
Festplatte  /dev/sda:  15,5GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos
Disk-Flags:

Nummer  Anfang  Ende    Größe   Typ      Dateisystem  Flags
 2      455kB   4518kB  4063kB  primary               esp
 3      1927MB  15,5GB  13,5GB  primary  ext4


Modell: ATA ST1000DM003-9YN1 (scsi)
Festplatte  /dev/sdb:  1000GB
Sektorgröße (logisch/physisch): 512B/4096B
Partitionstabelle: gpt
Disk-Flags:

Nummer  Anfang  Ende    Größe   Dateisystem  Name                          Flags
 1      1049kB  106MB   105MB   fat32        EFI system partition          boot, esp
 2      106MB   123MB   16,8MB               Microsoft reserved partition  msftres
 3      123MB   528GB   528GB   ntfs         Basic data partition          msftdata
 4      528GB   1000GB  472GB   ext4
-------------------------------------------------------------------
mint@mint:~$ [ -d /sys/firmware/efi ] && echo UEFI || echo BIOS
UEFI
---------------------------------------------------------------------



[MOD: Ausgabe bitte zur besseren Lesbarkeit als Text im Codeblock zeigen. Dazu den Text im Editor auswählen und mit der '#' Schaltfläche formatieren. Siehe auch oben im Forums-Menü unter "Hilfe".]
« Letzte Änderung: 21.12.2020, 11:57:44 von toffifee »

Re: Problem: Windows10 utimate und LinuxMin20 multiboot
« Antwort #1 am: 21.12.2020, 12:06:15 »
Hallo,
Da sind 100% bei Windows10 Updates eingespielt worden, die den Bootloader von Windows auf 1 gesetzt haben.

zeige Bitte mal:
efibootmgr

Re: Problem: Windows10 utimate und LinuxMin20 multiboot
« Antwort #2 am: 21.12.2020, 13:07:42 »
ja die updates waren gestern, heute Mint neu installiert, aber Problem blieb
Wie bekomme ich das Menü zurück?

mint@mint:~$ sudo efibootmgr
BootCurrent: 0009
Timeout: 5 seconds
BootOrder: 0000,0008,0009,0004,0007
Boot0000* Windows Boot Manager
Boot0004  Hard Drive
Boot0007  CD/DVD Drive
Boot0008* USB
Boot0009* UEFI: KingstonDataTraveler 3.0
« Letzte Änderung: 21.12.2020, 13:16:54 von mu222 »

Re: Problem: Windows10 utimate und LinuxMin20 multiboot
« Antwort #3 am: 21.12.2020, 13:45:51 »
Auffällig ist, dass die Partitionstabelle auf der einen Platte msdos und auf der anderen gpt ist. Ist die Kingston DataTraveler 3.0 eine externe Festplatte?

Die Bootreihenfolge änderst du generell folgendermaßen:sudo efibootmgr -o NUMMER,NUMMER Die NUMMERN entnimmst du der Ausgabe des Befehls efibootmgr und trägst sie in der gewünschten Reihenfolge ein. Windows dürfte bei dir 0000 sein. Linux Mint kann ich da allerdings nicht entdecken.

Re: Problem: Windows10 utimate und LinuxMin20 multiboot
« Antwort #4 am: 21.12.2020, 13:55:51 »
Zitat
Ist die Kingston DataTraveler 3.0 eine externe Festplatte?
Das ist ein USB Stick mit dem ich boote.
Zitat
Linux Mint kann ich da allerdings nicht entdecken.
Das ist ja das Problem,  kurz nach der Mint Installation war Mint noch als ubuntu vorhanden (Anlage)

Re: Problem: Windows10 utimate und LinuxMin20 multiboot
« Antwort #5 am: 21.12.2020, 13:58:56 »
Dann scheinst du bei der 2. Installation einen Fehler gemacht zu haben, evtl. nicht den Grub in die Efi Partition schreiben lassen?!?

Du kannst auch mal versuchen, mit dem Livesystem zu starten und "Boot Repair" sein Werk verrichten zu lassen.

Re: Problem: Windows10 utimate und LinuxMin20 multiboot
« Antwort #6 am: 21.12.2020, 14:16:02 »
Zitat
Grub in die Efi Partition schreiben lassen?!?
danach hat mich die Install routine nicht gefragt

Boot-Reparatur sagt es ist ein Fehler aufgetreten: soll ich die lange Ausgabe hier posten?.
sudo efibootmgr zeigt danach auch ubuntu nicht an

Könnte es sein dass Windos10 ultimate sich anders als Win10  Pro verhält?
« Letzte Änderung: 21.12.2020, 14:22:16 von mu222 »

Re: Problem: Windows10 utimate und LinuxMin20 multiboot
« Antwort #7 am: 21.12.2020, 14:35:08 »
Boot-Reparatur sagt es ist ein Fehler aufgetreten:
Das alleine hat noch nicht viel zu sagen.
sudo efibootmgr zeigt danach auch ubuntu nicht an
Dann war es tatsächlich nicht erfolgreich.

Re: Problem: Windows10 utimate und LinuxMin20 multiboot
« Antwort #8 am: 21.12.2020, 14:39:16 »
Bin bereit alles von vorn zu versuchen. Gibt es eine schrittweise Anleitung für dual boot?
Kann alles platt machen, da noch keine wichtige Daten drauf sind.

Re: Problem: Windows10 utimate und LinuxMin20 multiboot
« Antwort #9 am: 21.12.2020, 15:04:35 »
Vielleicht helfen dir diese Anleitungen (letztere wurde nicht mit Linux Mint 20 getestet):
https://www.linuxmintusers.de/index.php?action=wiki;page=Installationsanleitung_Linux_Mint_20
https://www.linuxmintusers.de/index.php?action=wiki;page=Windows10_und_LinuxMint_im_uefi_installieren

Windows lässt du drauf, wie es ist? Ich schlage folgendes vor:
1) Windows installieren
2) In Windows Fast Boot und im Bios Secure Boot abschalten
3) Anschließend Linux installieren (beide Betriebssysteme entweder im UEFI oder Bios-Modus)

Während der Installation von Linux Mint kannst du unter dem Punkt "Etwas anderes" einzelne Partitionen erstellen und zuordnen:
eine Root-Partition, eine separate Home-Partition für Daten, eine Swap-Partition (falls genug Platz vorhanden ist, ansonsten wird eine Swap-File erstellt). Im UEFI-Modus gehört Grub auf die vorhandene EFI-Partition.
Für den Dateiaustausch zwischen Linux und Windows benötigst du ggf. eine NTFS Partition, ansonsten ext4.

Cato d. A.

  • Gast
Re: Problem: Windows10 utimate und LinuxMin20 multiboot
« Antwort #10 am: 21.12.2020, 16:49:57 »
Hallo,
ich nehme an, Du meinst Windows 10 Pro, denn ein Ultimate gab es nur bei Vista.

Zu Deinem Problem: Da Du Win 10 Pro hast, besteht die einfachste Methode auch Linux zu nutzen darin das WSL, das Windows-Subsystem-für-Linux zu installieren, und dort dann Deine Linux-Distri. So braucht man sich auch nicht um UEFI & Co zu kümmern.

https://docs.microsoft.com/de-de/windows/wsl/about
https://docs.microsoft.com/de-de/windows/wsl/reference

Ist alles installiert, kann man es entweder Über Start -> Distri-Icon starten, oder man legt eine Verknüpfung auf dem Desktop an. Bei mir ist es openSuSE; siehe Foto.


Re: Problem: Windows10 utimate und LinuxMin20 multiboot
« Antwort #11 am: 21.12.2020, 17:12:07 »
Ob das die einfachste Methode ist lasse ich mal dahin gestellt sein. Aber Support wird er dafür nur schwer bekommen!

Cato d. A.

  • Gast
Re: Problem: Windows10 utimate und LinuxMin20 multiboot
« Antwort #12 am: 21.12.2020, 17:30:53 »
Ob das die einfachste Methode ist lasse ich mal dahin gestellt sein. Aber Support wird er dafür nur schwer bekommen!
Wenn man schon Windows hat, gibt es keine einfachere Möglichkeit als das WSL zu nutzen - auch den ganzen Multibootkram kann man vergessen. Was den Support anbetrifft, die Nutzung einer Linux-Distri im WSL ist doch im Prinzip nichts anderes als sich unter Windows in einer VBox eine Linux-Distri zu installieren, und da gibt es doch wohl auch Support . . . für die Distri.

Unter dem WSL spart man sich das ganze schwerfällige Gedöns, daß mit der VirtualBox mitgeliefert wird. Unter dem WSL ist es so, als hätte man tatsächlich einen Linux-Rechner.

Falls Du auch ein Win 10 Pro laufen hast, probiere es aus.

Re: Problem: Windows10 utimate und LinuxMin20 multiboot
« Antwort #13 am: 21.12.2020, 18:01:14 »
Nun ja.
ICH würde die Finger davon lassen (WSL), vor allem als Linux Anfänger.
Denn wer macht den Support?
Was immer Fakt ist, Leistungsverlust.
Besser setze ich mich hin und Installiere das alle nochmal im BIOS-Mode.
« Letzte Änderung: 21.12.2020, 18:46:01 von tommix »

Re: Problem: Windows10 utimate und LinuxMin20 multiboot
« Antwort #14 am: 21.12.2020, 18:28:05 »
Unter dem WSL ist es so, als hätte man tatsächlich einen Linux-Rechner.
Nein, es bleibt eine Virtualisierung.