Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
24.02.2021, 21:36:41

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 718060
  • Themen insgesamt: 58075
  • Heute online: 649
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr  (Gelesen 2255 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
« Antwort #15 am: 01.12.2020, 08:35:45 »
Hallo,
Mir ist aufgefallen, dass du einen neueren Kernel installiert hast als ich (5.4.0-56 vs. 5.4.0.-54).
der Kernel 5.4.0-56 wurde Hier Gestern auf beiden Systemen automatisch über die Akt.-Verwalt. angezeigt und installiert.
Gelistet ist er ja in der Aktualisierungsverwaltung (LM 20), aber die Installation läuft ins Leere.
mal den Server gewechselt, hier ist netcologne eingestellt.


Ich habe jetzt beide LM20 Cin. Systeme im Grubmenü mit Kernel 5.4.0.-54 gestartet um damit das "per E-mail versenden" aus nemo heraus zu prüfen.

Gleicher Status wie Gestern, mit alter Version xdg-utils (1.1.3-2ubuntu1):
TB 68.10.0 öffnet kein Neues "Verfassen Fenster"
TB 78.5.0 öffnet ein Neues "Verfassen Fenster" und der zu versendende Anhang wird automatisch eingefügt, s.Anhang #1

Das Problem resultiert anscheinend nicht vom Kernel oder Thunderbird.
Wohl eher aus den xdg-utils, denn ein ähnliches Problem bestand hier in der Vergangenheit mit LM19.1Cin.:
https://www.linuxmintusers.de/index.php?topic=55570.msg750938#msg750938

Dort wurde die thunderbird-desktop verändert und durch eine userapp-Thunderbird-123xyz.desktop Datei ersetzt weshalb nemo die Datei nicht mehr an Thunderbird versendete/übergab. Jetzt sieht es hier wieder genau so aus, es befinden sich aktuell neun (9) thunderbird und userapp.desktop Dateinen im Verzeichnis ~/.local/share/applications :o s. Anhang #2

« Letzte Änderung: 01.12.2020, 09:19:52 von kuehhe1 »

Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
« Antwort #16 am: 01.12.2020, 10:05:41 »
Das Problem resultiert anscheinend nicht vom Kernel
Merkwürdig, hier kann ich das genaue Gegenteil verifizieren, nämlich dass der Kernel 5.4.0-56 der Übeltäter ist.

Heute früh wurde mir der 56er endlich wie gewohnt aktiv zur Installation angeboten und korrekt installiert (und nicht wie zuvor nur in der Kernelübersicht aufgeführt).
Ansonsten wurden keine weiteren Updates eingespielt und endlich kann auch ich euren Mailanhangsfehler bestaunen. ;)

Ich denke mal, da wird in Kürze eine Korrektur erfolgen. Das Einfachste wird sein, das Problem auszusitzen.
« Letzte Änderung: 01.12.2020, 10:09:02 von Parmenides »

Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
« Antwort #17 am: 01.12.2020, 10:21:33 »
Ich hatte keine Lust, lang nach einem Fehler zu suchen (der dürfte m.E. in xdg-email, send-by-mail.py oder send-by-mail.nemo_action liegen), daher ein anderer Weg:

Nemo öffnen ==> Bearbeiten ==> Module ==> "Per E-Mail versenden" deaktivieren

Script erstellen:
xed ~/.local/share/nemo/actions/attach.nemo_action

Inhalt:
[Nemo Action]
Active=true
Name=Per E-Mail versenden
Exec=thunderbird -compose to=,"attachment='%F'"
Icon-Name=mail-attachment
Selection=Any
Extensions=nodirs
Separator=,
Dependencies=thunderbird;

Funktioniert hier mit LM 19.3 Cinnamon/Thunderbird 68.10.0 und LM 20 Cinnamon/Thunderbird 68.10.0

Oder aber global in der Datei
sudo -H xed /usr/share/nemo/actions/send-by-mail.nemo_action"Exec" und "Dependencies" gegen die oben genannten austauschen. Die Frage ist allerdings, ob das das nächste Update überleben wird...

Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
« Antwort #18 am: 01.12.2020, 10:55:45 »
Hallo,
Script erstellen:
Code: [Auswählen]
xed ~/.local/share/nemo/actions/attach.nemo_action
so hatte ich es seinerzeit: https://www.linuxmintusers.de/index.php?topic=55570.msg750296#msg750296 auch gelöst, warte jetzt aber auch erstmal ab.

Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
« Antwort #19 am: 01.12.2020, 12:56:22 »
Hi :)
mensch leute.. der kernel verändert doch keine anwendungsprogramme  :-\

btw.. hier auf lm20 cin gehts auch nicht... für mich unwichtig da ich per d&d rein ziehe... somit keine ahnung woher es kommt... TB oder desktop?
per e-mail versenen modul ist in nemo aktviert.

Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
« Antwort #20 am: 01.12.2020, 13:25:13 »
Ich glaube auch nicht, dass der Kernel Schuld ist. Der Fehler taucht hier gleichermaßen beim Kernel 5.4.0-54 und 5.4.0-56 (der kam heute als Update) auf.
Ich kann mir gut vorstellen, dass xdg-utils 1.1.3-2ubuntu1.20.04.1 der Übeltäter ist, warte aber auch erst mal ab.

Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
« Antwort #21 am: 01.12.2020, 13:28:22 »
mensch leute.. der kernel verändert doch keine anwendungsprogramme
Hat so auch niemand behauptet. Was genau der Kernel verändert hat, weiß ich nicht. Das Changelog ergibt für mich keinen Hinweis auf unser Thema.

Hier noch mal meine Begründung, weshalb ich den Kernel als Ursache ansehe:

Testdauer 5 Minuten

1. Test des Kontextmenüpunkts "per E-mail versenden" > Ergebnis: OK, funktioniert.
2. Kernelupdate von 5.4.0-54 auf 5.4.0-56 (es wurden keine weiteren Updates oder sonstige Änderungen durchgeführt).
3. Neustart
4. Test des Kontextmenüpunkts "per E-mail versenden" > Ergebnis: funktioniert nicht mehr. TB wird zwar gestartet, jedoch ohne den Anhang automatisch einzubinden.

Habe jetzt nochmal den Kernel 5.4.0-54 reaktiviert. Der Fehler bleibt bestehen.
Da fahre ich mit meiner Logik offenbar gegen eine Wand. ???
« Letzte Änderung: 01.12.2020, 13:32:08 von Parmenides »

Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
« Antwort #22 am: 01.12.2020, 13:37:49 »
@Parmenides: Wann kam denn bei dir das Update xdg-utils 1.1.3-2ubuntu1.20.04.1?

Zitat
remove attachment handling from mailto in scripts/xdg-email.in
https://launchpad.net/ubuntu/+source/xdg-utils
Aus den Bug-Reports werde ich aber auch nicht schlau: https://ubuntu.com/security/CVE-2020-27748

Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
« Antwort #23 am: 01.12.2020, 13:39:37 »
Gestern Abend.

Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
« Antwort #24 am: 01.12.2020, 13:54:20 »
System:    Kernel: 5.4.0-54-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Cinnamon 4.6.7
           Distro: Linux Mint 20 Ulyana base: Ubuntu 20.04 focal
Machine:   Type: Desktop Mobo: ASUSTeK model: H110M-A/M.2 v: Rev X.0x serial: <filter>
           UEFI [Legacy]: American Megatrends v: 4202 date: 02/28/2019
CPU:       Topology: Quad Core model: Intel Core i7-6700 bits: 64 type: MT MCP arch: Skylake-S rev: 3
           L2 cache: 8192 KiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 54398
           Speed: 800 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 879 2: 899 3: 878 4: 1025 5: 912 6: 868
           7: 942 8: 902
Graphics:  Device-1: Intel HD Graphics 530 vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0
           Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa resolution: 1920x1200~60Hz
           OpenGL: renderer: Mesa Intel HD Graphics 530 (SKL GT2) v: 4.6 Mesa 20.0.8 direct render: Yes
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
           bus ID: 00:1f.3
           Sound Server: ALSA v: k5.4.0-54-generic
Network:   Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k port: f040 bus ID: 00:1f.6
           IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    Local Storage: total: 1.60 TiB used: 1.00 TiB (62.9%)
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZALQ256HAJD-000L2 size: 238.47 GiB
           ID-2: /dev/sda vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB
           ID-3: /dev/sdb vendor: Samsung model: HD103UJ size: 931.51 GiB
Partition: ID-1: / size: 211.69 GiB used: 28.99 GiB (13.7%) fs: ext4 dev: /dev/nvme0n1p1
           ID-2: /home size: 400.10 GiB used: 130.96 GiB (32.7%) fs: ext4 dev: /dev/sda1
           ID-3: swap-1 size: 8.50 GiB used: 2.37 GiB (27.9%) fs: swap dev: /dev/sda5
Sensors:   System Temperatures: cpu: 23.0 C mobo: 27.8 C
           Fan Speeds (RPM): cpu: 1031 fan-1: 913 fan-5: 0 fan-6: 0
Info:      Processes: 319 Uptime: 14d 2h 42m Memory: 15.51 GiB used: 5.47 GiB (35.3%) Init: systemd runlevel: 5
           Compilers: gcc: 9.3.0 Shell: bash v: 5.0.17 inxi: 3.0.38

Heute hab ich versucht wie üblich per Kontextmenü einige PDF per Mail zu versenden. Und es geht bei mir auch nicht mehr. ;-(

Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
« Antwort #25 am: 01.12.2020, 13:59:11 »
Und wieder spricht das gegen den Kernel als Ursache.

Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
« Antwort #26 am: 01.12.2020, 14:17:35 »
Zitat
Jens Mueller discovered that xdg-utils incorrectly handled certain URI.
An attacker could possibly use this issue to expose sensitive information.
The problem can be corrected by updating your system to the following package versions:
 xdg-utils - 1.1.3-2ubuntu1.20.04.1
https://ubuntu.com/security/notices/USN-4649-1
Möglicherweise gibt es da einen Zusammenhang zu "per email versenden" im Nemo?

Abgesehen davon sind email-Anhänge ohnehin als Sicherheitsrisiko verrufen.

Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
« Antwort #27 am: 01.12.2020, 14:39:01 »
Wie jetzt schon von verschiedener Seite vermutet, liegt die Ursache tatsächlich im Update von xdg-utils 1.1.3-2ubuntu1.20.04.1.

Habe per Timeshift das System auf den Stand von vor 2 Tagen zurückgesetzt.
Danach alle Updates außer xdg-utils 1.1.3-2ubuntu1.20.04.1. erneut eingespielt.
Nun funktioniert das automatische Einfügen eines Anhangs in TB wieder. Auch mit dem neuen Kernel 5.4.0-56.

Nach dem Hinweis von @aexe auf den (Un)-Sicherheitsakpekt dieser Funktion, scheint mir aber Verzicht angeraten. Für mich kein großes Problem, da ich diesen Komfort eh selten genutzt habe.
Bequemlichkeit scheint mal wieder der Sicherheit zuwider zu laufen.

Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
« Antwort #28 am: 01.12.2020, 15:23:34 »
Danach alle Updates außer xdg-utils 1.1.3-2ubuntu1.20.04.1. erneut eingespielt.
Und warum hast du dir nicht einfach deine eigene "per_mail_senden.nemo_action" geschrieben (AW #17)? Dann hättest du kein Problem mit dem Versand und auch keines mit einem alten, nicht aktualisierten Paket.

Re: Kontextmenü "Per E-Mail versenden" funktioniert nicht mehr
« Antwort #29 am: 01.12.2020, 15:59:29 »
Weshalb sollte ich, wenn ich doch die Funktion gar nicht brauche?
Es hat mich einfach interessiert, diesem Problem auf den Grund zu gehen und Ungereimtheiten zu klären.

Für alle, die diese Funktion öfters benutzen, ist dein Script aber sicher eine gangbare Lösung. Wobei aber meine Linuxkenntnisse nicht ausreichen, die angesprochenen Sicherheitsaspekte im Bezug auf das Script beurteilen zu können.

« Letzte Änderung: 01.12.2020, 16:07:04 von Parmenides »