Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
28.02.2021, 08:34:22

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 25320
  • Letzte: SvRe
Statistiken
  • Beiträge insgesamt: 718718
  • Themen insgesamt: 58131
  • Heute online: 520
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  USBTastatur und Maus-Problem  (Gelesen 674 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] USBTastatur und Maus-Problem
« am: 27.11.2020, 21:21:06 »
Moin,
schon seit längerem habe ich neben Win10 auch Linux Mint 19.3 (Cinnamon) installiert mit dem entsprechenden Boot-Menü. So beides lief bis heute Morgen ;-) tadellos.
Ich bekamm dann von meinem Junior sein gebrauchtes Gigabyte-Board/Prozessor/32 GB Ram. Dann hab ich meinen Rechner damit umgerüstet.
Ging problemlos, da der Win10-Startversuch perfekt funktionierte und alles funktionierte wie vorher.
Dann hab ich Mint gestartet und bemerkte schon, dass die Tastaturled dreimal blinkte und dann ausblieb. ERgebnis: Mauszeiger steht still in der Mitte und Passwort war nicht über die Tastatur einzugeben.
In der Folgezeit habe ich alle USB2.0 Ports getestet: keine Änderung bei Linux.
Win10 funktionierte immer wie anfangs, das Bios ist per Tastatur oder Maus bedienbar, das Auswahlmenü Win10/Linux auch. Beim Windowsstart ist die Tastatur aktiv - beim Linuxstart ist sie nach dreimaligem Blinken deaktiv....
Kann mir jemand verraten wie ich weiterkomme?
« Letzte Änderung: 30.11.2020, 16:44:24 von RaiLI »

Re: USBTastatur und Maus-Problem
« Antwort #1 am: 28.11.2020, 12:47:08 »
Update ;-)
Keine wirkliche Lösung: aber Tastatur und Maus mal an USB 3.0 und beides funktioniert.....

Re: USBTastatur und Maus-Problem
« Antwort #2 am: 28.11.2020, 13:07:12 »
Schon mal nach einem BIOS Update für das Board geschaut?

Re: USBTastatur und Maus-Problem
« Antwort #3 am: 28.11.2020, 20:38:55 »
Hallo,
ja hatte ich. Das neueste Bios ist geflasht.
Inzwischen habe ich 19.3 auf DVD gebrannt und davon gebootet. Im 1. Menü habe ich Linux ausprobieren ausgewählt- Dann setzt sich das "Laden" fort.
Die LED auf der Tastatur erlischt und auf dem Monitor erscheinen Fehlermeldungen - USB betreffend (3 notdürftige Smartphonefotos habe ich beigefügt.
Die Led bleibt aus bis der Desktop erscheint und ich bin wieder da wo ich bin, wenn ich Linux von der Platte boote :o

Re: USBTastatur und Maus-Problem
« Antwort #4 am: 29.11.2020, 05:55:53 »
Moin,
versuch mal, wenn dein BIOS die Optionen bietet, die folgenden Einstellung:

>xHCI handoff - Enabled<
>EHCI handoff - Enabled<
>IOMMU controller - Enabled<

Gruß
Wolfgang
« Letzte Änderung: 29.11.2020, 06:03:40 von Wolfgang58 »

Re: USBTastatur und Maus-Problem
« Antwort #5 am: 29.11.2020, 10:12:46 »
Moin,
vielen Dank für den Tipp - ich hatte ihn gestern Abend, spät, auch in einem Forum einer mir unbekannten Linuxversion gefunden.
Ja, aktivieren von IOMMU hatte zur Folge, dass Tastatur und Maus funktionierten, aber dafür die USB3.0-Ports abgeschaltet waren (2 ext. Platten waren nicht mehr "da").
xHCI und EHCI.
Ich hatte dann noch im Bios "an und aus" für Onboard 3.0 und zusätzliche USB3.0 gefunden. "zusätzliche USB3.0-Funktion" habe ich abgeschaltet und dann wurden die beiden USB-Platten wieder mir Strom versorgt, aber nicht von Linux erkannt :-[.....
(übrigens: alle Änderungen/Versuche hatten auf die Funktion von Win10 keine Einwirkungen)
So mal sehen was der neue Tag bringt...... :)

Re: USBTastatur und Maus-Problem
« Antwort #6 am: 29.11.2020, 10:31:48 »
xHCI und EHCI.
Was ist damit?
Führ doch mal folgenden Befehl aus:
journalctl -b -1 >boot_log.txtDie Datei ist dann im >Persönlicher Ordner<, diese dann mal hier hochladen.
Gruß
Wolfgang

Re: USBTastatur und Maus-Problem
« Antwort #7 am: 29.11.2020, 13:54:25 »
xHCI und EHCI, dazu hatte ich vergessen zu schreiben, dass sich zu "meinem Problem" nichts änderte (aktiv oder nicht).
Anliegend die Bootlog.txt
Gruss RMS

Re: USBTastatur und Maus-Problem
« Antwort #8 am: 29.11.2020, 17:54:53 »
Kannst du bitte noch:
inxi -Fznachschieben...
Dann bitte mal
dmesgdann die USB-Platte einstecken und warten bis sie angelaufen ist, dann nochmal:
dmesgHier sollte nun die Festplatte zu erkennen sein (am Ende der Ausgabe), dies bitte mal hier posten.
Gruß
Wolfgang
« Letzte Änderung: 29.11.2020, 18:19:54 von Wolfgang58 »

Re: USBTastatur und Maus-Problem
« Antwort #9 am: 29.11.2020, 18:21:17 »
Gerne:
rms@rms-System-Product-Name:~$ inxi -Fz
System:
  Host: rms-System-Product-Name Kernel: 5.4.0-54-generic x86_64 bits: 64
  Desktop: Cinnamon 4.4.8 Distro: Linux Mint 19.3 Tricia
Machine:
  Type: Desktop System: Gigabyte product: N/A v: N/A serial: <filter>
  Mobo: Gigabyte model: 970A-DS3P serial: <filter> BIOS: American Megatrends
  v: FD date: 02/26/2016
CPU:
  Topology: 8-Core model: AMD FX-8300 bits: 64 type: MCP L2 cache: 2048 KiB
  Speed: 1541 MHz min/max: 1400/3300 MHz Core speeds (MHz): 1: 1406 2: 1406
  3: 1406 4: 1401 5: 1406 6: 1406 7: 1404 8: 1405
Graphics:
  Device-1: NVIDIA driver: nvidia v: 455.38
  Display: x11 server: X.Org 1.20.8 driver: nvidia
  unloaded: fbdev,modesetting,nouveau,vesa resolution: 1680x1050~60Hz
  OpenGL: renderer: GeForce GTX 1650/PCIe/SSE2 v: 4.6.0 NVIDIA 455.38
Audio:
  Device-1: AMD SBx00 Azalia driver: snd_hda_intel
  Device-2: NVIDIA driver: snd_hda_intel
  Sound Server: ALSA v: k5.4.0-54-generic
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
  IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 2.73 TiB used: 475.95 GiB (17.0%)
  ID-1: /dev/sda vendor: SanDisk model: SSD PLUS 1000GB size: 931.52 GiB
  ID-2: /dev/sdb vendor: Seagate model: ST31000528AS size: 931.51 GiB
  ID-3: /dev/sdc vendor: Seagate model: ST31000524AS size: 931.51 GiB
Partition:
  ID-1: / size: 915.89 GiB used: 87.26 GiB (9.5%) fs: ext4 dev: /dev/sdb1
Sensors:
  System Temperatures: cpu: 17.6 C mobo: N/A gpu: nvidia temp: 28 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 50%
Info:
  Processes: 249 Uptime: 2m Memory: 31.39 GiB used: 1.17 GiB (3.7%)
  Shell: bash inxi: 3.0.32
rms@rms-System-Product-Name:~$

Übrigens: ID-1Win10, ID-2 Linux und Grub, ID-3 Daten

Gruss RMS

Der Strom zu den USB3.0-Anschlüssen wird beim Booten "abgeschaltet" - die LEDs beider Platten erlöschen (so wie anfangs Tastatur und Maus) und laufen daher nicht an.....

« Letzte Änderung: 29.11.2020, 18:29:35 von RaiLI »

Re: USBTastatur und Maus-Problem
« Antwort #10 am: 29.11.2020, 22:00:34 »
Guten Abend,
bitte, bitte zukünftig Terminalausgaben bitte im Codeblock...! Wie das geht? Schau in der Hilfe! Danke!
Grub-Konfiguration bearbeiten:
Versuch mal folgendes:

sudo nano /etc/default/grubBearbeiten Sie die Zeile, die so aussieht:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"Füge hier folgendes hinzu: "amd_iommu=on iommu=pt"
Das sollte dann so aussehen:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash amd_iommu=on iommu=pt"Dann noch noch ein freundliches:
sudo update-grubBIOS-Einstellungen:
IOMMU = enabled,
XHCI handoff = enabled,
EHCI handoff = disabled,
USB Legacy support = enabled
Gruß
Wolfgang

Re: USBTastatur und Maus-Problem
« Antwort #11 am: 30.11.2020, 00:20:20 »
Erstmal vielen Dank für deine Mühe - den Fehler mit der Terminalausgabe werde wohl in den Griff bekommen....
So ich habe deine Tipps in der Reihenfolge abgearbeitet: bei sudo update-grub kam eine Fehlermeldung (Anhang 1).
Nach ausführen des Grub-Customizers erschien wieder eine Fehlermeldung, so dass der Customizer nicht öffnete. Wenn ich es verstanden habe, was ich gefunden/gelesen habe soll die "device.map" im Verzeichnis grub erneuert werden. Diese Datei gibt es auf meinem System nicht!......
Gruss

Re: USBTastatur und Maus-Problem
« Antwort #12 am: 30.11.2020, 05:07:17 »
Guten Morgen,
das >Device.map< File wird nicht automatisch bei der Grubinstallation angelegt.
Dies sollte helfen:
sudo grub-mkdevicemapDamit wird die >device.map< in dem Verzeichnis "/boot/grub" erstellt.
Zeig hier bitte mal die >etc/grub< (im Codeblock).
Gruß
Wolfgang
« Letzte Änderung: 30.11.2020, 06:08:04 von Wolfgang58 »

Re: USBTastatur und Maus-Problem
« Antwort #13 am: 30.11.2020, 07:23:03 »
Moin,
ein ist mir noch aufgefallen, dein Board ist, wenn ich das richtig recherchiert habe, aus dem Jahr 2013. Eventuell solltest du da mal einen älteren Kernel verwenden.
Bei LM 19.3 würde ich den aus der >4.15.0< Serie empfehlen, der wird auch noch bis 2023 unterstützt. Aktuell ist der Kernel  >4.15.0-124<.
Gruß
Wolfgang

Re: USBTastatur und Maus-Problem
« Antwort #14 am: 30.11.2020, 16:40:14 »
Hallo Wolfgang,
nochmals vielen Dank für deine vielen Tipps, auch wenn die letzten Tipps von heute Morgen bei mir nichts brachten. ABER das lag an meinem Linux. Da war offensichtlich was mit Grub, was nicht zu reparieren war. Und um Dich und mich nicht weiter zu strapazieren habe ich meinen Rechner aufgeräumt und nur eine nichtgenutzte Platte und eine USBplatte drangehängt und Linux 19.3 neu installiert. Nebenbei habe ich in den Tiefen des Inet gesucht und gelesen.....
Gefunden habe ich, dass der Via-Chipsatz auf diesem Board (übrigens letzte Revision von 2016) "etwas speziell" ist. Letztendlich hat es so geklappt:
1. Im Bios IOMMU aktivieren, speichern und Linux starten
2. Terminal öffnen, dann sudo nano /etc/default/grub öffnen
3. In der Zeile Grub_CMDLINE_Default="" - zwischen den "" iommu=soft einfügen und dann grub speichern
4. Im Terminal sudo update-grub eingeben, Terminal schliessen

Rechner neu starten, Bios öffnen und iommu DEaktivieren, Bios speichern und Rechner neu starten...

Rechnerneustart: USB 3.0 bekommt Strom und Platten sind ansprechbar. Eine Mischung aus deinen und anderen Tipps...

Vielen Dank