Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
30.11.2020, 20:39:03

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24840
  • Letzte: Foxinity
Statistiken
  • Beiträge insgesamt: 697674
  • Themen insgesamt: 56459
  • Heute online: 734
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Kein Grub bei Mint neben Windows  (Gelesen 206 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Kein Grub bei Mint neben Windows
« am: 17.11.2020, 22:22:42 »
Linux Mint 20 Cinnamon

Hallo,

habe Boot auf UEFI umgestellt, mit externem GParted die gesamte SSD-Platte ntfs formatiert, Windows 10 unter UEFI vom USB-Stick installiert (2 Durchläufe, da zunächst wieder erste Partitionen entstehen), Windows-Updates durchgeführt, dann Lenovo-System-Update-Tool unter Windows installiert und damit Treiber etc. geupdated, den ntfs-Bereich mit Windows-Datenträgerbearbeitung verkleinert und von DVD Linux installiert. Es gibt / (root) und /home Partition. Linux-Installation wurde regulär beendet.

Ergebnis: Beim Hochfahren komme ich direkt in Windows, die erwartete Frage des Grub, ob man mit Windows oder Linux weitermachen möchte, taucht nicht auf. In den Boot-Einstellungen habe ich Fast-Boot deaktiviert.

Wie macht man es richtig?

Viele Grüße

sudo parted -l
Model: ATA Samsung SSD 840 (scsi)
Disk /dev/sda: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number  Start   End    Size    File system  Name                          Flags
 1      1049kB  106MB  105MB   fat32        EFI system partition          boot, esp
 2      106MB   123MB  16.8MB               Microsoft reserved partition  msftres
 3      123MB   126GB  126GB   ntfs         Basic data partition          msftdata
 4      126GB   186GB  60.0GB  ext4
 5      186GB   226GB  40.0GB  ext4


Model: ATA Samsung SSD 840 (scsi)
Disk /dev/sdb: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number  Start   End    Size   Type     File system  Flags
 1      1049kB  256GB  256GB  primary  ntfs


Warning: Unable to open /dev/sr0 read-write (Read-only file system).  /dev/sr0
has been opened read-only.
Model: HL-DT-ST DVD-RAM GHA2N (scsi)                                     
Disk /dev/sr0: 1985MB
Sector size (logical/physical): 2048B/2048B
Partition Table: mac
Disk Flags:

Number  Start  End     Size    File system  Name   Flags
 1      2048B  6143B   4096B                Apple
 2      332kB  4395kB  4063kB               EFI

....

inxi -SMDP
System:    Host: mint Kernel: 5.4.0-26-generic x86_64 bits: 64 Desktop: Cinnamon 4.6.6 Distro: Linux Mint 20 Ulyana
Machine:   Type: Desktop System: LENOVO product: 056854G v: ThinkStation S30 serial: <superuser/root required>
           Mobo: LENOVO model: LENOVO serial: <superuser/root required> UEFI: LENOVO v: A0KT61AUS date: 03/27/2017
Drives:    Local Storage: total: 476.95 GiB used: 197.4 MiB (0.0%)
           ID-1: /dev/sda vendor: Samsung model: SSD 840 PRO Series size: 238.47 GiB
           ID-2: /dev/sdb vendor: Samsung model: SSD 840 PRO Series size: 238.47 GiB
Partition: ID-1: / size: 15.66 GiB used: 197.4 MiB (1.2%) fs: overlay source: ERR-102

...

efibootmgr
BootCurrent: 000F
Timeout: 2 seconds
BootOrder: 0000,0001,000F,000C,000D,000E,0005
Boot0000* ubuntu
Boot0001* Windows Boot Manager
Boot0005* IBA GE Slot 00C8 v1372
Boot000C* HL-DT-STDVD-RAM GHA2N
Boot000D* Samsung SSD 840 PRO Series
Boot000E* Samsung SSD 840 PRO Series
Boot000F* UEFI: HL-DT-STDVD-RAM GHA2N

Re: Kein Grub bei Mint neben Windows
« Antwort #1 am: 17.11.2020, 22:30:41 »
Hallo:
ein inxi -Fzist besser!
Bitte auch zeigen:[ -d /sys/firmware/efi ] && echo UEFI || echo BIOS
Kannst du mit der <F12> - Taste kein Linux booten?

Re: Kein Grub bei Mint neben Windows
« Antwort #2 am: 17.11.2020, 22:32:14 »
4      126GB   186GB  60.0GB  ext4
 5      186GB   226GB  40.0GB  ext4
Was ist jetzt was?

Re: Kein Grub bei Mint neben Windows
« Antwort #3 am: 18.11.2020, 19:58:56 »
Update
1. Hardware: Habe die SSDs an schnellere Ports SATA1 und SATA2 gehaengt und die DVD an einen mittelschnellen Port.
2. Habe in Windows Schnellstart abgeschaltet
3. In Windows mit Datentraegerverwaltung die beiden Linux-Partitionen geloescht.
4. Per DVD Mint neu neben Windows installiert

Alles unter UEFI (Booteinstellung)

Ergebnis
Gleicher Fehler: Beim Booten wird Grub uebergangen und sofort zu Windows gegangen. Kein Zugriff auf das installierte Mint moeglich.

Hallo:
ein inxi -Fzist besser!

mint@mint:~$ inxi -Fz
System:
  Kernel: 5.4.0-26-generic x86_64 bits: 64 Desktop: Cinnamon 4.6.6
  Distro: Linux Mint 20 Ulyana
Machine:
  Type: Desktop System: LENOVO product: 056854G v: ThinkStation S30
  serial: <filter>
  Mobo: LENOVO model: LENOVO serial: <filter> UEFI: LENOVO v: A0KT61AUS
  date: 03/27/2017
CPU:
  Topology: Quad Core model: Intel Xeon E5-1620 0 bits: 64 type: MT MCP
  L2 cache: 10.0 MiB
  Speed: 1197 MHz min/max: 1200/3800 MHz Core speeds (MHz): 1: 1197 2: 1197
  3: 1197 4: 1197 5: 1197 6: 1197 7: 1198 8: 1197
Graphics:
  Device-1: AMD Cayman PRO [Radeon HD 6950] driver: radeon v: kernel
  Display: x11 server: X.Org 1.20.8 driver: ati,radeon
  unloaded: fbdev,modesetting,vesa resolution: 1280x1024~60Hz
  OpenGL: renderer: AMD CAYMAN (DRM 2.50.0 / 5.4.0-26-generic LLVM 9.0.1)
  v: 4.3 Mesa 20.0.4
Audio:
  Device-1: Intel C600/X79 series High Definition Audio
  driver: snd_hda_intel
  Device-2: AMD Cayman/Antilles HDMI Audio [Radeon HD 6930/6950/6970/6990]
  driver: snd_hda_intel
  Sound Server: ALSA v: k5.4.0-26-generic
Network:
  Device-1: Intel 82579LM Gigabit Network driver: e1000e
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 476.95 GiB used: 128.5 MiB (0.0%)
  ID-1: /dev/sda vendor: Samsung model: SSD 840 PRO Series size: 238.47 GiB
  ID-2: /dev/sdb vendor: Samsung model: SSD 840 PRO Series size: 238.47 GiB
Partition:
  ID-1: / size: 15.66 GiB used: 128.5 MiB (0.8%) fs: overlay source: ERR-102
Sensors:
  System Temperatures: cpu: 40.0 C mobo: N/A gpu: radeon temp: 50 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 245 Uptime: 18m Memory: 31.32 GiB used: 1.23 GiB (3.9%)
  Shell: bash inxi: 3.0.38
mint@mint:~$


Bitte auch zeigen:[ -d /sys/firmware/efi ] && echo UEFI || echo BIOS

mint@mint:~$ [ -d /sys/firmware/efi ] && echo UEFI || echo BIOS
UEFI
mint@mint:~$


Kannst du mit der <F12> - Taste kein Linux booten?

Nein, mit F12 komme ich in die Auswahl, von wo man booten moechte, siehe Foto



Re: Kein Grub bei Mint neben Windows
« Antwort #4 am: 18.11.2020, 20:00:57 »
4      126GB   186GB  60.0GB  ext4
 5      186GB   226GB  40.0GB  ext4
Was ist jetzt was?

Hat sich eruebrigt> es gibt nur noch eine grosse automatisch erzeugte Linux-Partition.

Re: Kein Grub bei Mint neben Windows
« Antwort #5 am: 18.11.2020, 20:28:33 »
Kannst du bitte mal im UEFI Bootmode auf UEFI Only um stellen.

Re: Kein Grub bei Mint neben Windows
« Antwort #6 am: 18.11.2020, 20:40:08 »
Kannst du bitte mal im UEFI Bootmode auf UEFI Only um stellen.

Das ist von Beginn an eingestellt (kein Auto, kein Legacy)

 

1. Advent
1. Advent