Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
23.11.2020, 20:33:49

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24814
  • Letzte: GrischanB
Statistiken
  • Beiträge insgesamt: 696327
  • Themen insgesamt: 56360
  • Heute online: 705
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Maus und dann alles friert ein - Licht an Maus leuchtet weiter  (Gelesen 387 mal)

0 Mitglieder und 3 Gäste betrachten dieses Thema.

Desktop-Rechner mit LM20 xfce Neuinstallation. Nach einiger Zeit musste ich den proprietäre Nvidia-Treiber deinstallieren, weil ich zum allerersten Mal seit vielen Jahren Linuxmint Einfriereffekte hatte und teils gar kein Start mehr möglich war. Also Nouveau-Treiber.
Sah einige Wochen sehr gut aus. Unklar ob zufällig begann das Problem ab einer Kernelversion mit dem Verlangsamen, dann Einfrieren der Maus und des Gesamtsystems (alle Anzeigen, Tastatur ....)
Erst schien das Zurückgreifen auf ältere Kernel eine Lösung - aber der Effekt tritt nur seltener oder später auf.
Die Situation ist besser, aber nicht behoben.

Verstärkter Auslöser dürfte die Telegram-Nutzung gewesen sein, wenn ich das im Hintergrund laufen habe und noch an einem Browser was mache, dann verlangsamt sich die Mausreaktionszeit und teils friert alles komplett ein. Ich schrieb das dem Fehlen der starken GPU-Leisung der Nvidia Geforce GTX 1080 zu. Allerdings ist der Intel i7-4790K Core Prozessor (4.44 GHz, Max. Turbo) an sich auch nicht so schnell überfordert.
Also meine ich, HW kanns eig. nicht sein von der Performance her, weil es ja längere Zeit (einige Wochen) gut funktioniert hat. Außer die HDD?

Ich suche daher eine bei Linuxmint leicht installierbare, verwendbare und aussagekräftige SW zum Testen meiner recht alten Festplatte (ist nur eine verbaut mit mehreren Partitionen), vielleicht liegts daran: eine Alternative für crystaldisk, ich habe gelesen GSmartControl soll verständliche und erklärte Auswertungen liefern - wie kann ich das in LM 20xfce auf meinem Desktop-PC installieren oder wenn nicht, was könnt Ihr mir empfehlen? Was in Deutsch wäre gut.
Die smart-tabelle von "Laufwerke" zeigt das, gerade mal noch die Langtestung durchlaufen lassen:
smartwerte festplatte 20201116langtest
smartwerte festplatte 20201116langtest
Davor war nach dem Kurztest das zu lesen:
smartwerte festplatte 20201116
smartwerte festplatte 20201116

Wie kann ich mit derzeit wenig verfügbarer Zeit auf Fehlersuche gehen - nach Wahrscheinlichkeit, dass ich nicht tagelang dran bin?

Könnte eine neue Festplatte was bringen - ich nutze eine alte HDD 500GB, also zB eine knackige SSD mit 512GB, auf die ich das System rüberklone?

Zuletzt noch: unter LM19xfce gabs nie irgendwas, ich habe zwar schon viel Zeit erst ins gescheiterte upgrade und jetzt ins Herreichten nach der Neuinstall investiert, aber wenn Ihr sagt, alles zu aufwändig - geht gleich zurück aufs LM 19xfce .... naja  :-X

Re: Maus und dann alles friert ein - Licht an Maus leuchtet weiter
« Antwort #1 am: 20.11.2020, 00:20:33 »
Hat wer eine Idee, Hinweise?
Mir fiel noch auf: wenn ich länger warte, also ca. 8-10 Minunten nachdem Maus und Tastatur eingefroren sind (teils das Maussymbol sogar weg ist) statt einen Neustart zu machen,
dann "erholt" sich das ganze manchmal völlig und läuft komplett den Tag problemlos durch. Muss ich noch mehr austesten.

Re: Maus und dann alles friert ein - Licht an Maus leuchtet weiter
« Antwort #2 am: 20.11.2020, 01:04:51 »
Gib hier mal die Ausgabe von inxi -Fz, hier an und teile mal mit wieviel RAM du nutzt bzw. verbaut hast.
Tritt dieses Einfrieren unregelmäßig ein, also unabhängig was du gerade machst oder häuft sich dieser Ausfall bei bestimmten Aktionen.
So wie ich das lese hat die Festplatte keine Schuld. Ich tippe eher auf einen RAM Fehler/Defekt. Im schlimmsten Fall könnte sogar das Motherboard selber defekt sein. Da reicht schon manchmal, ein "unsichtbarer" Haarriss.
Lass doch mal den Memtest durchlaufen um zu prüfen ob deine Speicherriegel eventuell defekt sind.
Bevor du das machst, prüfe erst mal ob auch alle Anschlüsse/Stecker im PC wackelfrei dort sind, wo sie hingehören.

Re: Maus und dann alles friert ein - Licht an Maus leuchtet weiter
« Antwort #3 am: 20.11.2020, 12:50:16 »
Die Platte zeigt bei ID 199 UDMA Fehler. Hier könntest du versuchen die Kontakte zu reinigen und das Sata Kabel zu tauschen. Die SMART Werte weiterhin beobachten und falls der Wert weiterhin ansteigt ist die Platte zu tauschen. Ich denke aber nicht das die Platte für das einfrieren verantwortlich ist. 

Re: Maus und dann alles friert ein - Licht an Maus leuchtet weiter
« Antwort #4 am: 21.11.2020, 12:25:16 »
Danke für die Hinweise!
Mir kommt grad einiges dazwischen, kann alles erst später checken, hier mal die Terminalausgaben zu Ramgröße etc:
sudo inxi -mxx     
Memory:
  RAM: total: 31.30 GiB used: 855.6 MiB (2.7%)
  Array-1: capacity: 32 GiB slots: 4 EC: None max module size: 8 GiB
  note: est.
  Device-1: ChannelA-DIMM0 size: 8 GiB speed: 1600 MT/s type: DDR3
  manufacturer: 1315 part-no: BLS8G3D1609DS1S00.
  Device-2: ChannelA-DIMM1 size: 8 GiB speed: 1600 MT/s type: DDR3
  manufacturer: 1315 part-no: BLS8G3D1609DS1S00.
  Device-3: ChannelB-DIMM0 size: 8 GiB speed: 1600 MT/s type: DDR3
  manufacturer: 1315 part-no: BLS8G3D1609DS1S00.
  Device-4: ChannelB-DIMM1 size: 8 GiB speed: 1600 MT/s type: DDR3
  manufacturer: 1315 part-no: BLS8G3D1609DS1S00.
~$ inxi -Fz
System:
  Kernel: 5.4.0-54-generic x86_64 bits: 64 Desktop: Xfce 4.14.2
  Distro: Linux Mint 20 Ulyana
Machine:
  Type: Desktop Mobo: ASRock model: Z87 Extreme11/ac serial: <filter>
  UEFI [Legacy]: American Megatrends v: P1.50 date: 03/29/2016
CPU:
  Topology: Quad Core model: Intel Core i7-4790K bits: 64 type: MT MCP
  L2 cache: 8192 KiB
  Speed: 3300 MHz min/max: 800/4400 MHz Core speeds (MHz): 1: 3299 2: 3300
  3: 3307 4: 3297 5: 3303 6: 3302 7: 3307 8: 3301
Graphics:
  Device-1: NVIDIA GP104 [GeForce GTX 1080] driver: nouveau v: kernel
  Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa
  resolution: 1680x1050~60Hz
  OpenGL: renderer: NV134 v: 4.3 Mesa 20.0.8
Audio:
  Device-1: Intel 8 Series/C220 Series High Definition Audio
  driver: snd_hda_intel
  Device-2: NVIDIA GP104 High Definition Audio driver: snd_hda_intel
  Sound Server: ALSA v: k5.4.0-54-generic
Network:
  Device-1: Intel Ethernet I217-V driver: e1000e
  IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Intel I211 Gigabit Network driver: igb
  IF: enp113s0 state: down mac: <filter>
  Device-3: Broadcom and subsidiaries BCM4352 802.11ac Wireless Network
  Adapter
  driver: wl
  IF: wlp114s0 state: down mac: <filter>
Drives:
  Local Storage: total: 465.76 GiB used: 147.47 GiB (31.7%)
  ID-1: /dev/sdb vendor: Western Digital model: WD5000AADS-00S9B0
  size: 465.76 GiB
Partition:
  ID-1: / size: 194.27 GiB used: 147.47 GiB (75.9%) fs: ext4 dev: /dev/sdb6
Sensors:
  System Temperatures: cpu: 34.0 C mobo: N/A gpu: nouveau temp: 41 C
  Fan Speeds (RPM): N/A gpu: nouveau fan: 462
Info:
  Processes: 280 Uptime: 1h 48m Memory: 31.30 GiB used: 1.30 GiB (4.2%)
  Shell: bash inxi: 3.0.38

Re: Maus und dann alles friert ein - Licht an Maus leuchtet weiter
« Antwort #5 am: 21.11.2020, 12:53:48 »
Anhand dieser Daten kann man davon ausgehen, das es nicht an einer "Unterdimensonierung" der verbauten Hardware liegt. Es ist von allem reichlich und genug vorhanden.  :)
Warten wir erst mal den Memtest ab. Dieser sollte mindestens ein paar Stunden laufen (eventuell über Nacht) um brauchbare Ergebnisse zu erhalten.

Folgendes probiert:
1. Beim Reinigen auch das Mauspad getauscht - seitdem tritt der Fehler fast nie mehr auf (!)
2. Satakabel kann ich erst morgen tauschen
3. Beim Hochstarten wollte ich in den memtest machen, der wird nicht angeboten, aber ich habe beim Aufruf der System Übersicht - system summary folgenden Eintrag gefunden (trotz der Smart-Werte, die an sich unbedenklich sind, siehe oben):
Zitat
LVM-Zustand
Physikalischer Datenträger: Nicht OK (schlecht)
Dateiträgergruppen: OK (gut)
Was bedeutet das genau? Vor allem im Vergleich zu obigen Testergebnissen, ist die Festplatte nun doch schlecht?

4. Zum RAM-Test, da hatte ich früher diesen memtest beim Grub/Bootvorgang angeboten. Offenbar gibts das so nicht mehr, ich fand diesen Beitrag, woraus ich vermute, dass ich mit dem LM Install-Stick einen (extern) machen könnte, aber zuvor ein Programm dazu suchen müsste.
In dem Beitrag ist nicht klar, ob ich den memtest auch direkt am Rechner im terminal nachinstallieren könnte, allerdings wirds einen Grund haben, warum der nicht mehr vorinstalliert ist ....?
Hm.
memtest86+ oder auch memtester gibt es auch in der Anwendungsverwaltung direkt angeboten: kann ich davon einen nehmen bzw. welchen und läuft der dann übers Grub/Bootmenü?

Edit: im BIOS habe ich auch keine memtest-Funktion gefunden

Hallo,
memtest gibt es normalerweise nicht im BIOS. Das gehört zum Linux-System und muss vor dem hochfahren des Linux-System über das Grub-Bootmenü gestartet werden. Wird das Grub-Bootmenü bei Systemstart nicht angezeigt (das ist durchaus normal)? Drücke ESC oder die Umschalttaste (Shift) nach den BIOS POST-Meldungen um es aufzurufen. Der Menüeintrag nennt sich Memory test (memtest86+)

"LVM-Zustand Physikalischer Datenträger: Nicht OK (schlecht)" ist zumindest kein gutes Zeichen. Kann ggf. durch Neuformatierung/Reparatur/Neuinstallation behoben werden. Wäre aber Glücksache bei dem Alter des Systems/der Festplatte. Das System ist ja vor kurzem bereits neu installiert worden. SMART-Werte prüfen wäre auch nicht verkehrt. Vielleich wird dein System auch nur etwas zu warm bei heißen Tagen was die Lebensdauer der Komponenten deutlich reduziert.
sudo apt-get install smartmontools
sudo update-smart-drivedb
# kurze Übersicht
sudo smartctl -A /dev/sdb

Sie auch https://wiki.ubuntuusers.de/Festplattenstatus/

PS: die alte WD 3,5'' 500GB Festplatte sollte man sowieso mal durch eine schnelle SSD ersetzen/ergänzen wenn möglich. Kostenpunkt etwa 35€-50€
https://www.mindfactory.de/product_info.php/240GB-Crucial-BX500-2-5Zoll--6-4cm--SATA-6Gb-s-3D-NAND-TLC--CT240BX500S_1274637.html  240GB ~26€
https://www.mindfactory.de/product_info.php/500GB-Crucial-MX500-2-5Zoll--6-4cm--SATA-6Gb-s-3D-NAND-TLC--CT500MX500S_1222727.html 500GB ~52€

Es wird noch der freie Treiber nouveau bei der Grafikkarte GeForce GTX 1080 verwendet. Manchmal funktioniert die Temperatur/Lüftersteuerung damit nicht richtig.


« Letzte Änderung: Heute um 08:26:38 von Flash63 »

ich fand diesen Beitrag
Sorry, ich vergaß hier den Link dazu: https://www.linuxmintusers.de/index.php?topic=55804.0

Daraus hatte ich vermutet, dass der memtest nicht mehr so wie bisher standardmäßig installiert ist. Ich habe nur die Auwahl der Kernels und die Recovery-Modes und sonst komme ich halt in die Befehlszeile von grub. Memtest kann ich auch da keinen starten.
Wenn ich im laufenden Betrieb ins Terminal gehe, erhalte ich diese Auskunft:
~$ dpkg -l memtest* | grep ii
dpkg-query: Kein Paket gefunden, das auf memtest* passt
Schaut für mich aus, als wäre kein memtest Programm installiert. Daher war die Frage, ob ich memtest86+ oder auch memtester aus der Anwendungsverwaltung direkt heraus nachinstallieren soll/kann. Alternative mit Installations-Stick und extra Programm möchte ich eher vermeiden.

Hitze kann ich ausschließen, die Temperatur wird primär vom BeQuiet-Gehäuse selbst gesteuert und ist auf max Kühlung eingestellt (weil ich sonst ja die nvidia Karte mit proprietärem Treiber nutze, was derzeit aber offenbar bis LM20.3 noch Probleme macht - daher auch der nouveau-Treiber, Temperatur sehe ich außerdem laufend mit PSensor).

Ausgabe vom nachinstallierten smarttool (ich hatte oben halt das von "Laufwerke" gepostet):
~$ sudo smartctl -A /dev/sdb
smartctl 7.1 2019-12-30 r5022 [x86_64-linux-5.4.0-54-generic] (local build)
Copyright (C) 2002-19, Bruce Allen, Christian Franke, www.smartmontools.org

=== START OF READ SMART DATA SECTION ===
SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x002f   200   200   051    Pre-fail  Always       -       0
  3 Spin_Up_Time            0x0027   147   146   021    Pre-fail  Always       -       3616
  4 Start_Stop_Count        0x0032   095   095   000    Old_age   Always       -       5031
  5 Reallocated_Sector_Ct   0x0033   200   200   140    Pre-fail  Always       -       0
  7 Seek_Error_Rate         0x002e   200   200   000    Old_age   Always       -       0
  9 Power_On_Hours          0x0032   079   079   000    Old_age   Always       -       15552
 10 Spin_Retry_Count        0x0032   100   100   000    Old_age   Always       -       0
 11 Calibration_Retry_Count 0x0032   100   100   000    Old_age   Always       -       0
 12 Power_Cycle_Count       0x0032   095   095   000    Old_age   Always       -       5004
192 Power-Off_Retract_Count 0x0032   200   200   000    Old_age   Always       -       597
193 Load_Cycle_Count        0x0032   001   001   000    Old_age   Always       -       729863
194 Temperature_Celsius     0x0022   112   104   000    Old_age   Always       -       31
196 Reallocated_Event_Count 0x0032   200   200   000    Old_age   Always       -       0
197 Current_Pending_Sector  0x0032   200   200   000    Old_age   Always       -       0
198 Offline_Uncorrectable   0x0030   200   200   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x0032   200   200   000    Old_age   Always       -       7
200 Multi_Zone_Error_Rate   0x0008   200   200   000    Old_age   Offline      -       0
« Letzte Änderung: Heute um 14:24:58 von Worf »

Zitat
Daher war die Frage, ob ich memtest86+ oder auch memtester aus der Anwendungsverwaltung direkt heraus nachinstallieren soll/kann.
Ja, das sollte problemlos funktionieren und dann auch im Grub-Menü dann angezeigt werden.

Festplatten Kurzübersicht ist für mich soweit unauffällig. Ein gründlicher Test dauert erheblich länger, siehe Wiki-Artikel. So aber für mich noch kein Indiz die Platte schleunigst zu wechseln. Datensicherung ist immer eine gute Idee, Hardware verabschiedet sich i.d.R. plötzlich und ohne große Vorankündigung.

« Letzte Änderung: Heute um 20:15:39 von Flash63 »

Danke, habe mich jetzt etwas eingelesen und memtest86+ installiert, weil ja nur dieses Prog den gesamten RAM prüfen kann. Scheint auch in der Grub-Auswahl auf jetzt.
Werds über Nacht machen - dazu aber noch bitte 2 Fragen:

- Ich finde das Log-File nicht, sollte unter Dateisystem/efi/boot/memtest sein, ich finde aber nur einen Pfad Dateisystem/boot/efi (also umgekehrt) und der Ordner ist leer bzw. fehlt der letzte Ordner memtest. Dachte, da wäre zumindest jetzt ein Ordner angelegt. Siehe:
memtest logfile ort unklar
memtest logfile ort unklar
Wo finde ich dann das Logfile verlässlich? Bitte genauen Pfad, wenn ich vom Standard-User (nicht root) aus suche, bin da kein Profi  :-X
Ich werde nicht dabeisitzen wenns nicht sein muss, um die Berichtsausgabe mit zu verfolgen.

- Wie kann ich erkennen, welcher der 4 Riegel oder mehrere betroffen sind?
(Sonst müsste ich ja alle einzeln testen, das wäre schon recht mühsam und weil auch mehrere betroffen sein können wären das etliche Durchläufe ...)

Die Idee mit der doch schon älteren Festplatte hatte ich ja auch angesprochen: kann das tatsächlich diese Effekte bewirken (Maus verlangsamt, gewisse Abläufe verlangsamen zB Öffnen von Seiten ... wenn ich größere Anwendungen schließe gehts wieder normal weiter, manchmal auch mit nur Zuwarten).
Kann auch tagelang überhaupt gut gehen ohne was.
« Letzte Änderung: Heute um 18:38:02 von Worf »

Zitat
Wo finde ich dann das Logfile verlässlich? Bitte genauen Pfad, wenn ich vom Standard-User (nicht root) aus suche, bin da kein Profi 
Muss ich so direkt auch passen. Habe memtest schon lange nicht mehr benötigt/durchgeführt.
Zitat
Wie kann ich erkennen, welcher der 4 Riegel oder mehrere betroffen sind?
Da gibt es IMHO nur die Möglichkeit das anhand der angegebenen Speicheradresse in etwa zu berechnen (unsicher/auch nicht einfacher) oder eben den Weg die Module einzeln zu testen (langwieriger aber eindeutig).
Zitat
Die Idee mit der doch schon älteren Festplatte hatte ich ja auch angesprochen: kann das tatsächlich diese Effekte bewirken (Maus verlangsamt, gewisse Abläufe verlangsamen zB Öffnen von Seiten ...
Prüfe zusätzlich die Prozessor- und Speicherauslastung (RAM) wenn das System stockt:
htopAber bei ~32GB RAM und i7 ...

Nimm einfach mal zwei Speicherriegel im Wechsel probeweise aus dem System.

« Letzte Änderung: Heute um 20:22:08 von Flash63 »