Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
01.12.2020, 09:12:10

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24840
  • Letzte: Foxinity
Statistiken
  • Beiträge insgesamt: 697746
  • Themen insgesamt: 56462
  • Heute online: 549
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Miracast mit MiracleCast TV als sink, Laptop mit LM20C als source Fehlermeldung  (Gelesen 480 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Ich habe schon ziemlich viel gesucht, komme aber auf keinen grünen Zweig. Hier wurde das Thema 7/2019 das letzte Mal behandelt, um den goldenen Spaten zu vermeiden hier also daran anknüpfend ein neuer Thread. Also folgendes:

Ich hab das Miraclecast von https://github.com/albfan/miraclecast runtergeladen und mit der cmake methode wie unter https://github.com/albfan/miraclecast/wiki/Building beschrieben erstellt und installiert.

Schonmal vorab: an der Hardware liegts laut mitgeliefertem test-tool anscheinend nicht:

~/Downloads/mcast/miraclecast-master/res$ bash test-hardware-capabilities.sh
wlp6s0 supports P2P

Ich bin eigentlich vorgegangen, wie in der readme.md beschrieben:

Zitat
Steps to use it as sink

  1.  shutdown wpa_supplicant and NetworkManager

    $ systemctl stop NetworkManager.service
    $ systemctl stop wpa_supplicant.service

   2. launch wifi daemon

    $ sudo miracle-wifid &

Zitat
Steps to use it as peer

   1. Repeat steps 1 and 2 from "use as sink"

   2. launch wifi control

    $ sudo miracle-wifictl
   3. Enable visibility for other devices

   4. Locate them using scanning

    > p2p-scan
.....

 Zu Punkt 3 kam es dann schon nicht mehr wegen eines Fehlers:

~$ systemctl stop NetworkManager.service
~$ systemctl stop wpa_supplicant.service
~$ sudo miracle-wifid &
[1] 24766
~$ sudo miracle-wifictl
[sudo] password for $USER:             
ERROR: cannot retrieve objects: The name org.freedesktop.miracle.wifi was not provided by any .service files (ctl_wifi_fetch() in /home/$USER/Downloads/mcast/miraclecast-master/src/ctl/ctl-wifi.c:1171)
[miraclectl] #

[1]+  Stopped                 sudo miracle-wifid

Tja, da bin ich dann wieder mal mit meinem Latein am Ende.

Hat jemand eine Ahnung oder Idee, wie ich das zum Laufen bringen könnte?

Vielen Dank schonmal. Und hier noch ein paar allgemeine Angaben zur Maschine:

~$ inxi -Fz
System:
  Kernel: 5.4.0-52-generic x86_64 bits: 64 Desktop: Cinnamon 4.6.7
  Distro: Linux Mint 20 Ulyana
Machine:
  Type: Portable System: Dell product: XPS 15 9530 serial: <filter>
  Mobo: Dell model: XPS 15 9530 serial: <filter> UEFI: Dell 
  date: 07/30/2015
Battery:
  ID-1: BAT1 charge: 60.9 Wh condition: 60.9/91.0 Wh (67%)
CPU:
  Topology: Quad Core model: Intel Core i7-4702HQ bits: 64 type: MT MCP
  L2 cache: 6144 KiB
  Speed: 997 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 898 2: 898
  3: 898 4: 898 5: 898 6: 898 7: 898 8: 898
Graphics:
  Device-1: Intel 4th Gen Core Processor Integrated Graphics driver: i915
  v: kernel
  Device-2: NVIDIA GK107M [GeForce GT 750M] driver: nouveau v: kernel
  Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa
  resolution: 3200x1800~60Hz
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2)
  v: 4.5 Mesa 20.0.8
Audio:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
  driver: snd_hda_intel
  Device-2: Intel 8 Series/C220 Series High Definition Audio
  driver: snd_hda_intel
  Sound Server: ALSA v: k5.4.0-52-generic
Network:
  Device-1: Intel Wireless 7260 driver: iwlwifi
  IF: wlp6s0 state: up mac: <filter>
  IF-ID-1: docker0 state: down mac: <filter>
Drives:
  Local Storage: total: 3.19 TiB used: 711.67 GiB (21.8%)
  ID-1: /dev/sda vendor: Samsung model: SSD SM841 mSATA 512GB
  size: 476.94 GiB
  ID-2: /dev/sdb type: USB vendor: Toshiba model: External USB 3.0
  size: 2.73 TiB
Partition:
  ID-1: / size: 36.42 GiB used: 17.17 GiB (47.1%) fs: ext4 dev: /dev/sda10
  ID-2: /boot size: 9.10 GiB used: 441.1 MiB (4.7%) fs: ext4 dev: /dev/sda9
  ID-3: /home size: 155.15 GiB used: 127.30 GiB (82.0%) fs: ext4
  dev: /dev/sda12
  ID-4: swap-1 size: 16.76 GiB used: 644.5 MiB (3.8%) fs: swap
  dev: /dev/sda11
Sensors:
  System Temperatures: cpu: 61.5 C mobo: N/A gpu: nouveau temp: 27 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 290 Uptime: 20h 47m Memory: 15.54 GiB used: 3.16 GiB (20.3%)
  Shell: bash inxi: 3.0.38

Nach meinem Wissensstand ist Miraclecast unbrauchbar.
Wir hatten das Thema schon früher; neues habe ich seitdem nicht gelesen.

Guten Abend,
ich habe mich auch mal mit diesem Thema beschäftigt, hier mein letzer Beitrag zu dem Thema: https://www.linuxmintusers.de/index.php?topic=55606.msg753198#msg753198
Gruß
Wolfgang

ich habe mich auch mal mit diesem Thema beschäftigt,
Ja genau, habe ich gelesen. Das war vor einem guten Jahr. Damals hat dein Wlan-Adapter kein P2P unterstützt, was bei mir ja laut Diagnosescript funktioniert.

Bist Du zwischenzeitig weiter gekommen, evtl. mit einem anderen Rechner?

Moin,
ich werde nochmal einen Anlauf nehmen.
Werde dann berichten...
Gruß
Wolfgang

Moin,
versuch mal folgendes:
1.
systemctl stop NetworkManager.servicesystemctl stop wpa_supplicant.service 2.
sudo miracle-wifid3. Weiteres Terminal öffnen, da geht es dann weiter mit:
4.sudo miracle-wifid & dbus-send --system --dest=org.freedesktop.DBus --type=method_call --print-reply /org/freedesktop/DBus org.freedesktop.DBus.ListNames | grep miracle
Hier sollte als Ergebnis: "org.freedesktop.miracle.wifi" ausgegeben werden.
5.
sudo miracle-sinkctl6.run 3

So konnte ich auf einem Windowrechner zumindest mal "Miracle" sehen und zum Verbinden anklicken...
ABER: Die Verbindung bricht immer wieder ab!
Vielleicht klappt es ja bei dir...
Zur Info, ich habe es auf eine LM20 Cinnamon, mit "autogen.sh" installiert (die ppa gehen leider nicht für LM20).
Gruß
Wolfgang


« Letzte Änderung: 24.10.2020, 12:59:56 von Wolfgang58 »

OK, danke vielmals Wolfgang. Bis zum run-Befehl komme ich auch so wie von dir beschrieben. Bei mir war es dann run 2:

sudo miracle-sinkctl
[ADD] Link: 2
[miraclectl] # run 2
now running on link 2
[ADD] Peer: MACadresse@2
[miraclectl] #


Leider tut sich dann nirgendwo etwas sichtbares. Weder das Bild des verbundenen Fernsehers auf dem Laptop noch umgekehrt. Der Fernseher wartet weiter auf die Verbindung. 


Hallo Mäck,
ich bin auf folgendes Projekt gestoßen:
https://gitlab.gnome.org/GNOME/gnome-network-displays
Ich habe das Programm  "gnome-network-displays"  mit meson installiert.
So richtig läuft es bei mir nicht, aber eventuell geht es ja mit deiner Hardware. Die ganze Sache, mit Miracast & Linux" scheint mir sehr "difficult" zu sein.
Ein Versuch wäre ist es Wert...
Gruß
Wolfgang

Moin,
ich bin etwas weiter gekommen..
Ich konnte mit:
NETWORK_DISPLAYS_DUMMY=1  gnome-network-displaysEinen "Dummy WFD Sink" sehen. Diesen muss man starten und mit VLC habe kann eine Verbindung mit:
rtsp://localhost:7236/wfd1.0hergestellt.
Gruß
Wolfgang



Einen schönen guten Morgen,
ich habe hier die Flatpak Anwendung des Projektes "GNOME Network Displays" gefunden.
Gruß
Wolfgang

Tatsächlich ein neues Projekt
Zitat
experimental implementation of Wi-Fi Display (aka Miracast)
Schaun mer mal, ob was draus wird ...

Ein Versuch wäre ist es Wert...
Gruß
Wolfgang
Ja, muss ich bei Gelegenheit mal ausprobieren. Momentan fehlt es an der Zeit. Danke für den Tipp, Wolfgang.

Guten Abend,
es ist eine Versuch Wert... :)
Ich habe mit meinem alten ASUS EeePC und LM20 (Chinnamon) mit der "GNOME Network Displays" Anwendung, welche ich als Flatpak installiert habe, eine Spieglung des Desktop auf dem TV erreicht.
Als Empfänger habe ich einen MiraScreen G4 (ca. 16,-- € bei Ebay) am TV über einen Denon-Receiver angeschlossen.
Ich habe das mit verschiedenen Leonovo Laptops T520, T420 und T530 probiert, wobei nur der T520 über die notwendige p2p Unterstützung verfügt, aber eine Verbindung hat nicht funktioniert.   
Der MiraScreen funktioniert auch mit dem iPhone und mit Win10 (T530) einwandfrei.
Während der Verbindung funktioniert übrigens auch das Internet...
Gruß
Wolfgang
« Letzte Änderung: 08.11.2020, 23:20:31 von Wolfgang58 »

 

1. Advent
1. Advent