Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
01.12.2020, 09:06:31

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24840
  • Letzte: Foxinity
Statistiken
  • Beiträge insgesamt: 697744
  • Themen insgesamt: 56462
  • Heute online: 537
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Externe Festplatte wird nicht mehr erkannt, unter anderem Linuxrechner schon.  (Gelesen 451 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo in die Runde,

bin erstmalig hier im Forum tätig. Habe leider bisher keine Lösung für das Problem gefunden.
Habe das Problem auch beim Ubuntu-Forum gepostet.

Am Linuxrechner einer Freundin (Linux Mint 19.1 Tessa 64-bit, Kernel Linux 4.15.0-118-generic x86_64, MATE 1.20.1) wird die 1 TB Festplatte (NTFS Formatierung) von Transcend an allen USB-Schnittstellen scheinbar nicht mehr erkannt. Bis vor kurzem ging das noch laut Freundin. Andere Festplatten (NTFS oder ext-4 oder oder) werden erkannt und sind benutzbar. Die Festplatte wird auf meinem Linuxrechner (Ubuntu 16.04 amd64) erkannt und ist benutzbar.

Ich habe verschiedene Befehle aus dem Forum angewandt, um das Problem zu Umkreisen, finde aber keinen Lösungsweg.

Hoffentlich kann hier jemand helfen.

Beste Grüße Michael

Hier die verschiedenen Ausgaben für die benutzen Befehle.

sudo fdisk -l
heike@heike-ThinkPad:~$ sudo fdisk -l
[sudo] Passwort für heike:         
Festplatte /dev/sda: 119,2 GiB, 128035676160 Bytes, 250069680 Sektoren
Einheiten: Sektoren von 1 * 512 = 512 Bytes
Sektorgröße (logisch/physikalisch): 512 Bytes / 512 Bytes
E/A-Größe (minimal/optimal): 512 Bytes / 512 Bytes
Festplattenbezeichnungstyp: dos
Festplattenbezeichner: 0x3d417002

Gerät      Boot    Anfang      Ende  Sektoren Größe Kn Typ
/dev/sda1  *         2048    718847    716800  350M  7 HPFS/NTFS/exFAT
/dev/sda2          718848 103118847 102400000 48,8G  7 HPFS/NTFS/exFAT
/dev/sda4       103120894 250068991 146948098 70,1G  5 Erweiterte
/dev/sda5       173432832 250068991  76636160 36,6G 83 Linux
/dev/sda6       103120896 173432831  70311936 33,5G 83 Linux

Partitionstabelleneinträge sind nicht in Festplatten-Reihenfolge.


lsusb
heike@heike-ThinkPad:~$ lsusb
Bus 001 Device 002: ID 8087:8000 Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 006: ID 138a:0011 Validity Sensors, Inc. VFS5011 Fingerprint Reader
Bus 002 Device 005: ID 5986:029d Acer, Inc
Bus 002 Device 002: ID 1bcf:0005 Sunplus Innovation Technology Inc. Optical Mouse
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

lspci -v | grep -i usb
heike@heike-ThinkPad:~$ lspci -v | grep -i usb
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04) (prog-if 30 [XHCI])
Subsystem: Lenovo 8 Series USB xHCI HC
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04) (prog-if 20 [EHCI])
Subsystem: Lenovo 8 Series USB EHCI

lsmod | grep -i usb (Kernelmodul auf usb prüfen)
heike@heike-ThinkPad:~$ lsmod | grep -i usb
usb_storage            69632  1 uas
btusb                  45056  0
btrtl                  16384  1 btusb
btbcm                  16384  1 btusb
btintel                16384  1 btusb
bluetooth             548864  11 btrtl,btintel,btbcm,bnep,btusb
usbhid                 49152  0
hid                   118784  2 usbhid,hid_generic

dmesg –> Festplatte anschließen und nochmal dmesg –> keine neuen Ausgabezeilen

neo67

  • Administrator
  • *****
Hi Michael,

erstmal willkommen im Grünen.

Könnte das hier helfen:
https://www.linuxmintusers.de/index.php?topic=59753.0


Eine andere Möglichkeit wäre eine hohe Stromaufnahme der Platte. Die brauchen nach etwa 1A zum Starten. USB2 liefert nach Norm nur 0,5 A, USB3 glaube ich 0,9 A. Dort könnte ein Unterschied liegen. Manche USB Anschlüsse sind intern Doppelanschlüsse, so dass sie sich die Stromversorgung teilen müssen.
Ein Versuch wäre es einen aktiven Hub zwischen zu schalten.

Hey,

vielen Dank... ;)

Also den Hinweis unter dem Link bin ich nachgegangen.
Das hat nichts wirkliches gebracht und ist dort auch ein anderes Problem.

Zu der Stromaufnahme:
Die Festplatte hatte ja vorher noch an diesem Computer funktioniert, wurde gelesen etc.. Der Computer, ein ThinkPad neueren Datums ist auch recht leistungsstark und ließt auch ohne scheinbare Probleme andere 1TB Festplatten formatiert in NTFS. Nur eben jene eine nicht mehr, die aber an anderen Rechnern, z.B. mit Ubuntu 16.04 Betriebssystem ohne Zögern gelesen wird.

Mit gparted und auch der Laufwerksanzeige hatte ich schon zu aller Anfang gearbeitet. Die Festplatte taucht da aber überhaupt nicht auf. Die Lampe an der Festplatte leuchtet aber, wenn man an USB anschließt. Nur die typischen Lesegeräusche finden nicht statt. An anderen Rechnern schon. FestplattenLesetest via Laufwerksprogramm hatte ich auch unter Ubuntu am anderen Rechner mit dieser Festplatte. Da werden auch keine Fehler oder Ungereimtheiten angezeigt. Scheint mit ein Software-Fehler-Bug in Linux Mint 19.1 Tessa...but who knows...

Ich hoffe weiter auf Eure Hilfe. Ich würde mich nicht als vollkommenen Neuling bezeichnen, da ich schon so manche Nächte in den letzten Jahren mit den einen oder anderen Herausforderungen in Linux zu tun hatte und die meisten auch lösen konnte. Aber hier komme ich gerade gar nicht weiter, habe nichts in den beiden Foren gefunden und tappe vollkommen im Dunkeln....

Freue mich weiter auf Eure Hinweise...

Beste Grüße aus dem Abend
Michael

Das gemeine an der Stromversorgung für solche externen Platten über den normalen USB-Port ist, dass der USB-Port damit prinzipiell überfordert ist, es aber zumeist noch geht. Dann wird deine Platte etwas älter, irgend ein Lager hat so seine Probleme und der Strombedarf steigt um einige Miliampere, die dann nicht mehr geliefert werden können. Oder du hast einen Doppel-USB-Port und schließt ein neues zusätzliches USB-Gerät an, dass sich dann mit der Platte den Strom teilen muss.
Daher wäre der Versuch, einen aktiven USB-Port zwischen zu schalten, sehr aufschlussreich.
« Letzte Änderung: 23.10.2020, 23:26:22 von Bernibär »

Öffne doch mal ein Terminal und gib "dmesg --follow" ohne Anführungszeichen ein, Enter drücken und dann die Platte einstecken.

Off-Topic:
@tam
Warum setzt du den Befehl nicht wie es üblich ist in Codeblock?

dmesg --follow

Hey...

war kurz woanders.

dmesg --follow
brachte tatsächlich nach etwa 10 Sekunden folgendes:

[ 1851.865858] [UFW BLOCK] IN=enp3s0 OUT= MAC=01:00:5e:00:00:01:e0:28:6d:91:f3:b2:08:00 SRC=192.168.178.1 DST=224.0.0.1 LEN=36 TOS=0x00 PREC=0xC0 TTL=1 ID=46103 DF PROTO=2
Das sieht aber nicht nach Festplattenaktivität aus. Beim Zweiten und dritten Mal einhängen passierte auch nichts mehr.

ABER die HUB-Geschichte
....

Also einen aktiven USB-Hub mit Stromversorgung habe ich leider gerade nicht an der Hand. ABER einen ohne Stromversorgung. Ich dachte ich probier's mal. ei der Daus...Die Festplatte regt sich. Wird ind gparted und Laufwerke erkannt.

Mit [code]dmesg --follow 
[/code] sowie Festplatte am USB-Hub und diesen an USB-Port einstecken 

kommt folgendes neu:
[ 3587.290335] usb 2-2: new full-speed USB device number 14 using xhci_hcd
[ 3587.439004] usb 2-2: New USB device found, idVendor=058f, idProduct=9254
[ 3587.439009] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 3587.439012] usb 2-2: Product: Generic USB Hub
[ 3587.439014] usb 2-2: Manufacturer: ALCOR
[ 3587.439575] hub 2-2:1.0: USB hub found
[ 3587.439673] hub 2-2:1.0: 4 ports detected
[ 3587.503153] [UFW BLOCK] IN=enp3s0 OUT= MAC= SRC=fe80:0000:0000:0000:8833:ae3a:e350:a55f DST=ff02:0000:0000:0000:0000:0000:0000:0001 LEN=64 TC=0 HOPLIMIT=1 FLOWLBL=189851 PROTO=UDP SPT=8612 DPT=8612 LEN=24
[ 3587.503167] [UFW BLOCK] IN=enp3s0 OUT= MAC= SRC=fe80:0000:0000:0000:8833:ae3a:e350:a55f DST=ff02:0000:0000:0000:0000:0000:0000:0001 LEN=64 TC=0 HOPLIMIT=1 FLOWLBL=837001 PROTO=UDP SPT=8612 DPT=8610 LEN=24
[ 3591.878318] usb 2-2.1: new full-speed USB device number 15 using xhci_hcd
[ 3592.019406] usb 2-2.1: not running at top speed; connect to a high speed hub
[ 3592.027265] usb 2-2.1: New USB device found, idVendor=174c, idProduct=5106
[ 3592.027272] usb 2-2.1: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[ 3592.027275] usb 2-2.1: Product: StoreJet Transcend
[ 3592.027278] usb 2-2.1: Manufacturer: StoreJet Transcend
[ 3592.027281] usb 2-2.1: SerialNumber: S318J9JG703924     
[ 3592.028216] usb-storage 2-2.1:1.0: USB Mass Storage device detected
[ 3592.028487] scsi host4: usb-storage 2-2.1:1.0
[ 3593.049474] scsi 4:0:0:0: Direct-Access     StoreJet Transcend        0    PQ: 0 ANSI: 6
[ 3593.050432] sd 4:0:0:0: Attached scsi generic sg1 type 0
[ 3593.051515] sd 4:0:0:0: [sdb] 1953525168 512-byte logical blocks: (1.00 TB/932 GiB)
[ 3593.051972] sd 4:0:0:0: [sdb] Write Protect is off
[ 3593.051973] sd 4:0:0:0: [sdb] Mode Sense: 43 00 00 00
[ 3593.052488] sd 4:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[ 3593.083578]  sdb: sdb1
[ 3593.085378] sd 4:0:0:0: [sdb] Attached SCSI disk
[ 3601.868375] [UFW BLOCK] IN=enp3s0 OUT= MAC=01:00:5e:00:00:01:e0:28:6d:91:f3:b2:08:00 SRC=192.168.178.1 DST=224.0.0.1 LEN=36 TOS=0x00 PREC=0xC0 TTL=1 ID=59109 DF PROTO=2

Die Festplatte mounted aber nicht. Vielleicht ist es wirklich die Stromversorgung.Das scheint's... ;D

bis gleich...
WOW

Beste Grüße
Michael

thebookkeeper

  • aka AnanasDampf
  • *****
...
dmesg --follow
brachte tatsächlich nach etwa 10 Sekunden folgendes:

[ 1851.865858] [UFW BLOCK] IN=enp3s0 OUT= MAC=01:00:5e:00:00:01:e0:28:6d:91:f3:b2:08:00 SRC=192.168.178.1 DST=224.0.0.1 LEN=36 TOS=0x00 PREC=0xC0 TTL=1 ID=46103 DF PROTO=2
Das sieht aber nicht nach Festplattenaktivität aus ...
Nein, sieht nach Aktivität der Desktop-Firewall aus (ufw),
evtl. probiere mal:
dmesg -T -l err

Festplatte via USB-HUB ohne Stromversorgung mountet nach etwa 20 Sekunden und Datenzugriff ist möglich...

Nun hier der Befehl via Terminal in drei Varianten...

mit eingesteckter Festplatte ohne USB-HUB ergibt:

heike@heike-ThinkPad:~$ dmesg -T -l err
[Fr Okt 23 20:53:25 2020] ACPI Exception: AE_BAD_PARAMETER, Returned by Handler for [EmbeddedControl] (20170831/evregion-300)
[Fr Okt 23 20:53:25 2020] ACPI Error: Method parse/execution failed \_TZ.TZ01._TMP, AE_BAD_PARAMETER (20170831/psparse-550)
[Fr Okt 23 20:53:25 2020] ACPI Exception: AE_BAD_PARAMETER, Returned by Handler for [EmbeddedControl] (20170831/evregion-300)
[Fr Okt 23 20:53:25 2020] ACPI Error: Method parse/execution failed \_TZ.TZ01._TMP, AE_BAD_PARAMETER (20170831/psparse-550)
[Fr Okt 23 20:53:30 2020] Bluetooth: hci0: unexpected event for opcode 0xfc2f
[Fr Okt 23 21:21:11 2020] Bluetooth: hci0: unexpected event for opcode 0xfc2f
[Fr Okt 23 21:45:09 2020] Buffer I/O error on dev sdb1, logical block 976787872, async page read
[Fr Okt 23 21:45:09 2020] Buffer I/O error on dev sdb1, logical block 976787873, async page read
[Fr Okt 23 21:45:09 2020] Buffer I/O error on dev sdb1, logical block 976787874, async page read
[Fr Okt 23 21:45:09 2020] Buffer I/O error on dev sdb1, logical block 976787875, async page read
[Fr Okt 23 21:45:09 2020] Buffer I/O error on dev sdb1, logical block 976787876, async page read
[Fr Okt 23 21:45:09 2020] Buffer I/O error on dev sdb1, logical block 976787877, async page read
[Fr Okt 23 21:45:09 2020] Buffer I/O error on dev sdb1, logical block 976787878, async page read
[Fr Okt 23 21:45:09 2020] Buffer I/O error on dev sdb1, logical block 976787879, async page read
[Fr Okt 23 21:52:22 2020] Buffer I/O error on dev sdb1, logical block 976812704, async page read
[Fr Okt 23 21:52:22 2020] Buffer I/O error on dev sdb1, logical block 976812705, async page read
[Fr Okt 23 21:52:22 2020] Buffer I/O error on dev sdb1, logical block 976812706, async page read
[Fr Okt 23 21:52:22 2020] Buffer I/O error on dev sdb1, logical block 976812707, async page read
[Fr Okt 23 21:52:22 2020] Buffer I/O error on dev sdb1, logical block 976812708, async page read
[Fr Okt 23 21:52:22 2020] Buffer I/O error on dev sdb1, logical block 976812709, async page read
[Fr Okt 23 21:52:22 2020] Buffer I/O error on dev sdb1, logical block 976812710, async page read
[Fr Okt 23 21:52:22 2020] Buffer I/O error on dev sdb1, logical block 976812711, async page read
[Fr Okt 23 21:52:22 2020] print_req_error: I/O error, dev sdb, sector 0
[Fr Okt 23 22:46:50 2020] Buffer I/O error on dev sdb1, logical block 0, async page read

Festplatte nicht eingesteckt  und Befehl ... ergibt nichts

Festplatte via USB-HUb eingesteckt und Befehl ergibt:
heike@heike-ThinkPad:~$ dmesg -T -l err
[Fr Okt 23 20:53:25 2020] ACPI Exception: AE_BAD_PARAMETER, Returned by Handler for [EmbeddedControl] (20170831/evregion-300)
[Fr Okt 23 20:53:25 2020] ACPI Error: Method parse/execution failed \_TZ.TZ01._TMP, AE_BAD_PARAMETER (20170831/psparse-550)
[Fr Okt 23 20:53:25 2020] ACPI Exception: AE_BAD_PARAMETER, Returned by Handler for [EmbeddedControl] (20170831/evregion-300)
[Fr Okt 23 20:53:25 2020] ACPI Error: Method parse/execution failed \_TZ.TZ01._TMP, AE_BAD_PARAMETER (20170831/psparse-550)
[Fr Okt 23 20:53:30 2020] Bluetooth: hci0: unexpected event for opcode 0xfc2f
[Fr Okt 23 21:21:11 2020] Bluetooth: hci0: unexpected event for opcode 0xfc2f
[Fr Okt 23 21:45:09 2020] Buffer I/O error on dev sdb1, logical block 976787872, async page read
[Fr Okt 23 21:45:09 2020] Buffer I/O error on dev sdb1, logical block 976787873, async page read
[Fr Okt 23 21:45:09 2020] Buffer I/O error on dev sdb1, logical block 976787874, async page read
[Fr Okt 23 21:45:09 2020] Buffer I/O error on dev sdb1, logical block 976787875, async page read
[Fr Okt 23 21:45:09 2020] Buffer I/O error on dev sdb1, logical block 976787876, async page read
[Fr Okt 23 21:45:09 2020] Buffer I/O error on dev sdb1, logical block 976787877, async page read
[Fr Okt 23 21:45:09 2020] Buffer I/O error on dev sdb1, logical block 976787878, async page read
[Fr Okt 23 21:45:09 2020] Buffer I/O error on dev sdb1, logical block 976787879, async page read
[Fr Okt 23 21:52:22 2020] Buffer I/O error on dev sdb1, logical block 976812704, async page read
[Fr Okt 23 21:52:22 2020] Buffer I/O error on dev sdb1, logical block 976812705, async page read
[Fr Okt 23 21:52:22 2020] Buffer I/O error on dev sdb1, logical block 976812706, async page read
[Fr Okt 23 21:52:22 2020] Buffer I/O error on dev sdb1, logical block 976812707, async page read
[Fr Okt 23 21:52:22 2020] Buffer I/O error on dev sdb1, logical block 976812708, async page read
[Fr Okt 23 21:52:22 2020] Buffer I/O error on dev sdb1, logical block 976812709, async page read
[Fr Okt 23 21:52:22 2020] Buffer I/O error on dev sdb1, logical block 976812710, async page read
[Fr Okt 23 21:52:22 2020] Buffer I/O error on dev sdb1, logical block 976812711, async page read
[Fr Okt 23 21:52:22 2020] print_req_error: I/O error, dev sdb, sector 0
[Fr Okt 23 22:46:50 2020] Buffer I/O error on dev sdb1, logical block 0, async page read

thebookkeeper

  • aka AnanasDampf
  • *****
Festplatte via USB-HUB ohne Stromversorgung mountet nach etwa 20 Sekunden und Datenzugriff ist möglich...
Und das Ding erscheint dann als sdb1 per Ausgabe von:
blkid -o list -w /dev/null?

joo

mit Festplatte Am USB-HUB und
blkid -o list -w /dev/null
kommt dann folgendes:

heike@heike-ThinkPad:~$ blkid -o list -w /dev/null
device                                                                            fs_type         label            mount point                                                                           UUID
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
/dev/sda1                                                                                                  ntfs                  System-reserviert      /media/heike/System-reserviert                                                                                 021617C71617BA9D
/dev/sda2                                                                                                  ntfs                                         /media/heike/F84E196D4E192642                                                                                  F84E196D4E192642
/dev/sda5                                                                                                  ext4                                         /home                                                                                                          7575567e-4bcd-4d32-ac36-1a2a26c0cb64
/dev/sda6                                                                                                  ext4                                         /                                                                                                              7dbbcdc0-fc67-4851-a58d-186e225d2007
/dev/sdb1                                                                                                  ntfs                  Transcend 1            /media/heike/Transcend 1 

und hier noch Festplatte ohne USB-HUB eingesteckt:

heike@heike-ThinkPad:~$ blkid -o list -w /dev/null
device                                                                            fs_type         label            mount point                                                                           UUID
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
/dev/sda1                                                                                                  ntfs                  System-reserviert      /media/heike/System-reserviert                                                                                 021617C71617BA9D
/dev/sda2                                                                                                  ntfs                                         /media/heike/F84E196D4E192642                                                                                  F84E196D4E192642
/dev/sda5                                                                                                  ext4                                         /home                                                                                                          7575567e-4bcd-4d32-ac36-1a2a26c0cb64
/dev/sda6                                                                                                  ext4                                         /                                                                                                              7dbbcdc0-fc67-4851-a58d-186e225d2007
heike@heike-ThinkPad:~$

wird wieder nur die interne Festplatte angezeigt...

Mache mich erst mal in die Herbstferien und bin ab dem 1.11. wieder online.

Vielen vielen Dank erst mal bis hierhin.

Michael  :)

Gemounted ist sie aber doch.
/dev/sdb1   ntfs   Transcend 1   /media/heike/Transcend 1

 

1. Advent
1. Advent