Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
27.11.2020, 23:36:58

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24828
  • Letzte: kohlhaas
Statistiken
  • Beiträge insgesamt: 697099
  • Themen insgesamt: 56412
  • Heute online: 669
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Installation von Epson EcoTank L3110  (Gelesen 531 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Installation von Epson EcoTank L3110
« am: 17.10.2020, 11:49:24 »
Liebe LMUler,

ich versuche gerade einen Epson EcoTank L3110 auf Linux Mint 19.3 Tricia zu installieren und bin am verzweifeln.

Ziel ist es, den Drucker, aber noch wichtiger, den Scanner über USB (notfalls auch über WLAN) zu installieren.

Ich bin dabei im Wesentlichen wie von LiMinter auf
https://www.linuxmintusers.de/index.php?topic=57781.msg778250#msg778250
beschrieben vorgegangen, d.h. ich habe

1.+2. "epson-inkjet-printer-escpr_NUMMER_XXX_amd64.deb" installiert       
     3.  "epson-printer-utility_NUMMER_XXX_amd64.deb" installiert 
4.+5. "imagescan-bundle-linuxmint-NUMMER_XXX.deb.tar.gz"entpackt und "Im Terminal öffnen" ausgewählt, sowie im
           Terminal "./install.sh" eingegeben
       -  den Drucker eingeschaltet
     7.  in der „Systemverwaltung“-> „Drucker“ ->„hinzufügen“ gewählt
     8.  Dort den Drucker „Epson L3110“ ausgewählt und Mint die Treiber installieren lassen
       
Ich vermute, dass der Drucker tatsächlich installiert ist und funktioniert, habe aber keine Testseite ausgedruckt, da ich - bevor der Scanner nicht läuft - eigentlich noch keine Farbe in den Drucker einfüllen möchte. Jedenfalls bekomme ich jetzt unter Drucker einen „Epson L3110-Series“ (Geräteadresse: usb://EPSON/L3110%20Series?serial=583634363032393614&interface=1) und einen „L3110-Series“ (Geräteadresse: 3634363032393614&interface=1) angezeigt

10.  den Ordner /etc/imagescan/ als Systemverwalter geöffnet und die Datei "imagescan.conf" anzupassen versucht . Hier habe ich das
      Problem, dass ich nicht weiß,
  • ob ich das überhaupt machen muss, um den Scanner am USB-Anschluss zum Laufen zu bringen.
  • wie ich herausbekomme, welche IP ich eintragen muss
  • welches Modell ich explizit angeben muss (ich habe erfolglos 4 verschiedene Varianten ausprobiert: mit/ohne Epson und mit/ohne Bindestrich)

Derzeit steht folgende Änderung in der Datei (Die früheren ; sind weg)
myscanner.udi    = esci:networkscan://192.168.0.2:1865
myscanner.vendor = Epson
myscanner.model  = L3110-Series
Allerdings funktioniert der Scanner nicht.
SimpleScan meldet
Scannen fehlgeschlagen – Verbindung zum Scanner konnte nicht hergestellt werden Imagescan meldet
Zugriff auf Epson L3110_Series (esci:usb:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-5/1-5:1.0) Gerät ausgelastet nicht möglich wobei mich der letzte Satz ("Gerät ausgelastet") besonders irritiert.

Sudo sane-find-scanner liefert
# sane-find-scanner will now attempt to detect your scanner. If the
  # result is different from what you expected, first make sure your
  # scanner is powered up and properly connected to your computer.

  # No SCSI scanners found. If you expected something different, make sure that
  # you have loaded a kernel SCSI driver for your SCSI adapter.

found USB scanner (vendor=0x04b8 [EPSON], product=0x1142 [L3110 Series]) at libusb:001:003
could not fetch string descriptor: Pipe error
could not fetch string descriptor: Pipe error
  # Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

  # Not checking for parallel port scanners.

  # Most Scanners connected to the parallel port or other proprietary ports
  # can't be detected by this program.

Scanimage -L liefert

device `imagescan:esci:networkscan://192.168.0.2:1865' is a Epson L3110-Series
device `imagescan:esci:usb:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-5/1-5:1.0' is a EPSON L3110_Series

Hat irgendjemand eine Idee, wie ich den Scanner zum Laufen bringe?

Für Eure Bemühungen schon einmal herzlichen Dank

Jnewbie

Re: Installation von Epson EcoTank L3110
« Antwort #1 am: 17.10.2020, 12:31:02 »
Ich würde das Usb Kabel erstmal entfernen und über Wlan probieren.
Bei SimpleScan in den Einstellungen den richtigen Scanner/Drucker auswählen.
Manchmal dauert es ein paar Sekunden bis SimpleScan den NetztwerkScanner (WlanScanner) gefunden hat.

Wird er nicht erkannt ggf. SimpleScan einmal mit Systemverwalterrechten starten. Wird er da erkannt, dann fehlen die Userrechte zum Scannen.
« Letzte Änderung: 17.10.2020, 12:36:18 von Mintnix »

Re: Installation von Epson EcoTank L3110
« Antwort #2 am: 17.10.2020, 17:02:46 »
Liebe LMUler

eine kurze Aktualisierung:

Ich habe mich nun dazu durchgerungen die Druckerfarben doch einzufüllen.
Es zeigt sich, dass der Drucker tatsächlich richtig eingerichtet war.

Bleibt der Scanner:
Simple Scan:   - mittlerweile keine Fehlermeldung mehr. Allerdings funktioniert die Software dennoch nicht wie gewünscht. Software „dreht am Rad“, bricht nach 1-2 Sekunden ab. Der Scanner fängt aber nicht zu scannen an.

Image Scan:  -bei Auswahl des einen Druckers Fehlermeldung Zugriff auf Epson L3110-Series (esci:networkscan://192.168.0.2:1865) //192.168.0.2:1865: error receiving nicht möglich - bei Auswahl des anderen (USB?)-Druckers kann Speicherort festgelegt werden, auch macht der Scanner Geräusche. Nach Ende des Scannvorgangs wird die Datei jedoch nicht gespeichert.

Gscan2pdf: führt Scandurchgang durch und zeigt das Ergebnis im „Hauptfenster“ an. Dieses lässt sich abspeichern! Damit bin ich jetzt wenigstens in der Lage zu scannen. Lieber wäre es mir natürlich, wenn auch die anderen Scanprogramme funktionieren würden. Deshalb schließe ich den Thread jetzt mal noch nicht.

Sudo sane-find-scanner und Scanimage -L liefern das selbe Ergebnis wie im ersten Thread beschrieben (Ausnahme: Sudo sane-find-scanner findet den Scanner nun auf libusb:001:003. Dies liegt wohl daran, dass ich zwischenzeitlich den Drucker in einen anderen USB-Anschluss gesteckt habe).

@Mintnix: Wie öffne ich SimpleScan mit Systemverwalterrechten? Ich glaube allerdings, dass mein Standarduser die Rechte zum Scannen besitzt, denn sein Kontotyp ist laut Systemverwaltung -> Benutzer und Gruppen "Systemverwalter".

Für weitere Ratschläge wäre ich sehr dankbar.

Liebe Grüße
   Jnewbie

Re: Installation von Epson EcoTank L3110
« Antwort #3 am: 17.10.2020, 17:13:56 »
Ich glaube allerdings, dass mein Standarduser die Rechte zum Scannen besitzt, denn sein Kontotyp ist laut Systemverwaltung -> Benutzer und Gruppen "Systemverwalter".
Das heißt aber nicht, dass du dauernd Admin bist, du kannst es bei Bedarf werden, und das ist auch gewollt und gut so!

Ein grafisches Programm startest du im Terminal mit
sudo -H PROGRAMMNAME(Ein normaler User hat diese Option nicht!)

Meist reicht es, das einmal zu tun, danach klappt es auch ohne sudo.

Re: Installation von Epson EcoTank L3110
« Antwort #4 am: 17.10.2020, 22:47:41 »
Bist du in den Gruppen scanner und saned drin? Wenn nicht, könnte das helfen.

Re: Installation von Epson EcoTank L3110
« Antwort #5 am: 18.10.2020, 07:39:29 »
Hallo, mal eine dumme Frage. Hasst du vor der Treiberinstallation
LSB installiert? Bei meinem Epson musst du nämlich als erstes
lsb installieren.

Re: Installation von Epson EcoTank L3110
« Antwort #6 am: 18.10.2020, 15:56:44 »
Liebe LMUler

Mein Standarduser war tatsächlich weder in der Gruppe „scanner“ noch in der Gruppe „saned“.
Ich habe in der Systemverwaltung → Benutzer und Gruppen diese Rechte nun meinem User zugeordnet.

Leider hat das das Problem aber nicht gelöst.

@timberlake: Auch LSB war vor der Installation schon installiert (ich weiß jetzt nicht mehr, ob ich das gestern oder zu einem früheren Zeitpunkt gemacht habe oder vielleicht bei Mint standardmäßig vorinstalliert ist, aber in der Paketverwaltung werden die LSB-Dateien als installiert angezeigt)

@Mintnix: das Entfernen des USB-Kabels macht m.E. das Problem nur noch größer, denn bisher habe ich noch keine Antwort auf die drei in meinem Startpost unter 10. genannten Fragen erhalten (Insbesondere bin ich mir nicht mal sicher, ob die IP-Adresse 192.168.0.2 richtig ist. Unter der parallel laufenden proprietären Software ist beispielsweise eine andere IP-Adresse angegeben, die ich mittlerweile auch – erfolglos – ausprobiert habe). Auch glaube ich, dass die jetzige Lösung unter GScan2pdf über den USB-Scanner läuft und nicht über WLAN.

Für die bisherigen und hoffentlich auch weitere Hinweise schon einmal herzlichen Dank

Jnewbie

Re: Installation von Epson EcoTank L3110
« Antwort #7 am: 19.10.2020, 18:10:42 »
Hallo,
könntest du noch das Programm Xsane probieren?
ich hatte mit meinem Epson Printer/Scanner  teilweise identische Probleme wie oben beschrieben, xsane war das einzigste meiner Programme das unter 19.3 Cinnamon gescannt hat.


Re: Installation von Epson EcoTank L3110
« Antwort #8 am: 20.10.2020, 21:42:25 »
Lieber Muggel,

ich habe soeben Xsane ausprobiert.

Es zeigt ein ähnliches Verhalten wie gscan2pdf
Xsane erstellt keine Vorschaubilder, zeigt aber Scans an und erlaubt auch, sie zu speichern.

Xsane wäre also ein zweites Programm, das irgendwie halb funktioniert.

Herzlichen Dank für den Tipp

Herzliche Grüße
    Jnewbie

Re: Installation von Epson EcoTank L3110
« Antwort #9 am: 20.10.2020, 21:58:06 »
Hallo,
also ähnlich wie bei mir, falls du noch etwas Lust und auch Plattenkapazität über hast kannst du mal lm20 neuinstallieren, das habe ich auch gemacht.
Mit dem Ergebnis SimpleScan geht, Gscan2pdf geht, Skanlite geht, image scan geht nicht, (kein scanner gefunden)
und bei Xsane ist es noch ominöser, es scannt und zeigt als Ergebnis etwas an was mit der Vorlage nichts zu tun hat. also ich bleibe bei 20.
Aber mit den 3 funktionierenden Programmen hab ich  mehr als genug.