Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
01.12.2020, 03:07:41

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24840
  • Letzte: Foxinity
Statistiken
  • Beiträge insgesamt: 697732
  • Themen insgesamt: 56462
  • Heute online: 475
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 3
Gäste: 397
Gesamt: 400

Autor Thema: [gelöst]  Bootloader zerschossen nach Neuinstallation Mint 20  (Gelesen 668 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Re: Bootloader zerschossen nach Neuinstallation Mint 20
« Antwort #15 am: 15.10.2020, 17:10:37 »
Auch die Platte richtig platt gemacht und eine neue Partitionstabelle geschrieben?

Nummer  Anfang  Ende    Größe  Typ       Dateisystem  Flags
 1      1049kB  538MB   537MB  primary   fat32        boot, esp
 2      538MB   1076MB  538MB  primary   fat32
 3      1077MB  240GB   239GB  extended
 5      1077MB  240GB   239GB  logical   ext4

Nein! es ist immer noch die EFI - Partition mit den Flag's boot,esp da und solange wird das nichts mit der Platte.
« Letzte Änderung: 15.10.2020, 17:14:54 von tommix »

Re: Bootloader zerschossen nach Neuinstallation Mint 20
« Antwort #16 am: 15.10.2020, 17:23:35 »
Und Linux neu installieren, im BIOS - Mode.
das hat er ja schon - siehe Antwort #6
Da der Rechner ja mit LM19.3 gebootet hat (inkl. Win) muss das ja der "BIOS-Mode" gewesen sein.
Dann folgt eine Installation LM 20 unbeabsichtigt im "EFI-Mode" - mein Tipp im UEFI (alt BIOS) ist "both" eingestellt ?! und LM20 konnte ohne Probleme gebootet werden -
allerdings wurde WIN nicht mehr erkannt - was dann logisch ist.
Ich würde jetzt
- LM 20 über die SG2D starten
- den SG2D-Stick ziehen
- mit "gparted" der "EFI-Partition" die Markierung (boot, esp) nehmen 
- das Terminal öffnen und grub neu schreiben mit
sudo grub-install /dev/sdx
das "sdx" anzupassen - je nach den die 240`er Platte dann heißt (sdd oder sde ?)
danach
sudo update-grubRechner runter fahren - neu booten - hoffen das es klappt.


-

« Letzte Änderung: 15.10.2020, 17:29:40 von billyfox05 »

Re: Bootloader zerschossen nach Neuinstallation Mint 20
« Antwort #17 am: 15.10.2020, 17:27:54 »
@billyfox05
Das geht so nicht, da im MBR infos zur EFI - Partition stehen.
Wenn, geht es über eine leere, unformatierte Partition mit dem Flag bios_grub.
Daher bitte eine neue Partitionstabelle mit GParted erstellen.
Anleitung: siehe WIKI.

Er nutzte eine msdos - Partitionstabelle für die UEFI - Installation. und das ist das Problem.
« Letzte Änderung: 15.10.2020, 17:32:08 von tommix »

Re: Bootloader zerschossen nach Neuinstallation Mint 20
« Antwort #18 am: 15.10.2020, 17:28:27 »
Ich habe jetzt zum 3.x Mint inst. Vorher die sde formartiert, zum neustart meldet der Monitor "grub rescue"

Re: Bootloader zerschossen nach Neuinstallation Mint 20
« Antwort #19 am: 15.10.2020, 17:30:37 »
Bitte, bitte!

Einen neue Partitionstabellle erstellen.

siehe: https://www.linuxmintusers.de/index.php?action=wiki;page=Arbeiten_mit_GParted

Re: Bootloader zerschossen nach Neuinstallation Mint 20
« Antwort #20 am: 15.10.2020, 17:36:03 »
Jooo, @tommix kann Recht haben
Formatieren reicht nicht - sondern eine neue Partitionstabelle (msdos) erstellen - dabei wird der MBR auch gelöscht - dann partitionieren / formatieren und neu installieren (im BIOS-Mode).
Dabei beachten das der Bootloader (grub) auf dieser Platte angelegt wird.
Vor dem Rechnerneustart im UEFI kontrollieren das diese Platte in der Bootreihenfolge an erster Stelle steht.

Re: Bootloader zerschossen nach Neuinstallation Mint 20
« Antwort #21 am: 15.10.2020, 18:52:27 »
Er läuft wieder :)

Ich habe es mit "Boot Repair Disk" vom USB Stick hinbekommen. Ich habe als DAU irgendwelche Änderungen durchgeführt und wohl den Bootsektor repariert. Ich würde mich freuen, wenn Ihr Euch  das nochmal ansehen könnt und ich ggf dann noch etwas berichtige um beim nächsten Mal nicht wieder ein solches Chaos anzurichten. Ich nutze Mint schon seit einigen Jahren und habe es auch schon zig mal installiert, aber meist ohne Probleme.

Modell: ATA ST1000DM003-1CH1 (scsi)
Festplatte  /dev/sda:  1000GB
Sektorgröße (logisch/physisch): 512B/4096B
Partitionstabelle: msdos
Disk-Flags:

Nummer  Anfang  Ende    Größe  Typ      Dateisystem  Flags
 1      1049kB  164GB   164GB  primary  ext4         boot
 3      164GB   582GB   418GB  primary  ntfs
 4      582GB   1000GB  418GB  primary  ntfs


Modell: ATA WDC WD10EZEX-00B (scsi)
Festplatte  /dev/sdb:  1000GB
Sektorgröße (logisch/physisch): 512B/4096B
Partitionstabelle: msdos
Disk-Flags:

Nummer  Anfang  Ende    Größe  Typ      Dateisystem  Flags
 1      1049kB  500GB   500GB  primary  ext4
 2      500GB   1000GB  500GB  primary  ext4


Modell: ATA Intenso SSD (scsi)
Festplatte  /dev/sdc:  128GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos
Disk-Flags:

Nummer  Anfang  Ende   Größe  Typ      Dateisystem  Flags
 1      1049kB  127GB  127GB  primary  ntfs         boot
 2      127GB   128GB  558MB  primary  ntfs         msftres


Modell: ATA KINGSTON SA400M8 (scsi)
Festplatte  /dev/sdd:  240GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos
Disk-Flags:

Nummer  Anfang  Ende   Größe  Typ      Dateisystem  Flags
 1      1049kB  240GB  240GB  primary  ext4

[ -d /sys/firmware/efi ] && echo UEFI || echo BIOS
BIOS

Grub gefunden: /dev/sda
Kein Grub: /dev/sda1
Kein Grub: /dev/sda3
Kein Grub: /dev/sda4
Grub gefunden: /dev/sdb
Kein Grub: /dev/sdb1
Kein Grub: /dev/sdb2
Grub gefunden: /dev/sdc
Kein Grub: /dev/sdc1
Kein Grub: /dev/sdc2
Grub gefunden: /dev/sdd
Kein Grub: /dev/sdd1

Modell: ATA ST1000DM003-1CH1 (scsi)
Festplatte  /dev/sda:  1000GB
Sektorgröße (logisch/physisch): 512B/4096B
Partitionstabelle: msdos
Disk-Flags:

Nummer  Anfang  Ende    Größe  Typ      Dateisystem  Flags
 1      1049kB  164GB   164GB  primary  ext4         boot
 3      164GB   582GB   418GB  primary  ntfs
 4      582GB   1000GB  418GB  primary  ntfs


Modell: ATA WDC WD10EZEX-00B (scsi)
Festplatte  /dev/sdb:  1000GB
Sektorgröße (logisch/physisch): 512B/4096B
Partitionstabelle: msdos
Disk-Flags:

Nummer  Anfang  Ende    Größe  Typ      Dateisystem  Flags
 1      1049kB  500GB   500GB  primary  ext4
 2      500GB   1000GB  500GB  primary  ext4


Modell: ATA Intenso SSD (scsi)
Festplatte  /dev/sdc:  128GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos
Disk-Flags:

Nummer  Anfang  Ende   Größe  Typ      Dateisystem  Flags
 1      1049kB  127GB  127GB  primary  ntfs         boot
 2      127GB   128GB  558MB  primary  ntfs         msftres


Modell: ATA KINGSTON SA400M8 (scsi)
Festplatte  /dev/sdd:  240GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos
Disk-Flags:

Nummer  Anfang  Ende   Größe  Typ      Dateisystem  Flags
 1      1049kB  240GB  240GB  primary  ext4


Re: Bootloader zerschossen nach Neuinstallation Mint 20
« Antwort #22 am: 15.10.2020, 19:03:10 »
Ja, wenn es läuft ist doch gut.
Nur von welcher Platte bootest du jetzt?

Re: Bootloader zerschossen nach Neuinstallation Mint 20
« Antwort #23 am: 15.10.2020, 19:13:34 »
1. ich schließe mich @tommix an  ;)
2. was ist mit der Markierung "boot" bei sda1 ?
3. auf sdd hat sich ja reichlich zum Positiven getan - das kann m. E. "Boot Repair" nicht vollbracht haben ?!

Re: Bootloader zerschossen nach Neuinstallation Mint 20
« Antwort #24 am: 15.10.2020, 19:15:52 »
Hab die Kiste erst mal ausgeschaltet, mir raucht der Kopf. Morgen Früh geht es weiter.
Danke Euch schon mal ganz herzlich!!!

Re: Bootloader zerschossen nach Neuinstallation Mint 20
« Antwort #25 am: 16.10.2020, 11:16:10 »
Moin,
zu Euren Fragen kann ich nichts antworten da ich nicht weiß wie ich herausfinden kann. Da ich es aber auch gerne wissen möchte, würde ich mich über einen (weiteren) Tip freuen.
Und vor allen Dingen, habe ich jetzt die richtigen Einstellungen für eine spätere Neuinstallation?
Wie ich schon schrieb, habe ich auf mehreren Rechnern seit vielen Jahren Linux Mint und Win7/10 im Dualboot und soweit ich mich erinnern kann, noch nie solche Sorgen (wenn dann eher andere ;) ).

Danke Euch für Eure Geduld und Hilfestellungen!!!

Re: Bootloader zerschossen nach Neuinstallation Mint 20
« Antwort #26 am: 16.10.2020, 12:18:42 »
Das Problem ist hier wie immer das Windows.
Windows entscheidet über die vorhandene Partitionstabelle auf der Platte ob es im BIOS oder UEFI - Mode installiert wird.
msdos --> BIOS - Mode
gpt --> UEFI - Mode
Und das unabhängig von den UEFI/BIOS Einstellungen.

Linux ist die Partitionstabelle egal. Es wird so installiert, wie das Live-System gestartet wurde.

Wobei ich gestern durch deinen Thread feststellen musste, das zur Zeit da zumindest in einen BIOS - Mode VM etwas falsch läuft.
Bei der Installation "Platte löschen LM installieren" wurde trotzdem eine EFI-Partition erstellt.

 

1. Advent
1. Advent