Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
29.10.2020, 23:44:54

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 691577
  • Themen insgesamt: 55984
  • Heute online: 694
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Installation von Systemback unter LM20  (Gelesen 1553 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Installation von Systemback unter LM20
« am: 14.10.2020, 08:38:39 »
Hallo!

Gemäß https://wiki.ubuntuusers.de/Systemback/ wurde Systemback unter Ubuntu 20.04 Focal Fossa getestet.
Es ist mir unter LM20 jedoch nicht möglich, das PPA hinzuzufügen.

Gibt es da noch etwas, das nicht in der Installationsanleitung steht?

Re: Installation von Systemback unter LM20
« Antwort #1 am: 14.10.2020, 08:53:05 »
Moin,
ich würde da mal den Hinweis in dem Artikel beachten und dann nachdenken, ob es sich wirklich lohnt sich mit solch einem Programm zu beschäftigen...
Zitat
Hinweis:
Die letzte Version des Programms stammt aus März 2015. Die Entwicklung wurde zwischenzeitlich eingestellt und es gibt auch keinen Support mehr seitens der Entwickler.
und
wolfgang@Freia:~$ sudo add-apt-repository ppa:nemh/systemback
PPA kann nicht hinzugefügt werden: »'Dieses PPA unterstützt focal nicht'«.
Das ist mehr als deutlich...
Gruß
Wolfgang
« Letzte Änderung: 14.10.2020, 08:56:48 von Wolfgang58 »

Re: Installation von Systemback unter LM20
« Antwort #2 am: 14.10.2020, 09:16:04 »
Bei einer funktionierenden Software ist es doch egal, in welchem Jahr die entwickelt wurde. Was neu ist, muss nicht zwingend besser sein. Außerdem kenne ich auch keine Alternative mit entsprechendem Umfang für Ubuntu20/LM20.
Natürlich ist die zitierte Meldung deutlich, was aber nicht bedeutet, dass eine Installation nicht trotzdem möglich ist.
Genau deswegen stelle ich doch diese Anfrage.

Ich halte ubuntuusers.de für eine vertrauenswürdige Seite. Ich habe es noch nie erlebt, dass hier Unfug verbreitet wird und wenn dort steht, dass es getestet wurde, möchte ich das erst einmal glauben.

Re: Installation von Systemback unter LM20
« Antwort #3 am: 14.10.2020, 09:33:33 »
Im Wiki ist ja noch die manuelle Installation erwähnt....

Re: Installation von Systemback unter LM20
« Antwort #4 am: 14.10.2020, 09:34:23 »
das sieht aber doch nach einem Fehler im Ubuntu WIKI aus ?! Zumindest für die Variante mit PPA ?!
Auszug aus dem WIKI-Artikel
Zitat
Ein PPA unterstützt nicht zwangsläufig alle Ubuntu-Versionen. Weitere Informationen sind der Wiki/Vorlagen/PPA/ppa.png PPA-Beschreibung des Eigentümers/Teams nemh zu entnehmen.
und in der PPA_Beschreibung steht u.a.
Zitat
Currently supported Ubuntu releases:
- 14.04.X LTS
- 15.04
- 15.10
- 16.04.X LTS
- 16.10

Re: Installation von Systemback unter LM20
« Antwort #5 am: 14.10.2020, 09:40:50 »
Moin,
ich bin zwar nicht dafür eine Software die nicht mehr gewartet wird zu installieren, aber bitte:
- Download: https://sourceforge.net/projects/systemback/
- Entpacken und in diesem Verzeichnis
- sudo ./install.sh- dann hier:  die Nummer 4 wählen
 Your system is not compatible with this Systemback Install Pack!

 Press 'A' to abort the installation, or select one of the following releases:

  1 ─ Ubuntu 14.04.X LTS (Trusty Tahr)
  2 ─ Ubuntu 15.04 (Vivid Vervet)
  3 ─ Ubuntu 15.10 (Wily Werewolf)
  4 ─ Ubuntu 16.04.X LTS (Xenial Xerus)
  5 ─ Debian 8.0 (Jessie)
4
Installation startet...
Das Programm läuft, aber ob alles funktioniert habe ich nicht getestet...
Gruß
Wolfgang

Re: Installation von Systemback unter LM20
« Antwort #6 am: 14.10.2020, 10:36:15 »
Die manuelle Installation funktioniert auch nicht.

Ebenfalls nicht die Anleitung unter https://www.linuxbabe.com/ubuntu/install-systemback-ubuntu-18-04-bionic-18-10

Sieht so aus, als sei das Ubuntu WIKI doch fehlerhaft.

Kennt denn jemand eine funktionierende Alternative für LM20?

Re: Installation von Systemback unter LM20
« Antwort #7 am: 14.10.2020, 10:39:19 »
Ist dafür nicht Timeshift gedacht?

Re: Installation von Systemback unter LM20
« Antwort #8 am: 14.10.2020, 11:22:13 »
Die manuelle Installation funktioniert auch nicht.
Nach meiner Methode funktioniert das...
In der Anleitung wird ja nur das ppa für 20 eingerichtet, dass Programm als solches wird nicht verändert, da kannst du auch meine Methode probieren..
Leg dir aber vorher einen Wiederherstellungspunkt mit Timeshift an.
Gruß
Wolfgang

Re: Installation von Systemback unter LM20
« Antwort #9 am: 14.10.2020, 12:01:58 »
Systemback ist schon so ein Tool was "unique" ist. Es gibt keinen adäquaten Ersatz. Schade, dass es nicht mehr weiterentwickelt wird.

Re: Installation von Systemback unter LM20
« Antwort #10 am: 14.10.2020, 12:30:34 »
@toffifee
Wenn es ausschließlich um die Sicherung des Systems geht, ist Timeshift (und auch fsarchiver) exzellente Software. Leider können diese Kandidaten nicht zusätzlich eine ISO erstellen.
Für diesen Zweck könnte ich natürlich auch etwas Spezielles nehmen, die Frage ist nur was?

- Remastersys funktioniert unter LM20 nicht mehr.

- Bei BodhiBuilder bekomme schon die bodhibuilder_2.18.5_all.deb nicht installiert wegen unerfüllbarer Abhängigkeiten.

- PinguyBuilder funktioniert unter LM20 nicht mehr.

- PinguyBuilder incl. vielversprechender Anleitung mit dem Patch auf https://askubuntu.com/questions/1241877/ubuntu-20-04-app-to-make-live-iso ergibt bei mir im Ergebnis eine ISO von lediglich 35 KB für das ganze System (wäre ganz toll, wenn man so komprimieren könnte).

Deshalb der Versuch mit Systemback.

@Wolfgang58
Interessant dass das bei Dir funktioniert hat. Bei mir mit LM20-64 Xfce lief das nicht. Unter welcher Distribution/Desktop konntest Du das denn installieren?

@dphn
So sehe ich das auch!

Wenn ich das richtig im Sinn habe, dann hast Du doch auch schon selbsterstellte ISO's vorgestellt. Mit welchem Tool waren die eigentlich gemacht?

Re: Installation von Systemback unter LM20
« Antwort #11 am: 14.10.2020, 12:52:47 »
Moin,
hier das System auf welchem ich "Systemback" installiert habe:
System:
  Kernel: 5.4.0-48-generic x86_64 bits: 64 Desktop: Cinnamon 4.6.7
  Distro: Linux Mint 20 Ulyana
Machine:
  Type: Laptop System: LENOVO product: 4243F53 v: ThinkPad T520
  serial: <filter>
  Mobo: LENOVO model: 4243F53 serial: <filter> UEFI [Legacy]: LENOVO
  v: 8AET65WW (1.45 ) date: 05/14/2015
Battery:
  ID-1: BAT0 charge: 9.0 Wh condition: 9.0/47.5 Wh (19%)
CPU:
  Topology: Dual Core model: Intel Core i5-2520M bits: 64 type: MT MCP
  L2 cache: 3072 KiB
  Speed: 975 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 1147 2: 906
  3: 867 4: 1167
Graphics:
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
  driver: i915 v: kernel
  Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa
  resolution: 1366x768~60Hz
  OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2)
  v: 3.3 Mesa 20.0.8
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
  driver: snd_hda_intel
  Sound Server: ALSA v: k5.4.0-48-generic
Network:
  Device-1: Intel 82579LM Gigabit Network driver: e1000e
  IF: enp0s25 state: down mac: <filter>
  Device-2: Realtek RTL8188CE 802.11b/g/n WiFi Adapter driver: rtl8192ce
  IF: wlp3s0 state: up mac: <filter>
Drives:
  Local Storage: total: 178.87 GiB used: 64.97 GiB (36.3%)
  ID-1: /dev/sda vendor: Seagate model: ST9160412AS size: 149.05 GiB
  ID-2: /dev/sdb type: USB vendor: Intenso model: Alu Line size: 29.82 GiB
Partition:
  ID-1: / size: 27.37 GiB used: 12.73 GiB (46.5%) fs: ext4 dev: /dev/sda1
  ID-2: /home size: 118.71 GiB used: 50.32 GiB (42.4%) fs: ext4
  dev: /dev/sda5
Sensors:
  System Temperatures: cpu: 48.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0
Info:
  Processes: 231 Uptime: 4h 02m Memory: 3.63 GiB used: 946.9 MiB (25.5%)
  Shell: bash inxi: 3.0.38
Das ist hier bei mir eine Testrechner mit LM 20.
Zwischenzeitlich habe ich mal einen Wiederherstellungspunkt angelegt und gerade bring ich das Live-Image auf den Stick...
Ich werde dann noch berichten..
Gruß
Wolfgang

Re: Installation von Systemback unter LM20
« Antwort #12 am: 14.10.2020, 13:02:28 »
So!
Das Live-Image hat er geschrieben. Aber der Rechner startet damit nicht...  :(

Re: Installation von Systemback unter LM20
« Antwort #13 am: 14.10.2020, 14:08:29 »
Off-Topic:
habe hier systemback 1.9.4 auf Buster installiert, läuft

Re: Installation von Systemback unter LM20
« Antwort #14 am: 14.10.2020, 14:49:37 »
Wenn ich das richtig im Sinn habe, dann hast Du doch auch schon selbsterstellte ISO's vorgestellt. Mit welchem Tool waren die eigentlich gemacht?

Ich mache das entweder innerhalb einer chroot-Umgebung im Terminal, wenn ich ein Remaster erstelle. Ich baue aber auch von ganz vorne Debian-Systeme mit Debian Live-Build. Das ist das offizielle Tool vom Debian Live-Team.

Das ist jetzt kein One-Klick Mechanismus, sondern braucht einige Erfahrung. Ich lerne auch mit jedem ISO mehr dazu. Die letzte war die Cinnamon/MATE-Edition von LMDE 4, wo ich LMDE so nah wie möglich kommen wollte, aber auch einiges an fettem Zeug weggelassen habe. Deshalb hat die auch nur 1,6 GB, aber zwei Desktops.

Das ISO enthält alles an Firmware, auch Broadcom-WL damit es überall startet und benutzbar ist, es enthält aber keine Tonnen an Druckertreiber, kein Samba, kein Java, etc. (wer es braucht kanns nachinstallieren, im Repo läuft ja nix davon. Ist für eine Live-Umgebung halt nicht erforderlich).