Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
05.03.2021, 12:03:36

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 719937
  • Themen insgesamt: 58220
  • Heute online: 671
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  LM19.3+Cin: Problem mit SANE Installation  (Gelesen 634 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

LM19.3+Cin: Problem mit SANE Installation
« am: 09.10.2020, 20:13:55 »
Hallo Ihr,

seit einiger Zeit meckert die Aktualisierungsverwaltung wegen Problemen mit sane. Jetzt bekomme ich bei Shell-Kommando
sudo apt install libgconf-2-4 libcanberra-gtk-module

folgende Meldungen

Entpacken von libcanberra-gtk0:amd64 (0.30-5ubuntu1) ...
Vormals nicht ausgewähltes Paket libcanberra-gtk-module:amd64 wird gewählt.
Vorbereitung zum Entpacken von .../libcanberra-gtk-module_0.30-5ubuntu1_amd64.deb ...
Entpacken von libcanberra-gtk-module:amd64 (0.30-5ubuntu1) ...
libsane:amd64 (1.0.31+git20200904-bionic1) wird eingerichtet ...
Sie sind dabei das folgende PPA zu entfernen:
 Ubuntu SANE packages from SANE daily git snapshots (http://www.sane-project.org/snapshots/).

Unchanged SANE daily git snapshots are ignored!

Please send scanner related questions to the SANE mailing list:
sane-devel at alioth-lists dot debian dot net.

***Update***
This ppa has been replaced by https://launchpad.net/~sane-project/+archive/ubuntu/sane-git. The last update from this ppa automatically switches to the new ppa in your package manager.
 Mehr Informationen: https://launchpad.net/~rolfbensch/+archive/ubuntu/sane-git
Entfernen von PPA »[Errno 2] Datei oder Verzeichnis nicht gefunden: '/etc/apt/sources.list.d/rolfbensch-sane-git-bionic.list'« ist fehlgeschlagen.
Usage: add-apt-repository [options] repository

add-apt-repository: error: no such option: -u
dpkg: Fehler beim Bearbeiten des Paketes libsane:amd64 (--configure):
 »installiertes libsane:amd64-Skript des Paketes post-installation«-Unterprozess gab den Fehlerwert 2 zurück
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libsane1:amd64:
 libsane1:amd64 hängt ab von libsane (>= 1.0.31+git20200904-bionic1); aber:
  Paket libsane:amd64 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes libsane1:amd64 (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
libcanberra-gtk0:amd64 (0.30-5ubuntu1) wird eingerichtet ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von sane-utils:
 sane-utils hängt ab von libsane (>= 1.0.31+git20200904); aber:
  Paket libsane:amd64 ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes sane-utils (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
libcanberra-gtk-module:amd64 (0.30-5ubuntu1) wird eingerichtet ...
Trigger für libc-bin (2.27-3ubuntu1.2) werden verarbeitet ...
Fehler traten auf beim Bearbeiten von:
 libsane:amd64
 libsane1:amd64
 sane-utils
E: Sub-process /usr/bin/dpkg returned an error code (1)

Kann mir jemand einen Tipp geben, was da mit SANE los ist ?

maksimilian

Re: LM19.3+Cin: Problem mit SANE Installation
« Antwort #1 am: 10.10.2020, 12:00:09 »
Zitat
***Update***
This ppa has been replaced by https://launchpad.net/~sane-project/+archive/ubuntu/sane-git. The last update from this ppa automatically switches to the new ppa in your package manager.
 Mehr Informationen: https://launchpad.net/~rolfbensch/+archive/ubuntu/sane-git
Entfernen von PPA »[Errno 2] Datei oder Verzeichnis nicht gefunden: '/etc/apt/sources.list.d/rolfbensch-sane-git-bionic.list'« ist fehlgeschlagen.
Das ursprüngliche PPA wird nicht mehr unter stützt und das automatische Entfernen ist gescheitert. Da musst du wohl manuell eingreifen. Suche im Cinnamon-Menü nach Anwendungspaketquellen

Re: LM19.3+Cin: Problem mit SANE Installation
« Antwort #2 am: 10.10.2020, 17:34:58 »
Die Anwendung Anwendungspaketquellen zeigt unter Offizielle Paketquellen die beiden Spiegelserver (tricia und bionic) und keine Optionale Quellen sowie keine PPAs.
Ich kenne mich mit der Paketverwaltung nicht aus. Mich wundert nur, dass das Problem mit der Beanstandung der sane-Konfiguration durch die Aktualisierungsverwaltung irgendwann mal begann um  dann jedesmal bei einer Aktualisierung aufzutreten.

Sollte ich alle Pakete, welche mit sane zusammenhängen reinstallieren ? Ich benötige sane für Flachbett- und Dia-Scanner.

Re: LM19.3+Cin: Problem mit SANE Installation
« Antwort #3 am: 20.01.2021, 12:55:38 »

Die Anwendung Anwendungspaketquellen zeigt unter Offizielle Paketquellen die beiden Spiegelserver (tricia und bionic) und keine Optionale Quellen sowie keine PPAs.
Ich kenne mich mit der Paketverwaltung nicht aus. Mich wundert nur, dass das Problem mit der Beanstandung der sane-Konfiguration durch die Aktualisierungsverwaltung irgendwann mal begann um  dann jedesmal bei einer Aktualisierung aufzutreten.

Sollte ich alle Pakete, welche mit sane zusammenhängen reinstallieren ? Ich benötige sane für Flachbett- und Dia-Scanner.

konntest du es mittlerweile lösen? ich habe dasselbe problem..

Re: LM19.3+Cin: Problem mit SANE Installation
« Antwort #4 am: 21.01.2021, 11:22:56 »
Das Problem besteht weiterhin. Ich drücke mich um eine Neuinstallation.

Re: LM19.3+Cin: Problem mit SANE Installation
« Antwort #5 am: 21.01.2021, 16:31:48 »
ich glaube nicht, dass das notwendig ist. ich mein am ende ist es ja nur ein schönheitsfehler. dein scanner etc funktioniert und die updates ja auch, ergeben halt einen fehler. aber deswegen neu installieren würde ich nicht. ich habe nochmal einen neuen artikel https://www.linuxmintusers.de/index.php?topic=66737.0 aufgemacht, vielleicht kommt da ja etwas...

Re: LM19.3+Cin: Problem mit SANE Installation
« Antwort #6 am: 22.01.2021, 12:27:55 »
Danke für Deine Initiative. Vielleicht führt Dein Thread zu einer Lösung.

Re: LM19.3+Cin: Problem mit SANE Installation
« Antwort #7 am: 27.02.2021, 23:55:20 »
ich denke ich habe dir lösung gefunden.
mach einfach das hier der reihe nach und einzeln!
sudo apt-get remove sane-utilssudo apt-get autoremove sane-utilssudo apt-get remove libsane:amd64sudo apt-get autoremove libsane:amd64sudo apt-get remove libsane:i386sudo apt-get autoremove libsane:i386
bei mit hat es funktioniert, der mist ist weg.
wäre der hammer wenn ich hier auch mal jemandem helfen könnte :-[

Re: LM19.3+Cin: Problem mit SANE Installation
« Antwort #8 am: 01.03.2021, 11:09:04 »
Nicht so bescheiden sein. Auch bei mir ist "der Mist" jetzt weg. Hoffentlich funktioniert sane auch noch. Danke, dass Du immer noch nach mir geschaut hast. Ist ja nicht selbstverständlich.