Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
29.10.2020, 23:57:14

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 691577
  • Themen insgesamt: 55984
  • Heute online: 694
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  LM "ULYANA" Cinnamon Installation auf UEFI  (Gelesen 807 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] LM "ULYANA" Cinnamon Installation auf UEFI
« am: 06.10.2020, 18:38:16 »
Hallo,
meine bisherigen LM Installationen habe ich immer problemlos unter einem alten LEGACY BIOS problemlos hinbekomme (oft auch mit Hilfe dieses Forums). So auch die Probeinstallation von LM "ULYANA" Cinnamon, mit der ich die verbaute Hardware und Peripherie getestet habe.

Jetzt möchte ich "ULYANA" endgültig auf der SSD als alleiniges System installieren und möchte im BIOS den Kompatibilitätsmodus abschalten, d.h. die Installation erfolgt unter UEFI Bedingungen.

Gibt es etwas Besonderes zu beachten? Bei einem im Hause vorhandenen WIN10 Laptop erreicht man die UEFI Einstellungen nicht mehr über die DEL-Taste (oder F2) beim Systemstart, sondern man muss erst unter WIN10 eine .exe ausführen, um dann bei einem folgenden Neustart in die UEFI Einstellungen zu gelangen! Droht mir bei LM auch eine solche Prozedur, oder bleibt es bei F2 beim Start des Rechners?

Welche Vorteile hätte ein Betrieb von LM "ULYANA" unter UEFI Bedingungen?
« Letzte Änderung: 11.10.2020, 19:42:16 von mrotscheidt »

Re: LM "ULYANA" Cinnamon Installation auf UEFI
« Antwort #1 am: 06.10.2020, 19:00:29 »
Mit welcher Taste du an das UEFI ran kommst ist Hersteller des UEFI und der Hardware abhängig.
So z.B. bei HP:
ESC  ---> Auswahl Menü

F1 Systeminformationen
F2 Systemdiagnose

F7 HP SpareKey
F9 Bootgeräteoptionen
F10 BIOS-Setup

F12 Netzwerkstart

Eingabetaste - Systemstart fortsetzen

Weitere Informationen finden Sie hier: www.hp.com/go/techcenter/startup

Re: LM "ULYANA" Cinnamon Installation auf UEFI
« Antwort #2 am: 06.10.2020, 19:10:39 »
Danke für die schnelle Antwort. Meine Befürchtung war und ist, daß ich (wie bei dem erwähnten Laptop) nicht mehr an die UEFI Einstellungen beim Systemstart mit F2, Ctrl., oder DEL gelange!
Beim WIN10 Laptop war erst WIN7 über BIOS/LEGACY installiert. Da klappte der Zugang noch über F2. Nach Umstieg auf WIN10 reagiert der Rechner nicht mehr auf F2, sondern läuft durch und erst über das entsprechende Programm zeigt sich beim nächsten Systemstart das UEFI Menü!

Ich möchte nur bei meinem Rechner einen solchen Unfug vermeiden! Ansonsten bleibe ich beim BIOS/LEGACY! Aber das nächste, modernere MB wird gar kein BIOS/LEGACY mehr kennen!

Re: LM "ULYANA" Cinnamon Installation auf UEFI
« Antwort #3 am: 06.10.2020, 19:29:49 »
Vielleicht kannst du mal ein:
inxi -Fz vom dem Rechner zeigen.
Und es kennt sich jemand mit dem Rechner/Hersteller aus.  ;)

Re: LM "ULYANA" Cinnamon Installation auf UEFI
« Antwort #4 am: 06.10.2020, 19:31:58 »
System:
  Host: LMWS1 Kernel: 5.4.0-48-generic x86_64 bits: 64
  Desktop: Cinnamon 4.4.8 Distro: Linux Mint 19.3 Tricia
Machine:
  Type: Desktop Mobo: ASRock model: H87 Performance serial: <filter>
  UEFI [Legacy]: American Megatrends v: P2.60 date: 01/14/2016
CPU:
  Topology: Quad Core model: Intel Core i5-4670K bits: 64 type: MCP
  L2 cache: 6144 KiB
  Speed: 1000 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 945 2: 975
  3: 986 4: 1056
Graphics:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics
  driver: i915 v: kernel
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa
  resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2)
  v: 4.5 Mesa 20.0.8
Audio:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
  driver: snd_hda_intel
  Device-2: Intel 8 Series/C220 Series High Definition Audio
  driver: snd_hda_intel
  Sound Server: ALSA v: k5.4.0-48-generic
Network:
  Device-1: Intel Ethernet I217-V driver: e1000e
  IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 1.14 TiB used: 190.25 GiB (16.3%)
  ID-1: /dev/sda vendor: SanDisk model: SDSSDH3500G size: 465.76 GiB
  ID-2: /dev/sdb vendor: Seagate model: ST500DM002-1BD142 size: 465.76 GiB
  ID-3: /dev/sdc vendor: Western Digital model: WD2500BEVT-22A23T0
  size: 232.89 GiB
Partition:
  ID-1: / size: 457.45 GiB used: 141.11 GiB (30.8%) fs: ext4 dev: /dev/sda1
Sensors:
  System Temperatures: cpu: 36.0 C mobo: 33.0 C
  Fan Speeds (RPM): fan-1: 0 fan-2: 1006 fan-3: 0 fan-4: 1521 fan-5: 760
Info:
  Processes: 209 Uptime: 1h 06m Memory: 15.30 GiB used: 4.54 GiB (29.7%)
  Shell: bash inxi: 3.0.32

Wie in meiner Signatur zu sehen ist, handelt es sich um ein ASROCK H87 Performance

Re: LM "ULYANA" Cinnamon Installation auf UEFI
« Antwort #5 am: 06.10.2020, 19:57:46 »
Hallo .....
:-)

ggfs. könnte bei Dir auch das hier zutreffen:
https://www.linuxmintusers.de/index.php?topic=64450.msg845462#msg845462 ... schau mal auf #3 und zuletzt #7

Der Effekt, dass man einmalig "Secure Boot" einschalten muss und DAVON dann den USB-Stick booten muss, soll wohl auch bei Ubuntu 20 sein.
Bei mir hatte das bei dem Procedere mit Mate allerdings dann super geklappt....im UEFI-mode.

Re: LM "ULYANA" Cinnamon Installation auf UEFI
« Antwort #6 am: 06.10.2020, 20:15:57 »
Ich denke, das Problem das der TE meint, wenn Windows 10 das BIOS blockiert, hängt mit der Schnellstartfunktion von Windows zusammen. Kann mich aber nicht mehr erinnern wie das abzustellen geht. Habe schon lange kein Windows mehr.

Re: LM "ULYANA" Cinnamon Installation auf UEFI
« Antwort #7 am: 06.10.2020, 21:52:52 »
Habe noch etwas weiter gesucht. Und für WIN10 scheint die Schnellstartoption den direkten "Zutritt" zum UEFI zu vereiteln.

Aber wir sind ja hier bei LM.  :)

Also werde ich im BIOS/LEGACY auf UEFI umschalten (bei ASROCK ist das der CSM, Compatibility Support Module), dann "Secure BOOT" einschalten und dann das ISO von USB laden und dann auch installieren!

Nach der Installation kann ich dann den "Secure BOOT" wieder ausschalten.

Habe ich die Vorgehensweise so richtig verstanden?

Re: LM "ULYANA" Cinnamon Installation auf UEFI
« Antwort #8 am: 06.10.2020, 22:21:39 »
Boote das Live-System und mit dem Befehl:
[ -d /sys/firmware/efi ] && echo UEFI || echo BIOSüberprüfst du, ob dein System im UEFI oder BIOS - Mode läuft.

Re: LM "ULYANA" Cinnamon Installation auf UEFI
« Antwort #9 am: 06.10.2020, 22:27:43 »
z. Zt. läuft das System im BIOS Modus!
ULYANA soll dann mit neuer SSD im UEFI Modus laufen!

Re: LM "ULYANA" Cinnamon Installation auf UEFI
« Antwort #10 am: 06.10.2020, 22:31:20 »
Das Live-System muss im UEFI - Mode laufen, sonst geht die Installation nicht im UEFI.
Ich glaube der CSM - Mode ist der BIOS - Mode.
Normal seht an der Stelle dann: UEFI Only.

Re: LM "ULYANA" Cinnamon Installation auf UEFI
« Antwort #11 am: 06.10.2020, 22:43:00 »
Also zuerst auf UEFI umschalten, dann Live System starten, dort ISO auf USB speichern, dann von USB starten und installieren!
Wenn ich es richtig sehe!?
Wie muss der USB Stick formatiert werden?

Re: LM "ULYANA" Cinnamon Installation auf UEFI
« Antwort #12 am: 06.10.2020, 22:58:44 »
Also zuerst auf UEFI umschalten,
Ja.

dann Live System starten,
Ja, aber das reicht schon denn das sollte dann im UEFI schon laufen.
Fast jeder USB - Stick kann im UEFI und BIOS Mode starten.

Re: LM "ULYANA" Cinnamon Installation auf UEFI
« Antwort #13 am: 07.10.2020, 16:58:32 »
MOMENT........!
Nicht die ISO auf den USB-Stick kopieren ..... wenn Du Windows 10 hast, nimmst Du "Rufus" (ein freies Programm, um bootfähige USB-Sticks erstellen zu können). Dort wählst Du:
1. Deinen USB-Stick aus
2. die von Dir (idealer Weise von hier: https://www.linuxmintusers.de/index.php?topic=9668 herunter geladene ISO für Dein Mint
3. darauf achten, dass als Bootmodus im "Rufus" BIOS oder UEFI eingestellt ist - damit werden beide Bootfähigkeiten angelegt
4. dann auf erstellen gehen
5. nachdem Du im Windows 10 Fastboot deaktiviert hast (versteckt sich unter Energiesparoptionen .... erweiterte Einstellungen .... versteckte Eigenschaften) fähst Du Win runter
6. im UEFI schaltest Du CSM aus, FastBoot aus und UEFI alleinig an - mach einen Test, ob das auf DEINER Plattform im Bootmenü (meist F12) als UEFI oder EFI path angezeigt wird. DIESEN bootest Du dann. Wenn der Stick nicht bootet (wie bei mir) gehst Du nochmal ins UEFI und stellst SecureBoot auf ein - neu booten analog oben
7. meist kommt dann eine "komische, DOS-ähnliche Anzeige, die mit dem SecureBoot zu tun hat .... weiter machen
8. bei der Installation wird dann bei der Passworteingabe die Eingabe eines UEFI-Passworts angefordert - GUT merken!!!!!! .... dann normal weiter laufen lassen .....
9. neu booten bit SecureBoot aus .... falls es sich aufhängt, noch einmal booten ... ich mußte auch 2x

Re: LM "ULYANA" Cinnamon Installation auf UEFI
« Antwort #14 am: 07.10.2020, 19:53:54 »
Leute, solch ausführliche Antworten hatte ich garnicht erwartet! Tausend Dank!

Der Umstieg auf UEFI startet am Wochenende. Zuerst muß ich aber noch einige Klimmzüge unternehmen, um ein auf einer anderen SSD befindliches WIN10 auf UEFI umzustellen. Ich nutze dafür c't WIMage! Win10 macht wesentlich mehr Mucken bei der Umstellung auf UEFI. Ich weiß schon, warum ich für 99% aller Fälle auf LM umgestiegen bin.

Zur Erklärung: Ich nutze mehrere Betriebssysteme auf jeweils separaten SSD in einem Wechsellaufwer. Die BS wissen nichts voneinander1 Parallele Installationen auf einem Datenträger waren mir zu nervenaufreibend!

Zur Herstellung des bootfähigen USB-Sticks nehme ich den bei LM mitgelieferten USB-Abbildersteller!? Richtig?
« Letzte Änderung: 07.10.2020, 20:58:12 von mrotscheidt »