Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
29.10.2020, 23:56:25

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 691577
  • Themen insgesamt: 55984
  • Heute online: 694
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Fehlermeldung beim booten: ioapic 2 has no mapping iommu usw.  (Gelesen 856 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Moin,

meine erste Frage in diesem forum betrifft mein MacBook Pro mid 2012 15" 2,6 GHz antiglare mit Linux Mint 20 Ulyana (Ubuntu 20.04 focal).

Das frisch installierte system bootete mit der meldung:

Failed to Set MokListRT: Invalid Parameter Could not create mokListRT: Invalid Parameter Importing MOK states has failed: import_mok_state() failed: Invalid Parameter Continuing boot since secure mode is disabled.

Das habe ich nach dieser anleitung beheben können: https://askubuntu.com/questions/1279602/ubuntu-20-04-failed-to-set-moklistrt-invallid-parameter Das schreibe ich als vorgeschichte dazu.

Denn das gerät machte schon unter MacOS probleme. Nach einem sicherheitsupdate unter 10.14.6 drehten die lüfter ständig hoch und der computer war nicht mehr benutzbar, weil der kernel_task immer um die 600 prozent der prozessorleistung beanspruchte (wie immer das gehen soll). Ich glaube inzwischen, dass der zeitpunkt ein zufall war und nichts mit dem update zu tun hatte. Denn auch neuinstallationen des OS von El Capitan bis Catalina und booten von externer festplatte brachten keine besserung.

Aus dem grund probiere ich überhaupt Linux aus. Jetzt bleibt die obige meldung beim booten, die auf ein firmwareproblem hinweist. Ich finde diesen tipp https://unix.stackexchange.com/questions/317134/firmware-bug-error-message-on-arch-on-apple, der mir rät, die firmware zu flashen (was ich mir nicht zutraue) oder die meldung zu ignorieren.

Was würdet ihr tun? Hängt die meldung mit dem problem unter MacOS zusammen?

Danke für ideen!

Cowley


Re: Fehlermeldung beim booten: ioapic 2 has no mapping iommu usw.
« Antwort #1 am: 04.10.2020, 16:51:33 »
Hast du den von dir angegebenen Link zuende gelesen? Dort steht am Ende:
"This is not an error message. Basically, Linux assumes that when there is an IO-APIC and an IOMMU, interrupt remapping must be supported. However, on this hardware it is not supported - the IO-APIC has ID 2 but the IOMMU only matches ID 0. Linux notices this situation, correctly disables interrupt remapping, and prints this notice to dmesg."
Das Lüfterproblem hat meiner Meinung nach nichts damit zu tun. Hast du denn mal die CPU-Temperatur kontrolliert, wenn die Lüfter hochdrehen. Evtl. ist ja der CPU-Kühler verdreckt.

Re: Fehlermeldung beim booten: ioapic 2 has no mapping iommu usw.
« Antwort #2 am: 04.10.2020, 17:37:13 »
Hast du den von dir angegebenen Link zuende gelesen?
Zitat
der mir rät, die firmware zu flashen (was ich mir nicht zutraue) oder die meldung zu ignorieren.
Die lüfter habe ich schon gereinigt, die wärmeleitpaste könnte ich mal tauschen. Das war mir bisher zu viel arbeit, das ganzue logicboard muss dafür raus.

Die temperaturen sind wohl auch nicht das problem - ich hänge mal zwei screenshots an.

Bis vorhin lief das gerät unter Linux leise und einwandfrei. Dann habe ich es mal mit einer externen platte von MacOS Mojave gestartet, SMC und VRAM resettet und es ging wieder nix. Jetzt zurück auf Linux geht alles, aber die lüfter drehen voll hoch.

Ich weiß noch nicht, wie ich die abregeln kann. Für den Mac gibt's da Macs Fan Control.

Re: Fehlermeldung beim booten: ioapic 2 has no mapping iommu usw.
« Antwort #3 am: 04.10.2020, 18:27:30 »
Nur mal so eine Idee: Wenn du noch ein unterstütztes Apple Betriebssystem drauf hast, versuche doch darin mal ein EFI Firmware Update zu installieren (kommt glaube ich über die normalen Updates).

Re: Fehlermeldung beim booten: ioapic 2 has no mapping iommu usw.
« Antwort #4 am: 04.10.2020, 18:37:39 »
Nur mal so eine Idee: Wenn du noch ein unterstütztes Apple Betriebssystem drauf hast, versuche doch darin mal ein EFI Firmware Update zu installieren (kommt glaube ich über die normalen Updates).

Das sollte automatisch mit High Sierra draufgekommen sein, es lief ja schon Mojave drauf. Und vor ein paar tagen bin ich die ganzen upgrades von El Capitan bis Catalina durchgegangen. Ich weiß gerade nicht, wo ich die firmware-version einsehen kann. Notfalls frage ich noch mal im Macuser-Forum - aber eigentlich bin ich da schon gescheitert.

Edit:
Firmware ist aktuell: UEFI: Apple v: 233.0.0.0.0 date: 06/10/2020
« Letzte Änderung: 04.10.2020, 22:55:38 von Cowley »

Re: Fehlermeldung beim booten: ioapic 2 has no mapping iommu usw.
« Antwort #5 am: 04.10.2020, 23:00:01 »
Seht ihr, welchen grafikkartentreiber ich aktiv habe?:

Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Apple driver: i915 v: kernel
           bus ID: 00:02.0 chip ID: 8086:0166
           Device-2: NVIDIA GK107M [GeForce GT 650M Mac Edition] vendor: Apple driver: nvidia
           v: 390.138 bus ID: 01:00.0 chip ID: 10de:0fd5
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia
           unloaded: fbdev,nouveau,vesa resolution: 1680x1050~60Hz
           OpenGL: renderer: GeForce GT 650M/PCIe/SSE2 v: 4.6.0 NVIDIA 390.138 direct render: Yes

Mir wurde neulich der von nouveau angeboten, der soll aber die karte zu heiß werden lassen. Also hatte ich den von NVIDIA gewählt, finde aber nicht mehr, wo ich das eingestellt habe.
« Letzte Änderung: 05.10.2020, 16:52:34 von Cowley »

Re: Fehlermeldung beim booten: ioapic 2 has no mapping iommu usw.
« Antwort #6 am: 05.10.2020, 08:39:15 »
Bei dir laufen die interne Intelgrafik mit dem i915 und die Nvidia Karte mit der Treiberversion 390.138. Brauchst du die Nvidia Karte unbedingt? Teste es doch mal mit der internen Grafikkarte. Welchen Desktop nutzt du?? In Mint 20 kann man bequem zwischen der Nvidia und der Onboard Grafik umschalten.

Manchmal wird auch die Netzwerkkarte zu heiß. Zeig bitte auch mal die Ausgabe voninxi -N
inxi -Fz

Hinweis: Bitte immer die Mint Version inklusive des Desktops (Cinnamon, Mate oder Xfce) angeben. Angaben aus dem Terminal schreibst du in einen Codeblock, siehe Hilfe hier oben im Forum. Deinen Beitrag kannst du einfach nachträglich ändern.
« Letzte Änderung: 06.10.2020, 08:21:47 von skoopy »

Re: Fehlermeldung beim booten: ioapic 2 has no mapping iommu usw.
« Antwort #7 am: 05.10.2020, 16:57:53 »
Bei dir laufen die interne Intelgrafik mit dem i915 und die Nvidia Karte mit der Treiberversion 390.138. Brauchst du die Nvidia Karte unbedingt? Teste es doch mal mit der internen Grafikkarte. Welchen Desktop nutzt du?? In Mint 20 kann man bequem zwischen der Nvidia und der Onboard Grafik umschalten.
Ah, danke! Wie schalte ich denn um? Das system heißt Ulyana, meinst du das mit desktop? Ich glaube, das ist ein Cinnamon-nachfolger.

Nach der netzwerkkarte gucke ich später, bin gerade nicht an dem betreffenden computer.

Re: Fehlermeldung beim booten: ioapic 2 has no mapping iommu usw.
« Antwort #8 am: 05.10.2020, 19:44:37 »
Manchmal wird auch die Netzwerkkarte zu heiß. Zeig bitte auch mal die Ausgabe von
Code: [Auswählen]

inxi -N
inxi -Fz

Copy and paste geht wohl nicht im terminal, darum ein bild:

Edit: Hier geht's so: copy = ctrl+shift+c / paste = ctrl+v

~$ inxi -N
Network:
  Device-1: Broadcom and subsidiaries NetXtreme BCM57765 Gigabit Ethernet
  PCIe
  driver: tg3
  Device-2: Broadcom and subsidiaries BCM4331 802.11a/b/g/n driver: wl
~$ inxi -Fz
System:
  Kernel: 5.4.0-48-generic x86_64 bits: 64 Desktop: Xfce 4.14.2
  Distro: Linux Mint 20 Ulyana
Machine:
  Type: Laptop System: Apple product: MacBookPro9,1 v: 1.0 serial: <filter>
  Mobo: Apple model: Mac-4B7AC7E43945597E v: MacBookPro9,1 serial: <filter>
  UEFI: Apple v: 233.0.0.0.0 date: 06/10/2020
Battery:
  ID-1: BAT0 charge: 57.6 Wh condition: 69.8/75.2 Wh (93%)
CPU:
  Topology: Quad Core model: Intel Core i7-3720QM bits: 64 type: MT MCP
  L2 cache: 6144 KiB
  Speed: 1197 MHz min/max: 1200/3600 MHz Core speeds (MHz): 1: 1197 2: 1197
  3: 1197 4: 1197 5: 1197 6: 1198 7: 1197 8: 1197
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel
  Device-2: NVIDIA GK107M [GeForce GT 650M Mac Edition] driver: nvidia
  v: 390.138
  Display: x11 server: X.Org 1.20.8 driver: nvidia
  resolution: 1680x1050~60Hz
  OpenGL: renderer: GeForce GT 650M/PCIe/SSE2 v: 4.6.0 NVIDIA 390.138
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio
  driver: snd_hda_intel
  Device-2: NVIDIA GK107 HDMI Audio driver: snd_hda_intel
  Sound Server: ALSA v: k5.4.0-48-generic
Network:
  Device-1: Broadcom and subsidiaries NetXtreme BCM57765 Gigabit Ethernet
  PCIe
  driver: tg3
  IF: enp2s0f0 state: down mac: <filter>
  Device-2: Broadcom and subsidiaries BCM4331 802.11a/b/g/n driver: wl
  IF: wlp3s0 state: up mac: <filter>
Drives:
  Local Storage: total: 119.24 GiB used: 21.64 GiB (18.1%)
  ID-1: /dev/sda vendor: Samsung model: MZ7TD128HAFV-000L1 size: 119.24 GiB
Partition:
  ID-1: / size: 116.38 GiB used: 21.61 GiB (18.6%) fs: ext4 dev: /dev/sda2
Sensors:
  System Temperatures: cpu: 45.0 C mobo: N/A gpu: nvidia temp: 34 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 258 Uptime: 2m Memory: 15.58 GiB used: 962.3 MiB (6.0%)
  Shell: bash inxi: 3.0.38

« Letzte Änderung: 05.10.2020, 22:48:21 von Cowley »

Re: Fehlermeldung beim booten: ioapic 2 has no mapping iommu usw.
« Antwort #9 am: 05.10.2020, 19:47:00 »
Brauchst du die Nvidia Karte unbedingt? Teste es doch mal mit der internen Grafikkarte.
Unter MacOS gibt es ein kleines programm GFXCardStatus, mit dem ich die dedizierte karte abschalte. Das nützt aber nix, die lüfter drehen trotzdem hoch.

Auch jetzt mit Linux, gleich beim start des kalten computers.

Re: Fehlermeldung beim booten: ioapic 2 has no mapping iommu usw.
« Antwort #10 am: 05.10.2020, 19:53:12 »
Copy and paste geht wohl nicht im terminal
Copy=Ctrl+Shift+C, Paste=Ctrl+Shift+V.

Re: Fehlermeldung beim booten: ioapic 2 has no mapping iommu usw.
« Antwort #11 am: 05.10.2020, 20:05:15 »
Das system heißt Ulyana, meinst du das mit desktop? Ich glaube, das ist ein Cinnamon-nachfolger.
"Ulyana" ist der Release-Name, der Vorgänger heißt z.B. "Tricia". Der hat nichts mit dem Desktop zu tun.
In der Ausgabe von inxi -Fz siehst du unter dem Abschnitt "System" den Desktop Xfce. Wie das unter Xfce funktioniert, weiß ich nicht. Unter Cinnamon kann man ganz leicht zwischen den Karten wechseln, siehe hier unter "Nvidia Optimus": https://linuxmint.com/rel_ulyana_cinnamon_whatsnew.php

Copy and paste geht wohl nicht im terminal, darum ein bild:
Doch, geht: Text markieren und entweder mit Strg + Umschalt + C (Copy) bzw. Strg + Umschalt + V (Paste) oder mit rechter Maustaste: Kopieren + Einfügen. ;) Bitte ändere deine Beiträge noch mal dementsprechend, ist wesentlich übersichtlicher zu lesen. Nützlich sind folgende Angaben:inxi -Fz
inxi -N
iwconfig
« Letzte Änderung: 05.10.2020, 20:47:52 von skoopy »

Re: Fehlermeldung beim booten: ioapic 2 has no mapping iommu usw.
« Antwort #12 am: 05.10.2020, 22:53:25 »
Nützlich sind folgende Angaben:
Code: [Auswählen]

inxi -Fz
inxi -N
iwconfig
Die ersten beiden habe ich weiter oben hineineditiert.

~$ iwconfig
enp2s0f0  no wireless extensions.

wlp3s0    IEEE 802.11  ESSID:"xxx" 
          Mode:Managed  Frequency:5.5 GHz  Access Point: 34:81:C4:B7:CE:9B   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
         
lo        no wireless extensions.

Den WLAN-namen habe ich durch xxx ersetzt.

Re: Fehlermeldung beim booten: ioapic 2 has no mapping iommu usw.
« Antwort #13 am: 05.10.2020, 23:01:10 »
Wie das unter Xfce funktioniert, weiß ich nicht. Unter Cinnamon kann man ganz leicht zwischen den Karten wechseln
Kann ich ohne neuinstallation von Xfce auf Cinnamon wechseln? Das scheint ja komfortabler zu sein.

Übrigens gehen gerade ohne mein zutun die lüfter aus. Kann ich irgendwo sehen, was passiert ist?

Re: Fehlermeldung beim booten: ioapic 2 has no mapping iommu usw.
« Antwort #14 am: 05.10.2020, 23:09:09 »
Kann ich ohne neuinstallation von Xfce auf Cinnamon wechseln?
keine gute Idee, macht früher oder später Probleme