Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
29.10.2020, 23:36:48

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 691577
  • Themen insgesamt: 55984
  • Heute online: 694
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  Dualboot_ Win10&Archderivate_toschiba_L670-H9 Startprobleme  (Gelesen 297 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Dualboot_ Win10&Archderivate_toschiba_L670-H9 Startprobleme
« am: 30.09.2020, 10:25:43 »
Hallo liebe Linuxuser,
Bitte um Hilfe,
Standardmäßig mit Geparted neu partitioniert , Partitonstabelle Mdos, Primär Laufwerk Win 10 home, unter erweitertet wurden Arcolinux und Manjaro installiert , zuletzt wurde arco installiert  bootloader /sda,
Das Problem beim starten kommt kein Grub menu , kommt zu Bios fehlermeldung ,
Hier die Daten
[user@user-satellitel670 ~]$ efibootmgr
EFI variables are not supported on this system.
[user@user-satellitel670 ~]$ lsblk
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 223,6G  0 disk
├─sda1   8:1    0    50M  0 part
├─sda2   8:2    0  84,4G  0 part
├─sda3   8:3    0   521M  0 part
├─sda4   8:4    0     1K  0 part
├─sda5   8:5    0    30G  0 part
├─sda6   8:6    0    24G  0 part
├─sda7   8:7    0    30G  0 part /
├─sda8   8:8    0    24G  0 part /home
└─sda9   8:9    0   512M  0 part
[user@user-satellitel670 ~]$ df -h
Dateisystem    Größe Benutzt Verf. Verw% Eingehängt auf
dev             3,9G       0  3,9G    0% /dev
run             3,9G    9,3M  3,9G    1% /run
/dev/sda7        30G    6,5G   22G   24% /
tmpfs           3,9G       0  3,9G    0% /dev/shm
tmpfs           4,0M       0  4,0M    0% /sys/fs/cgroup
tmpfs           3,9G     43M  3,8G    2% /tmp
/dev/sda8        24G     67M   23G    1% /home
tmpfs           782M     52K  782M    1% /run/user/1000
/dev/sdb1        15G     11G  3,8G   75% /run/media/user/ventoy
[user@user-satellitel670 ~]$ sudo parted --list
[sudo] Passwort für user:
Modell: ATA SanDisk SDSSDA24 (scsi)
Festplatte  /dev/sda:  240GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos
Disk-Flags:

Nummer  Anfang  Ende    Größe   Typ       Dateisystem  Flags
 1      1049kB  53,5MB  52,4MB  primary   ntfs
 2      53,5MB  90,7GB  90,7GB  primary   ntfs
 3      90,7GB  91,3GB  546MB   primary   ntfs         msftres
 4      91,3GB  240GB   149GB   extended
 5      91,3GB  123GB   32,2GB  logical   ext4
 6      123GB   149GB   25,8GB  logical   ext4
 7      149GB   181GB   32,2GB  logical   ext4         boot
 8      181GB   207GB   25,8GB  logical   ext4
 9      207GB   208GB   537MB   logical   ntfs
[user@user-satellitel670 ~]$ update-grub
Generating grub configuration file ...
Found theme: /boot/grub/themes/Vimix/theme.txt
Found linux image: /boot/vmlinuz-linux
Found initrd image: /boot/initramfs-linux.img
Found fallback initrd image(s) in /boot: initramfs-linux-fallback.img
Found Windows 10 on /dev/sda1
Found Manjaro Linux (20.1) on /dev/sda5
Found memtest86+ image: /boot/memtest86+/memtest.bin
done
[user@user-satellitel670 ~]$

« Letzte Änderung: 02.10.2020, 10:24:28 von unitymedia »

Re: Dualboot_ Win10&Archderivate_toschiba_L670-H9 Startprobleme
« Antwort #1 am: 30.09.2020, 12:01:32 »
Zitat
Primär Laufwerk Win 10 home, unter erweitertet wurden Arcolinux und Manjaro installiert , zuletzt wurde arco installiert 
Gehört ja nicht wirklich in ein Linux Mint Forum ?! Aber trotzdem
- der "efibootmgr" ist hier nicht anwendbar - es ist keine "UEFI-Installation" erkennbar
- versuche einmal das Manjaro zu starten - eventuell mit Hilfe der SuperGrub2Disc (SG2D)
die gibt es u.a. hier https://sourceforge.net/projects/supergrub2/files/latest/download
Sollte das klappen dann im Manjaro über das Terminal
sudo grub-install /dev/sdadanach
sudo update-grub
Erscheint nach einem Neustart "grub" wieder und lassen sich zumindest Windows und Manjaro darüber starten ?
 

Re: Dualboot_ Win10&Archderivate_toschiba_L670-H9 Startprobleme
« Antwort #2 am: 30.09.2020, 22:09:20 »
Vielen Dank ,
Ja über supergrub lassen  die distris starten , folge dein Ratschlag ,  Anweisung für manjaro ausgeführt , leider lässt sich grub nicht blicken ,
Kann es sein das die Linux distris über logische Laufweke laufen  und aus dem grund spielt gub nicht mit

Re: Dualboot_ Win10&Archderivate_toschiba_L670-H9 Startprobleme
« Antwort #3 am: 30.09.2020, 22:40:38 »
Zeig doch mal die Ausgabe im Terminal mit den beiden Befehlen von billyfox05 mit Manjaro

Re: Dualboot_ Win10&Archderivate_toschiba_L670-H9 Startprobleme
« Antwort #4 am: 01.10.2020, 07:33:50 »
[user@user-satellitel670 ~]$ sudo grub-install /dev/sda
[sudo] Passwort für user:
i386-pc wird für Ihre Plattform installiert.
installation beendet. Keine Fehler aufgetreten.
[user@user-satellitel670 ~]$ sudo update-grub
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.8-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.8-x86_64.img
Found initrd fallback image: /boot/initramfs-5.8-x86_64-fallback.img
Found Windows 10 on /dev/sda1
Found ArcoLinux (rolling) on /dev/sda7
Found memtest86+ image: /boot/memtest86+/memtest.bin
done
[user@user-satellitel670 ~]$

Re: Dualboot_ Win10&Archderivate_toschiba_L670-H9 Startprobleme
« Antwort #5 am: 01.10.2020, 12:44:59 »
Das sieht unauffällig aus.
Sehe leider keinen Grund, warum der Grub nicht funktioniert.
Prinzipiell geht es ja, zumindest mit der SuperGrub2Disk.

Was mir noch einfällt:
in die Datei /etc/default/grub schauen und diese ggf. korrigieren (GRUB_HIDDEN_TIMEOUT=0 ?)
oder versuchen: sudo dpkg-reconfigure grub-pc
Evtl. auch das Boot-Info-Script herunterladen und anwenden, um zusätzliche Details abzufragen.

Weiß allerdings nicht, ob das alles so bei Manjaro funktioniert.
Vielleicht gibt es von Manjaro auch ein Forum oder Wiki?
Soweit ich weiß, funktioniert Arch/Manjaro beim Grub irgendwie anders als Debian/Ubuntu/Mint.
« Letzte Änderung: 01.10.2020, 12:52:35 von aexe »

Re: Dualboot_ Win10&Archderivate_toschiba_L670-H9 Startprobleme
« Antwort #6 am: 02.10.2020, 09:19:27 »
Neu formatiert, 4 primäre Partitionen angelegt,  1 win, 2 arco /, 3 arcohome, 4 Daten, und sehe da, Grub lässt sich blicken, also problem gelöst , liegt wohl am bios, kommt nicht klar mit erweiterten Partitionen, oder gibts Andere Erklärung