Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
30.11.2020, 21:09:02

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24840
  • Letzte: Foxinity
Statistiken
  • Beiträge insgesamt: 697684
  • Themen insgesamt: 56459
  • Heute online: 734
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Fritzbox 6490 update auf 7.20 danach NAS Problem  (Gelesen 2583 mal)

0 Mitglieder und 2 Gäste betrachten dieses Thema.

Re: Fritzbox 6490 update auf 7.20 danach NAS Problem
« Antwort #15 am: 06.11.2020, 19:49:06 »
...
Aber wenn ich eine Datei ändere oder eine neue Datei anlege, anschließend speichere und dann wieder öffne, dann ist diese Datei leider kaputt. Es wird der Import-Dialog von LibreOffice dann gestartet, wo ich nur noch Chinesische Zeichen sehe.

Leider habe ich noch keine andere Antwort oder Lösung auf dieses Problem gefunden.

Dieses Problem habe ich auch  :( aber nur mit LO, alle anderen "..Office" funktionieren ohne Zerstörung der Dateien. Bin auf Softmaker ausgewichen, damit geht es.

Re: Fritzbox 6490 update auf 7.20 danach NAS Problem
« Antwort #16 am: 07.11.2020, 09:39:44 »
Hallo meine Lösung sah so aus um Schreibrechte wiederzubekommen:

...  cifs vers=3.0,credentials=/home/username/.smbcredentials,uid=1000,gid=1000,file_mode=0777,dir_mode=0777,auto 0 0

Vielen Dank, dass du deinen Lösungsweg hier mitgeteilt hast. Leider funktioniert dieser nicht für mich. Hast Du ggfs. noch andere Änderungen vorgenommen, welche das Problem evtl. gelöst haben?

EDIT1: Ordner anlegen kann ich jetzt allerdings wieder. Nur nicht die bereits vorhandenen Dateien öffnen.

EDIT2: ich vermute mal, du hast die Teillösung von Rainman1983 ebenso implementiert (vielen Dank auch an ihn). Ich melde das Thema jetzt mal an den Fritz Support. Bei meiner letzten Meldung des Bugs in der Beta hatte ich keine Rückmeldung erhalten.
« Letzte Änderung: 07.11.2020, 10:39:53 von nbk_1970 »

Re: Fritzbox 6490 update auf 7.20 danach NAS Problem
« Antwort #17 am: 07.11.2020, 10:31:47 »
Hallo meine Lösung sah so aus um Schreibrechte wiederzubekommen:

...  cifs vers=3.0,credentials=/home/username/.smbcredentials,uid=1000,gid=1000,file_mode=0777,dir_mode=0777,auto 0 0

Hallo Helmfuss,
die Lösung funktioniert bei mir auch. Einschränkung ebenfalls bei LibreOffice: merkwürdiges Verhalten:

Fertige LibreOffice-Dateien auf Fritz-NAS kopiert, geöffnet -> ok
Diese Dateien auf dem Fritz-NAS geändert und gespeichert, dann wieder geöffnet -> Importdialog erscheint

Danke trotzdem, das hilft schon weiter!






Re: Fritzbox 6490 update auf 7.20 danach NAS Problem
« Antwort #18 am: 07.11.2020, 11:36:55 »
Softmaker kann ich noch installieren, dann wäre das Office Thema behoben.

Aber Gnucash funktioniert auch beim Abholen von Börsenkursen und Manueller Eingabe von Buchungen auch ohne Probleme. Bloß wenn ich dann zu meiner Bank die Buchungen dort abholen möchte, dann kann Gnucash keinen Lock für die Datei Bank.key erstellen.

Deswegen hoffe ich, wenn das FritzNAS Problem gelöst ist, dann sollte LibreOffice und Gnucash hoffentlich auch gelöst sein!

Re: Fritzbox 6490 update auf 7.20 danach NAS Problem
« Antwort #19 am: 09.11.2020, 16:41:39 »
Hallo Helmfuss,
die Lösung funktioniert bei mir auch. Einschränkung ebenfalls bei LibreOffice: merkwürdiges Verhalten:

Fertige LibreOffice-Dateien auf Fritz-NAS kopiert, geöffnet -> ok
Diese Dateien auf dem Fritz-NAS geändert und gespeichert, dann wieder geöffnet -> Importdialog erscheint

Danke trotzdem, das hilft schon weiter!
Hallo, ich muss mich leider heute wieder melden, da ich - trotz der Änderungen, die zwischenzeitlich funktioniert haben, s. oben - wieder die gleichen Probleme beim Zugriff auf das Fritz-NAS habe!
Ich kann keine Dateien mehr öffnen. Möglicherweise durch die täglichen Betriebssystem-Updates verursacht (Linux Mint 20, Kernel linux 5.4.0-47-generic)?
Habt Ihr Ähnliches erlebt?
Nur noch einmal zur Erinnerung meine FSTAB:

//192.168.178.1/FRITZ.NAS/ /home/meinname/fritzNAS cifs credentials=/home/meinname/.smbcredentials,vers=3.0,uid=1000,gid=1000,x-systemd.automount,x-systemd.requires=network-online.target 0 0


« Letzte Änderung: 10.11.2020, 16:35:41 von Linux2000 »

Nach einigem Rumprobieren bin ich mir ziemlich sicher und ich behaupte jetzt einmal kackfrech, dass an dem Fritz-NAS-Problem Linux Mint 20 schuld ist:

Habe eine alte Linux-Mint-18.3-Installation auf meiner SSD, in der ich damals noch kein Fritz-NAS integriert hatte, gestartet, dann

1. in der fstab die zusätzliche Mountanweisung
//192.168.178.1/FRITZ.NAS/ /home/meinname/fritzNAS cifs credentials=/home/meinname/.smbcredentials,vers=2.0,uid=1000,gid=1000,x-systemd.automount,x-systemd.requires=network-online.target 0 0
2. ein Verzeichnis /home/meinname/fritzNAS angelegt,
3. die .smbcredentials in das Home-Verzeichnis kopiert.

Ergebnis:
Zugriff auf NAS ohne irgendwelche Probleme, Bilder werden angezeigt, man kann in LibreOffice Dateien auf dem NAS erzeugen - und wieder ohne Fehler öffnen, keine komischen Locks etc.!!!

Das deutet auf ein Linuxproblem hin - meiner Meinung nach!



Re: Fritzbox 6490 update auf 7.20 danach NAS Problem
« Antwort #21 am: 10.11.2020, 17:17:21 »
Das deutet auf ein Linuxproblem hin - meiner Meinung nach!
... und LibreOffice Linuxversionen.

Ich habe in Virtualbox noch eine 32bit Debian9.13 (Kernel 4.9.0-14-686  2020-10-30) Distro am laufen, dort ist LO 5.2.7.2 drauf und mit dieser gibt es überhaupt keine Probleme beim speichern und wieder öffnen der Dateien auf der NAS der Fritzbox. Hier wird nichts zerstört. In der Samba.conf habe ich nur die Workgroup eingetragen, mehr nicht.
in der fstab reicht .... cifs vers=3.0,credentials=/home/user/.smbcredentials,uid=1000,gid=1000,auto 0 0

Warum es so ist und funktioniert kann ich nicht nachvollziehen, andersrum weiß ich auch nicht warum es nicht funktioniert bei aktuellen Systemen und Programmen

Re: Fritzbox 6490 update auf 7.20 danach NAS Problem
« Antwort #22 am: 10.11.2020, 18:44:51 »
Ich habe in meinem Netzwerk noch eine alte FritzBox als Switch und WLAN Hotspot im Einsatz. Habe meine Festplatte jetzt an dieser angeschlossen. Jetzt funktioniert es wieder wunderbar mit SMB 1.0.

Bin gespannt ob der Fehler wirklich am Linux liegt. Werde den Beitrag auf jeden Fall weiterverfolgen.

Re: Fritzbox 6490 update auf 7.20 danach NAS Problem
« Antwort #23 am: 11.11.2020, 09:20:45 »
Hallo in die Runde,
ich habe mich extra mal angemeldet, da sich hier doch einige Leidensgenossen sammeln.
Prinzipiell tritt bei mir das gleiche Problem auf. Ich wollte die im ChangeLog versprochenen Verbesserungen beim Gäste-WLAN mitnehmen und vom unsicheren SM1 weg.
Also hatte ich das Update auf die FritzBox 7490 (7.21) aufgespielt. Im Büro, es gibt einige Rechner, die Daten vom NAS nutzen. Darunter auch ZorinOS 18.3 (Ubuntu 18.04 LTS) & ich mit meinem Notebook mit Linux Mint 20 (Ubuntu 20.04). Bei beiden Distris ist auch das Verhalten genau gleich.

Nach dem Update konnte ich das NAS noch mounten, aber es war alles Schreibgeschützt. Durch das hinzufügen von noperm oder file_mode=0777,dir_mode0777 bekam ich die Schreibrechte wieder. Dann das nächste Problem beim öffnen von Dateien. E/A-Fehler, Stale file handle etc. Nach etwas umher suchen bin ich auf den Parameter noserverino gestoßen und auch der löste das Problem und ich hatte mich erstmal gefreut. Bis dann die Meldungen von Benutzern über kaputte LibreOffice Tabellen kamen.

Sehr ärgerlich, ich musste alle Linux-PCs jetzt quasi für die Bearbeitung von Dateien vom NAS sperren damit nicht aus versehen reihe rund die ganzen wichtigen LIbreOffice Dateien geschrottet werden. Weil wiederherstellen funktioniert nicht. Im "Archiv" ist die context.html betroffen. Beim reparieren des Archivs kommt die Meldung dass die context.html kein Ende habe. Hier scheinen wohl ein paar Bits zu kippen. Keine Ahnung warum anscheinend nur LIbreOffice betroffen ist. Mir scheint die Übertragung nicht sauber zu laufen. Eventuell ist LibreOffice nur empfindlich. Ich vermute hier eher die Spitze des Eisberges. Ich konnte noch keine Lösung finden. Ich konnte das Problem bereits an 2 FritzBoxen (beide 7490) und mehreren Linux PCs nachstellen. Für uns ist die FritzBox als NAS daher im Moment nicht mehr voll nutzbar. Ich habe schon 2 Nächte in das Problem versenkt und komme nicht mehr weiter.

Wie gesagt, ich glaube nicht an ein LibreOffice Problem, auch nicht unbedingt ein Linux Problem. Ich werde gleich noch ein Ticket bei AVM eröffnen.
Ich vermute eher ein Bug bei der SMB Implementierung. So ewig wie die bei SMB1 geblieben sind, obwohl es unsicher ist... schon komisch.

Re: Fritzbox 6490 update auf 7.20 danach NAS Problem
« Antwort #24 am: 11.11.2020, 11:22:44 »
Laut AVM für Fritz 7.20+

Sollten Sie Geräte nutzen, die nur SMBv1 beherrschen, können Sie die Unterstützung dieser Version über die FRITZ!Box Benutzeroberfläche unter Heimnetz->USB/Speicher wieder aktivieren.

...danach  funktionieren bei mir alle Rechner wieder mit NAS.

Re: Fritzbox 6490 update auf 7.20 danach NAS Problem
« Antwort #25 am: 11.11.2020, 12:53:09 »
Ja, das nuntzt bei mir z.B. nichts. Ob mit SMB1 support oder ohne. Ob mit SMB 1, 2 oder 3. Es ist immer das Gleiche. Ich brauche noserverino & dir_mode, file_mode. Und dann wie gesagt werden LibreOffice Dokumente zerschossen. Davon ab sollte es auch nicht die Lösung sein SMB1 zu nutzen. Das ist veraltet und unsicher. Max. als Workaround, wenn es denn ginge. Davon an kann Ubuntu 18.04 und neuer mit SMB2 und neuer umgehen.

Übrigens mounte ich über z.B Thunar (File-Manager) und nicht mit der fstab funktioniert es und die LibreOffice Dokumente bleiben heil. Beim geöffneten Dokument steht dann in der Titelzeile auch in Klammern (WEB) dahinter.

Damit gibts aber 2 Probleme. Zum einen ist das den Usern zu umständlich. Erst mounten, dann gehen die Desktop verknüpfungen etc. Und zum Anderen ist es dann fast immerso, auch bei frisch erzeugten Dokumenten, dass diese nur Schreibgeschützt geöffnet werden können, da diese bereits von einem unbekannten Benutzer geöffnet seien (was nicht sein kann). Also auch dieser Workaround hinkt sehr stark.

Und @herby, wer sind Sie eigentlich wenn ich fragen darf. Arbeiten Sie für AVM. Ich frage nur wegen der generischen Aussagen. Das klingt nach vom AVM Support-Blatt First-Level Service Desk kopiert. Das hilft hier nicht weiter. Eskaliert das und stellt es im Labor nach, bitte.
« Letzte Änderung: 11.11.2020, 13:03:53 von 3faltigkeit »

Re: Fritzbox 6490 update auf 7.20 danach NAS Problem
« Antwort #26 am: 11.11.2020, 13:53:59 »
Ich habe gerade mal in Terminal mit dem smbclient die Verbindung versucht. Ich bekam als Meldung, dass SMB1 deaktiviert sei. Der Haken in der GUI der Fritzbox für SBM1 support ist aber gesetzt. Ich habe jetzt die smb.conf bearbeitet und als max protocol NT1 gesetzt, also SMB1. Jetzt erhalte ich eine negotiation failed Meldung.
Ich habe den Verdacht, dass SMB1 nicht funktioniert obwohl es aktiviert ist und damit immer mehr, dass mit dem FritzOS 7.21 etwas nicht stimmt.
Als Hintergrund, ich versuche es erstmal so zum Laufen zu bekommen, wie es vorher war. Also SMB1. Aber auch das scheint nicht möglich zu sein

Re: Fritzbox 6490 update auf 7.20 danach NAS Problem
« Antwort #27 am: 11.11.2020, 14:02:02 »
Ich werde gleich noch ein Ticket bei AVM eröffnen

Das habe ich schon vor einiger Zeit gemacht. Antwort war: "Das können wir nicht nachvollziehen und scheint ein Einzelfall zu sein". Das war es dann und mit den Hinweistext den @herby geschrieben hat. Das dieser zwar Geräte einbindet die nur Vers.1 können, hilft aber nicht das Problem mit LO zulösen. Bei LO gibt es das Problem auch noch nicht, auch nur ein Einzelfall. Hatte da auch schon angefragt. Die neue 7 Version zerstört auch noch alles. Selbst Microsoft Office 2007 mit Wine kann in der NAS schreiben ohne das was kaputt geht. Ich lege alles nur noch in meiner Nextcloud ab. Die Angst bleibt aber das man oder jemand ausversehen eine wichtige Datei im NAS speichert.

Re: Fritzbox 6490 update auf 7.20 danach NAS Problem
« Antwort #28 am: 11.11.2020, 14:03:46 »
Ich habe den Verdacht, dass SMB1 nicht funktioniert
Die Box auch neugestartet?

Re: Fritzbox 6490 update auf 7.20 danach NAS Problem
« Antwort #29 am: 11.11.2020, 14:43:34 »
Hallo,

Ich habe den Verdacht, dass SMB1 nicht funktioniert obwohl es aktiviert ist und damit immer mehr, dass mit dem FritzOS 7.21 etwas nicht stimmt.

Meine FB 7490 habe ich vor 2-3 Wochen auf die neue Version 7.21 gebracht. Keine Änderungen an der Fritz-NAS vorgenommen ... und rufe diese wie immer via SMB auf, wenn ich sie mal brauche. Bei mir funktioniert alles wie immer. Testweise mal LibreOffice gestartet und Dokumente verarbeitet ... hm ... ich sehe da für mich kein Problem unter LMDE4.

MfG Jang

 

1. Advent
1. Advent