Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
27.11.2020, 05:00:01

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24827
  • Letzte: petergunn
Statistiken
  • Beiträge insgesamt: 696907
  • Themen insgesamt: 56399
  • Heute online: 466
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 7
Gäste: 333
Gesamt: 340

Autor Thema: [gelöst]  LM20Cin. APT meldet: W: Problem beim Entfernen (unlink) der Datei deb_cdrom_pool  (Gelesen 399 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo,
ich verwende ein Triple-Boot bestehend aus Win10 und LM20Cin. mit separater Home Partition als Produktivsystem und ein weiteres LM20Cin. (lm20-test) System ohne separate Home Partition zum Testen vorhanden.
Beide LM20 Cin. können auf die swap Partion zugreifen.
Alle Systeme sind im UEFI Mode installiert.

Beide LM20Cin. Systeme sind bis auf das getrennte /home identisch und mit gleichen Anwendungen (TB, Google-Chrom und Jameica und mit drei gleichen Desklets (Time and Date, Weather und google-calendar) installiert.

Das lm20-test System mit seinem internen /home meldete zu wenig Speicherplatz, innerhalb kürzester Zeit sind von 40GB nur noch 5GB frei, es sind nur zwei (2) Kernel installiert.

Darum versuchte ich aufzuräumen und erhalte auf Beiden Systemen die Rückmeldung:kuehhe1@HP-470:~$ sudo apt-get autoremove && sudo apt-get clean && sudo apt-get autoclean
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
W: Problem beim Entfernen (unlink) der Datei deb_cdrom_pool - pkgAcquire::Clean (21: Ist ein Verzeichnis)
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die Fehlermeldung kommt auch mit:kuehhe1@HP-470:~$ apt clean
W: Problem beim Entfernen (unlink) der Datei deb_cdrom_pool - pkgAcquire::Clean (21: Ist ein Verzeichnis)
kuehhe1@HP-470:~$

Eine Suche mit nemo nach: "deb_cdrom_pool" findet dieses Verzeichnis in:/var/cache/apt/archives/deb_cdrom_poolDas Verzeichnis ist leer und der Rückmeldung (Problem beim Entfernen (unlink)) nach müsste es sich um einen Link (Symlink) handeln, nur wo ist er abgelegt oder woher stammt er?

In der Akt.-Verwaltung ist das CD-ROM als Quelle deaktiviert.

Meine /etc/apt/sources List enthält den mit # auskommentierten Standard Eintrag:# deb cdrom:[Linux Mint 20 _Ulyana_ - Release amd64 20200624]/ focal contrib main
# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.

Die Datei /etc/apt/sources.list.d/official-repositories.list:deb http://mirror.netcologne.de/linuxmint/packages ulyana main upstream import backport

deb http://mirror.netcologne.de/ubuntu focal main restricted universe multiverse
deb http://mirror.netcologne.de/ubuntu focal-updates main restricted universe multiverse
deb http://mirror.netcologne.de/ubuntu focal-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ focal partner

Ein Wechsel der Spiegelserver behebt die Fehlermeldung nicht.

Die Bordsuche ergab nichts aber im Netz fand ich z.B dieses Thema:
https://askubuntu.com/questions/816503/w-problem-unlinking-the-file-lists-clean-21-is-a-directory-error-when-runn

Darin wird der Inhalt des Verzeichnises:/var/lib/apt/lists/als mögliche Fehlerquelle genannt, ich konnte darin aber keine Datei namens deb_cdrom_pool finden und habe das Verzeichnis mit erhöhtem Recht wie im Thema angegeben geleert und anschließend sudo apt-get update ausgeführt.

Danach war das Verzeichnis zwar wieder gefüllt aber die Rückmeldung von: sudo apt-get autoremove && sudo apt-get clean && sudo apt-get autocleanenhält weiterhin die Zeile:W: Problem beim Entfernen (unlink) der Datei deb_cdrom_pool - pkgAcquire::Clean (21: Ist ein Verzeichnis)
Noch ein Hinweis, Gestern kamen einige Upgrade der Akt.-Verwaltung herein die auch aptdeamon und python3-aptdeamon Pakete betrafen besteht da möglicherweise einen Zusammenhang?

Synaptic Verlauf:Commit Log for Thu Sep 24 20:18:51 2020

Die folgenden Pakete wurden aktualisiert:
alsa-ucm-conf (1.2.2-1ubuntu0.3) to 1.2.2-1ubuntu0.4
aptdaemon (1.1.1+bzr982-0ubuntu32.1) to 1.1.1+bzr982-0ubuntu32.2
aptdaemon-data (1.1.1+bzr982-0ubuntu32.1) to 1.1.1+bzr982-0ubuntu32.2
finalrd (5) to 6~ubuntu20.04.1
gir1.2-packagekitglib-1.0 (1.1.13-2ubuntu1) to 1.1.13-2ubuntu1.1
gstreamer1.0-packagekit (1.1.13-2ubuntu1) to 1.1.13-2ubuntu1.1
libpackagekit-glib2-18 (1.1.13-2ubuntu1) to 1.1.13-2ubuntu1.1
packagekit (1.1.13-2ubuntu1) to 1.1.13-2ubuntu1.1
packagekit-tools (1.1.13-2ubuntu1) to 1.1.13-2ubuntu1.1
python3-aptdaemon (1.1.1+bzr982-0ubuntu32.1) to 1.1.1+bzr982-0ubuntu32.2
python3-aptdaemon.gtk3widgets (1.1.1+bzr982-0ubuntu32.1) to 1.1.1+bzr982-0ubuntu32.2
shim (15+1533136590.3beb971-0ubuntu1) to 15+1552672080.a4a1fbe-0ubuntu2
shim-signed (1.40.3+15+1533136590.3beb971-0ubuntu1) to 1.40.4+15+1552672080.a4a1fbe-0ubuntu2

Woran liegt das und was kann ich tun?

Ach jo, mein System:kuehhe1@HP-470:~$ inxi -Fz
System:    Kernel: 5.4.0-48-generic x86_64 bits: 64 Desktop: Cinnamon 4.6.7 Distro: Linux Mint 20 Ulyana
Machine:   Type: Laptop System: HP product: HP ProBook 470 G5 v: N/A serial: <filter>
           Mobo: HP model: 837F v: KBC Version 02.3E.00 serial: <filter> UEFI: HP v: Q85 Ver. 01.12.00 date: 07/29/2020
Battery:   ID-1: BAT0 charge: 37.5 Wh condition: 38.4/38.4 Wh (100%)
CPU:       Info: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP L2 cache: 6144 KiB
           Speed: 800 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800
Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
           Device-2: NVIDIA GM108M [GeForce 930MX] driver: nvidia v: 450.66
           Device-3: Lite-On HP HD Camera type: USB driver: uvcvideo
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia unloaded: fbdev,nouveau,vesa resolution: 1600x900~60Hz
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.0.8
Audio:     Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
           Sound Server: ALSA v: k5.4.0-48-generic
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
           IF: enp2s0 state: down mac: <filter>
           Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi
           IF: wlp3s0 state: up mac: <filter>
Drives:    Local Storage: total: 1.14 TiB used: 227.62 GiB (19.5%)
           ID-1: /dev/nvme0n1 vendor: SK Hynix model: PC401 HFS256GD9TNG-62A0A size: 238.47 GiB
           ID-2: /dev/sda vendor: Samsung model: SSD 860 EVO 1TB size: 931.51 GiB
Partition: ID-1: / size: 39.38 GiB used: 34.27 GiB (87.0%) fs: ext4 dev: /dev/nvme0n1p9
Swap:      ID-1: swap-1 type: partition size: 10.00 GiB used: 0 KiB (0.0%) dev: /dev/nvme0n1p7
Sensors:   System Temperatures: cpu: 41.0 C mobo: 40.0 C
           Fan Speeds (RPM): N/A
Info:      Processes: 322 Uptime: 58m Memory: 7.21 GiB used: 3.17 GiB (43.9%) Shell: Bash inxi: 3.1.06
« Letzte Änderung: 02.10.2020, 12:32:34 von kuehhe1 »

Eine Suche mit nemo nach "deb_cdrom_pool" findet diese Verzeichnis in:/var/cache/apt/archives/deb_cdrom_poolDas Verzeichnis ist leer und der Rückmeldung nach müsste es sich um einen Link handeln, nur wo oder woher?
Das müsste über die Eigenschaften sichtbar werden.
Oder im Terminal mit
ls -l /var/cache/apt/archives/ | grep deb_cdrom_pool
Aber die Meldung sagt doch schon, dass es ein Verzeichnis ist, obwohl ein Link erwartet würde
Zitat
W: Problem beim Entfernen (unlink) der Datei deb_cdrom_pool - pkgAcquire::Clean (21: Ist ein Verzeichnis)
Aus dem Bauch raus würde ich die Eigenschaften notieren und das Verzeichnis manuell verschieben (mit erweiterten Rechten). Sollte das mehr Probleme bereiten, ließe es sich zurück schieben; zur Not mit den notierten Eigenschaften (Besitzer, Gruppe, Rechte) wieder erstellen lassen.

Die Bordsuche ergab nichts aber im Netz fand ich z.B dieses Thema:
https://askubuntu.com/questions/816503/w-problem-unlinking-the-file-lists-clean-21-is-a-directory-error-when-runn
Andere Meldung, also kaum eine Lösung.

Hi :)
einfach mal das verzeichnis löschen oder woanders hin kopieren? ;)

Hallo und Danke erst mal
Das müsste über die Eigenschaften sichtbar werden.
Oder im Terminal mit

so schauts aus:kuehhe1@HP-470:~$ ls -l /var/cache/apt/archives/ | grep deb_cdrom_pool
drwxr-xr-x 2 root root 4096 Sep 22 13:48 deb_cdrom_pool
hab sicherheitshalber nen Screenshot der Dateirechte gemacht und das Verzeichnis erst mal testhalber in: deb_cdrom_pool.old umbenannt.

Anschliessend nach: /var/cache/apt/ verschoben:
kuehhe1@HP-470:~$ ls -l /var/cache/apt/ | grep deb_cdrom_pool
drwxr-xr-x 2 root root     4096 Sep 22 13:48 deb_cdrom_pool.old

Neue Versuche aufzuräumen verlaufen jetzt Fehlerfrei:
sudo apt-get autoremove && sudo apt-get clean && sudo apt-get autoclean
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
kuehhe1@HP-470:~$ apt clean
kuehhe1@HP-470:~$

Auffrischen der Akt.-Verwalt. und Neu Laden in Synaptic und  apt update && apt upgrade funktioniert

Ich werde es beobachten, aber warum oder wodurch wurde der Fehler auf Beiden Systemen ausgelöst bzw. verursacht es lief doch bisher sauber?


Hi :)
Zitat
Ich werde es beobachten, aber warum oder wodurch wurde der Fehler auf Beiden Systemen ausgelöst bzw. verursacht es lief doch bisher sauber?

du musst doch wissen was du auf deinen systemen zwischenzeitlich gebastelt bzw. installiert / entfernt hast.

Off-Topic:
du musst doch wissen …
Was?
Frommer Wunsch eines Phantasten!

Außerdem müsste man auch in der Lage sein, die gesamten Folgen seines Tuns zu durchblicken.
Wer außer Dir kann das schon leisten?   ;)
« Letzte Änderung: 25.09.2020, 16:33:51 von aexe »

Hi :)
du musst doch wissen was du auf deinen systemen zwischenzeitlich gebastelt bzw. installiert / entfernt hast.
Du denkst wohl ich bastle nur herum,
kannst mir schon glauben das ich heil froh bin nach dem Gestrigen grub Debakel beide Systeme wieder am Laufen zu haben, schau mal das Ergebnis nach heutigem morgendlichen Neustart: https://www.linuxmintusers.de/index.php?topic=64246.msg843235#msg843235

Es handelte sich um Zwei Frische Neuinstallationen, mit plötzlich auftauchenden gleichem Fehlerbild nach einem Apt Upgrade.

Hi :)
wenn ich mir das so ansehe, hätte ein einfache
sudo apt-get clean
auch geholfen...

sind schon komisch deine systeme ;)

Hi ehtron,
nein hätte es nicht , denn auch damit kam der Fehler,
hatte ich doch eingangs gezeigt
Die Fehlermeldung kommt auch mit:
Code: [Auswählen]
kuehhe1@HP-470:~$ apt clean
W: Problem beim Entfernen (unlink) der Datei deb_cdrom_pool - pkgAcquire::Clean (21: Ist ein Verzeichnis)
kuehhe1@HP-470:~$
« Letzte Änderung: 26.09.2020, 14:46:00 von kuehhe1 »

Da in beiden Systemen der selbe Fehler bestand ist nun auch im Produktivsystem nach Verschieben des bemängeltem Verzeichnisses: /var/cache/apt/archives/deb_cdrom_pool nach: /var/cache/apt/deb_cdrom_pool wieder ein fehlerfreies apt clean möglich. Theoretisch könnte man ja /var/cache/ komplett leeren da es sich ja um ein Cache Verzeichnis handelt.

Ich habe nochmal gesucht und mir die jeweils fünf (5) Timeshift Sicherungen meiner beiden Systeme angeschaut. Bis zum 21.09.2020 war dieses bemängelte Verzeichnis: /var/cache/apt/archives/deb_cdrom_poolin keinem Schnappschuss vorhanden. Ich frag mich nur welches Update oder welche Anwendung dieses Verzeichnis unnützerweise anlegte. Schon der Name deb_cdrom_pool klingt nach einer *.deb Paket Installation mit dem Paketinstaller, andererseits habe ich gar kein CD-Rom Laufwerk.  ::)

Danke für Eure Hilfe, meinerseits gelöst.
« Letzte Änderung: 26.09.2020, 14:52:33 von kuehhe1 »

Hi :)
Zitat
in keinem Schnappschuss vorhanden. Ich frag mich nur welches Update oder welche Anwendung dieses Verzeichnis unnützerweise anlegte

hört sich nach einem nicht zu mint gehörenden ppa / quelle (fremdquellen können...... ;)  ) oder eben von hand installiertem .deb an ;)


Zitat von: kuehhe1
Schon der Name deb_cdrom_pool klingt nach einer *.deb Paket Installation mit dem Paketinstaller, andererseits habe ich gar kein CD-Rom Laufwerk.  ::)
Ich bezweifel zwar, dass etwas gefunden wird, aber die Probe auf's Exempel geht u. a. so
dpkg -S /var/cache/apt/archives/deb_cdrom_pool

Ich bezweifel zwar, dass etwas gefunden wird, aber die Probe auf's Exempel geht u. a. so

kuehhe1@HP-470:~$ dpkg -S /var/cache/apt/archives/deb_cdrom_pool
dpkg-query: Kein Pfad gefunden, der auf Muster /var/cache/apt/archives/deb_cdrom_pool passt


hört sich nach einem nicht zu mint gehörenden ppa / quelle (fremdquellen können......   ) oder eben von hand installiertem .deb an
daran hatte ich auch gedacht und die fünf (5) *.deb Pakete de- und erneut installiert und mit sudo apt update die Listen auffrischen lassen, dass Verzeichnis /var/cache/apt/archives/deb_cdrom_pool wurde dabei aber nicht erstellt.

Deb-Pakete:
google-chrome-stable_85.0.4183.121-1_amd64.deb
conky-fonts-0.0.2_all.deb
radiotray-ng_0.2.7_ubuntu_20.04_amd64.deb
tvbrowser_4.2-1_all.deb
flameshot_0.6.0_bionic_x86_64.deb

PPA:kuehhe1@HP-470:~$ inxi -r
Repos:     No active apt repos in: /etc/apt/sources.list
           Active apt repos in: /etc/apt/sources.list.d/dieterbaum-qt-fsarchiver-focal.list
           1: deb http://ppa.launchpad.net/dieterbaum/qt-fsarchiver/ubuntu focal main
           Active apt repos in: /etc/apt/sources.list.d/gezakovacs-ppa-focal.list
           1: deb http://ppa.launchpad.net/gezakovacs/ppa/ubuntu focal main
           Active apt repos in: /etc/apt/sources.list.d/google-chrome.list
           1: deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
           Active apt repos in: /etc/apt/sources.list.d/graphics-drivers-ppa-focal.list
           1: deb http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu focal main
           Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
           1: deb http://mirror.netcologne.de/linuxmint/packages ulyana main upstream import backport
           2: deb http://mirror.netcologne.de/ubuntu focal main restricted universe multiverse
           3: deb http://mirror.netcologne.de/ubuntu focal-updates main restricted universe multiverse
           4: deb http://mirror.netcologne.de/ubuntu focal-backports main restricted universe multiverse
           5: deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
           6: deb http://archive.canonical.com/ubuntu/ focal partner
           Active apt repos in: /etc/apt/sources.list.d/skype-stable.list
           1: deb [arch=amd64] https://repo.skype.com/deb stable main
           Active apt repos in: /etc/apt/sources.list.d/slgobinath-gcalendar-focal.list
           1: deb http://ppa.launchpad.net/slgobinath/gcalendar/ubuntu focal main
           Active apt repos in: /etc/apt/sources.list.d/unit193-inxi-focal.list
           1: deb http://ppa.launchpad.net/unit193/inxi/ubuntu focal main
Die PPA's für google-chrome und skypeforlinux werden automatisch während der Installation hinzugefügt, die PPA's hatte ich aber auch schon vor der LM20 Neuinstallation aktiv und bisher keine Probleme. Testhalber die PPA deaktiviert die Anwendungen mit Synaptic deinstalliert und der Reihe nach wieder aktiviert und die Anwendungen neu installiert, aber auch dabei wurde kein Verzeichnis: /var/cache/apt/archives/deb_cdrom_pool angelegt.

Die PPA und *.deb Pakete hatte ich aber schon immer installiert und nie Probleme damit.
Ich kann es nur weiter beobachten und setzte es später auf gelöst
« Letzte Änderung: 27.09.2020, 15:30:50 von kuehhe1 »

Habe jetzt nur den letzten Beitrag gelesen, aber bei "deb_cdrom_pool" fällt mir diese normalerweise inaktive Quelle "#deb cdrom:[Linux Mint 20 _Ulyana_" in /etc/apt/sources.list ein.
Vielleicht gibt es damit einen Zusammenhang?

Moin @aexe
aber bei "deb_cdrom_pool" fällt mir diese normalerweise inaktive Quelle "#deb cdrom:[Linux Mint 20 _Ulyana_" in /etc/apt/sources.list ein.
ui, mein Fehler, da hatte ich die falsche "inxi -r Rückmeldung" gezeigt, habs schon korrigiert.

Das CD-ROM als Quelle war und ist hier immer deaktiviert, ausserdem war nach beiden Installationen der lm20cin.iso hier vom Board die Einstellung der CD-ROM Quelle bei beiden Systemen als Vorgabe bereits deaktiviert. Wäre das CD-ROM als Quelle aktiv gesetzt würde doch schon beim ersten Auffrischen mit der Akt.-Verwaltung die bekannte Fehlermeldung im Aktualisierungs-Fenster erscheinen. Man kann sich natürlich auch schon mal verklicken aber jene Einstellungen habe ich noch vor Themeneröffnung geprüft, siehe Anhang.

Und die /etc/apt/sources.list kontrolliert und mit der Mint.iso hier vom Board sieht sie inhaltlich so aus:
Meine /etc/apt/sources List enthält den Standard Eintrag:
Code: [Auswählen]
# deb cdrom:[Linux Mint 20 _Ulyana_ - Release amd64 20200624]/ focal contrib main
# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.
also keine Aktivierung der CD-ROM als Quelle ersichtlich.

Ich mußte ja aus einem anderen Grund mein System neu aufsetzen und weil ich schon dabei war hatte ich mir 40GB Platz für ein zusätzliches LM20Cin.-Testsystem (lm20-test) geschaffen und nach und nach in beiden Systemen meine benötigten Anwendungen installiert. Ich spiele hier auch im Produktivsystem nicht herum, nutze es nur für HomeOffice, HomeBanking und etwas Musik hören, von daher kein Spielgerät. Wenn es in der Vergangenheit mal etwas Neues zu installieren gab wurden immer Timeshift und qt-fsarchiver Sicherungen angelegt.  ;)

Dennoch sehr merkwürdig das diese(r) Fehler bei beiden Neu installierten System sehr zeitnah erschien, dem Zeitfenster der Aktualisierungs-Historie vom 21.09.2020 nach zu urteilen kann es sich eigentlich nur um die Aktualisierungen von google-chrome oder die Kernelupdates vom Standardkernel 5.4.0-26 auf 5.4.0-47 gehandelt haben.

Aber wie zuvor gesagt ist derzeit alles ok, ich werde es aber weiterhin beobachten.
« Letzte Änderung: 27.09.2020, 15:30:30 von kuehhe1 »