Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
19.09.2020, 17:19:11

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 683202
  • Themen insgesamt: 55316
  • Heute online: 348
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Problem mit defekten Paketen  (Gelesen 171 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Problem mit defekten Paketen
« am: 13.09.2020, 09:51:26 »
Seit der Installation von Mint 2.0 läuft etwas schief.
Wenn ich in der Paketverwaltung etwas installieren oder deinstallieren will, wird das angehakte Kästchen rot, und ich bekomme die Bemerkung, dass ich erst mal die defekten Pakete reparieren soll.

Wenn ich dann die entsprechende Funktion anwähle, bekomme ich folgende Meldung:

E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
E: Fehler: Unterbrechungen durch pkgProblemResolver::Resolve hervorgerufen; dies könnte durch zurückgehaltene Pakete verursacht worden sein.
E: Auflösen der Abhängigkeiten ist fehlgeschlagen
E: Fehler: Unterbrechungen durch pkgProblemResolver::Resolve hervorgerufen; dies könnte durch zurückgehaltene Pakete verursacht worden sein.
E: Auflösen der Abhängigkeiten ist fehlgeschlagen

Ansonsten läuft mein System ganz gut, aber einiges ist eben durch dieses Problem blockiert. Wie kann ich vorgehen?

Ich möchte dazu bemerken, dass ich bereits ausgiebig gegoogelt habe (auch in diesem Forum) und alles ausprobiert habe. Ohne Erfolg! Ich denke, die Lösung ist vielleicht zu finden, wenn ich herausfinde, welches die defekten Pakete sind.
« Letzte Änderung: 13.09.2020, 10:14:35 von Sonoptikon »

Re: Problem mit defekten Paketen
« Antwort #1 am: 13.09.2020, 10:28:15 »
gefunden habe ich inzwischen einen Befehl:

sudo dpkg --purge `dpkg --get-selections | awk '/deinstall/ {print $1}'`
(bei print $1 normale oder geschweifte Klammer?)

Ich habe mit dpkg --list | grep ^rc eine Liste mit defekten Paketen ausgeben lassen. dabei ist folgendes herausgekommen:

rc  adobeair                                      1:2.6.0.19170-devolo1                    amd64        Adobe AIR 2
rc  chromium-browser                              83.0.4103.61-0ubuntu0.18.04.1            amd64        Chromium web browser, open-source version of Chrome
rc  devolo-dlan-cockpit                           5.1.3-0                                  amd64        devolo Cockpit
rc  grub2-theme-mint                              1.2.2                                    all          Grub2 theme for Linux Mint
rc  ibus                                          1.5.22-2ubuntu2.1                        amd64        Intelligent Input Bus - core
rc  imagemagick                                   8:6.9.7.4+dfsg-16ubuntu6.8               amd64        image manipulation programs -- binaries
rc  kinit                                         5.68.0-0ubuntu1                          amd64        process launcher to speed up launching KDE applications
rc  libapache2-mod-php7.2                         7.2.24-0ubuntu0.18.04.6                  amd64        server-side, HTML-embedded scripting language (Apache 2 module)
rc  libapache2-mod-python                         3.3.1-11ubuntu2                          amd64        Python-embedding module for Apache 2
rc  libgdk-pixbuf2.0-0:i386                       2.40.0+dfsg-3                            i386         GDK Pixbuf library
rc  libgtk2.0-0:i386                              2.24.32-4ubuntu4                         i386         GTK graphical user interface library - old version
rc  libimage-magick-perl                          8:6.9.10.23+dfsg-2.1ubuntu11             all          Perl interface to the ImageMagick graphics routines
rc  libmagick++-6-headers                         8:6.9.7.4+dfsg-16ubuntu6.8               all          object-oriented C++ interface to ImageMagick - header files
rc  libmagick++-dev                               8:6.9.7.4+dfsg-16ubuntu6.8               all          object-oriented C++ interface to ImageMagick -- dummy package
rc  libmagickcore-6-headers                       8:6.9.7.4+dfsg-16ubuntu6.8               all          low-level image manipulation library - header files
rc  libmagickwand-6-headers                       8:6.9.7.4+dfsg-16ubuntu6.8               all          image manipulation library - headers files
rc  libopenexr-dev                                2.2.0-11.1ubuntu1.1                      amd64        development files for the OpenEXR image library
rc  libpsm-infinipath1                            3.3+20.604758e7-6                        amd64        PSM Messaging library for Intel Truescale adapters
rc  libqtcore4:amd64                              4:4.8.7+dfsg-7ubuntu1                    amd64        Qt 4 core module
rc  libsensors4:amd64                             1:3.4.0-4                                amd64        library to read temperature/voltage/fan sensors
rc  libsensors4:i386                              1:3.4.0-4                                i386         library to read temperature/voltage/fan sensors
rc  libxaw7:i386                                  2:1.0.13-1                               i386         X11 Athena Widget library
rc  lilypond-data                                 2.18.2-12build1                          all          LilyPond music typesetter (data files)
rc  linux-image-4.15.0-111-generic                4.15.0-111.112                           amd64        Signed kernel image generic
rc  linux-modules-4.15.0-111-generic              4.15.0-111.112                           amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-extra-4.15.0-111-generic        4.15.0-111.112                           amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  odbcinst                                      2.3.6-0.1build1                          amd64        Helper program for accessing odbc ini files
rc  phonon4qt5:amd64                              4:4.11.1-3build1                         amd64        multimedia framework from KDE using Qt 5 - metapackage
rc  php7.2-fpm                                    7.2.17-0ubuntu0.18.04.1                  amd64        server-side, HTML-embedded scripting language (FPM-CGI binary)
rc  puredata-gui                                  0.48.1-3                                 all          realtime computer music and graphics system - GUI
rc  redshift-gtk                                  1.11-1ubuntu1mint1                       all          Adjusts the color temperature of your screen with GTK+ integration
rc  texinfo                                       6.7.0.dfsg.2-5                           amd64        Documentation system for on-line information and printed output
rc  transmission-gtk                              2.92-3ubuntu2                            amd64        lightweight BitTorrent client (GTK+ interface)
rc  zoom                                          5.2.440215.0803                          amd64        Zoom, #1 Video Conferencing and Web Conferencing Service


Kann es sein, dass diese Pakete alle defekt sind. Bei einigen habe ich schon den verdacht (z.B. zoom, puredata), aber bei den anderen bin ich mir nicht so sicher, z.B. libapache usw.
Was tun?

Re: Problem mit defekten Paketen
« Antwort #2 am: 13.09.2020, 10:49:44 »
gefunden habe ich inzwischen einen Befehl:

sudo dpkg --purge `dpkg --get-selections | awk '/deinstall/ {print $1}'`
(bei print $1 normale oder geschweifte Klammer?)


Nun habe ich diesen langen Befehl ausprobiert und als Parameter zoom angegeben. Dann wurde einiges entfernt und anschließend konnte ich mit dem list-Befehl keine fehlerhaften Pakete mehr listen. Kann es sein, dass nur dieses eine Programm für den ganzen Mist verantwortlich war?

Die Paketverwaltung macht bei "defekte Pakete reparieren" keine Ausgabe mehr - komisch ... sollte das alles gewesen sein?

So, nun geht das ganze von vorne los:

Ich hatte ZOOM installiert, ich konnte sogar an einer ZOOM-Sitzung teilnehmen, aber es hat sich sehr seltsam verhalten. Aber das ist ein anderes Thema.

Re: Problem mit defekten Paketen
« Antwort #3 am: 13.09.2020, 12:26:00 »
Off-Topic:
Seit der Installation von Mint 2.0 läuft etwas schief.
Da muss schon vorher was schiefgelaufen sein.
Frag mal dort nach:
https://lessing-schule.de/2020/09/09/mint-2-0-die-rezertifizierung/
Oder dort:
https://mint.bildung-rp.de/
#MINT läuft!

Ohne Scherz:
Ich habe mit dpkg --list | grep ^rc eine Liste mit defekten Paketen ausgeben lassen
"rc" bedeutet "removed configured", also das Paket wurde entfernt, die Konfiguration ist aber noch vorhanden.
Bedeutet nicht: defekt.
Mit "apt purge <Paket>" (purge = vollständig entfernen) wird auch die Konfiguration gelöscht.

Des weiteren gibt es oft noch Konfigurationsdateien von Programmen im persönlichen Verzeichnis.
Diese werden durch Entfernen der Software-Pakete nicht gelöscht.
Das muss der Benutzer selbst tun.

Edit
Eine Liste nur mit den Namen der "rc"-Pakete liefert: dpkg -l | grep ^rc | cut -d" " -f3
« Letzte Änderung: 13.09.2020, 13:38:22 von aexe »

Re: Problem mit defekten Paketen
« Antwort #4 am: 14.09.2020, 16:22:21 »
Hi :)
defekte pakete kannst du am besten in
synaptic
unter status sehen