Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
28.11.2020, 09:20:07

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24828
  • Letzte: kohlhaas
Statistiken
  • Beiträge insgesamt: 697113
  • Themen insgesamt: 56413
  • Heute online: 447
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  LM20 Cinnamon: Bluetooth - Sound zerhackt  (Gelesen 99 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

LM20 Cinnamon: Bluetooth - Sound zerhackt
« am: 15.11.2020, 01:07:03 »
inxi:
System:
  Host: host Kernel: 5.4.0-53-generic x86_64 bits: 64
  Desktop: Cinnamon 4.6.7 Distro: Linux Mint 20 Ulyana
Machine:
  Type: Laptop System: LENOVO product: 2182 v: Lenovo G780
  serial: <superuser/root required>
  Mobo: LENOVO model: INVALID v: 31900003WIN8 STD MLT
  serial: <superuser/root required> UEFI: LENOVO v: 5ECN95WW(V9.00)
  date: 12/19/2012
Battery:
  ID-1: BAT1 charge: 17.4 Wh condition: 31.7/47.5 Wh (67%)
CPU:
  Topology: Dual Core model: Intel Core i3-2328M bits: 64 type: MT MCP
  L2 cache: 3072 KiB
  Speed: 800 MHz min/max: 800/2200 MHz Core speeds (MHz): 1: 798 2: 798
  3: 798 4: 798
Graphics:
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
  driver: i915 v: kernel
  Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa
  resolution: 1600x900~60Hz
  OpenGL: renderer: Mesa DRI Intel HD Graphics 3000 (SNB GT2)
  v: 3.3 Mesa 20.0.8
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio
  driver: snd_hda_intel
  Sound Server: ALSA v: k5.4.0-53-generic
Network:
  Device-1: Qualcomm Atheros AR8162 Fast Ethernet driver: alx
  IF: enp1s0 state: down mac: 20:89:84:3a:2d:c7
  Device-2: Broadcom and subsidiaries BCM4313 802.11bgn Wireless Network
  Adapter
  driver: wl
  IF: wlp2s0 state: up mac: 68:94:23:fb:fb:95
  IF-ID-1: pan1 state: unknown speed: N/A duplex: N/A mac: 9a:b1:b7:8d:03:b5
Drives:
  Local Storage: total: 465.76 GiB used: 271.59 GiB (58.3%)
  ID-1: /dev/sda vendor: Seagate model: ST500LT012-9WS142 size: 465.76 GiB
Partition:
  ID-1: / size: 29.40 GiB used: 22.13 GiB (75.3%) fs: ext4 dev: /dev/sda2
  ID-2: /home size: 427.43 GiB used: 124.73 GiB (29.2%) fs: ext4
  dev: /dev/sda3
Sensors:
  System Temperatures: cpu: 44.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Repos:
  No active apt repos in: /etc/apt/sources.list
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
  1: deb http://ftp-stud.hs-esslingen.de/pub/Mirrors/packages.linuxmint.com ulyana main upstream import backport
  2: deb http://ftp.hosteurope.de/mirror/archive.ubuntu.com focal main restricted universe multiverse
  3: deb http://ftp.hosteurope.de/mirror/archive.ubuntu.com focal-updates main restricted universe multiverse
  4: deb http://ftp.hosteurope.de/mirror/archive.ubuntu.com focal-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ focal partner
  Active apt repos in: /etc/apt/sources.list.d/vivaldi.list
  1: deb http://repo.vivaldi.com/stable/deb/ stable main
Info:
  Processes: 223 Uptime: 2h 46m Memory: 3.71 GiB used: 1.49 GiB (40.0%)
  Shell: bash inxi: 3.0.38

Zunächst klappte das alles, neues Gerät (JBL-Headset Reflect Mini 2) einrichten, und schon kamen Töne raus.
Schien alles gut.

Dann wurde manchmal der Sound zerhackt, Unterbrechungen der Übertragung scheinbar.
Das waren nur Sekundenbruchteile.
Dann hab ich per jitsi mit meiner Süßen geschnackt, und das ging gar nicht.
Unterbrechungen von zehn Sekunden, zwischendurch ging die Verbindung verloren, wurde dann wiederhergestellt, und dabei saß ich genau vor dem Gerät.

Ich hab versucht, meinen Blauzahn nach der Anleitung auf ubuntuusers.de einzurichten und bin leider unfallfrei nur bis zur NAP/DUN gekommen. Bei der NAP-Einrichtung bekomme ich unter allen möglichen Varianten (PAN=NetworkManager, DUN=NetworkManager/PAN=Blueman (dhcpclient), DUN=NetworkManager/PAN=Blueman (dhcpclient), DUN=Blueman) exeptions von blueman:
g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.Failed: Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/blueman/main/DbusService.py", line 124, in _handle_method_call
    ok(method(*args))
  File "/usr/lib/python3/dist-packages/blueman/plugins/mechanism/Network.py", line 47, in _enable_network
    nc.apply_settings()
  File "/usr/lib/python3/dist-packages/blueman/main/NetConf.py", line 386, in apply_settings
    self.add_ipt_rule("nat", "POSTROUTING", "-s %s/%s -j MASQUERADE" % (self.ip4_address, self.ip4_mask))
  File "/usr/lib/python3/dist-packages/blueman/main/NetConf.py", line 324, in add_ipt_rule
    ret = call(args)
  File "/usr/lib/python3.8/subprocess.py", line 340, in call
    with Popen(*popenargs, **kwargs) as p:
  File "/usr/lib/python3.8/subprocess.py", line 854, in __init__
    self._execute_child(args, executable, preexec_fn, close_fds,
  File "/usr/lib/python3.8/subprocess.py", line 1702, in _execute_child
    raise child_exception_type(errno_num, err_msg, err_filename)
FileNotFoundError: [Errno 2] Datei oder Verzeichnis nicht gefunden: '/sbin/iptables'
 (0)
g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.Failed: Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/blueman/main/DbusService.py", line 124, in _handle_method_call
    ok(method(*args))
  File "/usr/lib/python3/dist-packages/blueman/plugins/mechanism/Network.py", line 47, in _enable_network
    nc.apply_settings()
  File "/usr/lib/python3/dist-packages/blueman/main/NetConf.py", line 370, in apply_settings
    raise NetworkSetupError("Failed to add ip address %s with netmask %s" % (self.ip4_address,
blueman.main.NetConf.NetworkSetupError: Failed to add ip address 10.255.248.1 with netmask 255.255.255.0
 (0)
g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.Failed: Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/blueman/main/DbusService.py", line 124, in _handle_method_call
    ok(method(*args))
  File "/usr/lib/python3/dist-packages/blueman/plugins/mechanism/Network.py", line 47, in _enable_network
    nc.apply_settings()
  File "/usr/lib/python3/dist-packages/blueman/main/NetConf.py", line 370, in apply_settings
    raise NetworkSetupError("Failed to add ip address %s with netmask %s" % (self.ip4_address,
blueman.main.NetConf.NetworkSetupError: Failed to add ip address 10.255.248.1 with netmask 255.255.255.0
 (0)
Das verstehe ich nicht.

Die Deaktivierung des Autostarts hab ich hinbekommen.^^

Zitat
Edit: Ich sehe schon, daß irgendwas bei Python vermarmelt ist. Das geht allerdings so weit ins Getriebe, daß ich nicht weiß, wie die richtigen Fragen heißen.
Niemand eine Idee?


Grüße

mungo
« Letzte Änderung: 16.11.2020, 23:04:28 von mungo »