Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
28.09.2020, 13:30:32

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 685186
  • Themen insgesamt: 55453
  • Heute online: 668
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  HPLIP 3.17.10 unter Linuxmint Mate 19.3 nicht updatefähig?  (Gelesen 490 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Moin,

 ich verstehe die Zusammenhänge nicht:
 
cord@cord-desktop:~$ sudo apt dist-upgrade hplip
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
hplip ist schon die neueste Version (3.17.10+repack0-5).
Paketaktualisierung (Upgrade) wird berechnet... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

cord@cord-desktop:~$ sh hplip-3.17.10-plugin.run
Verifying archive integrity... All good.
Uncompressing HPLIP 3.17.10 Plugin Self Extracting Archive................................................
Error importing HPLIP modules.  Is HPLIP installed?

Ich habe nun schon alles durch. Deinstalliert, versucht neue Versionen zu installieren und Recherche ohne Ende. Zwar läuft der Drucker ein HP-MFW M375nw und scannt auch sogar über ADF nur ist er zum direkt faxen von PC aus nicht zu gebrauchen.

Alle Versuche auf 3.20.6 upzudaten scheitern. Auch werden bei 3.17.10 Fehlermeldung bei hp-check -r angezeigt, obwohl es sich um die Original Installation(CD) handelt. Auf die ich immer via Timeshift zurückgegangen bin.

Status Types:
    OK
    MISSING       - Missing Dependency or Permission or Plug-in
    INCOMPAT      - Incompatible dependency-version or Plugin-version

warning: 22-19.3 version is not supported. Using 22-18.2 versions dependencies to verify and install...


warning: HPLIP-Installation: Auto installation is not supported for 22 distro  19.3 version

Missing Required Dependencies
-----------------------------
error: 'libsnmp-dev' package is missing/incompatible
error: 'snmp-mibs-downloader' package is missing/incompatible
error: 'openssl' package is missing/incompatible


Die dateien Libcsnmp-dev, snmp-mibs-downloader und openssl sind neuer als die 3.17.10 haben will was die inkompabilität begründen könnte.

Es gibt ein Programm  hp-sendfax mit dem das senden von Faxen möglich wäre, die Meldung allerdings lässt darauf schließen das was fehlt.
qt5ct: using qt5ct plugin
qt5ct: D-Bus global menu: no

Weiß jemand Abhilfe?

Re: HPLIP 3.17.10 unter Linuxmint Mate 19.3 nicht updatefähig?
« Antwort #1 am: 29.07.2020, 20:35:16 »
sudo apt dist-upgrade
Führt bereits ein volles Update aller Pakete durch, so dass das Angeben von "hplip" überflüssig ist.
Davon ab wird das Faxen sicherlich durch so ein Update allein nicht funktionieren. Das wird an etwas anderem scheitern. Hast du denn  mit diesem Gerät unter Mint schon mal in der geschilderten Weise faxen können?

Re: HPLIP 3.17.10 unter Linuxmint Mate 19.3 nicht updatefähig?
« Antwort #2 am: 29.07.2020, 23:22:07 »
Zitat
Hast du denn  mit diesem Gerät unter Mint schon mal in der geschilderten Weise faxen können?

Der Post mit dem upgrade sollte nur zeigen das alle installierbaren Pakete vorhanden sind, bei der Installation der plugins aber nicht gefunden werden.

Laufen tat es bisher nicht, auch nicht unter Ubuntu 20 oder Linuxmint 20.04, beides hab ich auf meine Laptop installiert. Führe ich unmittelbar nach der Installation und dem Update Hp-check -r aus erscheinen haufenweise Fehlermeldungen. Dort ist hplip 3.20.3 in den Paketen, ansonsten die gleiche Inkompalität wie in 3.17 unter 19.3. in linuxmint 20 steht analog das gleiche wie in 19.3 ein Verweis auf die Vorgängerversion.
 
Zitat
Status Types:
    OK
    MISSING       - Missing Dependency or Permission or Plug-in
    INCOMPAT      - Incompatible dependency-version or Plugin-version

warning: linuxmint- 20 version is not supported. Using 22-19.3 versions dependencies to verify and install...


warning: HPLIP-Installation: Auto installation is not supported for 22 distro  19.3 version

Theoretisch könnte ich jetzt 19.3 auf 3.20.3 updaten. Aber so vermute ich, wurde hp-lip mit veränderten Pfaden tiefer als mit purge auffindbar in das System "eingegraben", wodurch immer noch Reste verbleiben und stören.
 


Re: HPLIP 3.17.10 unter Linuxmint Mate 19.3 nicht updatefähig?
« Antwort #3 am: 29.07.2020, 23:40:08 »
Zitat
Aber so vermute ich, wurde hp-lip mit veränderten Pfaden tiefer als mit purge auffindbar in das System "eingegraben", wodurch immer noch Reste verbleiben und stören.

Im persönlichen Ordner gibt es den versteckten Ordner .hplip mit Konfigurationsdateien, der muss per Hand gelöscht werden, das passiert nicht mit purge.

Re: HPLIP 3.17.10 unter Linuxmint Mate 19.3 nicht updatefähig?
« Antwort #4 am: 30.07.2020, 11:24:58 »
Moin,

Ist vorhanden, ich hab die hplip.conf versehentlich zerschossen. Kann sie mir aber zurückholen, das lustige das hat null Auswirkung, scannen, drucken geht, sogar erheblich schneller als bisher.

je länger ich mich mit HPLip beschäftige je mehr erhärtet sich mein Eindruck, da passt einiges nicht zusammen. Drucken und scannen funktioniert. Kann es sein das hplip 3.17.10 in der Disburtion verändert wurde? hp-check -r liefert dazu Hinweise wie inkompalität und Warnungen, die sich ja in Linuxmint 20.4 wiederholen.

Ich frag das, weil ich seit Geburt ne Bimmel am Hintern hab, auf der steht, du bist der erste.

Re: HPLIP 3.17.10 unter Linuxmint Mate 19.3 nicht updatefähig?
« Antwort #5 am: 30.07.2020, 18:44:29 »
Update: ich bin mir mittlerweile sicher das hplip 3.17.10 nichts mit dem gleichnamigen HP Treiber zu tun hat.

Wie ich darauf komme? ich habe mir Linuxmint 19.3 auf einem Rechner installiert. die Updates durchgeführt. Und hp-check -r durchlaufen lassen, Hier das Ergebnis ergänzt durch einen Abgleich mit in Synaptic angebotenen Paketen. Vorh= war vorhanden mn= manuell nachgeladen 

cb-e4300@cbe4300-Latitude-E4300:~$ hp-check -r
Saving output in log file: /home/cb-e4300/hp-check.log

HP Linux Imaging and Printing System (ver. 3.17.10)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the
HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
are installed to successfully compile HPLIP.                                   
2. Run-time check mode (-r or --run): Use this mode to determine if a distro   
supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball   
has the proper dependencies installed to successfully run.                     
3. Both compile- and run-time check mode (-b or --both) (Default): This mode   
will check both of the above cases (both compile- and run-time dependencies).   

Check types:                                                                   
a. EXTERNALDEP - External Dependencies                                         
b. GENERALDEP - General Dependencies (required both at compile and run time)   
c. COMPILEDEP - Compile time Dependencies                                       
d. [All are run-time checks]                                                   
PYEXT SCANCONF QUEUES PERMISSION                                               

Status Types:
    OK
    MISSING       - Missing Dependency or Permission or Plug-in
    INCOMPAT      - Incompatible dependency-version or Plugin-version

warning: 22-19.3 version is not supported. Using 22-18.2 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 5.0.0-32-generic #34~18.04.2-Ubuntu SMP Thu Oct 10 10:36:02 UTC 2019 GNU/Linux
 Host: cbe4300-Latitude-E4300
 Proc: 5.0.0-32-generic #34~18.04.2-Ubuntu SMP Thu Oct 10 10:36:02 UTC 2019 GNU/Linux
 Distribution: 22 19.3
 Bitness: 64 bit


-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.17.10
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for 22 distro  19.3 version

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.17.10

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/hplip/HP
ppdbase=/usr/share/ppd/hplip
doc=/usr/share/doc/hplip
html=/usr/share/doc/hplip-doc
icon=no
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=yes
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=yes
foomatic-ppd-install=yes
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.17.10
restricted-build=no
ui-toolkit=qt5
qt3=no
qt4=no
qt5=yes
policy-kit=yes
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no


Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
[installation]
date_time = 07/30/20 17:26:20
version = 3.17.10


 <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>

-------------------------
| External Dependencies |
-------------------------

 error: cups          CUPS - Common Unix Printing System                           REQUIRED        1.1             -               INCOMPAT   'CUPS may not be installed or not running'
 gs                   GhostScript - PostScript and PDF language interpreter and previewer REQUIRED        7.05            9.26            OK         -
 error: xsane         xsane - Graphical scanner frontend for SANE                  OPTIONAL        0.9             -               MISSING    'xsane needs to be installed'
 scanimage            scanimage - Shell scanning program                           OPTIONAL        1.0             1.0.27          OK         -
 error: dbus          DBus - Message bus system                                    REQUIRED        -               1.12.2          MISSING    'DBUS may not be installed or not running'
 policykit            PolicyKit - Administrative policy framework                  OPTIONAL        -               0.105           OK         -
 network              network -wget                                                OPTIONAL        -               1.19.4          OK         -
 avahi-utils          avahi-utils                                                  OPTIONAL        -               0.7             OK         -

------------------------
| General Dependencies |
------------------------

 error: libjpeg       libjpeg - JPEG library                                       REQUIRED        -               -               MISSING    'libjpeg needs to be installed'
 error: cups-devel    CUPS devel- Common Unix Printing System development files    REQUIRED        -               -               MISSING    'cups-devel needs to be installed'
 error: cups-image    CUPS image - CUPS image development files                    REQUIRED        -               -               MISSING    'cups-image needs to be installed'
 libpthread           libpthread - POSIX threads library                           REQUIRED        -               b'2.27'         OK         -
 error: libusb        libusb - USB library                                         REQUIRED        -               1.0             MISSING    'libusb needs to be installed'
 sane                 SANE - Scanning library                                      REQUIRED        -               -               OK         -
 error: sane-devel    SANE - Scanning library development files                    REQUIRED        -               -               MISSING    'sane-devel needs to be installed'
 error: libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED        5.0.9           -               MISSING    'libnetsnmp-devel needs to be installed'
 error: libcrypto     libcrypto - OpenSSL cryptographic library                    REQUIRED        -               1.1.1           MISSING    'libcrypto needs to be installed'
 python3X             Python 2.2 or greater - Python programming language          REQUIRED        2.2             3.6.9           OK         -
 error: python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL        -               -               MISSING    'python3-notify2 needs to be installed'
 error: python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4                         OPTIONAL        4.0             -               MISSING    'python3-pyqt4-dbus needs to be installed'
 error: python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x)         REQUIRED        4.0             -               MISSING    'python3-pyqt4 needs to be installed'
 python3-dbus         Python DBus - Python bindings for DBus                       REQUIRED        0.80.0          1.2.6           OK         -
 python3-xml          Python XML libraries                                         REQUIRED        -               2.2.5           OK         -
 error: python3-devel Python devel - Python development files                      REQUIRED        2.2             3.6.9           MISSING    'python3-devel needs to be installed'
 python3-pil          PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL        -               1.1.7           OK         -
 python3-reportlab    Reportlab - PDF library for Python                           OPTIONAL        2.0             3.4.0           OK         -

--------------
| COMPILEDEP |
--------------

 error: libtool       libtool - Library building support services                  REQUIRED        -               -               MISSING    'libtool needs to be installed'
 error: gcc           gcc - GNU Project C and C++ Compiler                         REQUIRED        -               7.5.0           MISSING    'gcc needs to be installed'
 make                 make - GNU make utility to maintain groups of programs       REQUIRED        3.0             4.1             OK         -

---------------------
| Python Extentions |
---------------------

 cupsext              CUPS-Extension                                               REQUIRED        -               3.17.10         OK         -
 hpmudext             IO-Extension                                                 REQUIRED        -               3.17.10         OK         -

----------------------
| Scan Configuration |
----------------------

'/etc/sane.d/dll.d/hpaio' not found.
 hpaio                HPLIP-SANE-Backend                                           REQUIRED        -               3.17.10         OK         'hpaio found in /etc/sane.d/dll.conf'
 scanext              Scan-SANE-Extension                                          REQUIRED        -               3.17.10         OK         -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

No Scanner found.

--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 

--------------
| PERMISSION |
--------------

 
-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
error: 'libcups2' package is missing/incompatible vorh
error: 'libdbus-1-dev' package is missing/incompatible mn
error: 'libjpeg8-dev' package is missing/incompatible mn
error: 'libcups2-dev' package is missing/incompatible mn
error: 'cups-bsd' package is missing/incompatible vorh
error: 'cups-client' package is missing/incompatible vorh
error: 'libcupsimage2-dev' package is missing/incompatible mn
error: 'libusb-1.0.0-dev' package is missing/incompatible gibt es nicht
error: 'libsane-dev' package is missing/incompatible mn
error: 'libsnmp-dev' package is missing/incompatible mn
error: 'snmp-mibs-downloader' package is missing/incompatible mn
error: 'openssl' package is missing/incompatible vorh (oppenssl 1.0 zusätzlich geladen)
error: 'python3-pyqt4' package is missing/incompatible mn
error: 'python3-dev' package is missing/incompatible mn
error: 'libtool' package is missing/incompatible vorh
error: 'libtool-bin' package is missing/incompatible mn
error: 'build-essential' package is missing/incompatible mn

Missing Optional Dependencies
-----------------------------
error: 'xsane' package is missing/incompatible mn
error: 'python3-notify2' package is missing/incompatible mn
error: 'mate-notification-daemon' package is missing/incompatible vorh
error: 'python3-dbus.mainloop.qt' package is missing/incompatible mn

Total Errors: 16
Total Warnings: 0


Done.

nach der manuellen Korrektur

cb-e4300@cbe4300-Latitude-E4300:~$ hp-check -r
Saving output in log file: /home/cb-e4300/hp-check.log

HP Linux Imaging and Printing System (ver. 3.17.10)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the
HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
are installed to successfully compile HPLIP.                                   
2. Run-time check mode (-r or --run): Use this mode to determine if a distro   
supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball   
has the proper dependencies installed to successfully run.                     
3. Both compile- and run-time check mode (-b or --both) (Default): This mode   
will check both of the above cases (both compile- and run-time dependencies).   

Check types:                                                                   
a. EXTERNALDEP - External Dependencies                                         
b. GENERALDEP - General Dependencies (required both at compile and run time)   
c. COMPILEDEP - Compile time Dependencies                                       
d. [All are run-time checks]                                                   
PYEXT SCANCONF QUEUES PERMISSION                                               

Status Types:
    OK
    MISSING       - Missing Dependency or Permission or Plug-in
    INCOMPAT      - Incompatible dependency-version or Plugin-version

warning: 22-19.3 version is not supported. Using 22-18.2 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 5.0.0-32-generic #34~18.04.2-Ubuntu SMP Thu Oct 10 10:36:02 UTC 2019 GNU/Linux
 Host: cbe4300-Latitude-E4300
 Proc: 5.0.0-32-generic #34~18.04.2-Ubuntu SMP Thu Oct 10 10:36:02 UTC 2019 GNU/Linux
 Distribution: 22 19.3
 Bitness: 64 bit


-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.17.10
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for 22 distro  19.3 version

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.17.10

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/hplip/HP
ppdbase=/usr/share/ppd/hplip
doc=/usr/share/doc/hplip
html=/usr/share/doc/hplip-doc
icon=no
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=yes
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=yes
foomatic-ppd-install=yes
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.17.10
restricted-build=no
ui-toolkit=qt5
qt3=no
qt4=no
qt5=yes
policy-kit=yes
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no


Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
[installation]
date_time = 07/30/20 18:02:45
version = 3.17.10


 <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>

-------------------------
| External Dependencies |
-------------------------

 cups                 CUPS - Common Unix Printing System                           REQUIRED        1.1             2.2.7           OK         'CUPS Scheduler is running'
 gs                   GhostScript - PostScript and PDF language interpreter and previewer REQUIRED        7.05            9.26            OK         -
 xsane                xsane - Graphical scanner frontend for SANE                  OPTIONAL        0.9             0.999           OK         -
 scanimage            scanimage - Shell scanning program                           OPTIONAL        1.0             1.0.27          OK         -
 dbus                 DBus - Message bus system                                    REQUIRED        -               1.12.2          OK         -
 policykit            PolicyKit - Administrative policy framework                  OPTIONAL        -               0.105           OK         -
 network              network -wget                                                OPTIONAL        -               1.19.4          OK         -
 avahi-utils          avahi-utils                                                  OPTIONAL        -               0.7             OK         -

------------------------
| General Dependencies |
------------------------

 libjpeg              libjpeg - JPEG library                                       REQUIRED        -               -               OK         -
 cups-devel           CUPS devel- Common Unix Printing System development files    REQUIRED        -               2.2.7           OK         -
 cups-image           CUPS image - CUPS image development files                    REQUIRED        -               2.2.7           OK         -
 libpthread           libpthread - POSIX threads library                           REQUIRED        -               b'2.27'         OK         -
 error: libusb        libusb - USB library                                         REQUIRED        -               1.0             MISSING    'libusb needs to be installed'
 sane                 SANE - Scanning library                                      REQUIRED        -               -               OK         -
 sane-devel           SANE - Scanning library development files                    REQUIRED        -               -               OK         -
 libnetsnmp-devel     libnetsnmp-devel - SNMP networking library development files REQUIRED        5.0.9           5.7.3           OK         -
 libcrypto            libcrypto - OpenSSL cryptographic library                    REQUIRED        -               1.1.1           OK         -
 python3X             Python 2.2 or greater - Python programming language          REQUIRED        2.2             3.6.9           OK         -
 python3-notify2      Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL        -               -               OK         -
 python3-pyqt4-dbus   PyQt 4 DBus - DBus Support for PyQt4                         OPTIONAL        4.0             4.12.1          OK         -
 python3-pyqt4        PyQt 4- Qt interface for Python (for Qt version 4.x)         REQUIRED        4.0             4.12.1          OK         -
 python3-dbus         Python DBus - Python bindings for DBus                       REQUIRED        0.80.0          1.2.6           OK         -
 python3-xml          Python XML libraries                                         REQUIRED        -               2.2.5           OK         -
 python3-devel        Python devel - Python development files                      REQUIRED        2.2             3.6.9           OK         -
 python3-pil          PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL        -               1.1.7           OK         -
 python3-reportlab    Reportlab - PDF library for Python                           OPTIONAL        2.0             3.4.0           OK         -

--------------
| COMPILEDEP |
--------------

 libtool              libtool - Library building support services                  REQUIRED        -               2.4.6           OK         -
 gcc                  gcc - GNU Project C and C++ Compiler                         REQUIRED        -               7.5.0           OK         -
 make                 make - GNU make utility to maintain groups of programs       REQUIRED        3.0             4.1             OK         -

---------------------
| Python Extentions |
---------------------

 cupsext              CUPS-Extension                                               REQUIRED        -               3.17.10         OK         -
 hpmudext             IO-Extension                                                 REQUIRED        -               3.17.10         OK         -

----------------------
| Scan Configuration |
----------------------

'/etc/sane.d/dll.d/hpaio' not found.
 hpaio                HPLIP-SANE-Backend                                           REQUIRED        -               3.17.10         OK         'hpaio found in /etc/sane.d/dll.conf'
 scanext              Scan-SANE-Extension                                          REQUIRED        -               3.17.10         OK         -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

No Scanner found.

--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 

--------------
| PERMISSION |
--------------

 
-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
error: 'libusb-1.0.0-dev' package is missing/incompatible

Missing Optional Dependencies
-----------------------------
None


Total Errors: 1
Total Warnings: 0


Done.

Dieser Fehler lässt sich in den Foren bis in Vorgängerversionen zurückverfolgen. ist aber in 20.4 immer noch gegeben. Die einzige Erklärung ist das Teile von Hplip für andere Funktionen benutzt werden, was die Inkomplität begründen würde. Durch die Namensgleichheit entsteht so ein Wirrwar. Da aber auf Wundersame Weise Drucker und Scanner funktionieren, der Rest aber nicht fällt das kaum auf. Cups macht das schon. Schuld hat nun HP.

Bezeichned ist auch die Warnung durch HP-check in Linuxmint 19.3

warning: 22-19.3 version is not supported. Using 22-18.2 versions dependencies to verify and install...
unter Linuxmint das hplip 3.20.3 installiert lautet die dann:

warning: 22-20.4 version is not supported. Using 22-19.3 versions dependencies to verify and install...
All das kann doch kein zufall sein? Es deutet vielmehr auf eine Version in 19.3 von hp-lip 3.17.10 hin, die bearbeitet wurde und nicht mehr der entspricht die HP unter 3.17.10 zum download bereitstellt. Ansonsten wären das zuviele Fehler für einen Harwarehersteller. Was auch die Installtionprobleme bis hin zu Deinstallation erklären könnte. 

Verdammt das muss doch sauber zu lösen sein?
« Letzte Änderung: 30.07.2020, 23:08:56 von Alter Mann »

Re: HPLIP 3.17.10 unter Linuxmint Mate 19.3 nicht updatefähig?
« Antwort #6 am: 02.08.2020, 20:40:06 »
So jetzt versuch ichs zum vierten Mal, Irgendwie spinnt hier der Editor....

Hallo @Alter Mann,
hatten wir das HP-FAX Problem nicht schon mal im LM20 Cin. Upgrade Thread angesprochen?

Bei meinem HP Deskjet 980cxi funktioniert die FAX Funktion in Linux nicht weil sie laut Liste nicht unterstützt wird.

Hier nochmal die HPLIP Mindestanforderungen: https://developers.hp.com/hp-linux-imaging-and-printing/hp-linux-what-are-minimum-system-requirements
Zitat
HP-Linux: Was sind die Mindestsystemanforderungen?
Antworten:
Linux-Kernel 2.4.19 und höher (2.6.x empfohlen).
Zum Erstellen aus dem Quellcode sind GNU-Softwaretools erforderlich. Dies umfasst den ANSI C-Compiler, den ANSI C ++ - Compiler und die POSIX-kompatible Umgebung.
libusb 0.1.8 oder höher.
GPL Ghostscript  7.05 oder höher.
Foomatic  3.0.2 oder höher.
Qt  3.x oder höher für das UI-Toolkit.
PyQt  3.14 oder höher für Qt-Wrapper für Python.
Python  2.2 oder höher und Python-Devel (Python 2.3+ für Faxunterstützung)
Reportlab  (optional - bietet Unterstützung für Faxdeckblätter )
CUPS  1.1.15 oder höher und Cups-Entwicklung.
libjpeg 6b oder höher und libjpeg-devel.
net-snmp  5.0.9 oder höher und net-snmp-devel für die Netzwerkunterstützung.
CUPS DDK 1.2 oder höher für dynamische PPD-Unterstützung.

HPLIP wurde auf den meisten großen Linux-Distributionen getestet.
Laut HPLIP Seite wird aktuell die automatische Installation bis einschließlich LinuxMint 19.3 unterstützt:
Zitat
Vom automatischen Installationsprogramm unterstützte Linux-Distributionen:

SUSE Linux (13.2, 42.1, 42.2, 42.3.15.0.15.1)
Fedora (22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32)
Linux Mint (17, 17.1, 17.2, 17.3, 18, 18.1, 18.2, 18.3, 19, 19.1.19.2.19.3)
Red Hat Enterprise Linux (6.0, 7.0, 7.2.7.6.8.0.8.2)
Boss (5.0)
Ubuntu (12.04, 14.04, 15.10, 16.04, 16.10, 17.04, 17.10, 18.04.18.10.19.04.19.10)
Debian (7,0, 7,1, 7,2, 7,3, 7,4, 7,5, 7,6, 7,7, 7,8, 7,9, 8,0, 8,1, 8,2, 8,3, 8,4, 8,5, 8,6, 8,7, 8,8, 9,1, 9,2, 9,3, 9,4,9,5, 9,6,9,7,9,8,9,9,10,10,1,10,2,2,10,3)
Manjaro Linux (17.1.4.18.0.18.0.4.18.1.0.18.1.2.19.0.20.0)
Anweisungen zur Verwendung des automatischen Installationsprogramms .
Hilfe-Seite für die automatische Installation: https://developers.hp.com/es/hp-linux-imaging-and-printing/howtos/install

Eine manuelle Installation ist dort beschrieben: https://developers.hp.com/hp-linux-imaging-and-printing/install/manual/distros/linuxmint


Zum Vergleich, auf meinem LM20 Cin. wurde HPLIP-3.20.3 aus dem offiziellen Repository automatisch installiert nachdem ich den Drucker über USB ans Notebook anschloss.

Wenn ich hier mit hp-check -r prüfe erhalte ich sehr viele ähnlich lautende ERROR Meldungen wie in deinem Protokoll:
kuehhe1@HP470:~$ hp-check -r
Saving output in log file: /home/kuehhe1/hp-check.log

HP Linux Imaging and Printing System (ver. 3.20.3)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies are   
installed to successfully compile HPLIP.                                                                                                                               
2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball has the     
proper dependencies installed to successfully run.                                                                                                                     
3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above cases (both compile- and run-time dependencies).             

Check types:                                                                                                                                                           
a. EXTERNALDEP - External Dependencies                                                                                                                                 
b. GENERALDEP - General Dependencies (required both at compile and run time)                                                                                           
c. COMPILEDEP - Compile time Dependencies                                                                                                                               
d. [All are run-time checks]                                                                                                                                           
PYEXT SCANCONF QUEUES PERMISSION                                                                                                                                       

Status Types:
    OK
    MISSING       - Missing Dependency or Permission or Plug-in
    INCOMPAT      - Incompatible dependency-version or Plugin-version

warning: linuxmint-20 version is not supported. Using linuxmint-19.3 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 5.4.0-42-generic #46-Ubuntu SMP Fri Jul 10 00:24:02 UTC 2020 GNU/Linux
 Host: HP470
 Proc: 5.4.0-42-generic #46-Ubuntu SMP Fri Jul 10 00:24:02 UTC 2020 GNU/Linux
 Distribution: linuxmint 20
 Bitness: 64 bit


-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.20.3
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for linuxmint distro  20 version

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.20.3

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/hplip/HP
ppdbase=/usr/share/ppd/hplip
doc=/usr/share/doc/hplip
html=/usr/share/doc/hplip-doc
icon=no
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=yes
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.20.3
restricted-build=no
ui-toolkit=qt5
qt3=no
qt4=no
qt5=yes
policy-kit=yes
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no
class-driver=no


Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
[commands]
scan = /usr/bin/simple-scan %SANE_URI%

[fax]
email_address =
voice_phone =

[installation]
date_time = 08/02/20 18:10:04
version = 3.20.3

[last_used]
device_uri = "hp:/usb/DeskJet_980C?serial=ES166180H2OF"
printer_name = DESKJET-980C
working_dir = ('/mnt/Mint-Safe/Downloads

[polling]
device_list =
enable = false
interval = 5

[refresh]
enable = true
rate = 30
type = 1

[settings]
systray_messages = 2
systray_visible = 0

[upgrade]
last_upgraded_time = 1538987276
notify_upgrade = true
pending_upgrade_time = 0


 <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>

-------------------------
| External Dependencies |
-------------------------

 error: cups          CUPS - Common Unix Printing System                           REQUIRED        1.1             -               INCOMPAT   'CUPS may not be installed or not running'
 gs                   GhostScript - PostScript and PDF language interpreter and previewer REQUIRED        7.05            9.50            OK         -
 error: xsane         xsane - Graphical scanner frontend for SANE                  OPTIONAL        0.9             -               MISSING    'xsane needs to be installed'
 scanimage            scanimage - Shell scanning program                           OPTIONAL        1.0             1.0.29          OK         -
 error: dbus          DBus - Message bus system                                    REQUIRED        -               1.12.16         MISSING    'DBUS may not be installed or not running'
 policykit            PolicyKit - Administrative policy framework                  OPTIONAL        -               0.105           OK         -
 network              network -wget                                                OPTIONAL        -               1.20.3          OK         -
 avahi-utils          avahi-utils                                                  OPTIONAL        -               0.7             OK         -

------------------------
| General Dependencies |
------------------------

 error: libjpeg       libjpeg - JPEG library                                       REQUIRED        -               -               MISSING    'libjpeg needs to be installed'
 error: cups-devel    CUPS devel- Common Unix Printing System development files    REQUIRED        -               -               MISSING    'cups-devel needs to be installed'
 error: cups-image    CUPS image - CUPS image development files                    REQUIRED        -               -               MISSING    'cups-image needs to be installed'
 libpthread           libpthread - POSIX threads library                           REQUIRED        -               b'2.31'         OK         -
 error: libusb        libusb - USB library                                         REQUIRED        -               1.0             MISSING    'libusb needs to be installed'
 sane                 SANE - Scanning library                                      REQUIRED        -               -               OK         -
 error: sane-devel    SANE - Scanning library development files                    REQUIRED        -               -               MISSING    'sane-devel needs to be installed'
 error: libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED        5.0.9           -               MISSING    'libnetsnmp-devel needs to be installed'
 error: libcrypto     libcrypto - OpenSSL cryptographic library                    REQUIRED        -               1.1.1           MISSING    'libcrypto needs to be installed'
 python3X             Python 2.2 or greater - Python programming language          REQUIRED        2.2             3.8.2           OK         -
 error: python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL        -               -               MISSING    'python3-notify2 needs to be installed'
 error: python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4                         OPTIONAL        4.0             -               MISSING    'python3-pyqt4-dbus needs to be installed'
 error: python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x)         REQUIRED        4.0             -               MISSING    'python3-pyqt4 needs to be installed'
 python3-dbus         Python DBus - Python bindings for DBus                       REQUIRED        0.80.0          1.2.16          OK         -
 python3-xml          Python XML libraries                                         REQUIRED        -               2.2.9           OK         -
 error: python3-devel Python devel - Python development files                      REQUIRED        2.2             3.8.2           MISSING    'python3-devel needs to be installed'
 python3-pil          PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL        -               7.0.0           OK         -
 python3-reportlab    Reportlab - PDF library for Python                           OPTIONAL        2.0             3.5.34          OK         -

--------------
| COMPILEDEP |
--------------

 error: libtool       libtool - Library building support services                  REQUIRED        -               -               MISSING    'libtool needs to be installed'
 error: gcc           gcc - GNU Project C and C++ Compiler                         REQUIRED        -               9.3.0           MISSING    'gcc needs to be installed'
 make                 make - GNU make utility to maintain groups of programs       REQUIRED        3.0             4.2.1           OK         -

---------------------
| Python Extentions |
---------------------

 cupsext              CUPS-Extension                                               REQUIRED        -               3.20.3          OK         -
 hpmudext             IO-Extension                                                 REQUIRED        -               3.20.3          OK         -

----------------------
| Scan Configuration |
----------------------

'/etc/sane.d/dll.d/hpaio' not found.
 hpaio                HPLIP-SANE-Backend                                           REQUIRED        -               3.20.3          OK         'hpaio found in /etc/sane.d/dll.conf'
 scanext              Scan-SANE-Extension                                          REQUIRED        -               3.20.3          OK         -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

No Scanner found.

--------------------------
| DISCOVERED USB DEVICES |
--------------------------

  Device URI                                Model                           
  ----------------------------------------  ---------------------------------
  hp:/usb/DeskJet_980C?serial=ES166180H2OF  HP DeskJet 980C                 

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 
DESKJET-980C
------------
Type: Printer
Device URI: hp:/usb/DeskJet_980C?serial=ES166180H2OF
PPD: /etc/cups/ppd/DESKJET-980C.ppd
warning: Failed to read /etc/cups/ppd/DESKJET-980C.ppd ppd file
PPD Description:
Printer status: Drucker DESKJET-980C ist im Leerlauf.  Aktiviert seit Mo 06 Jul 2020 10:34:40 CEST
Communication status: Good


--------------
| PERMISSION |
--------------

USB             DESKJET-980C                   Required        -        -        OK       Node:'/dev/bus/usb/001/006' Perm:'  root  lp rw- rw- rw- rw- r--'
 
-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
error: 'libcups2' package is missing/incompatible
error: 'libdbus-1-dev' package is missing/incompatible
error: 'libjpeg8-dev' package is missing/incompatible
error: 'libcups2-dev' package is missing/incompatible
error: 'cups-bsd' package is missing/incompatible
error: 'cups-client' package is missing/incompatible
error: 'libcupsimage2-dev' package is missing/incompatible
error: 'libusb-1.0.0-dev' package is missing/incompatible
error: 'libsane-dev' package is missing/incompatible
error: 'python3-pyqt4' package is missing/incompatible
error: 'python3-dev' package is missing/incompatible
error: 'libtool' package is missing/incompatible
error: 'libtool-bin' package is missing/incompatible
error: 'build-essential' package is missing/incompatible

Missing Optional Dependencies
-----------------------------
error: 'xsane' package is missing/incompatible
error: 'python3-notify2' package is missing/incompatible
error: 'mate-notification-daemon' package is missing/incompatible
error: 'python3-dbus.mainloop.qt' package is missing/incompatible

Total Errors: 16
Total Warnings: 0

Done.
Dies deutet m.M.n. auf bestehende Versionskonflikte hin, auf die auch die HPLIP Support Seiten hinweisen.
Weitere Versionskonflikte ergeben sich mit Python, denn die (seinerzeitige) hplip Version geht von Python 2.2 und 2.7 aus während dessen mitlerweile Python 3 supportet aber Python3.8 installiert und verwendet wird: https://www.reportlab.com/documentation/relnotes/#whats-new-in-reportlab-30


Ich hab nun schon zum vierten mal versucht die Rückmeldung von: dpkg -l | grep python hier als Code einzufügen. Obwohl noch 33681 Zeichen übrig sind wird die korrekte Vorschau nicht so übernommen und mitten im [ code ] Codeblock abgeschnitten und der restliche Text gelöscht  :o
weiter in nächster Antwort..... >:(
« Letzte Änderung: 03.08.2020, 06:54:28 von kuehhe1 »

Re: HPLIP 3.17.10 unter Linuxmint Mate 19.3 nicht updatefähig?
« Antwort #7 am: 02.08.2020, 20:51:35 »
meine installierten python Pakete:kuehhe1@HP470:~$ dpkg -l | grep python
ii  libpython2-stdlib:amd64                       2.7.17-2ubuntu4                       amd64        interactive high-level object-oriented language (Python2)
ii  libpython2.7:amd64                            2.7.18~rc1-2                          amd64        Shared Python runtime library (version 2.7)
ii  libpython2.7-minimal:amd64                    2.7.18~rc1-2                          amd64        Minimal subset of the Python language (version 2.7)
ii  libpython2.7-stdlib:amd64                     2.7.18~rc1-2                          amd64        Interactive high-level object-oriented language (standard library, version 2.7)
ii  libpython3-stdlib:amd64                       3.8.2-0ubuntu2                        amd64        interactive high-level object-oriented language (default python3 version)
ii  libpython3.8:amd64                            3.8.2-1ubuntu1.2                      amd64        Shared Python runtime library (version 3.8)
ii  libpython3.8-minimal:amd64                    3.8.2-1ubuntu1.2                      amd64        Minimal subset of the Python language (version 3.8)
ii  libpython3.8-stdlib:amd64                     3.8.2-1ubuntu1.2                      amd64        Interactive high-level object-oriented language (standard library, version 3.8)
ii  python-apt                                    2.0.0ubuntu0.20.04.1                  amd64        Python interface to libapt-pkg
ii  python-apt-common                             2.0.0ubuntu0.20.04.1                  all          Python interface to libapt-pkg (locales)
ii  python-cairo:amd64                            1.16.2-2ubuntu2                       amd64        Python bindings for the Cairo vector graphics library
ii  python-crypto                                 2.6.1-13ubuntu2                       amd64        cryptographic algorithms and protocols for Python
ii  python-dbus                                   1.2.16-1build1                        amd64        simple interprocess messaging system (Python interface)
ii  python-gi                                     3.36.0-1                              amd64        Python 2.x bindings for gobject-introspection libraries
ii  python-gi-cairo                               3.36.0-1                              amd64        Python Cairo bindings for the GObject library
ii  python-gobject-2                              2.28.6-14ubuntu1                      amd64        deprecated static Python bindings for the GObject library
ii  python-lxml:amd64                             4.5.0-1                               amd64        pythonic binding for the libxml2 and libxslt libraries
ii  python-nemo                                   4.6.0+ulyana                          amd64        Python binding for Nemo components
ii  python-pip-whl                                20.0.2-5ubuntu1                       all          Python package installer
ii  python-psutil                                 5.5.1-1ubuntu4                        amd64        module providing convenience functions for managing processes
ii  python-setproctitle:amd64                     1.1.10-1ubuntu1                       amd64        Setproctitle implementation for Python 2
ii  python-six                                    1.14.0-2                              all          Python 2 and 3 compatibility library (Python 2 interface)
ii  python-tinycss2-common                        1.0.2-1                               all          Low-level CSS parser (test data)
ii  python-xdg                                    0.26-1ubuntu1                         all          Python 2 library to access freedesktop.org standards
ii  python-xlib                                   0.23-2build1                          all          interface for Python to the X11 protocol
ii  python2                                       2.7.17-2ubuntu4                       amd64        interactive high-level object-oriented language (Python2 version)
ii  python2-minimal                               2.7.17-2ubuntu4                       amd64        minimal subset of the Python2 language
ii  python2.7                                     2.7.18~rc1-2                          amd64        Interactive high-level object-oriented language (version 2.7)
ii  python2.7-minimal                             2.7.18~rc1-2                          amd64        Minimal subset of the Python language (version 2.7)
ii  python3                                       3.8.2-0ubuntu2                        amd64        interactive high-level object-oriented language (default python3 version)
ii  python3-apport                                2.20.11-0ubuntu27.4                   all          Python 3 library for Apport crash report handling
ii  python3-apt                                   2.0.0ubuntu0.20.04.1                  amd64        Python 3 interface to libapt-pkg
ii  python3-aptdaemon                             1.1.1+bzr982-0ubuntu32.1              all          Python 3 module for the server and client of aptdaemon
ii  python3-aptdaemon.gtk3widgets                 1.1.1+bzr982-0ubuntu32.1              all          Python 3 GTK+ 3 widgets to run an aptdaemon client
ii  python3-blinker                               1.4+dfsg1-0.3ubuntu1                  all          fast, simple object-to-object and broadcast signaling library
ii  python3-brlapi:amd64                          6.0+dfsg-4ubuntu6                     amd64        Braille display access via BRLTTY - Python3 bindings
ii  python3-bs4                                   4.8.2-1                               all          error-tolerant HTML parser for Python 3
ii  python3-cachetools                            4.0.0-1                               all          extensible memoizing collections and decorators for Python 3
ii  python3-cairo:amd64                           1.16.2-2ubuntu2                       amd64        Python3 bindings for the Cairo vector graphics library
ii  python3-certifi                               2019.11.28-1                          all          root certificates for validating SSL certs and verifying TLS hosts (python3)
ii  python3-cffi-backend                          1.14.0-1build1                        amd64        Foreign Function Interface for Python 3 calling C code - runtime
ii  python3-chardet                               3.0.4-4build1                         all          universal character encoding detector for Python3
ii  python3-click                                 7.0-3                                 all          Wrapper around optparse for command line utilities - Python 3.x
ii  python3-colorama                              0.4.3-1build1                         all          Cross-platform colored terminal text in Python - Python 3.x
ii  python3-commandnotfound                       20.04.2                               all          Python 3 bindings for command-not-found.
ii  python3-configobj                             5.0.6-4                               all          simple but powerful config file reader and writer for Python 3
ii  python3-crypto                                2.6.1-13ubuntu2                       amd64        cryptographic algorithms and protocols for Python 3
ii  python3-cryptography                          2.8-3                                 amd64        Python library exposing cryptographic recipes and primitives (Python 3)
ii  python3-cups                                  1.9.73-3build1                        amd64        Python3 bindings for CUPS
ii  python3-cupshelpers                           1.5.12-0ubuntu1                       all          Python utility modules around the CUPS printing system
ii  python3-dateutil                              2.7.3-3ubuntu1                        all          powerful extensions to the standard Python 3 datetime module
ii  python3-dbus                                  1.2.16-1build1                        amd64        simple interprocess messaging system (Python 3 interface)
ii  python3-dbus.mainloop.pyqt5                   5.14.1+dfsg-3build1                   amd64        D-Bus Qt main loop support for Python 3
ii  python3-debconf                               1.5.73                                all          interact with debconf from Python 3
ii  python3-debian                                0.1.36ubuntu1                         all          Python 3 modules to work with Debian-related data formats
ii  python3-defer                                 1.0.6-2.1                             all          Small framework for asynchronous programming (Python 3)
ii  python3-distro                                1.4.0-1                               all          Linux OS platform information API
ii  python3-distro-info                           0.23ubuntu1                           all          information about distributions' releases (Python 3 module)
ii  python3-distupgrade                           1:20.04.23                            all          manage release upgrades
ii  python3-distutils                             3.8.2-1ubuntu1                        all          distutils package for Python 3.x
ii  python3-dnspython                             1.16.0-1build1                        all          DNS toolkit for Python 3
ii  python3-entrypoints                           0.3-2ubuntu1                          all          Discover and load entry points from installed packages (Python 3)
ii  python3-fasteners                             0.14.1-2                              all          provides useful locks - Python 3.x
ii  python3-future                                0.18.2-2                              all          Clean single-source support for Python 3 and 2 - Python 3.x
ii  python3-gdbm:amd64                            3.8.2-1ubuntu1                        amd64        GNU dbm database support for Python 3.x
ii  python3-gi                                    3.36.0-1                              amd64        Python 3 bindings for gobject-introspection libraries
ii  python3-gi-cairo                              3.36.0-1                              amd64        Python 3 Cairo bindings for the GObject library
ii  python3-google-auth                           1.5.1-2                               all          Google Authentication Library - Python 3.x
ii  python3-google-auth-httplib2                  0.0.3-2                               all          Google Authentication Library: httplib2 transport
ii  python3-googleapi                             1.7.11-3                              all          Google APIs Client Library - Python 3.x
ii  python3-grpcio                                1.16.1-1ubuntu5                       amd64        GRPC system (Python 3)
ii  python3-httplib2                              0.14.0-1ubuntu1                       all          comprehensive HTTP client library written for Python3
ii  python3-icu                                   2.4.2-0ubuntu3                        amd64        Python 3 extension wrapping the ICU C++ API
ii  python3-idna                                  2.8-1                                 all          Python IDNA2008 (RFC 5891) handling (Python 3)
ii  python3-ifaddr                                0.1.6-1                               all          Pure Python implementation for detecting IP addresses
ii  python3-jwt                                   1.7.1-2ubuntu2                        all          Python 3 implementation of JSON Web Token
ii  python3-keyring                               18.0.1-2ubuntu1                       all          store and access your passwords safely - Python 3 version of the package
ii  python3-launchpadlib                          1.10.13-1                             all          Launchpad web services client library (Python 3)
ii  python3-lazr.restfulclient                    0.14.2-2build1                        all          client for lazr.restful-based web services (Python 3)
ii  python3-lazr.uri                              1.0.3-4build1                         all          library for parsing, manipulating, and generating URIs
ii  python3-ldb                                   2:2.0.10-0ubuntu0.20.04.1             amd64        Python 3 bindings for LDB
ii  python3-lib2to3                               3.8.2-1ubuntu1                        all          Interactive high-level object-oriented language (lib2to3)
ii  python3-louis                                 3.12.0-3                              all          Python bindings for liblouis
ii  python3-lxml:amd64                            4.5.0-1                               amd64        pythonic binding for the libxml2 and libxslt libraries
ii  python3-macaroonbakery                        1.3.1-1                               all          Higher-level macaroon operations for Python 3
ii  python3-mako                                  1.1.0+ds1-1ubuntu2                    all          fast and lightweight templating for the Python 3 platform
ii  python3-markupsafe                            1.1.0-1build2                         amd64        HTML/XHTML/XML string library for Python 3
ii  python3-minimal                               3.8.2-0ubuntu2                        amd64        minimal subset of the Python language (default python3 version)
ii  python3-monotonic                             1.5-0ubuntu2                          all          implementation of time.monotonic() - Python 3.x
ii  python3-nacl                                  1.3.0-5                               amd64        Python bindings to libsodium (Python 3)
ii  python3-netifaces                             0.10.4-1ubuntu4                       amd64        portable network interface information - Python 3.x
ii  python3-nose                                  1.3.7-5                               all          test discovery and running for Python3 unittest
ii  python3-oauth2client                          4.1.2-5                               all          OAuth 2.0 client library - Python 3.x
ii  python3-oauthlib                              3.1.0-1ubuntu2                        all          generic, spec-compliant implementation of OAuth for Python3
ii  python3-openssl                               19.0.0-1build1                        all          Python 3 wrapper around the OpenSSL library
ii  python3-pam                                   0.4.2-13.2ubuntu8                     amd64        Python interface to the PAM library
ii  python3-parsedatetime                         2.4-5                                 all          Python 3 module to parse human-readable date/time expressions
ii  python3-parted                                3.11.2-11.1build1                     amd64        Python 3 interface for libparted
ii  python3-pexpect                               4.6.0-1build1                         all          Python 3 module for automating interactive applications
ii  python3-pikepdf                               1.10.3+dfsg-1                         amd64        Python library to read and write PDFs with QPDF
ii  python3-pil:amd64                             7.0.0-4ubuntu0.1                      amd64        Python Imaging Library (Python3)
ii  python3-pip                                   20.0.2-5ubuntu1                       all          Python package installer
ii  python3-pkg-resources                         45.2.0-1                              all          Package Discovery and Resource Access using pkg_resources
ii  python3-problem-report                        2.20.11-0ubuntu27.4                   all          Python 3 library to handle problem reports
ii  python3-protobuf                              3.6.1.3-2ubuntu5                      amd64        Python 3 bindings for protocol buffers
ii  python3-psutil                                5.5.1-1ubuntu4                        amd64        module providing convenience functions for managing processes (Python3)
ii  python3-ptyprocess                            0.6.0-1ubuntu1                        all          Run a subprocess in a pseudo terminal from Python 3
ii  python3-pyasn1                                0.4.2-3build1                         all          ASN.1 library for Python (Python 3 module)
ii  python3-pyasn1-modules                        0.2.1-0.2build1                       all          Collection of protocols modules written in ASN.1 language (Python 3)
ii  python3-pyatspi                               2.36.0-1                              all          Assistive Technology Service Provider Interface - Python3 bindings
ii  python3-pycurl                                7.43.0.2-1ubuntu5                     amd64        Python bindings to libcurl (Python 3)
ii  python3-pyinotify                             0.9.6-1.2ubuntu1                      all          simple Linux inotify Python bindings
ii  python3-pymacaroons                           0.13.0-3                              all          Macaroon library for Python 3
ii  python3-pyqt5                                 5.14.1+dfsg-3build1                   amd64        Python 3 bindings for Qt5
ii  python3-reportlab                             3.5.34-1ubuntu1                       all          ReportLab library to create PDF documents using Python3
ii  python3-reportlab-accel:amd64                 3.5.34-1ubuntu1                       amd64        C coded extension accelerator for the ReportLab Toolkit
ii  python3-requests                              2.22.0-2ubuntu1                       all          elegant and simple HTTP library for Python3, built for human beings
ii  python3-requests-unixsocket                   0.2.0-2                               all          Use requests to talk HTTP via a UNIX domain socket - Python 3.x
ii  python3-rfc3339                               1.1-2                                 all          parser and generator of RFC 3339-compliant timestamps (Python 3)
ii  python3-rsa                                   4.0-3                                 all          Pure-Python RSA implementation (Python 3)
ii  python3-samba                                 2:4.11.6+dfsg-0ubuntu1.3              amd64        Python 3 bindings for Samba
ii  python3-secretstorage                         2.3.1-2ubuntu1                        all          Python module for storing secrets - Python 3.x version
ii  python3-setproctitle:amd64                    1.1.10-1ubuntu1                       amd64        Setproctitle implementation for Python 3
ii  python3-setuptools                            45.2.0-1                              all          Python3 Distutils Enhancements
ii  python3-simplejson                            3.16.0-2ubuntu2                       amd64        simple, fast, extensible JSON encoder/decoder for Python 3.x
ii  python3-sip                                   4.19.21+dfsg-1build1                  amd64        Python 3/C++ bindings generator runtime library
ii  python3-six                                   1.14.0-2                              all          Python 2 and 3 compatibility library (Python 3 interface)
ii  python3-soupsieve                             1.9.5+dfsg-1                          all          modern CSS selector implementation for BeautifulSoup (Python 3)
ii  python3-speechd                               0.9.1-4                               all          Python interface to Speech Dispatcher
ii  python3-sqlalchemy                            1.3.12+ds1-1ubuntu2                   all          SQL toolkit and Object Relational Mapper for Python 3
ii  python3-systemd                               234-3build2                           amd64        Python 3 bindings for systemd
ii  python3-talloc:amd64                          2.3.0-3ubuntu1                        amd64        hierarchical pool based memory allocator - Python3 bindings
ii  python3-tdb                                   1.4.2-3build1                         amd64        Python3 bindings for TDB
ii  python3-tinycss2                              1.0.2-1                               all          Low-level CSS parser (Python3 version)
ii  python3-tz                                    2019.3-1                              all          Python3 version of the Olson timezone database
ii  python3-unidecode                             1.1.1-3build1                         all          ASCII transliterations of Unicode text (Python 3 module)
ii  python3-uno                                   1:6.4.4-0ubuntu0.20.04.1              amd64        Python-UNO bridge
ii  python3-update-manager                        1:20.04.10.1                          all          python 3.x module for update-manager
ii  python3-uritemplate                           0.6-4                                 all          implementation of RFC6570 - Python 3.x
ii  python3-urllib3                               1.25.8-2                              all          HTTP library with thread-safe connection pooling for Python3
ii  python3-wadllib                               1.3.3-3build1                         all          Python 3 library for navigating WADL files
ii  python3-webencodings                          0.5.1-1ubuntu1                        all          Python implementation of the WHATWG Encoding standard
ii  python3-wheel                                 0.34.2-1                              all          built-package format for Python
ii  python3-xapp                                  2.0.1                                 all          Python 3 XApp library
ii  python3-xdg                                   0.26-1ubuntu1                         all          Python 3 library to access freedesktop.org standards
ii  python3-xkit                                  0.5.0ubuntu4                          all          library for the manipulation of xorg.conf files (Python 3)
ii  python3-xlib                                  0.23-2build1                          all          interface for Python 3 to the X11 protocol
ii  python3-yaml                                  5.3.1-1                               amd64        YAML parser and emitter for Python3
ii  python3-zeroconf                              0.24.4-0ubuntu1                       all          Pure Python implementation of multicast DNS service discovery (Python3)
ii  python3.8                                     3.8.2-1ubuntu1.2                      amd64        Interactive high-level object-oriented language (version 3.8)
ii  python3.8-minimal                             3.8.2-1ubuntu1.2                      amd64        Minimal subset of the Python language (version 3.8)
kuehhe1@HP470:~$

Bevor ich mir jetzt mein funktionierendes System nur wegen einer FAX-Funktion verbiegen würde neige ich aber eher dazu etwas Gegebenes zu nutzen.

Off-Topic:
Genau wegen dieser HP-FAX Problematik hatte ich für mich eine andere Lösung vorgezogen.
Ich hab eine FAX-Telefonnummer bei T-Online, über das Webinterface kann ich FAX auch mit Anhängen Senden und Empfangen. Ein eingehendes FAX wird ins Email-Postfach weitergeleitet, der FAX-Empfang in Thunderbird als Email funktioniert. Nur das Senden an eine FAX-Telefonnummer wird in TB nicht unterstützt, kann also auch nicht direkt beantwortet werden, dass mach ich dann per T-Online Web-Interface.
Soll jetzt keine Werbung sein, geht nur ums Prinzip:
https://www.telekom.de/hilfe/festnetz-internet-tv/produkte/homepages-und-shops/e-mail-funktionen-bei-homepage-produkten/pc-fax-fuer-homepage-postfaecher?samChecked=true

Wie wäre es wenn auch du dir bei deinem Provider eine FAX-Telefonnummer zuteilen lässt?
« Letzte Änderung: 07.08.2020, 09:36:31 von kuehhe1 »