Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
01.10.2020, 07:03:23

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24584
  • Letzte: klaatu2
Statistiken
  • Beiträge insgesamt: 685701
  • Themen insgesamt: 55504
  • Heute online: 492
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 4
Gäste: 314
Gesamt: 318

Autor Thema:  LM20C: Umschaltung des Audio Ausgabegerätes funktioniert nicht richtig  (Gelesen 668 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo Leute!

Es steckt an der Front-Audioschnittstelle meines Rechners immer ein Kopfhörer. Außerdem steckt hinten noch eine Soundanlage mit zwei Lautsprechern und Subwoofer. Leider funktioniert das Umschalten des Audio Ausgabegerätes unter Linux nicht richtig. Wenn der Ton über den Kopfhörer läuft, was automatisch passiert sobald er eingesteckt wird, kann ich zwar, wie im Screenshot ersichtlich, auf den Line-Ausgang, also die Soundanlage umschalten, aber wenn ich das mache, erhalte ich überhaupt keinen Ton mehr, weder über die Kopfhörer, noch über die Anlage. Wenn ich die Kopfhörer aber wieder abstecke, kommt der Ton sofort ganz normal über die Anlage.

Was läuft hier schief? Handelt es sich hier um einen Bug? Was passiert bei euch, wenn ihr Kopfhörer ansteckt? Aber vor allem: Wie kann ich das Problem lösen?

Grüße,
Athlan

Mich würd wirklich interessieren, ob jemand das Problem reproduzieren kann.

Hi Leute!

Wie sieht es aus? Kennt ihr dieses Problem auch? Eigentlich müsste man über den Schalter im Menü doch problemlos das Ausgabegerät umschalten können, oder nicht? Nochmals:

Fall 1: Keine Kopfhörer eiingesteckt --> Ton kommt über die Soundanlage.
Fall 2: KH eingesteckt --> Output wird automatisch auf die Kopfhörer umgeschaltet und der Ton kommt auch aus den KH. Problem: Umschaltung auf die Soundanlage funktioniert nicht. Wenn der Line-Ausgang gewählt ist (die Anlage) kommt überhaupt kein Ton, weder aus den Lautsprechern, noch aus den Kopfhörern.

Ich frage mich nun, wie ich dieses Problem beheben kann, dh. wie schaffe ichs, dass der Ton in Fall 2 bei gewähltem Line-Ausgang über die Anlage kommt und bei gewählten Kopfhörern über eben diese?

Hat denn keiner eine Idee?

Liebe Grüße,
Athlan

Das mit der mangelnden Idee wird vermutlich daran liegen, dass für viele dein "Problem" kein Problem darstellt, sondern eher einen völlig normalen Vorgang. Genau das, was du schilderst, erwarte ich, wenn ich den Kopfhörer anschließe, nämlich die Unterbrechung der Wiedergabe über die Boxen.

Wie es heute ausgelöst wird, kann ich nicht sagen, vielleicht softwareseitig so etwas wie eine "Frontanschlusserkennung". Früher wurde das manuell geregelt, indem durch das Einstecken des Klinkensteckers ein Kontakt in der Buchse und damit auch die externe Übertragung unterbrochen wurde.

Du könntest es an der hinteren Buchse versuchen (Frontbuchse deaktivieren) und, wenn es da auch nicht funktioniert, mit einer billigen zweiten Soundkarte. Ob die gleichzeitig angesteuert werden können? Keine Ahnung.
Eine weitere Möglichkeit wäre ein Splitter, den gibts als Kabel oder Stecker. Allerdings würde da eine eigene Lautstärkeregelung der jeweiligen Geräte Sinn machen.

Es steckt an der Front-Audioschnittstelle meines Rechners immer ein Kopfhörer. Außerdem steckt hinten noch eine Soundanlage mit zwei Lautsprechern und Subwoofer. Leider funktioniert das Umschalten des Audio Ausgabegerätes unter Linux nicht richtig.
Muss dabei nicht auf das passende Ausgabegerät von Stereo auf 2.1 wegen des Subwoofers umgestellt werden??

Kontrolle in Menü > Einstellungen: Klang oder im Terminal mit: alsamixer
Eventuell bietet pavucontol (PulseAudio-Lautstärkeregler), das Paket muss wahrscheinlich erst installiert werden

Ich kann das hier nicht nachstellen hab nur Stereo.
« Letzte Änderung: 04.08.2020, 11:14:25 von kuehhe1 »

Das mit der mangelnden Idee wird vermutlich daran liegen, dass für viele dein "Problem" kein Problem darstellt, sondern eher einen völlig normalen Vorgang. Genau das, was du schilderst, erwarte ich, wenn ich den Kopfhörer anschließe, nämlich die Unterbrechung der Wiedergabe über die Boxen.

Ja, dieses Verhalten erwarte ich auch. Wenn Kopfhörer angesteckt werden, soll der Ton auch nur über die Kopfhörer kommen. Das Problem ist vielmehr, dass ich nicht jedesmal die Kopfhörer abstecken will, nur damit der Ton wieder über die Boxen kommt. Ich möchte die Kopfhörer angesteckt lassen und bei Bedarf einfach umschalten können, wie es im oben angehängten Screenshot dargestellt ist. Je nachdem, ob Line-In, oder die Kopfhörer gewählt sind, soll der Ton aus der Anlage, oder eben den Kopfhörern kommen. Das wäre das von mir erwartete normale Verhalten. Wieso sonst gibt es denn überhaupt die Option zum Umschalten?

Muss dabei nicht auf das passende Ausgabegerät von Stereo auf 2.1 wegen des Subwoofers umgestellt werden??

Kontrolle in Menü > Einstellungen: Klang oder im Terminal mit: alsamixer
Eventuell bietet pavucontol (PulseAudio-Lautstärkeregler), das Paket muss wahrscheinlich erst installiert werden

Ich kann das hier nicht nachstellen hab nur Stereo.

Ja, genau, und exakt diese Umstellung funktioniert nicht; das ist das Problem, das ich habe. Wenn die Kopfhörer eingesteckt sind und ich auf das Ausgabegerät für die Anlage umstelle, kommt kein Ton, obwohl eigentlich über die Anlage Ton kommen sollte. Die einzige Möglichkeit, wieder Ton über die Anlage zu erhalten ist, die Kopfhörer abzustecken, wodurch aber natürlich auch keine Umstellung bzw. Umschaltung mehr nötig ist.

Ergo: Die Umschaltung funktioniert nicht, wie sie soll. Ich kann zwar die Audiogeräte über die GUI auswählen, aber, wie gesagt: bei eingesteckten Kopfhörern kommt über die Anlage, wenn diese explizit ausgewählt ist, kein Ton.

Ich kann zwar die Audiogeräte über die GUI auswählen, aber, wie gesagt: bei eingesteckten Kopfhörern kommt über die Anlage, wenn diese explizit ausgewählt ist, kein Ton.
Ich meine das Verhalten ist so völlig korrekt,
Kopfhörer Angesteckt=Wiedergabe über Kopfhörer=Anlage-Aus
Kopfhörer Abgesteckt=Wiedergabe über Anlage

Kontrolle in Menü > Einstellungen: Klang oder im Terminal mit: alsamixer
Eventuell bietet pavucontrol (PulseAudio-Lautstärkeregler), das Paket muss wahrscheinlich erst installiert werden
wurden die drei Varianten zur Einstellung der Geräte getestet?

Also...
Einstellungen: Klang
Terminal: alsamixer  (ist in alsamixer ein Ausgang heruntergezogen (Aus), bitte Rückmeldung als Codeblock oder Screenshot zeigen)
Einstellungen: PulseAudio-Lautstärkeregler, (Paket: pavucontrol installiert?)

Mehr weis ich auch nicht, kanns leider am Notebook nicht nachstellen.
« Letzte Änderung: 04.08.2020, 21:20:20 von kuehhe1 »

Hi, danke für die Antwort :)

Zitat
Ich meine das Verhalten ist so völlig korrekt,
Kopfhörer Angesteckt=Wiedergabe über Kopfhörer=Anlage-Aus
Kopfhörer Abgesteckt=Wiedergabe über Anlage

Schau mal, im Grunde stimmt schon, was du sagst, aber mein Punkt ist folgender: selbst wenn die Kopfhörer angesteckt sind, habe ich immer noch die Möglichkeit, über die GUI (Einstelltungen --> Klang bzw. unten in der Taskleiste wie am Screenshot oben) das Ausgabegerät zu wechseln. Da es diese Möglichkeit gibt, würde ich von korrektem Verhalten genau dann sprechen, wenn die Audioausgabe der Einstellung folgt, die ich in der GUI vornehme. Das heißt, wenn Kopfhörer eingesteckt sind, aber die Lautsprecher ausgewählt, müssten die Kopfhörer stumm sein und die Lautsprecher den Ton wiedergeben. Der Sinn des Ganzen ist der, nicht dauernd aus- und einstecken zu müssen, sondern gleich alles fix verkabelt zu lassen und einfach nach Bedarf umzuschalten.

Zitat
wurden die drei Varianten zur Einstellung der Geräte getestet?

Also...
Einstellungen: Klang
Terminal: alsamixer  (ist in alsamixer ein Ausgang heruntergezogen (Aus), bitte Rückmeldung als Codeblock oder Screenshot zeigen)
Einstellungen: PulseAudio-Lautstärkeregler, (Paket: pavucontrol installiert?)

Ja, ich hab alle drei Varianten getestet. Pavucontrol ist installiert und man kann damit auch das Ausgabegerät wechseln, aber wie auch über Einstellungen --> Klang, oder die Taskleiste besteht mein Problem weiter, dh. bei eingesteckten Kopfhörern und ausgewählten Lautsprechern bleiben die Lautsprecher stumm.

Hier die Ausgabe von alsamixer. Ich hab alle Regler bis auf "Mic" hochgezogen. Keine Veränderung:
┌────────────────────────────── AlsaMixer v1.2.2 ──────────────────────────────┐
│   Gerät: HDA Intel PCH                             F1:  Hilfe                │
│    Chip: Realtek ALC892                            F2:  System-Informationen │
│ Ansicht: F3:[Wiedergabe] F4: Aufnahme  F5: Alle    F6:  Klangkarte auswählen │
│ Element: Front Mic [dB-Änderung: -30,00; -30,00]   Esc: Beenden              │
│                                                                              │
│     ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐     ┌──┐      │
│     │  │     │▒▒│     │▒▒│     │▒▒│     │  │     │  │     │  │     │  │      │
│     │  │     │▒▒│     │▒▒│     │▒▒│     │  │     │  │     │  │     │  │      │
│     │  │     │▒▒│     │▒▒│     │▒▒│     │  │     │  │     │  │     │  │      →
│     │  │     │▒▒│     │▒▒│     │▒▒│     │  │     │  │     │  │     │  │      →
│     │  │     │▒▒│     │▒▒│     │▒▒│     │  │     │  │     │  │     │  │      →
│     │  │     │▒▒│     │▒▒│     │▒▒│     │  │     │  │     │  │     │  │      →
│     │  │     │▒▒│     │▒▒│     │▒▒│     │  │     │  │     │  │     │  │      →
│     │  │     │▒▒│     │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │  │      →
│     │▒▒│     │▒▒│     │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      →
│     │▒▒│     │▒▒│     │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      │
│     │▒▒│     │▒▒│     │▒▒│     │▒▒│     │  │     │  │     │▒▒│     │▒▒│      │
│     ├──┤     ├──┤     └──┘     ├──┤     ├──┤     └──┘     ├──┤     ├──┤      │
│     │OO│     │OO│              │OO│     │MM│              │MM│     │MM│      │
│     └──┘     └──┘              └──┘     └──┘              └──┘     └──┘      │
│      27    100<>100 100<>100 100<>100   4<>4     0<>0    36<>36     27       │
│    Master  Headphon   PCM     Front  <Front Mi>Front Mi Surround  Center     │
└──────────────────────────────────────────────────────────────────────────────┘

Zitat
Mehr weiß ich auch nicht, kanns leider am Notebook nicht nachstellen.

Müsstest du egtl schon können. Schau mal, auf welches Ausgabegerät dein Notebook standardmäßig eingestellt ist, stecke Kopfhörer ein, schalte auf das standardmäßige Ausgabegerät zurück und prüfe, ob der Ton über die Laptoplautsprecher kommt. Wenn ja, funktioniert die Umschaltung bei dir.

Grüße,
Athlan
« Letzte Änderung: 05.08.2020, 11:54:39 von Athlan »

Da es diese Möglichkeit gibt, würde ich von korrektem Verhalten genau dann sprechen, wenn die Audioausgabe der Einstellung folgt, die ich in der GUI vornehme.
Hier wird, sobald der Kopfhörer angeschlossen wird, der Line-Ausgang auf "unplugged" gesetzt und lässt sich somit auch gar nicht mehr einschalten (pavucontrol), oder aber, unter "Klang" (cinnamon-settings sound controls), wird umgeschaltet von Kopfhörer auf Line-Ausgang und wieder zurück. Der jeweils andere lässt sich somit gar nicht auswählen. Auch beim Applet taucht das "Eingebaute Tongerät Analog Stereo" nicht mehr auf.

Es ist merkwürdig, dass bei dir der Line-Ausgang noch auszuwählen ist. Normal scheint das aber nicht zu sein. 

Seltsam, aber zumindest erklärt das die Verwirrung. Das heißt, das Linux die Umschaltung gar nicht kann und der Fehler darin besteht, dass der Line-Ausgang nicht ausgeblendet wird. Unter Win10 funktioniert die Umschaltung so, wie von mir erwartet.

Gibts eine Möglichkeit, Linux die Umschaltung beizubringen?

Hallo, versuche es bitte mal damit:

sudo apt-get install qasmixer
und unter Absicht "Geräteauswahl Anzeigen" anklicken.
--------------------------

Wenn es nicht hinhaut zweite Soundkarte einbauen.



Hallo, versuche es bitte mal damit:

sudo apt-get install qasmixer
und unter Absicht "Geräteauswahl Anzeigen" anklicken.


Interessant. Hier kann ich zusehen, wie sich die Regler verschieben, je nachdem, ob der Kopfhörer, oder die Anlage in den bekannten Menüs als Ausgabegerät gewählt werden. Der Kopfhörer wird korrekterweise runtergedreht, wenn ich die Anlage auswähle und "Umgebung", "Mitte" und "LIFE" werden hochgedreht. Trotzdem kommt kein Sound aus den Boxen. Ich höre erst etwas, wenn ich den Auto-Stumm-Modus deaktiviere. Das führt aber dazu, dass, wenn ich als Ausgabegerät wieder die Kopfhörer wähle, Sound aus beiden Endgeräten kommt. Also:

Kopfhörer sind immer eingesteckt.
Fall1: Anlage gewählt + Auto-Stumm an:  Kein Sound
Fall2: Anlage gewählt + Auto-Stumm aus: Sound kommt aus der Anlage wie gewünscht
Fall3: Kopfhörer gewählt + Auto-Stumm an: Sound über Kopfhörer wie gewünscht
Fall4: Kopfhörer gewählt + Auto-Stumm aus: Sound über beide Endgeräte

Ich denke mir, das man das System so modifizieren müsste, dass bei eingesteckten Kopfhörern je nach Auswahl automatisch immer Fall2 und Fall3 eintreten, dass also der Auto-Stumm Modus bei Klick auf das auszuwählende Endgerät automatisch entsprechend eingestellt wird.

Ist das machbar?

Grüße,
Athlan

Evtl. hilft dir dieser Link weiter.
https://wiki.archlinux.org/index.php/PulseAudio/Examples#Having_both_speakers_and_headphones_plugged_in_and_switching_in_software_on-the-fly

Ich möchte die Anleitung befolgen, aber ich hänge gleich beim ersten Schritt. Ich habe keinen Abschnitt in meiner Datei, der [Jack Headphone] heißt. Soll ich ihn einfach einfügen?

Hier mal meine /usr/share/pulseaudio/alsa-mixer/paths/analog-output-lineout.conf:
  GNU nano 4.8                                                                                  /usr/share/pulseaudio/alsa-mixer/paths/analog-output-lineout.conf                                                                                             

[Jack Dock Line Out Phantom]
state.plugged = unknown
state.unplugged = unknown
required-any = any

[Element Hardware Master]
switch = mute
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

[Element Master]
switch = mute
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right

[Element Speaker+LO]
switch = mute
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right
required-any = any

[Element Headphone+LO]
switch = mute
volume = merge
override-map.1 = all
override-map.2 = all-left,all-right
required-any = any

[Element Master Mono]
switch = off
volume = off

[Element Line HP Swap]
switch = off
required-any = any

; This profile path is intended to control line out, let's mute headphones
; else there will be a spike when plugging in headphones
[Element Headphone]
switch = off
volume = off

[Element Headphone2]
switch = off
volume = off

[Element Speaker]
switch = off
volume = off

[Element Desktop Speaker]
switch = off
volume = off


^G Hilfe          ^O Speichern      ^W Wo ist         ^K Ausschneiden   ^J Ausrichten     ^C Textmarke      M-U Rückgängig    M-A Text markierenM-] Zu Klammer    M-Q Vorige        ^B Zurück         ^◀ Vorheriges Wort^A Pos 1          ^P Zeile zurück
^X Beenden        ^R Datei öffnen   ^\ Ersetzen       ^U Text einfügen  ^T Rechtschr.     ^_ Zu Zeile gehen M-E Wiederholen   M-6 Kopieren      ^Q Wo war         M-W Nächste       ^F Vorwärts       ^▶ Nächstes Wort  ^E Ende           ^N Zeile vor
« Letzte Änderung: 05.08.2020, 16:35:24 von Athlan »