Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
12.08.2020, 11:09:03

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24383
  • Letzte: Servus20
Statistiken
  • Beiträge insgesamt: 676765
  • Themen insgesamt: 54850
  • Heute online: 563
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Fingerprint Reader Mint 20  (Gelesen 439 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Fingerprint Reader Mint 20
« am: 28.07.2020, 18:33:18 »
Habe erfolgreich von Mint 19 auf Mint 20 geupgraded.

Zuvor musste ich einige Apps deinstallieren. Unter anderem musste ich auch Fingerprint-Gui runterschmeißen.

Anscheinend gibt es Fingerprint-Gui nicht für Mint 20.

Gibt es bereits eine funktionierende Lösung?

Wäre schön, könnte ich den Fingerprint Reader auf meinem T61p nutzen.

Linux_Peppermint

  • Gast
Re: Fingerprint Reader Mint 20
« Antwort #1 am: 28.07.2020, 19:52:05 »
Es wird unter 20.04 nicht mehr unterstützt!
O-Text:
Zitat
NOTE: Fingerprint GUI is no longer maintained and is not compatible with Ubuntu 20.04 and newer
siehe hier: https://launchpad.net/~fingerprint/+archive/ubuntu/fingerprint-gui

Re: Fingerprint Reader Mint 20
« Antwort #2 am: 29.07.2020, 14:41:25 »
Hi :)
fprintd läuft einwandfrei..

trotz des textes wird focal angeboten.. ich würde es einfach mal testen.

Re: Fingerprint Reader Mint 20
« Antwort #3 am: 03.08.2020, 19:48:53 »
Wie hast du es zum funktionieren bekommen? Beim Enroll Befehl im Terminal bekomme ich ein Timeout.

Re: Fingerprint Reader Mint 20
« Antwort #4 am: 03.08.2020, 20:43:38 »
Hallo,
ich würde meinen FingerprintReader auch gern ans Laufen bekommen, aber die Seite sagt das mein FP-Reader nicht unterstützt wird.
lsusb
Bus 001 Device 005: ID 138a:003f Validity Sensors, Inc. VFS495 Fingerprint Reader
Das war vor zwei Jahren schon so und wird sich wohl auch nicht mehr ändern, denn erfolglose Versuche mit fingerprint-gui hatte ich so einige:
https://www.linuxmintusers.de/index.php?topic=52186.0

Was ist denn nun aktueller das PPA oder das Paket aus dem Repository?
https://launchpad.net/~fingerprint/+archive/ubuntu/fprint
Übersetzung:
Zitat
Bitte beachten Sie, dass diese Pakete seit Ubuntu 12.10 in den Standard-Repositorys vorhanden sind. Diese PPA enthält jedoch eine neuere Version der Software, die eine größere Auswahl an Fingerabdrucklesern unterstützt. Die in Ubuntu 18.10 und höher ausgelieferte Version ist auf dem neuesten Stand, und diese PPA enthält die Pakete nicht.
anscheinend ruht das Projekt seit zwei Jahren, letzte Änderungen waren in 04.2018.
« Letzte Änderung: 04.08.2020, 09:15:50 von kuehhe1 »

Re: Fingerprint Reader Mint 20
« Antwort #5 am: 04.08.2020, 14:06:57 »
Hi :)

hier meine aufzeichnungen... läuft auf 3 rechnern sauber... 2 davon upgrade auf 20.. dort musste ich nur neu enrollen.
 
sudo apt-get install fprintd libfprint0 libpam-fprintdfprintd-enroll -f right-index-finger $USER
falls leser nicht erkannt wird
sudo apt-get install libbsapi
ggf. sind noch anpassungen in der xdg/autostart notwendig

Re: Fingerprint Reader Mint 20
« Antwort #6 am: 04.08.2020, 14:18:10 »
Zitat
blub@ThinkPad-T61:~$ sudo apt-get install fprintd libfprint0 libpam- fprintd
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paket libfprint0 ist nicht verfügbar, wird aber von einem anderen Paket
referenziert. Das kann heißen, dass das Paket fehlt, dass es abgelöst
wurde oder nur aus einer anderen Quelle verfügbar ist.

E: Für Paket »libfprint0« existiert kein Installationskandidat.
E: Paket libpam kann nicht gefunden werden.
blub@ThinkPad-T61:~$
Irgendwo ist der Wurm drin...

Re: Fingerprint Reader Mint 20
« Antwort #7 am: 04.08.2020, 14:21:49 »
Hallo @ehtron,
dankeschön
sudo apt-get install fprintd libfprint0 libpam-fprintd
anscheinend sieht das heute bei LM20 Cin. etwas anders aus.
kuehhe1@HP470:~$ sudo apt-get install fprintd libfprint0 libpam-fprintd -s
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
E: Paket libfprint0 kann nicht gefunden werden.

Meine Installationssimulation in LM20 Cin. für fpintd ergibt andere abhängige Pakete:kuehhe1@HP470:~$ sudo apt-get install fprintd -s
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden zusätzlichen Pakete werden installiert:
  libfprint-2-2 libfprint-2-tod1
Die folgenden NEUEN Pakete werden installiert:
  fprintd libfprint-2-2 libfprint-2-tod1
0 aktualisiert, 3 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Inst libfprint-2-tod1 (1:1.90.1+tod1-0ubuntu4 Ubuntu:20.04/focal [amd64])
Inst libfprint-2-2 (1:1.90.1+tod1-0ubuntu4 Ubuntu:20.04/focal [amd64])
Inst fprintd (1.90.1-1ubuntu1 Ubuntu:20.04/focal [amd64])
Conf libfprint-2-tod1 (1:1.90.1+tod1-0ubuntu4 Ubuntu:20.04/focal [amd64])
Conf libfprint-2-2 (1:1.90.1+tod1-0ubuntu4 Ubuntu:20.04/focal [amd64])
Conf fprintd (1.90.1-1ubuntu1 Ubuntu:20.04/focal [amd64])

In einer ganz ruhigen Stunde werde ich das versuchen. ;)

Re: Fingerprint Reader Mint 20
« Antwort #8 am: 04.08.2020, 14:40:57 »
Hi :)
ah ok, dann muss libfprint0 wohl raus.

Re: Fingerprint Reader Mint 20
« Antwort #9 am: 04.08.2020, 14:45:29 »
Hi :)
Zitat
libpam- fprintd

du solltest dir wirklich angewöhnen befehle zu kopieren statt sie einzutippen.


Re: Fingerprint Reader Mint 20
« Antwort #10 am: 04.08.2020, 15:02:43 »
Noch etwas:
falls leser nicht erkannt wird
Code: [Auswählen]
sudo apt-get install libbsapi

Simulation:
sudo apt-get install libbsapi -s
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
E: Paket libbsapi kann nicht gefunden werden.
woher bekomme man das Paket: libbsapi ?

Das Paket: libsapi war im ppa:fingerprint-gui enthalten:
https://launchpad.net/~fingerprint/+archive/ubuntu/fingerprint-gui
Jedoch wird Fingerprint-GUI von LM20 (Ubuntu 20.04) nicht mehr unterstützt....

Sollte Jemand fingerprint-gui via PPA dennoch in LM20 installieren wollen muss man bei der Deinstallation sehr vorsichtig sein, denn auf das dann fehlende Paket: policykit-1-gnome bin ich auch mal reingefallen (man kann sich danach nicht mehr anmelden):

Übersetzung der Deinstallation, Quelle: https://launchpad.net/~fingerprint/+archive/ubuntu/fingerprint-gui
Zitat
Deinstallation
===========
GNOME-Benutzer: Das Paket policykit-1-fingerprint-gui ersetzt den standard PolicyKit daemon von GNOME (ist im Paket policykit-1-gnome enthalten). Wenn Sie sich dazu entschließen Fingerprint-GUI zu deinstallieren werden durch APT alle von fingerprint-gui abhängigen Pakete und das policykit-1-fingerprint-gui mit entfernt jedoch das Standard Paket: policykit-1-gnome nicht automatisch wieder installiert, so dass im System anschliessend kein PolicyKit Daemon mehr vorhanden ist. Bevor Sie Fingerprint-GUI entfernen, müssen Sie erst das Paket policykit-1-gnome wieder installieren.
   sudo apt-get install policykit-1-gnome
   sudo apt-get remove fingerprint-gui
« Letzte Änderung: 04.08.2020, 20:56:06 von kuehhe1 »

Re: Fingerprint Reader Mint 20
« Antwort #11 am: 04.08.2020, 15:08:31 »
Hi :)
meine aufzeichnungen sind schon älter, war wohl früher im repo und ist wohl nicht mehr nötig.

Re: Fingerprint Reader Mint 20
« Antwort #12 am: 04.08.2020, 15:17:10 »
Ok,
wenn bei LM20 libsapi heute nicht mehr notwendig wäre ist dann müsste der vollständige Befehl zur Installation von fprintd so lauten:sudo apt-get install fprintd libfprint-2-2 libfprint-2-tod1und dann wird sich zeigen ob der FP-Reader erkannt wird..

Re: Fingerprint Reader Mint 20
« Antwort #13 am: 04.08.2020, 15:21:26 »
Hi :)
sudo apt-get install fprintd libpam-fprintd
der rest ist in den abhängikeiten