Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
12.08.2020, 11:53:35

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24383
  • Letzte: Servus20
Statistiken
  • Beiträge insgesamt: 676768
  • Themen insgesamt: 54850
  • Heute online: 563
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Mint Mate 20 - Nvidia-Treiber läßt sich nicht installieren - blackscreen boot  (Gelesen 3341 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

@Michelle_Br,
da steht aber u.a. "generi" ...... nicht generic
zieh mal die Paket-Spalte am Trenner | etwas nach rechts, dann erscheinen die Namen in voller Länge.   ;)
Synaptic Suche nvidia 430
Synaptic Suche nvidia 430

Verstehe nicht ganz warum du noch -generic Pakete manuell hinzufügen musst? Im Fall meines installierten 450.57 aus dem ppa:graphics-drivers werden die im Screenshot gezeigten (-azure, -generic, etc. ) nicht gefunden, da wird nur das Paket xserver-xorg-video-nvidia-450 gelistet.

Sieh auch nach, ob
Code: [Auswählen]
ubuntu-drivers-common
noch installiert ist.
Das Paket ubuntu-drivers-common hatte ich zuvor kontrolliert es war aber auf meinem LM20 Cin. bereits installiert:
ubuntu-drivers-commonkuehhe1@HP470:~$ dpkg -l | grep ubuntu-drivers-common
ii  ubuntu-drivers-common                         1:0.8.4~0.20.04.3                     amd64        Detect and install additional Ubuntu driver packages

Ich hatte kürzlich in meinem Thema Antwort #20 das Hinzufügen des ppa:graphics-drivers und die Installation für meine NVIDIA GM108M [GeForce 930MX] mit der Treiberverwaltung Schritt für Schritt beschrieben.

Keine Ahnung ob dir meine Rückmeldungen weiterhelfen, die dienen nur zum Vergleich mit dem Treiber 450.57:inxi -G
Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
           Device-2: NVIDIA GM108M [GeForce 930MX] driver: nvidia v: 450.57
           Device-3: Lite-On HP HD Camera type: USB driver: uvcvideo
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia unloaded: fbdev,nouveau,vesa resolution: 1600x900~60Hz
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.0.8

Installierte nvidia Pakete:kuehhe1@HP470:~$ dpkg -l | grep nvidia*
ii  libnvidia-cfg1-450:amd64                      450.57-0ubuntu0~0.20.04.2             amd64        NVIDIA binary OpenGL/GLX configuration library
ii  libnvidia-common-390                          390.138-0ubuntu0.20.04.1              all          Shared files used by the NVIDIA libraries
ii  libnvidia-common-430                          440.100-0ubuntu0.20.04.1              all          Transitional package for libnvidia-common-440
ii  libnvidia-common-435                          435.21-0ubuntu7                       all          Shared files used by the NVIDIA libraries
ii  libnvidia-common-440                          440.100-0ubuntu0.20.04.1              all          Shared files used by the NVIDIA libraries
ii  libnvidia-common-450                          450.57-0ubuntu0~0.20.04.2             all          Shared files used by the NVIDIA libraries
rc  libnvidia-compute-440:amd64                   440.100-0ubuntu0.20.04.1              amd64        NVIDIA libcompute package
ii  libnvidia-compute-450:amd64                   450.57-0ubuntu0~0.20.04.2             amd64        NVIDIA libcompute package
ii  libnvidia-compute-450:i386                    450.57-0ubuntu0~0.20.04.2             i386         NVIDIA libcompute package
ii  libnvidia-decode-450:amd64                    450.57-0ubuntu0~0.20.04.2             amd64        NVIDIA Video Decoding runtime libraries
ii  libnvidia-decode-450:i386                     450.57-0ubuntu0~0.20.04.2             i386         NVIDIA Video Decoding runtime libraries
ii  libnvidia-encode-450:amd64                    450.57-0ubuntu0~0.20.04.2             amd64        NVENC Video Encoding runtime library
ii  libnvidia-encode-450:i386                     450.57-0ubuntu0~0.20.04.2             i386         NVENC Video Encoding runtime library
ii  libnvidia-extra-450:amd64                     450.57-0ubuntu0~0.20.04.2             amd64        Extra libraries for the NVIDIA driver
ii  libnvidia-fbc1-450:amd64                      450.57-0ubuntu0~0.20.04.2             amd64        NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-fbc1-450:i386                       450.57-0ubuntu0~0.20.04.2             i386         NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-gl-450:amd64                        450.57-0ubuntu0~0.20.04.2             amd64        NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  libnvidia-gl-450:i386                         450.57-0ubuntu0~0.20.04.2             i386         NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  libnvidia-ifr1-450:amd64                      450.57-0ubuntu0~0.20.04.2             amd64        NVIDIA OpenGL-based Inband Frame Readback runtime library
ii  libnvidia-ifr1-450:i386                       450.57-0ubuntu0~0.20.04.2             i386         NVIDIA OpenGL-based Inband Frame Readback runtime library
ii  nvidia-compute-utils-450                      450.57-0ubuntu0~0.20.04.2             amd64        NVIDIA compute utilities
ii  nvidia-dkms-450                               450.57-0ubuntu0~0.20.04.2             amd64        NVIDIA DKMS package
ii  nvidia-driver-450                             450.57-0ubuntu0~0.20.04.2             amd64        NVIDIA driver metapackage
ii  nvidia-kernel-common-450                      450.57-0ubuntu0~0.20.04.2             amd64        Shared files used with the kernel module
ii  nvidia-kernel-source-450                      450.57-0ubuntu0~0.20.04.2             amd64        NVIDIA kernel source package
ii  nvidia-prime                                  0.8.14                                all          Tools to enable NVIDIA's Prime
ii  nvidia-settings                               440.82-0ubuntu0.20.04.1               amd64        Tool for configuring the NVIDIA graphics driver
ii  nvidia-utils-450                              450.57-0ubuntu0~0.20.04.2             amd64        NVIDIA driver support binaries
ii  screen-resolution-extra                       0.18build1                            all          Extension for the nvidia-settings control panel
ii  xserver-xorg-video-nvidia-450                 450.57-0ubuntu0~0.20.04.2             amd64        NVIDIA binary Xorg driver

Abfrage auf installierte generic Paketen zeigt hier:kuehhe1@HP470:~$ dpkg -l | grep generic
ii  fontconfig                                    2.13.1-2ubuntu3                       amd64        generic font configuration library - support binaries
ii  fontconfig-config                             2.13.1-2ubuntu3                       all          generic font configuration library - configuration
ii  initramfs-tools                               0.136ubuntu6.2                        all          generic modular initramfs generator (automation)
ii  initramfs-tools-core                          0.136ubuntu6.2                        all          generic modular initramfs generator (core tools)
ii  libboost-date-time1.71.0:amd64                1.71.0-6ubuntu6                       amd64        set of date-time libraries based on generic programming concepts
ii  libfontconfig1:amd64                          2.13.1-2ubuntu3                       amd64        generic font configuration library - runtime
ii  libgbm1:amd64                                 20.0.8-0ubuntu1~20.04.1               amd64        generic buffer management API -- runtime
ii  libnl-genl-3-200:amd64                        3.4.0-1                               amd64        library for dealing with netlink sockets - generic netlink
ii  libxml-namespacesupport-perl                  1.12-1                                all          Perl module for supporting simple generic namespaces
ii  linux-generic                                 5.4.0.42.46                           amd64        Complete Generic Linux kernel and headers
ii  linux-headers-5.4.0-40-generic                5.4.0-40.44                           amd64        Linux kernel headers for version 5.4.0 on 64 bit x86 SMP
ii  linux-headers-5.4.0-42-generic                5.4.0-42.46                           amd64        Linux kernel headers for version 5.4.0 on 64 bit x86 SMP
ii  linux-headers-generic                         5.4.0.42.46                           amd64        Generic Linux kernel headers
ii  linux-image-5.4.0-40-generic                  5.4.0-40.44                           amd64        Signed kernel image generic
ii  linux-image-5.4.0-42-generic                  5.4.0-42.46                           amd64        Signed kernel image generic
ii  linux-image-generic                           5.4.0.42.46                           amd64        Generic Linux kernel image
ii  linux-modules-5.4.0-40-generic                5.4.0-40.44                           amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
ii  linux-modules-5.4.0-42-generic                5.4.0-42.46                           amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
ii  linux-modules-extra-5.4.0-40-generic          5.4.0-40.44                           amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
ii  linux-modules-extra-5.4.0-42-generic          5.4.0-42.46                           amd64        Linux kernel extra modules for version 5.4.0 on 64 bit x86 SMP
ii  python3-oauthlib                              3.1.0-1ubuntu2                        all          generic, spec-compliant implementation of OAuth for Python3
« Letzte Änderung: 02.08.2020, 14:14:07 von kuehhe1 »

*seufz
Ganz am Anfang hatte ich schon beschrieben, dass u.a. das Nv@geobartidia-ppa eingebunden war. Trotzdem gab es nur einen empfohlenen Treiber, der aber wohl augenscheinlich nicht ganz richtig lief - es fehlten z.Bsp. die Prime-Einstellungen komplett.....

Der Ratschlag, die Dateien manuell aus Synaptik zu installieren, kam von @geobart - das würde ich gern tun, wenn ich wüßte, welche von den diversen Dateien ich anklicken muss.....es gibt die schon erläuterten Varianten.

Hinsichtlich "generi" hast Du recht ... oh man - das war mir gar nicht aufgefallen.....

apt install nvidia-340 würde den 340.108 installieren. 
In Synaptik heißt das Paket nvidia-340
Willst du den NV430, gib in die Synaptik - Suche nvidia-430 ein und such das entprechende Paket. 

Mich hat es auch erwischt auf meinem Desktop mit GF.
Kein NV-Treiber lässt sich noch funktionierend installieren. Leb erstmal mit dem Nouveau. 

Der NV 440 läuft auf demselben Rechner mit LMDE4 einwandfrei.
« Letzte Änderung: 03.08.2020, 01:38:35 von geobart »

Off-Topic:
@geobart

Falls du beim Nouveau etwas vermissen solltest:
Der von @ehtron in AW #4 erwähnte Workaround hat hier das Problem bis auf Weiteres gelöst.
Mit dem 450.57 läufts wieder wie am Schnürchen.
Fürs Gelingen scheints unerlässlich, auch nicht im kleinsten Detail von seinen Vorgaben abzuweichen.

https://www.linuxmintusers.de/index.php?topic=63300.msg832483#msg832483

Ich habe es jetzt mal mit der Suche nach "Nvidia-430" im Synaptic versucht und alles, was ich denke, dass es dazu gehören könnte, installiert - desgleichen mit Nvidia-prime .... ich boote gleich neu und dann mal sehen.....

Nach Reboot:
claudia@claudia-X751LD:~$ inxi -G
Graphics:  Device-1: Intel Haswell-ULT Integrated Graphics driver: i915 v: kernel
           Device-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] driver: N/A
           Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa resolution: 1600x900~60Hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) v: 4.5 Mesa 20.0.8

Aufruf der Treiberverwaltung - leer - es werden keine proprietären Treiber verwendet .....
Das sieht dann also noch schlechter aus ....

Dafür wird die Treiberverwaltung jetzt 3x geöffnet ... reproduzierbar  :-\
« Letzte Änderung: 04.08.2020, 17:22:36 von Michelle_Br »

Jetzt läuft der Intel-Chip.  Schlecht ist das nicht. Der Treiber ist im Kernel, deshalb nicht in der Treiberverwaltung.
sudo apt-get purge nvidia*  Neustart, dann inxi -G und ist dann weiterhin der Intel aktiv, wär es ja erstmal eine Lösung.
« Letzte Änderung: 04.08.2020, 22:01:10 von geobart »

so weit waren wir aber schon ..... sogar der Nvidia war ja schon aktiv - allerdings ohne Prime
;-)

alles ausgeführt ....
claudia@claudia-X751LD:~$ inxi -G
Graphics:  Device-1: Intel Haswell-ULT Integrated Graphics driver: i915 v: kernel
           Device-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT 620M/625M/630M/720M] driver: nouveau
           v: kernel
           Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa
           resolution: 1600x900~60Hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2) v: 4.5 Mesa 20.0.8


Dafür wird in der Treiberverwaltung nicht mal mehr der bisherige 440x'er Nvidia angezeigt ....

Nvidia-ppa wieder hinzugefügt ..... apt update gemacht ..... neustart .....
claudia@claudia-X751LD:~$ inxi -G
Graphics:
  Device-1: Intel Haswell-ULT Integrated Graphics driver: i915 v: kernel
  Device-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT
  620M/625M/630M/720M]
  driver: nouveau v: kernel
  Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa
  resolution: 1600x900~60Hz
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2)
  v: 4.5 Mesa 20.0.8

Treiberverwaltung trotz Nvidia-ppa immer noch leer.
« Letzte Änderung: 04.08.2020, 23:31:21 von Michelle_Br »

Habt Ihr noch eine Idee .... bitte?

Nvidia-ppa wieder hinzugefügt ..... apt update gemacht ..... neustart .....
ich meine in deiner Reihenfolge ist der Wurm....da fehlt zwischem dem: apt update gemacht ..... neustart ..... die Installation mit Synaptic des nvidia-driver-430

Vergleiche deshalb deine Schritte mit meinen im Thema, Antwort #20: https://www.linuxmintusers.de/index.php?topic=63278.msg832412#msg832412

Einzig im Schritt:
Zitat
Die Treiberverwaltung aufgerufen und nvidia-driver-450 / Version 450.57-0ubuntu0~0.20.04.2 installieren lassen
müsstest du dann über die Treiberverwaltung anstelle meines nvidia-driver-450 deinen passenden nvidia-driver-430 ?? installieren lassen.

Einzig der Bug der Treiberverwaltung nach Wechsel auf einen anderen als den bereits installierten Nvidia Treiber bleibt hier bestehen, weil ich @ehtrons Workarround: ( Eigene Service Unit für den Systemstart unter Systemd ) noch nicht eingepflegt habe.
« Letzte Änderung: 05.08.2020, 17:11:10 von kuehhe1 »

Nvidia-ppa wieder hinzugefügt ..... apt update gemacht ..... neustart .....
ich meine in deiner Reihenfolge ist der Wurm....da fehlt zwischem dem: apt update gemacht ..... neustart ..... die Installation mit Synaptic des nvidia-driver-430

Vergleiche deshalb deine Schritte mit meinen im Thema, Antwort #20: https://www.linuxmintusers.de/index.php?topic=63278.msg832412#msg832412

Einzig im Schritt:
Zitat
Die Treiberverwaltung aufgerufen und nvidia-driver-450 / Version 450.57-0ubuntu0~0.20.04.2 installieren lassen
müsstest du dann über die Treiberverwaltung anstelle meines nvidia-driver-450 deinen passenden nvidia-driver-430 ?? installieren lassen.

Einzig der Bug der Treiberverwaltung nach Wechsel auf einen anderen als den bereits installierten Nvidia Treiber bleibt hier bestehen, weil ich @ehtrons Workarround: ( Eigene Service Unit für den Systemstart unter Systemd ) noch nicht eingepflegt habe.

????
Das hatte ich doch alles gemacht?! Habe ich doch beschrieben! siehe #79
Ich habe über Synaptik die 430'er versucht zu installieren und die Folge war, dass seitdem die Treiberverwaltung total leer ist und mit dem Nvidia das Fenster der Treiberverwaltung sich mit einem Klick 3x öffnet ?!  :-\

Ich habe doch die einzelnen Schritte beschrieben, die ich lt. @geobart gemacht habe und auch inxi -G jedes Mal gepostet.

Dafür wird in der Treiberverwaltung nicht mal mehr der bisherige 440x'er Nvidia angezeigt ....
  Dann wäre auch was falsch gelaufen.  ;D    Jetzt ist die Intel mit ihrem Treiber aktiv. Die Nvidia läuft mit dem  Nouveau. Soll die Nvidia genutzt werden, ordnet man durch DRI_PRIME=1 ein Programm der nvidia zu und das Prg. läuft mit der NV und dem Nouveau-Treiber. 

Bevor du einen NV--Treiber zu installieren versuchst, muss die Treiberverwaltung wieder Inhalte haben. Versuch als erstes in Paketquellen>Wartung die ersten drei Punkte.
« Letzte Änderung: 05.08.2020, 22:26:40 von geobart »

Aufruf der Treiberverwaltung - leer - es werden keine proprietären Treiber verwendet .....
Habe in diesem Thread nicht jedes Detail nachvollzogen, da es um eine spezielle Karte geht.
Aber wie man von einer leeren Treiberverwaltung wieder auf eine vollständige,  mit allen zuvor angezeigten proprietären Treibern kommt, habe ich hier beschrieben:
s. AW# 7,8,9+10
https://www.linuxmintusers.de/index.php?topic=63286.0

Dafür wird in der Treiberverwaltung nicht mal mehr der bisherige 440x'er Nvidia angezeigt ....
  Dann wäre auch was falsch gelaufen.  ;D    Jetzt ist die Intel mit ihrem Treiber aktiv. Die Nvidia läuft mit dem  Nouveau. Soll die Nvidia genutzt werden, ordnet man durch DRI_PRIME=1 ein Programm der nvidia zu und das Prg. läuft mit der NV und dem Nouveau-Treiber. 

Bevor du einen NV--Treiber zu installieren versuchst, muss die Treiberverwaltung wieder Inhalte haben. Versuch als erstes in Paketquellen>Wartung die ersten drei Punkte.

Habe ich gemacht - ohne sichtbares Ergebnis ... alles leer.

Die Ratschläge von @Parmenides versuche ich morgen .....

Hi :)
warum beisst du dich denn so an prime fest.. das wird vermutlich mit dem alten modul nicht funktionieren.

lass die kiste doch einfach immer mit dem 340er laufen und gut.
wenn sie manchmal nicht durch bootet, baue meinen workaround ein.

@Michelle_Br
Wow, sechs Seiten!  :o
Hast Du denn meinen Tipp aus Antwort #8 am: 25.07.2020, 12:43:52 mal versucht, und die http://os-builder.com/UETOYS//nvidia-ultimate-live_1.9_all.deb installiert?
Auch wenn
Zitat
Es erfolgt die Ausgabe, dass die gleiche Version bereits installiert sei......
erscheint.
Ich hätte das an deiner Stelle schon in deinem vorangegangenen System versucht, bevor ich neu installiere, da TheeMahn schrieb:
Zitat
Ich zog Zorin O / S ein, baute das Nvidia-Deb wieder auf, exportierte es und nahm es eine Stufe höher. Dies ist eine Open Source Welt. Ich bin hier um zu helfen.
« Letzte Änderung: 06.08.2020, 16:42:13 von sidewinder »