Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
06.08.2020, 00:22:52

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24358
  • Letzte: walot1936
Statistiken
  • Beiträge insgesamt: 675509
  • Themen insgesamt: 54757
  • Heute online: 374
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 8
Gäste: 305
Gesamt: 313

Autor Thema: [erledigt] LM20 Cinnamon: RAM wird unter bestimmten Bedingungen extrem schnell verbraucht  (Gelesen 1116 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[erledigt] Re: LM20 Cinnamon: RAM wird unter bestimmten Bedingungen extrem schnell verbraucht
« Antwort #15 am: 23.07.2020, 23:31:10 »

Also normal ist dieses Verhalten von Rhythmbox nicht. Auch nicht beim Einlesen einer großen Musiksammlung.
Ich würde jetzt nicht an sämtlichen denkbaren Stellschrauben herumdoktern, sondern zunächst der Ursache für den exorbitanten RAM-Verbrauch von Rhythmbox auf den Grund gehen.

Ja, das würde ich gerne.

Den ultimativen Lösungsvorschlag kann ich dir leider nicht unterbreiten. Deshalb einfach ein paar Anregungen.

Hier läuft die Version 3.4.4.-1 ubuntu2. Du hast nicht etwa die Flatpak-Version installiert?

Es ist schon eine Weile her, aber irgendwo hatte ich mal gelesen, dass das Plugin „Alternatives Erscheinungsbild“ öfters Probleme macht. Kannst es ja mal testweise deaktivieren oder deinstallieren.
Funktioniert denn ansonsten Rhythmbox so wie du es gewohnt bist?

Evt. Schafft ja eine Neuinstallation der Anwendung Abhilfe.
Ggf. auch mal Protokolle und Systemberichte nach Hinweisen sichten.

Anbei noch eine Übersicht der Paketverwaltung, was bei mir dazu installiert ist.
« Letzte Änderung: 24.07.2020, 00:04:54 von Parmenides »

In deinem ersten Screenshot hat Rythmbox knapp 33% RAM im Verbrauch, im 2. nur 4,5%...

Wirklich interessant wäre zu wissen, wie es ausschaut, wenn du das System frisch startest und NUR Rythmbox aktiv ist und die Festplatte einliest. Da ist mMn etwas anderes, was so Ressourcen frisst.

Soo Leute!

Jetzt bin ich sauer auf das verdammte Programm. Das gibts nicht! Wie kann man nur so hirnlos programmieren! ich bin fassungslos! :o

Hab das Einlesen einfach über Nacht durchlaufen lassen, der Prozess ist abgeschlossen und ich seh einen Knopf, wo draufsteht [Gesamtanzahl der Titel] importieren; das sind fast 60.000 Titel, nur so nebenbei. So, und ich denk mir nix böses und klicke mal in die Liste rein, um irgendwelche Soundfiles von Spielen zu löschen, heißt gar nicht erst zu importieren. Nun ist ein Titel markiert, die Zahl oben ist dementsprechend auch auf "1" gesprungen und das verdammte Programm zeigt mir die Zunge, :P , denn ich habe keine Möglichkeit, wieder alle Titel auszuwählen. Importiere, oder lösche ich einen Titel wird einfach der darunterliegende markiert. Strg+A funktioniert nicht und mit der Maus kann ich auch keine Markierung vornehmen.  Es gibt auch keinen "alle auswählen" Knopf, oder so. :-\

Ich dreh hier noch durch. Ich fass es nicht, wie man so hirnlos programmieren kann. Der RAM-Bug ist eine Sache, aber das ist einfach nur noch idiotisch. Wenn ich das Programm jetzt schließe ist die gesamte Liste weg und die ganze Warterei war für die Fische. Wieso kann man überhaupt einen Track aus der Liste markieren, wenns keine Möglichkeit gibt, alle auszuwählen?  :-\

Grüße,
Athlan

EDIT: Mir reichts jetzt mit Rhythmbox. Ich installiere VLC und der wird funktionieren. Nochmal gebe ich mir diese Stotterei nicht.

EDIT2: Nein, VLC ist ungeeignet, denn ich kann ihn nicht nach Musik suchen lassen. Hätte ich alles an einem Ort, müsste ich das nicht tun, aber leider ist dem nicht so. Umpf.  :-\ OK, ich werd wieder den Rhythmboxplayer installieren (der bereits mit dem System mitkam, aber den ich nach diesem Schock grade deinstalliert hab) und hoffen, dass eine Neuinstallation den RAM-Bug behebt. Achja, und ich werd NICHT in die Liste reinklicken! ::)

EDIT3: Neuester Stand: System ist neu gestartet, Importprozess beginnt von neuem. Kann ich den RAM-Verbrauch vllt irgendwie mitloggen?
« Letzte Änderung: 24.07.2020, 11:17:33 von Athlan »

In deinem ersten Screenshot hat Rythmbox knapp 33% RAM im Verbrauch, im 2. nur 4,5%...

Ja, der Screenshot sollte eigentlich immer die Maximalauslastung zeigen, aber der zweite wurde anscheinend zu spät ausgelöst; das System hat dann einfach nichtmal mehr fürs Screenshot aufenehmen Speicher frei. Ich sage zu spät, weils immer so abläuft: RAM wird vollgefüllt, System hängt komplett, während er wieder entleert wird. Dann ist der Ram leer und alles funktioniert normal, bis er wieder voll wird. Wenn ich ein Youtube-Video nebenbei laufen lasse, geht die RAM-Befüllung viel schneller.

Wirklich interessant wäre zu wissen, wie es ausschaut, wenn du das System frisch startest und NUR Rythmbox aktiv ist und die Festplatte einliest. Da ist mMn etwas anderes, was so Ressourcen frisst.

Das ist jetzt der Fall. Es läuft kein Youtube, aber der Browser schon, weil ich das hier ja grade schreibe; außer diesem Forum ist sonst kein Tab geöffnet, und es stockt während des Schreibens dieses Postings schon wieder alles - derzeit so alle 6 Sekunden geschätzt. ---> Jetzt ists grad wieder ruhiger. Es wäre hilfreich, wenn ich nicht immer Screenshots machen müsste, sondern mitloggen könnte.

Grüße,
Athlan




60.000 Musiktitel sind schon ne Menge, aber auch die sollten in maximal 15-20 Minuten eingelesen sein. Soweit ich das verstehe, werden ja lediglich Verknüpfungen eingelesen bzw. generiert und nicht die eigentlichen Dateien.
Keine Ahnung was der Player da die ganze Nacht angestellt hat. Da hätte ich den Prozess schon nach 30 Minuten abgebrochen.
Auch bezweifle ich, das Rhythmbox „hirnlos programmiert“ wurde, denn in Ubuntu ist er schon seit längerem der Standard-Audioplayer und auch bei mir verrichtet er seit etlichen LM-Versionen klaglos seinen Dienst.

Zum reinen Musikhören nutze ich allerdings schon seit längerem „Clementine“. Finde diesen Player in der Bedienung komfortabler. Er bietet mehr Funktionen und hat eine zwar komplexerer GUI, bei der man sich aber schnell zurecht findet.

Da dein Herz ja offenbar nicht an Rhythmbox hängt, würde ich dir Clementine wärmstens empfehlen. Kannst du direkt aus der Anwendungsverwaltung heraus installieren.

Das mit LM Cinnamon ausgelieferte Celluloid konnte mich hingegen nicht wirklich überzeugen.

Übrigens bleibe ich skeptisch, dass dieses RAM-Problem alleine auf das Konto von Rhythmbox geht.
Nur so eine Bauchgefühl.
« Letzte Änderung: 24.07.2020, 11:59:49 von Parmenides »

Den ultimativen Lösungsvorschlag kann ich dir leider nicht unterbreiten. Deshalb einfach ein paar Anregungen.

Hier läuft die Version 3.4.4.-1 ubuntu2. Du hast nicht etwa die Flatpak-Version installiert?
nein, die normale .deb Variante.
Es ist schon eine Weile her, aber irgendwo hatte ich mal gelesen, dass das Plugin „Alternatives Erscheinungsbild“ öfters Probleme macht. Kannst es ja mal testweise deaktivieren oder deinstallieren.
Mal sehen, ob ich das finde. Als Paket ist es nicht installiert.
Funktioniert denn ansonsten Rhythmbox so wie du es gewohnt bist?
Ja. Sonst funktioniert alles normal.
Evt. Schafft ja eine Neuinstallation der Anwendung Abhilfe.
Schon geschehen und es gibt keine Veränderung.
Ggf. auch mal Protokolle und Systemberichte nach Hinweisen sichten.
Wo sind diese Protokolle? Wird auch der Ram-Verlauf mitprotokolliert? Das wäre sehr hilfreich hier.
Anbei noch eine Übersicht der Paketverwaltung, was bei mir dazu installiert ist.
Danke. Ich habe hier auch meine installierten Pakete angefügt.

Eine Idee hab ich noch. Kann ich den Maximal-RAM, den der Prozess rhythmbox-metadata verbrauchen darf, manuell festlegen? Das würde dieses nervige stottern zumindest temporär unterbinden und ich könnte das System wieder gut nutzen, während das Einlesen läuft.

Mal sehen, ob ich das finde. Als Paket ist es nicht installiert.
Wenn du es nicht installiert hast, kann es auch keine Probleme machen. :D

Zitat von: Parmenides am Gestern um 23:50:31

    Funktioniert denn ansonsten Rhythmbox so wie du es gewohnt bist?

Ja. Sonst funktioniert alles normal.

Dein Post #18 liest sich da aber ganz anders!

Wo sind diese Protokolle? Wird auch der Ram-Verlauf mitprotokolliert?
Protokolle und Systemberichte findest du im Startmenü unter Systemverwaltung, oder einfach in die Suchzeile eingeben.
Eine RAM-Protokollierung findet sich dort nicht, aber evt. Informationen über mögliche Übeltäter.

60.000 Musiktitel sind schon ne Menge, aber auch die sollten in maximal 15-20 Minuten eingelesen sein. Soweit ich das verstehe, werden ja lediglich Verknüpfungen eingelesen bzw. generiert und nicht die eigentlichen Dateien.
Vielleicht erklärt sich die Dauer daraus, dass von einer HDD eingelesen wird und nicht von einer SSD. Nur so eine Vermutung.
Keine Ahnung was der Player da die ganze Nacht angestellt hat. Da hätte ich den Prozess schon nach 30 Minuten abgebrochen.
Auch bezweifle ich, das Rhythmbox „hirnlos programmiert“ wurde, denn in Ubuntu ist er schon seit längerem der Standard-Audioplayer und auch bei mir verrichtet er seit etlichen LM-Versionen klaglos seinen Dienst.
Das war von mir in der Emotion natürlich angriffig formuliert, denn hirnlos zu programmieren ist unmöglich. Dennoch ist ein derartiger Designfehler m.E. schon auf ein Versäumnis der Entwickler zurückzuführen.
Zum reinen Musikhören nutze ich allerdings schon seit längerem „Clementine“. Finde diesen Player in der Bedienung komfortabler. Er bietet mehr Funktionen und hat eine zwar komplexerer GUI, bei der man sich aber schnell zurecht findet.

Da dein Herz ja offenbar nicht an Rhythmbox hängt, würde ich dir Clementine wärmstens empfehlen. Kannst du direkt aus der Anwendungsverwaltung heraus installieren.
Danke für den Tipp, ich werd ihn mir mal ansehen. Kann der auch Musikfiles einlesen und verwalten? Denn das möchte ich, nachdem meine Files verstreut rumliegen, ist es mein Ziel, sie mal gesammelt verfügbar zu haben und durchblättern zu können, was ich hören will. Nebenher kann ich dann auch die Metatags anpassen.

EDIT: Leider ist der Player für mich unbrauchbar, da er die Auflösungsskalierung nicht mitmacht und das UI somit ultraklein wird.

Übrigens bleibe ich skeptisch, dass dieses RAM-Problem alleine auf das Konto von Rhythmbox geht.
Nur so eine Bauchgefühl.

Hmm... Ich weiß nur, dass der Prozess rhythmbox-metadata derjenige ist, der den RAM schluckt. Der wird auch immer wieder aufgerufen und beendet während des Einlesens und läuft eben nicht kontinuierlich durch. Kann es sein, dass er sich ins Internet verbinden will, aber von der Firewall, oder meinem Pihole blockiert wird und er deswegen so viel RAM frisst?

Grüße,
Athlan
« Letzte Änderung: 24.07.2020, 12:39:24 von Athlan »

Vielleicht erklärt sich die Dauer daraus, dass von einer HDD eingelesen wird und nicht von einer SSD. Nur so eine Vermutung.
Nein, an der HDD liegts nicht. Habe hier auch von einer gemounteten HDD eingelesen.

Danke für den Tipp, ich werd ihn mir mal ansehen. Kann der auch Musikfiles einlesen und verwalten?

Ja, geht natürlich mit Clementine. Das gehört ja zu den Basics eines Musikplayers.

Ja, geht natürlich mit Clementine. Das gehört ja zu den Basics eines Musikplayers.

Leider ist der Player für mich keine Option, weil er, wie im obigen Screenshot sichtbar, die Auflösungsskallierung nicht mitmacht

Welche exotische Auflösung soll das denn sein, die der Player "nicht mitmacht"?

Irgendwie scheint in deinem System der Wurm drin zu stecken.
Vielleicht hätte ich besser gleich nach inxi -Fz fragen sollen?
« Letzte Änderung: 24.07.2020, 12:53:10 von Parmenides »

Verwendest du Cinnamon? Ich vermute, dass du KDE benutzt. Hab ich recht? Im Screenshot siehst du, was ich meine:

Grüße,
Athlan

Nein, hier läuft LM 20 Cinnamon.

OK, deine Screenshots kamen mir gleich schon so „großkalibrig“ vor. Die 125% Skalierung brauchst du?
Und wofür steht doppelt (HI-DPI)? (Ist nur eine Verständnisfrage.)

Edit: Swapfile ist hier 2 GiB
« Letzte Änderung: 24.07.2020, 13:01:15 von Parmenides »

Nein, an der HDD liegts nicht. Habe hier auch von einer gemounteten HDD eingelesen.

Hmmm.... Vielleicht ist dann doch einfach meine Swapfile zu klein. Wobei ich grade sehe, dass sie grade mal halbvoll ist, also das kanns auch nicht sein.

Grüße