Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
01.12.2020, 09:57:23

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24840
  • Letzte: Foxinity
Statistiken
  • Beiträge insgesamt: 697752
  • Themen insgesamt: 56462
  • Heute online: 616
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  DualBoot Win7/Mint19.3 - Fehler "Superblock checksum does not match superblock"  (Gelesen 570 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo.
Ich bin neu im Forum. Ich habe ein Problem mit dem Dualboot von Windows7 und LinuxMint 19.3 Tricia Cinnamon.
Diese sind auf einer Festplatte installiert ( zuerst Windows, dann Linux ).
Im Grub ist Linux als Standard-Startsystem eingetragen. Das funktioniert auch ohne Probleme.

Wenn ich jedoch beim Starten im Grub-Boot-Menü Windows auswähle, dann später Windows herunterfahre, startet beim nächsten Booten das Linux nicht und endet mit "initramfs"
Ich habe hier schon viel nachgelesen, aber leider nichts dazu gefunden, wie ich den Fehler wegbekomme.

Folgendes habe ich schon mit Hilfe aus diesem Forum gemacht.
- Mit live-Stick gestartet, dann mit gparted die Partition überprüfen lassen. Er findet Fehler im Superblock. Diese werden repariert und ich fahre das System danach wieder herunter.
Nach neuem Booten ohne Stick startet Linux wieder normal.

Ich habe daraufhin in der Datei "/etc/default/grub" diese Zeile angepasst:

GRUB_CMDLINE_LINUX_DEFAULT="fsck.mode=force fsck.repair=yes"

Somit wird beim jedem Booten der Linux-Partition der Fehler, wenn er auftritt,  automatisch behoben ( dauert so ca. 10 min. ).
Da ich Windows nicht mehr oft nutze, kann ich damit leben.

Ich wüsste allerdings gern, warum dieser Fehler auftritt.
Kann es sein, dass Windows beim Start etwas auf der Linux-Partition ändert?
« Letzte Änderung: 19.07.2020, 08:04:39 von kallelinux »

Re: Superblock checksum
« Antwort #1 am: 17.07.2020, 22:33:37 »
startet beim nächsten Booten das Linux nicht und endet mit "initramfs"
da könntest du mal hinter dieses initramfs:fsck /dev/sdaX eingeben, wobei sdaX angepasst werden sollte

Re: Superblock checksum
« Antwort #2 am: 17.07.2020, 22:40:28 »
Das habe ich schon  gemacht. Ist bei mir sda4.
Der Fehler wird auch behoben. Allerdings nachdem ich mal wieder Windows benutzt habe ist der Fehler erneut da.
Bleibe ich nur bei Linux beim Systemstart, gibt es keine Probleme.
Deshalb habe ich den Aufruf "automatisiert" durch den Eintrag in /etc/default/grub.

Re: Superblock checksum
« Antwort #3 am: 17.07.2020, 22:43:18 »
aja, da kann dir sicher jemand anders helfen,
weil ich hab hier mit Windows nix am Hut,
keinen Plan was Win da macht oder machen kann, sorry

Re: Superblock checksum
« Antwort #4 am: 17.07.2020, 22:47:59 »
ah was mir da grade ins Ohr geflüstert wird ist,
eventuell mal grub updaten, also
sudo update-grub

Re: Superblock checksum
« Antwort #5 am: 17.07.2020, 22:56:46 »
Das habe ich schon gemacht.
Deshalb wird jetzt bei diesem Fehler die "automatische" Reparatur gestartet und danach läuft Linux.
 

Re: Superblock checksum
« Antwort #6 am: 17.07.2020, 23:10:24 »
Ich hab mit Windows auch nichts am Hut, habe aber des öfteren hier im Forum gelesen, dass wenn die Schnellstartfunktion bei Windows eingeschaltet ist, es dann Bootprobleme bei Linux gibt.

Re: Superblock checksum
« Antwort #7 am: 17.07.2020, 23:17:42 »
Es hilft in einigen Fällen ...

Fastboot & Securityboot zu deaktivieren und nach jedem Win-update erneut kontrollieren !

Re: Superblock checksum
« Antwort #8 am: 18.07.2020, 07:43:55 »
Hallo.
Das habe ich kontrolliert. Unter Windows7 gibt es diese Optionen noch nicht.

Dafür durfte ich jetzt wieder 12 min. warten, bis Linux den Superblock repariert hatte.  8)

Re: Superblock checksum
« Antwort #9 am: 18.07.2020, 08:35:14 »
Moin ..

Secure-Boot im BIOS/UEFI abschalten.

Fast-Boot im Win(10) unter Einstellungen-->Energie (blabla...) abschalten.

Falls alles unter UEFI installiert ist:
CSM am besten im UEFI-Setup deaktivieren, damit z.B. das Installationsmedium nicht im
BIOS-Modus gestartet werden kann.
Sollte das nicht gehen : Alles auf UEFI Einstellen! Netzwerk kann auf disable.

Ist aber ein mischmasch Install gemacht worden gibt es auch des öfteren wohl Probleme, da bin ich aber dann raus ...

Re: Superblock checksum
« Antwort #10 am: 18.07.2020, 10:12:09 »
Im BIOS steht Legacy Boot auf Enable.
UEFI wird beim Laptop noch nicht unterstützt.

Win10 habe ich nicht drauf. Bei Win7 gibt es dieses Fastboot noch nicht.

Hat jemand noch eine andere Idee ?

Nach ca. 3 Monaten habe ich die Lösung gefunden für mein beschriebenes Problem.
Ich hatte unter Windows7 ein Programm "Ext2fsd V0.62" installiert. Damit kann man unter Windows die Linux-Laufwerke im Explorer sehen.
Ich weiß allerdings nicht, mit welchem Programm das auf meine Festplatte gekommen ist.
Nach Recherche auf der Hersteller-Webseite habe ich eine Warnung gelesen für genau meinem Fehler beim Starten von Linux.
Habe es deinstalliert und auch den Treiber im Geräte-Manager gelöscht.
Nun funktioniert der Start von Linux nach der Windows-Nutzung wieder.
Danke für die Ratschläge.

Das Problem ist damit gelöst. Muss jetzt nur noch schauen, wie das Thema als gelöst markiert wird.
« Letzte Änderung: 23.10.2020, 20:56:50 von kallelinux »

Setze bitte hier noch auf gelöst oder erledigt. Wie das richtig geht steht oben unter Hilfe. Danke.

In der Hilfe steht, dass ein Thema was älter als 2 Monate ist nur vom Moderator geschlossen werden kann.
Daraufhin habe ich den Moderator informiert.
Ich selber darf/kann das Thema leider nicht als gelöst markieren.

 

1. Advent
1. Advent