Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
12.08.2020, 11:24:26

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24383
  • Letzte: Servus20
Statistiken
  • Beiträge insgesamt: 676765
  • Themen insgesamt: 54850
  • Heute online: 563
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  LM 20 Cin. zeigt kein nVidia-Prime Icon in der Leiste  (Gelesen 1159 mal)

0 Mitglieder und 2 Gäste betrachten dieses Thema.

Hallo,
nach dem Upgrade meines HP Probook 470 G5 von LM19.3 Cin. zu LM20 Cin. habe ich kein nvidia-prime Icon in der Leiste und kann es auch nicht hinzufügen.

Mein System:kuehhe1@HP470:~$ inxi -Fz
System:    Kernel: 5.4.0-40-generic x86_64 bits: 64 Desktop: Cinnamon 4.6.6 Distro: Linux Mint 20 Ulyana
Machine:   Type: Laptop System: HP product: HP ProBook 470 G5 v: N/A serial: <filter>
           Mobo: HP model: 837F v: KBC Version 02.3D.00 serial: <filter> UEFI: HP v: Q85 Ver. 01.11.01 date: 04/27/2020
Battery:   ID-1: BAT0 charge: 41.2 Wh condition: 41.4/41.4 Wh (100%)
CPU:       Topology: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP L2 cache: 6144 KiB
           Speed: 2304 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 2260 2: 2343 3: 2376 4: 2048 5: 2105 6: 2089 7: 2093
           8: 2165
Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
           Device-2: NVIDIA GM108M [GeForce 930MX] driver: nvidia v: 440.100
           Device-3: Lite-On HP HD Camera type: USB driver: uvcvideo
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia unloaded: fbdev,nouveau,vesa resolution: 1600x900~60Hz
           OpenGL: renderer: GeForce 930MX/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100
Audio:     Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
           Sound Server: ALSA v: k5.4.0-40-generic
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8168
           IF: enp2s0 state: down mac: <filter>
           Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi
           IF: wlp3s0 state: up mac: <filter>
Drives:    Local Storage: total: 1.14 TiB used: 240.10 GiB (20.5%)
           ID-1: /dev/nvme0n1 vendor: SK Hynix model: PC401 HFS256GD9TNG-62A0A size: 238.47 GiB
           ID-2: /dev/sda vendor: Samsung model: SSD 860 EVO 1TB size: 931.51 GiB
Partition: ID-1: / size: 19.56 GiB used: 14.98 GiB (76.6%) fs: ext4 dev: /dev/nvme0n1p6
           ID-2: /home size: 68.43 GiB used: 6.38 GiB (9.3%) fs: ext4 dev: /dev/nvme0n1p8
Swap:      ID-1: swap-1 type: partition size: 10.00 GiB used: 0 KiB (0.0%) dev: /dev/nvme0n1p7
Sensors:   System Temperatures: cpu: 40.0 C mobo: 35.0 C gpu: nvidia temp: 36 C
           Fan Speeds (RPM): N/A
Info:      Processes: 325 Uptime: 5m Memory: 7.45 GiB used: 2.35 GiB (31.6%) Shell: Bash inxi: 3.1.04

Diese nvidia Pakete sind inclusive nvidia-prime-applet installiert:kuehhe1@HP470:~$ dpkg -l | grep nvidia*
ii  libnvidia-cfg1-440:amd64                      440.100-0ubuntu0.20.04.1              amd64        NVIDIA binary OpenGL/GLX configuration library
ii  libnvidia-common-390                          390.138-0ubuntu0.20.04.1              all          Shared files used by the NVIDIA libraries
ii  libnvidia-common-430                          440.100-0ubuntu0.20.04.1              all          Transitional package for libnvidia-common-440
ii  libnvidia-common-435                          435.21-0ubuntu7                       all          Shared files used by the NVIDIA libraries
ii  libnvidia-common-440                          440.100-0ubuntu0.20.04.1              all          Shared files used by the NVIDIA libraries
ii  libnvidia-compute-440:amd64                   440.100-0ubuntu0.20.04.1              amd64        NVIDIA libcompute package
ii  libnvidia-compute-440:i386                    440.100-0ubuntu0.20.04.1              i386         NVIDIA libcompute package
ii  libnvidia-decode-440:amd64                    440.100-0ubuntu0.20.04.1              amd64        NVIDIA Video Decoding runtime libraries
ii  libnvidia-decode-440:i386                     440.100-0ubuntu0.20.04.1              i386         NVIDIA Video Decoding runtime libraries
ii  libnvidia-encode-440:amd64                    440.100-0ubuntu0.20.04.1              amd64        NVENC Video Encoding runtime library
ii  libnvidia-encode-440:i386                     440.100-0ubuntu0.20.04.1              i386         NVENC Video Encoding runtime library
ii  libnvidia-extra-440:amd64                     440.100-0ubuntu0.20.04.1              amd64        Extra libraries for the NVIDIA driver
ii  libnvidia-fbc1-440:amd64                      440.100-0ubuntu0.20.04.1              amd64        NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-fbc1-440:i386                       440.100-0ubuntu0.20.04.1              i386         NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-gl-440:amd64                        440.100-0ubuntu0.20.04.1              amd64        NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  libnvidia-gl-440:i386                         440.100-0ubuntu0.20.04.1              i386         NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  libnvidia-ifr1-440:amd64                      440.100-0ubuntu0.20.04.1              amd64        NVIDIA OpenGL-based Inband Frame Readback runtime library
ii  libnvidia-ifr1-440:i386                       440.100-0ubuntu0.20.04.1              i386         NVIDIA OpenGL-based Inband Frame Readback runtime library
ii  nvidia-compute-utils-440                      440.100-0ubuntu0.20.04.1              amd64        NVIDIA compute utilities
ii  nvidia-dkms-440                               440.100-0ubuntu0.20.04.1              amd64        NVIDIA DKMS package
ii  nvidia-driver-440                             440.100-0ubuntu0.20.04.1              amd64        NVIDIA driver metapackage
ii  nvidia-kernel-common-440                      440.100-0ubuntu0.20.04.1              amd64        Shared files used with the kernel module
ii  nvidia-kernel-source-440                      440.100-0ubuntu0.20.04.1              amd64        NVIDIA kernel source package
ii  nvidia-prime                                  0.8.14                                all          Tools to enable NVIDIA's Prime
ii  nvidia-prime-applet                           1.2.1                                 all          An applet for NVIDIA Prime
ii  nvidia-settings                               440.64-0ubuntu1                       amd64        Tool for configuring the NVIDIA graphics driver
ii  nvidia-utils-440                              440.100-0ubuntu0.20.04.1              amd64        NVIDIA driver support binaries
ii  screen-resolution-extra                       0.18build1                            all          Extension for the nvidia-settings control panel
ii  xserver-xorg-video-nvidia-440                 440.100-0ubuntu0.20.04.1              amd64        NVIDIA binary Xorg driver

nvidia-x-server-settings funktioniert soweit und die nvidia ist auch ausgewählt
nvidia x server settings LM20
nvidia x server settings LM20

bei ausgewählter nvidia Grafik zeigt inxi -G:kuehhe1@HP470:~$ inxi -G
Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
           Device-2: NVIDIA GM108M [GeForce 930MX] driver: nvidia v: 440.100
           Device-3: Lite-On HP HD Camera type: USB driver: uvcvideo
           Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia unloaded: fbdev,nouveau,vesa resolution: 1600x900~60Hz
           OpenGL: renderer: GeForce 930MX/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100

Terminal Abfrage auf Aktivität:
prime-select query
nvidia

auch hiernach ist sie aktiv und übernimmt das Rendern:glxinfo | grep renderer
OpenGL renderer string: GeForce 930MX/PCIe/SSE2

Auswahl der intel Grafik in nvidia-xserver-settings:
nvidia x server settings intel LM20
nvidia x server settings intel LM20

Nach der Auswahl ist ein Neustart erforderlich (Abmelden reicht nicht),
danach zeigt inxi -G:
kuehhe1@HP470:~$ inxi -G
Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
           Device-2: NVIDIA GM108M [GeForce 930MX] driver: N/A
           Device-3: Lite-On HP HD Camera type: USB driver: uvcvideo
           Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa resolution: 1600x900~60Hz
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.0.8
kuehhe1@HP470:~$

Terminal Abfrage auf Aktivität:prime-select query
intel

So gesehen funktioniert die Umschaltung direkt aus nvidia-server-settings, und auch aus dem Terminal.
Wo ist das Problem oder gibt es bei LM20 kein nvidia-prime Leisten-Icon mehr? ::)
« Letzte Änderung: 17.07.2020, 20:08:36 von kuehhe1 »

Re: LM 20 Cin. zeigt kein nVidia-Prime Icon in der Leiste
« Antwort #1 am: 14.07.2020, 15:31:13 »
Hi :)
vielleicht als applet realisiert?

Re: LM 20 Cin. zeigt kein nVidia-Prime Icon in der Leiste
« Antwort #2 am: 14.07.2020, 16:55:42 »
Hi @ehtron
ii  nvidia-prime-applet                           1.2.1                                 all          An applet for NVIDIA Prime
das installierte aus den Quellen funktioniert jedenfalls nicht und via "Applets" Hinzufügen wird ebenso wenig angeboten wie auf "cinnamon-spices.linuxmint.com" . Danach hatte ich auch schon gesucht, gibt wohl (noch) nichts..

Abwarten..
« Letzte Änderung: 15.07.2020, 05:38:38 von kuehhe1 »

Re: LM 20 Cin. zeigt kein nVidia-Prime Icon in der Leiste
« Antwort #3 am: 14.07.2020, 20:39:09 »
Bei mir erscheint das in den Anwendungen als Nvidia X Server Settings und wurde in der Leiste übernommen bzw. kann wieder (aus den Anwendungen, nicht von der Leiste her) in die Leiste hinzugefügt werden: "+ zur Leiste hinzufügen". Hatte allerdings upgrade xfce von LM 19.3 auf LM 20.

Re: LM 20 Cin. zeigt kein nVidia-Prime Icon in der Leiste
« Antwort #4 am: 14.07.2020, 20:54:32 »
@Worf,
das per Kontext aus dem Menü heraus "zur Leiste hinzufügen" meine ich aber nicht,
Es geht um das Paket nvidia-prime-applet welches nach der Installation das nvidia-prime Icon in der Leiste re.-Unten (Systray) also neben der Uhr, Netzwerk, Lautstärke, Akku erscheinen lässt und von dort aus die nvidia-xserver-settings öffnet bzw. die Umschaltung der Grafikkarten  ermöglicht.
alter Screenshot aus LM 19.3
Leiste Desklets LM19 3
Leiste Desklets LM19 3
« Letzte Änderung: 15.07.2020, 05:42:12 von kuehhe1 »

Re: LM 20 Cin. zeigt kein nVidia-Prime Icon in der Leiste
« Antwort #5 am: 14.07.2020, 21:08:25 »
Okay, ich dachte, das ist dasselbe - ich verwende es nur mit dem Admin-Account, da sieht das so aus bei mir (das grüne neben der Treiberverwaltung) und ich kann hier auch die erwähnten Einstellungen vornehmen:
leiste root
leiste root
Beispiel:
leiste root nvidia settings
leiste root nvidia settings

Re: LM 20 Cin. zeigt kein nVidia-Prime Icon in der Leiste
« Antwort #6 am: 15.07.2020, 19:01:22 »
Hallo,
hab gerade nochmal in der LM 20 Vorstellung nachgelesen: https://linuxmint.com/rel_ulyana_cinnamon_whatsnew.php
Zitat
Linux Mint 20 bietet verbesserte Unterstützung für NVIDIA Optimus.

Das NVIDIA Prime-Applet zeigt jetzt Ihren GPU-Renderer an und Sie können direkt aus dem Menü auswählen, auf welche Karte Sie wechseln möchten.


Das NVIDIA-Profil "On-Demand" wird jetzt ebenfalls vollständig unterstützt. Wenn Sie in diesem Modus ausgeführt werden, wird die Sitzung von Ihrer Intel-Karte gerendert,
und es steht eine Menüoption zur Verfügung, mit der Sie eine bestimmte Anwendung auf Ihre NVIDIA-Karte auslagern können.


Die gezeigte Auswahlmöglichkeit aus dem Menü heraus die gewählte Anwendung mit der nVidia-Karte darzustellen funktioniert. Beim Test: Auswahl vlc Re.-Klick > Kontext: Mit NVIDIA-GPU ausführen und starten eines *.mkv Videos zeigt sich im Terminal das die Intel-Karte das Rendern übernimmt!?kuehhe1@HP470:~$ glxinfo | grep renderer
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
    GLX_MESA_query_renderer, GLX_MESA_swap_control, GLX_OML_swap_method,
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: Mesa Intel(R) UHD Graphics 620 (KBL GT2)
Folglich ist bei der Wiedergabe mit vlc die Intel aktiv. Irgendwie hab ich da ein Verständnisproblem?

In Nvidia X Server Settings hab ich alle Einstellungen getestet: NVIDIA, NVIDIA on-Demand und Intel, aber auch dadurch zeigt sich das nvidia-prime Icon nicht in der Leiste. Kann es sein das es nur mit einer NVIDIA-Optimus-Karte bzw. mit einem passenden nvidia-optimus- oder vulkan-Treiber funktioniert?

Funktioniert überhaupt bei Jemandem nach dem Upgrade zu LM20 das Applet: nvidia-prime im Systray? ?
« Letzte Änderung: 27.07.2020, 14:09:20 von kuehhe1 »

Re: LM 20 Cin. zeigt kein nVidia-Prime Icon in der Leiste
« Antwort #7 am: 16.07.2020, 18:16:11 »
Habe zwar die xfce, aber da sollte es ja auch unter LM20 laufen. Scheint bei mir aber nicht mal in den nvidia server settings auf - siehe Foto oben bei #5.
Ausgegeben wird bei mir: ~ $ dpkg -l | grep nvidia
ii  libnvidia-cfg1-440:amd64              440.100-0ubuntu0.20.04.1                            amd64        NVIDIA binary OpenGL/GLX configuration library
ii  libnvidia-common-440                  440.100-0ubuntu0.20.04.1                            all          Shared files used by the NVIDIA libraries
ii  libnvidia-compute-440:amd64           440.100-0ubuntu0.20.04.1                            amd64        NVIDIA libcompute package
ii  libnvidia-compute-440:i386            440.100-0ubuntu0.20.04.1                            i386         NVIDIA libcompute package
ii  libnvidia-decode-440:amd64            440.100-0ubuntu0.20.04.1                            amd64        NVIDIA Video Decoding runtime libraries
ii  libnvidia-decode-440:i386             440.100-0ubuntu0.20.04.1                            i386         NVIDIA Video Decoding runtime libraries
ii  libnvidia-encode-440:amd64            440.100-0ubuntu0.20.04.1                            amd64        NVENC Video Encoding runtime library
ii  libnvidia-encode-440:i386             440.100-0ubuntu0.20.04.1                            i386         NVENC Video Encoding runtime library
ii  libnvidia-extra-440:amd64             440.100-0ubuntu0.20.04.1                            amd64        Extra libraries for the NVIDIA driver
ii  libnvidia-fbc1-440:amd64              440.100-0ubuntu0.20.04.1                            amd64        NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-fbc1-440:i386               440.100-0ubuntu0.20.04.1                            i386         NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-gl-440:amd64                440.100-0ubuntu0.20.04.1                            amd64        NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  libnvidia-gl-440:i386                 440.100-0ubuntu0.20.04.1                            i386         NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  libnvidia-ifr1-440:amd64              440.100-0ubuntu0.20.04.1                            amd64        NVIDIA OpenGL-based Inband Frame Readback runtime library
ii  libnvidia-ifr1-440:i386               440.100-0ubuntu0.20.04.1                            i386         NVIDIA OpenGL-based Inband Frame Readback runtime library
ii  nvidia-compute-utils-440              440.100-0ubuntu0.20.04.1                            amd64        NVIDIA compute utilities
ii  nvidia-dkms-440                       440.100-0ubuntu0.20.04.1                            amd64        NVIDIA DKMS package
ii  nvidia-driver-440                     440.100-0ubuntu0.20.04.1                            amd64        NVIDIA driver metapackage
ii  nvidia-kernel-common-440              440.100-0ubuntu0.20.04.1                            amd64        Shared files used with the kernel module
ii  nvidia-kernel-source-440              440.100-0ubuntu0.20.04.1                            amd64        NVIDIA kernel source package
[color=green]ii  nvidia-prime                          0.8.14                                              all          Tools to enable NVIDIA's Prime[/color]
[color=green]ii  nvidia-prime-applet                   1.2.1                                               all          An applet for NVIDIA Prime
i[/color]i  nvidia-settings                       440.64-0ubuntu1                                     amd64        Tool for configuring the NVIDIA graphics driver
ii  nvidia-utils-440                      440.100-0ubuntu0.20.04.1                            amd64        NVIDIA driver support binaries
ii  screen-resolution-extra               0.18build1                                          all          Extension for the nvidia-settings control panel
ii  xserver-xorg-video-nvidia-440         440.100-0ubuntu0.20.04.1                            amd64        NVIDIA binary Xorg driver
~ $ nvidia-detect
nvidia-detect: Befehl nicht gefunden.

~ $ nvidia-settings
(nvidia-settings:54313): GLib-GObject-CRITICAL **: 18:06:14.594: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
** Message: 18:06:14.768: PRIME: No offloading required. Abort
[color=green]** Message: 18:06:14.768: PRIME: is it supported? no[/color]
Ev gibts aussagekräftigere Befehle, aber offenbar ist das prime applet vorhanden aber "not supported"?
Wie könnte man das manuell erneut installieren?
Die GPU ist jedenfalls mit der Technologie ausgestattet.

Re: LM 20 Cin. zeigt kein nVidia-Prime Icon in der Leiste
« Antwort #8 am: 16.07.2020, 19:55:48 »
Ev gibts aussagekräftigere Befehle,
nvidia-prime ist installiert und welche Karte jetzt aktiv ist zeigt:inxi -G
Sollte durch nvidia-prime oder prime auf wundersame Weise eine Umschaltung der Karten ausgeführt worden sein lässt sich das mit dem Befehl abfragen:prime-select query
Info: Nach Umschaltung meiner Grafik-Karten von Intel auf NVIDIA oder von NVIDIA auf Intel muß jeweils ein Neustart erfolgen damit sie übernommen werden.

Wie könnte man das manuell erneut installieren?
Du könntest versuchen das Paket nach diesem Befehl-Schema erneut zu installieren:apt install --reinstall <PAKETNAME>hiesse in deinem Fall:apt install --reinstall nvidia-prime
Wurde denn bei deinem LM19.3 Xfce vor dem Upgrade das installierte nvidia-prime Applet im Systray (Leiste) angezeigt?

~ $ nvidia-settings
(nvidia-settings:54313): GLib-GObject-CRITICAL **: 18:06:14.594: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
** Message: 18:06:14.768: PRIME: No offloading required. Abort
** Message: 18:06:14.768: PRIME: is it supported? no
prime scheint demnach nicht supported.

Der Befehl nvidia-settings startet das GUI Nvidia X Server Settings und liefert diese Rückmeldung:
kuehhe1@HP470:~$ nvidia-settings

(nvidia-settings:21525): GLib-GObject-CRITICAL **: 20:14:44.670: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
GPU at BusId 0x1 doesn't have a supported video decoder
** Message: 20:14:44.797: PRIME: Requires offloading
** Message: 20:14:44.797: PRIME: is it supported? yes
** Message: 20:14:44.829: PRIME: Usage: /usr/bin/prime-select nvidia|intel|on-demand|query
** Message: 20:14:44.829: PRIME: on-demand mode: "1"
** Message: 20:14:44.829: PRIME: is "on-demand" mode supported? yes
So gesehen sind zumindest bei mir die Möglichkeiten gegeben und funktionieren alle bis auf das Leisten-Icon.

Edit: ich hatte gar nicht gezeigt das es auch in Startprogramme einen Launcher für: nvidia-prime-applet gibt, der hinterlegte Startbefehl lautet:/usr/share/nvidia-prime/prime-quirks
Startprogramme nvidia prime applet
Startprogramme nvidia prime applet
funktioniert leider nicht. :(
« Letzte Änderung: 16.07.2020, 20:54:32 von kuehhe1 »

Re: LM 20 Cin. zeigt kein nVidia-Prime Icon in der Leiste
« Antwort #9 am: 17.07.2020, 00:50:54 »
Aha, bei mir zeigt sich zuerst folgendes:
~ $ inxi -G
Graphics:
  Device-1: NVIDIA GP104 [GeForce GTX 1080] driver: nvidia v: 440.100
  Display: x11 server: X.Org 1.20.8 driver: nvidia
  unloaded: fbdev,modesetting,nouveau,vesa resolution: 1920x1080~60Hz
  OpenGL: renderer: GeForce GTX 1080/PCIe/SSE2 v: 4.6.0 NVIDIA 440.100
~ $ prime-select query
nvidia
Aktiv ist sie. Was die Ausgabe zum 2. Befehl aussagt, hm.
Nach Eingabe von /usr/share/nvidia-prime/prime-quirks im Terminal erhalte ich seltsames:
~ $ /usr/share/nvidia-prime/prime-quirks
bash: /usr/share/nvidia-prime/prime-quirks: Keine Berechtigung
~ $ sudo /usr/share/nvidia-prime/prime-quirks
[sudo] Passwort für:               
sudo: /usr/share/nvidia-prime/prime-quirks: Befehl nicht gefunden
kurt_root@BigOne ~ $
Also zum Admin-Acc gewechselt und mit sudo ließ er mich ran, aber dann den Befehl nicht gefunden.
Oder wäre das bei den Startprogrammen einzugeben (hinzufügen)? - Dort ist seltsamerweise das Programm aktiv, daher habe ich da nicht nochmal hinzugefügt, siehe:
startverhalten startprogramme nvidia prime
startverhalten startprogramme nvidia prime

Ich könnte das aber noch versuchen, das sollte keine zusätzlichen Probleme machen oder? Im Prog Startverhalten kann ich Hinzufügen und würde dort Deine Eingaben machen:
nvidia prime aplet in startprog einfuegen
nvidia prime aplet in startprog einfuegen

PS: habe mich bisher nicht darum gekümmert, weil es hieß, die Optimustechnologie kommt bei Desktops nun doch nicht und dachte, das feature wäre nur bei Optimus vorhanden - vielleicht war das ein Irrtum, weil ja lt. meiner Anzeige das nvidia prime aplet von Haus aus sogar im Autostart mitläuft.
« Letzte Änderung: 17.07.2020, 02:02:50 von Worf »

Re: LM 20 Cin. zeigt kein nVidia-Prime Icon in der Leiste
« Antwort #10 am: 17.07.2020, 02:40:00 »
Folglich ist bei der Wiedergabe mit vlc die Intel aktiv. Irgendwie hab ich da ein Verständnisproblem?
 
Ich glaube ja.
Zieh dir das mal rein: https://de.wikipedia.org/wiki/GLX#Eigenschaften

Einfach gesagt:
On Demand (glx): Die Intel ist mit "ihren" Treibern aktiv, die ressourcenhungrigen von dir eingestellten Programme (VLC, Spiele usw.) holen sich zusätzliche Power von der Nvidia für 3D, die Ausgabe erfolgt aber über die Intel mit ihren Treibern. Bei Windows ist das schon lange so, deshalb die Game-ready Nvidiatreiber.
Prime:
Die Nvidia übernimmt alles, oder aber die Intel. Die Ausgaben in inxi zeigen jeweils andere Renderer.
Ich glaube, dass Prime auf den Ryzen mit Vega auch nicht mehr funktioniert. Wissen tu ich es aber nicht, mir fehlt so ein neues Ryzen-NB, um das selber mal alles durchzutesten.
Das Prime-Applet in seiner bisherigen Bezeichnung und Arbeitsweise passt einfach nicht mehr bei den neueren Grafikboliden.

Als Root Nvidia ein- und umzustellen war bei Nvidia  immer schon daneben, weil auch im /home einiges abgelegt wird. Im home des root dann, auf den der "Nichtroot" keinen zugriff hat.

Re: LM 20 Cin. zeigt kein nVidia-Prime Icon in der Leiste
« Antwort #11 am: 17.07.2020, 08:11:45 »
Was die Ausgabe zum 2. Befehl aussagt, hm.
m.M. nach zeigt der Befehl an:
prime-select query
nvidia
das auf die nvidia umgeschaltet wurde,
es gibt letztendlich drei Möglichkeiten bzw. Zustände: NVIDIA, NVIDIA-On-Demand und Intel
Die kann ich bei mir ja auch direkt in Nvidia X Server Settings auswählen. Früher bis unter LM19.3 konnte ich das auch im funktionierenden Leisten Applet nvidia-prime auswählen.

Nach Eingabe von
Code: [Auswählen]
/usr/share/nvidia-prime/prime-quirks
im Terminal erhalte ich seltsames:
Code: [Auswählen]
~ $ /usr/share/nvidia-prime/prime-quirks
bash: /usr/share/nvidia-prime/prime-quirks: Keine Berechtigung
~ $ sudo /usr/share/nvidia-prime/prime-quirks
[sudo] Passwort für:               
sudo: /usr/share/nvidia-prime/prime-quirks: Befehl nicht gefunden
das ist hier alsolut identisch:
kuehhe1@HP470:~$ sudo sh -c "/usr/share/nvidia-prime/prime-quirks"
[sudo] Passwort für kuehhe1:     
sh: 1: /usr/share/nvidia-prime/prime-quirks: Permission denied

Warum der Starterbefehl direkt im Terminal ausgeführt auch nichts bewirkt weiss ich auch nicht. Den bei dir vorhanden und bei mir im Screenshot der Antwort #8 gezeigten Starter in Startprogramme würde ich nicht noch mal hinzufügen, was soll das bringen.
weil ja lt. meiner Anzeige das nvidia prime aplet von Haus aus sogar im Autostart mitläuft.
ebenso wie hier, nur bewirkt der Starter mit dem Befehl:/usr/share/nvidia-prime/prime-quirks eben nicht das ein nvidia-prime Icon in die Leiste einfügt wird.

Und das sollte ob Game Bolide mit Ryzen oder Standard Nvidia / Intel Kombination schon funktionieren.

Re: LM 20 Cin. zeigt kein nVidia-Prime Icon in der Leiste
« Antwort #12 am: 17.07.2020, 08:16:16 »
Hallo @geobart,
danke für deine Erklärung. ;)
Einfach gesagt:
On Demand (glx): Die Intel ist mit "ihren" Treibern aktiv, die ressourcenhungrigen von dir eingestellten Programme (VLC, Spiele usw.) holen sich zusätzliche Power von der Nvidia für 3D, die Ausgabe erfolgt aber über die Intel mit ihren Treibern. Bei Windows ist das schon lange so, deshalb die Game-ready Nvidiatreiber.
Prime:
Die Nvidia übernimmt alles, oder aber die Intel. Die Ausgaben in inxi zeigen jeweils andere Renderer.
Das habe ich dann Gestern auch so verinnerlicht.
Bin aber zuvor davon ausgegangen das sich die aktive Grafikkarte je nach Situation welche Anwendung auf die nVidia Karte geleitet wird auch an der Rückmeldung von: inxi -G erkennen lässt.

Letztendlich gehts noch um das hier nicht angezeigte nvidia-prime Icon im Systray, was ja in der Vorstellung zu LM20 gut erkennbar ist.
Quelle:https://linuxmint.com/pictures/screenshots/ulyana/nvidia.png
« Letzte Änderung: 17.07.2020, 09:27:55 von kuehhe1 »

Re: LM 20 Cin. zeigt kein nVidia-Prime Icon in der Leiste
« Antwort #13 am: 17.07.2020, 15:11:43 »
Ich habe auch mal meine interne Intel-Grafik auf 'Auto' aktiviert (die hatte ich wohl noch nie aktiv) und das Applet NVidia-Prime installiert. Ergebnis ist das Gleiche wie bei Worf. Bei mir ist das aber ein Desktop-PC - hat es da jemals funktioniert?
Ich denke das klappt nur bei Hybrid-Notebooks.

-volker-

Re: LM 20 Cin. zeigt kein nVidia-Prime Icon in der Leiste
« Antwort #14 am: 17.07.2020, 16:35:10 »
Zitat
PS: habe mich bisher nicht darum gekümmert, weil es hieß, die Optimustechnologie kommt bei Desktops nun doch nicht und dachte, das feature wäre nur bei Optimus vorhanden - vielleicht war das ein Irrtum, weil ja lt. meiner Anzeige das nvidia prime aplet von Haus aus sogar im Autostart mitläuft.
Ja, ich habe noch versucht herauszufinden, ob das gesichtert nur für Laptops funktioniert, aber es sind viele widersprüchliche Infos zu finden. Auf Nvidia direkt findet sich nur der Laptop-Bezug.
Wie gesagt läuft das aplet aber von Haus aus in der Autostart aktiv mit .....
Wäre fein, wenn ein Experte da mal Klarheit schaffen könnte.