Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
28.09.2020, 15:07:34

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 685202
  • Themen insgesamt: 55454
  • Heute online: 668
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [erledigt] LM20 Xfce Thunar braucht 40 Sekunden, um Ordner anzuzeigen wegen NTFS-Partition  (Gelesen 444 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Ich benutze seit Jahren eine NTFS-Partition für die Daten, weil ich Windows für bestimmte Sachen brauche und gerne auch Zugriff von Windows aus auf meine Daten haben möchte.
Die Partition wird beim Start über fstab automatisch eingebunden ( gemäß Anleitung hier:  https://www.linuxmintusers.de/index.php?action=wiki;page=4)_Nachträglich_eine_Partition_in_fstab_einbinden  )

Auf die Ordner (Downloads, Bilder, Videos, Vorlagen, Dokumente und Musik) wird mit symbolischem Link verwiesen.
Klappt seit Jahren ohne Probleme.

Doch nun mit Mint 20 braucht Thunar beim ersten Aufruf 40 Sekunden, bis die Ordner angezeigt werden.
Wenn ich Thunar beende und neu aufrufe, braucht er ungefähr 9 Sekunden bis zur Anzeige der Ordner.

Das ist lästig, deshalb habe ich nemo installiert, den Dateimanager von Cinnamon, den ich sowieso besser finde, weil er die Partition (sda2, sda5, sda8 usw.) anzeigt, was kein anderer Dateimanager - außer der von KDE - macht.

nemo zeigt die Ordner mit einer winzigen Verzögerung von nicht einmal einer Sekunde an.

Andere Dateimanager wie PCManFM oder Caja zeigen die Ordner noch schneller als nemo an, sind aber nicht so komfortabel wie nemo.

Bevor ich die DATA-Partition über die fstab eingebunden habe, zeigte Thunar die Ordner ohne Verzögerung an.
So soll es sein.
Nach dem Einbinden dann die Verzögerung.

Vermutlich gibt es keine Lösung für dieses Problem, zumindest habe ich in keinem Forum eine gefunden, aber man weiß ja nie.
Vielleicht weiß einer der Experten hier weiter ?

sudo parted --list
[sudo] Passwort für franz:         
Modell: ATA SAMSUNG HD503HI (scsi)
Festplatte  /dev/sda:  500GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos
Disk-Flags:

Nummer  Anfang  Ende   Größe   Typ       Dateisystem     Flags
 1      1049kB  608MB  607MB   primary   ntfs            boot
 2      608MB   105GB  104GB   primary   ntfs
 3      105GB   500GB  395GB   extended                  LBA
 5      105GB   343GB  238GB   logical   ntfs
 6      343GB   375GB  32,7GB  logical   ext4
11      375GB   407GB  32,2GB  logical   ext4
 7      407GB   436GB  28,6GB  logical   ext4
 9      436GB   465GB  28,6GB  logical   ext4
10      465GB   493GB  28,3GB  logical   ext4
 8      493GB   500GB  7161MB  logical   linux-swap(v1)
« Letzte Änderung: 05.07.2020, 22:56:23 von mikon »

Re: LM20 Xfce Thunar braucht 40 Sekunden, um Ordner anzuzeigen
« Antwort #1 am: 05.07.2020, 13:26:41 »
Kleine Erfolgsmeldung:
In MX 19  hatte Thunar dasselbe Problem wie in LM20 Xfce.

Dort bastelte ich herum und benutzte ein MX-Werkzeug, mit dem man Partionen mounten kann.
Es trägt in der fstab folgende Zeile ein
#Entry for /dev/sda5 :
UUID=1EFE3CEAFE3CBC39   /media/DATA     ntfs-3g defaults,locale=de_DE.UTF-8     0       0

Nach dem Neustart zeigt Thunar keine Verzögerung mehr, ist super schnell, wie es sein soll.
Die DATA-Partition wird in Thunar unter "Geräte" angezeigt wie alle anderen vorhandenen Partionen auch. Der Eintrag hat eine andere Farbe, um anzuzeigen, daß DATA schon gemountet ist, wie "Dateisystem", also die root-Partition auf der MX-19 installiert ist.

Dass die Daten-Partition jetzt in /media  gemountet wird, ist nicht wichtig, es funktioniert auch auf /mnt/DATA .

Diesen Eintrag habe ich natürlich in der fstab auf LM20 Xfce gemacht.  Bringt aber leider nichts, Thunar braucht immer noch mehr als 40 Sekunden, bis er die Ordner anzeigt.

Wie ich jetzt mit meinen sehr begrenzten IT-Kenntnissen weiterkommen kann, weiß ich nicht.
MX-19 basiert auf Debian Buster,  LM20 Xfce auf Ubuntu 20. Ubuntu wiederum auf Debian.
 
Irgendwas passiert in Mint20, doch was und wie kann ich es so ändern, daß es wie bei MX-19 mit Thunar funktioniert ?


Re: LM20 Xfce Thunar braucht 40 Sekunden, um Ordner anzuzeigen
« Antwort #2 am: 05.07.2020, 14:18:48 »
Bei LinuxMint (ubuntu) ist der Pfad /media/$USER/DATA
$USER = Name des angemeldeten Benutzers

Bei LMDE4 (debian) ist es ebenso geregelt.

Beispiel: user@debbie-t450s:~$ cat /etc/fstab
# UNCONFIGURED FSTAB FOR BASE SYSTEM
proc /proc proc defaults 0 0
# /dev/sda4
UUID=1f4c35af-9f0c-4057-bb0e-c64c68ff6410 swap swap sw 0 0
# /dev/sda5
UUID=bf2d3355-8877-4717-a895-5bf2e49144ba / ext4 rw,errors=remount-ro 0 1
# /dev/sda2
UUID=f967305b-85aa-44cf-91d5-49c9126abb6c /media/user/DATEN auto nosuid,nodev,nofail,x-gvfs-show 0 0
# /dev/sda5
UUID=bd074e8a-8333-4d95-bcd0-5241f847f3ff /media/user/TVIDEO auto nosuid,nodev,nofail,x-gvfs-show 0 0

Ändern kann man die Einhängeoptionen auf der grafischen Oberfläche mit dem Werkzeug "Laufwerke", oder durch Bearbeiten der Datei /etc/fstab

Edit
In dem Beispiel handelt es sich bei "DATEN" und "TVIDEO" um ext4-Partitionen, ntfs benutze ich nicht mehr. 
« Letzte Änderung: 05.07.2020, 23:37:59 von aexe »

Re: LM20 Xfce Thunar braucht 40 Sekunden, um Ordner anzuzeigen
« Antwort #3 am: 05.07.2020, 22:54:49 »
Danke, @aexe .

Ich habe meinen Eintrag in den letzten Jahren immer gemäß der Anleitung von goldfinger in der Linux Mint-Community gemacht.
https://community.linuxmint.com/tutorial/view/1609
Hat auch die ganzen Jahre funktioniert, bis eben LM20 kam bzw.  MX-19 .

Die Lösung für MX-19 habe ich gefunden, aber die bringt nichts in Mint20.

Ich habe den von Dir vorgeschlagenen Eintrag so gemacht, hat leider auch nichts gebracht.

Thunar braucht beim ersten Aufruf mehr als 40 Sekunden.
Wenn ich ihn schliesse und gleich wieder aufrufe, dauert es nur noch 7 Sekunden, bis er die Ordner anzeigt.
Ist mir auch zu lahm, denn Pcmanfm und nemo haben keine Verzögerung.
Ich habe auch noch Dolphin installiert, auch der hat keine Verzögerung.  Es ist nur Thunar, der so lange braucht.

Es wurde mir jetzt zu bunt. Ich habe die Daten-Partition mit ext4 formatiert, denn dieser "Bug" in Xfce mit Thunar bei NTSF-Partitionen ist bekannt und die offiziellen "Lösungsvorschläge" funktionieren bei niemandem, soweit ich in den Foren Threads darüber finden konnte. Und falls doch, dann leider nicht bei mir.

Mein Eintrag in der fstab sieht nun so aus:
#Eintrag für die  /dev/sda5   DATA Partition :
LABEL=DATA  /media/DATA  ext4  defaults  0  0

Bin auf den Einhängepunkt "media" umgestiegen, hat aber keine Auswirkung auf die Schnelligkeit.
Statt der UUID nehme ich das LABEL, weil es sicher funktioniert und der Schritt  mit sudo blkid entfällt bei der Einrichtung.

Jetzt ist Thunar genauso schnell wie nemo.
Pcmanf ist gefühlt einen Tick schneller.

Fazit: Das Problem "Thunar braucht 40 Sekunden im LM20 Xfce, um Ordner anzuzeigen" ist für eine NTFS-Daten-Partition nicht gelöst.

Für mich ist es aber hiermit erledigt, weil ich keine Hoffnung habe, herauszufinden, weshalb  MX-19 es kann, LinuxMint20 Xfce aber nicht.
Ich benutze nun eine Daten-Partition, die mit ext4 formatiert ist.

In Windows brauche ich halt jetzt den Linux-Reader, der in der Grundversion zum Glück kostenlos ist. Nachteil: Kann nur lesen, aber nicht auf ext4-Partitionen schreiben.
So oft benutze ich Windows nicht und wenn ich eine Datei bearbeiten muss, die auf der ext4-Daten-Partition liegt, kann der Linux-Reader sie nach Windows kopieren. Dort kann ich sie dann  bearbeiten.

Falls doch noch jemand eine Lösung für eine eingebundene NTFS-Partition unter LM20 Xfce findet, würde ich mich freuen.
« Letzte Änderung: 06.07.2020, 12:25:35 von mikon »