Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
07.07.2020, 17:55:50

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 669261
  • Themen insgesamt: 54211
  • Heute online: 395
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]   touchpad aus/einschalten einem keycoe zuordnen fn key aktivieren  (Gelesen 137 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

LM20 Cinnamon. Hallo, bei meinem Touchpad (linksoben) und der dazugehörigen fn taste funktioniert die touchpad aus/einschaltfunktion nicht. Der entsprechende Keycode ist 133 (keysym 0xffeb, Super_L) die xinput ID = 13. Ich weiß leider nicht, und habe auch nicht herausgefunden wo und wie man mit diesen beiden Infos entsprechende Einstellungen vornehmen kann.
Vielen Dank für eure Hilfe!

« Letzte Änderung: 03.07.2020, 15:55:37 von F12345 »

Da bei den Tastenkombis die <Fn>-Taste nicht akzeptiert wird, kann ich dir nur einen Weg zeigen, wie du es über eine andere, nach deinen Wünschen vergebene Kombi einrichten kannst.

Erstelle eine Datei mit folgendem Inhalt und nenne sie beispielsweise "touchpad.sh":
#!/bin/bash
t=$(dconf read /org/cinnamon/settings-daemon/peripherals/touchpad/touchpad-enabled)
case "$t" in
false) dconf write /org/cinnamon/settings-daemon/peripherals/touchpad/touchpad-enabled true;;
true) dconf write /org/cinnamon/settings-daemon/peripherals/touchpad/touchpad-enabled false;;
esac

Diese Datei speicherst du an einem dir genehmen Ort und machst sie ausführbar (Rechtsklick, Eigenschaften, Zugriffsrechte, Ausführen: Haken rein bei "Der Datei erlauben...").

Unter Tastatur kannst du dir dann eine eigene Tastenkombi erstellen (z.B. "Touchpad"),  als Befehl trägst du die erstellte Datei ein. Beim Drücken der entsprechenden Tasten wird damit der Status (an/aus) überprüft und das Gegenteil aktiviert.

Hinweis: Funktioniert hier wie beschrieben einwandfrei unter LM 19.3 Cinnamon



Die Zuordnung zu einer anderen Tastenkombi ginge auch über das Menü - Tastatur - Tastenkombinationen- Geräte- Touchpad ein-/ausschalten. Das war jedoch nicht was ich suchte - die anderen FN Tasten funktionieren ja - vielen Dank trotzdem!