Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
14.07.2020, 15:32:50

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24262
  • Letzte: jamie
Statistiken
  • Beiträge insgesamt: 670847
  • Themen insgesamt: 54361
  • Heute online: 424
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Synaptics-Touchpad  (Gelesen 580 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Synaptics-Touchpad
« am: 29.06.2020, 21:38:09 »
HI;
Mein Touchpad will nicht mehr trotz aller ausgego....gelten Seiten in LinuxMintDE u.o. International.
Es war nach Anleitung und Installation kurzzeitig da, hat sich auch unter "Maus u. Touchpad" konfigurieren lassen.
Neustarts überlebt.
Aber jetzt ist es wieder weg. K.A. warum.
Lässt sich auch nicht mehr aktivieren.
Andere SSD, gleicher Rechner, Win10: Touchpad funktioniert.
Wie übrigens schon unter "Tricia".

Jemand(e) eine Idee ausser "never change a running system"?

Danke vorab

Installiert ist jetzt LM20 "Ulyana" auf einem sog. Surfbook von Trekstor "A13B"
« Letzte Änderung: 29.06.2020, 21:44:02 von wirdschon »

Re: Synaptics-Touchpad
« Antwort #1 am: 29.06.2020, 22:11:08 »
Hallo und Willkommen bei LMU!

Zitat
Hinweis: Bitte bei allen Supportanfragen unbedingt die verwendete Mint-Version und Desktopumgebung angeben.
;) ;)

https://www.linuxmintusers.de/index.php?action=wiki;page=Supportanfrage
« Letzte Änderung: 29.06.2020, 22:31:27 von tommix »

Re: Synaptics-Touchpad
« Antwort #2 am: 29.06.2020, 22:45:46 »
hmpf

ausser ein bischen was von "Inxi":

CPU: Dual Core Intel Celeron N3350 (-MCP-) speed/min/max: 1158/800/2400 MHz
Kernel: 5.4.0-39-generic x86_64 Up: 53m Mem: 1170.2/3779.5 MiB (31.0%)
Storage: 350.06 GiB (67.4% used) Procs: 200 Shell: bash 5.0.16 inxi: 3.0.38

Andere Terminal-Befehle sind mir entfallen oder habe ich nicht parat. Tschuldigung.

Nebenbei:
 Ich bin ein Maus-Schubser seit dem Kauf meines ersten Rechners 1997.
Insofern kein Drama, diese Dysfunktion.
Aus meiner ehemaligen beruflichen Vergangenheit her mag ich aber gerne Lösungen für ein Problem, das es nicht geben dürfte(sollte).

Grüsse und div.Tipps erwartend

Danke und wirdschon



« Letzte Änderung: 29.06.2020, 22:56:48 von wirdschon »

Re: Synaptics-Touchpad
« Antwort #3 am: 29.06.2020, 23:12:13 »
« Letzte Änderung: 29.06.2020, 23:21:34 von aexe »

Re: Synaptics-Touchpad
« Antwort #4 am: 30.06.2020, 00:26:15 »
Hi,

Zu "hmpf":
https://metager.de/meta/meta.ger3?eingabe=hmpf

zu allem anderen:

https://forums.linuxmint.com/viewtopic.php?t=195182
https://www.linuxmintusers.de/index.php?topic=52715.0

Problem gab es also schon einmal, jetzt wieder?

Unterstelle mir niemand, ich hätte mich nicht bemüht.
Weitere Spitzfindigkeiten mag ich nicht.

BS ist wie schon festgestellt jetzt LM20 XFCE "Ulyana" auf einem Trekstor-Surfbook "A13B".

Grüsse

Re: Synaptics-Touchpad
« Antwort #5 am: 03.07.2020, 13:22:34 »
Hi!

Ich tippe auf ein Problem mit Xorg, denn der Treiber wird ja wohl nicht plötzlich weg sein. Hast du unlängst den Grafiktreiber gewechselt, resp. aktualisiert?

Grüße,
Athlan

Re: Synaptics-Touchpad
« Antwort #6 am: 03.07.2020, 13:55:50 »
Guck mal in die Logdatei von Xorg. Bei mir zumindest (LMDE, Cinnamon) befindet sie sich unter /var/log/lightdm/x-0.log.
 

Re: Synaptics-Touchpad
« Antwort #7 am: 05.07.2020, 16:31:19 »
@ Athlan ; @Tam:

Grafiktreiber-Update? K.A.: LM20 ist erst seit einer Woche installiert, alle Updates bis heute sind installiert.

Fang ich mal an:
Das Touchpad-Verhalten lässt sich reproduzieren, indem ich einfach bei nicht vorhandenem Touchpad nach W10 umboote und wieder zurück:

Vorher:
$ xinput list
⎡ Virtual core pointer                    id=2 [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              id=4 [slave  pointer  (2)]
⎜   ↳ MX Anywhere 2 Mouse                      id=13 [slave  pointer  (2)]
⎣ Virtual core keyboard                    id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard              id=5 [slave  keyboard (3)]
    ↳ Video Bus                                id=6 [slave  keyboard (3)]
    ↳ Power Button                            id=7 [slave  keyboard (3)]
    ↳ USB 2.0 Web Camera: USB 2.0 Web          id=8 [slave  keyboard (3)]
    ↳ Intel HID events                        id=9 [slave  keyboard (3)]
    ↳ Intel HID 5 button array                id=10 [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            id=11 [slave  keyboard (3)]
    ↳ MX Anywhere 2 Keyboard                    id=15 [slave  keyboard (3)

Nacher:
$ xinput list
⎡ Virtual core pointer                    id=2 [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              id=4 [slave  pointer  (2)]
⎜   ↳ SYNA3602:00 0911:5288 Touchpad          id=9 [slave  pointer  (2)]
⎜   ↳ MX Anywhere 2 Mouse                      id=16 [slave  pointer  (2)]
⎜   ↳ SYNA3602:00 0911:5288 Mouse              id=11 [slave  pointer  (2)]
⎣ Virtual core keyboard                    id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard              id=5 [slave  keyboard (3)]
    ↳ Video Bus                                id=6 [slave  keyboard (3)]
    ↳ Power Button                            id=7 [slave  keyboard (3)]
    ↳ USB 2.0 Web Camera: USB 2.0 Web          id=8 [slave  keyboard (3)]
    ↳ SYNA3602:00 0911:5288 Keyboard          id=10 [slave  keyboard (3)]
    ↳ Intel HID events                        id=12 [slave  keyboard (3)]
    ↳ Intel HID 5 button array                id=13 [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            id=14 [slave  keyboard (3)]
    ↳ MX Anywhere 2 Keyboard                  id=15 [slave  keyboard (3)]

Vorher:
$ synclient
Couldn't find synaptics properties. No synaptics driver loaded?

Nachher:
$ synclient
Parameter settings:
    LeftEdge                = 105
    RightEdge               = 2523
    TopEdge                 = 71
    BottomEdge              = 1261
    FingerLow               = 25
    FingerHigh              = 30
    MaxTapTime              = 180
    MaxTapMove              = 129
    MaxDoubleTapTime        = 180
    SingleTapTimeout        = 180
    ClickTime               = 100
    EmulateMidButtonTime    = 0
    EmulateTwoFingerMinZ    = 282
    EmulateTwoFingerMinW    = 7
    VertScrollDelta         = 58
    HorizScrollDelta        = 58
    VertEdgeScroll          = 1
    HorizEdgeScroll         = 1
    CornerCoasting          = 0
    VertTwoFingerScroll     = 0
    HorizTwoFingerScroll    = 0
    MinSpeed                = 1
    MaxSpeed                = 1.75
    AccelFactor             = 0.0678887
    TouchpadOff             = 1
    LockedDrags             = 0
    LockedDragTimeout       = 5000
    RTCornerButton          = 2
    RBCornerButton          = 3
    LTCornerButton          = 0
    LBCornerButton          = 0
    TapButton1              = 1
    TapButton2              = 3
    TapButton3              = 2
    ClickFinger1            = 1
    ClickFinger2            = 3
    ClickFinger3            = 0
    CircularScrolling       = 0
    CircScrollDelta         = 0.1
    CircScrollTrigger       = 0
    CircularPad             = 0
    PalmDetect              = 0
    PalmMinWidth            = 10
    PalmMinZ                = 200
    CoastingSpeed           = 20
    CoastingFriction        = 50
    PressureMotionMinZ      = 30
    PressureMotionMaxZ      = 160
    PressureMotionMinFactor = 1
    PressureMotionMaxFactor = 1
    ResolutionDetect        = 1
    GrabEventDevice         = 0
    TapAndDragGesture       = 1
    AreaLeftEdge            = 0
    AreaRightEdge           = 0
    AreaTopEdge             = 0
    AreaBottomEdge          = 0
    HorizHysteresis         = 14
    VertHysteresis          = 14
    ClickPad                = 1
    RightButtonAreaLeft     = 1314
    RightButtonAreaRight    = 0
    RightButtonAreaTop      = 1092
    RightButtonAreaBottom   = 0
    MiddleButtonAreaLeft    = 0
    MiddleButtonAreaRight   = 0
    MiddleButtonAreaTop     = 0
    MiddleButtonAreaBottom  = 0

Mittlerweile habe ich mich durchs I-Net gearbeitet: Eine Lösung finde ich nicht.
Gibt es wohl (noch) nicht. Jedenfalls finde ich keine.
Mit manchen Nickelichkeiten bei einem neuen(?) BS muss man halt leben.
Woher kenne ich das?

Um die Diskussion zusammenzuführen, weil es sonst unübersichtlich wird:
https://www.linuxmintusers.de/index.php?PHPSESSID=afa1aa83a02e65379957dcff232f2d80&topic=62680.msg826570#new

Den Rest möge ein Moderator machen, bitte.



Grüsse

Off Topic:
Für "Master" und "Slave" werden sich (nicht nur) in der Linux-Welt hoffentlich in absehbarer Zeit Adäquate finden(lassen).



« Letzte Änderung: 05.07.2020, 16:48:59 von wirdschon »

Re: Synaptics-Touchpad
« Antwort #8 am: 05.07.2020, 16:57:57 »
Hallo,
der Treiber "xserver-xorg-input-synaptics" ist aber installiert? Kontrollier mal über die Synaptic-Paketverwaltung oder im Terminal mit:dpkg -l | grep xserver-xorg-input-synapticsmeine Rückmeldung:kuehhe1@HP470:~$ dpkg -l | grep xserver-xorg-input-synaptics
ii  xserver-xorg-input-synaptics                  1.9.0-1ubuntu1                                  amd64        Synaptics TouchPad driver for X.Org server

Eventuell wird oder ist das Touchpad deaktiviert wenn eine Maus angeschlossen ist?
Die Einstellung dazu findet man hier über: Menü > Systemverwaltung > dconf-Editor im Pfad:
/org/cinnamon/settings-daemon/peripherals/touchpad/disable-with-external-mouseSollte der dconf-Editor noch nicht installiert sein, lässt er sich mit nachfolgenden Befehl installieren:apt install dconf-editor
die Rückmeldung von xinput list bei aktiviertem Touchpad:
kuehhe1@HP470:~$ xinput list
⎡ Virtual core pointer                    id=2 [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              id=4 [slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver                    id=11 [slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver Consumer Control  id=12 [slave  pointer  (2)]
⎜   ↳ SYNA3065:00 06CB:826F Mouse              id=14 [slave  pointer  (2)]
⎜   ↳ SYNA3065:00 06CB:826F Touchpad          id=15 [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad              id=17 [slave  pointer  (2)]
⎣ Virtual core keyboard                    id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard              id=5 [slave  keyboard (3)]
    ↳ Power Button                            id=6 [slave  keyboard (3)]
    ↳ Video Bus                                id=7 [slave  keyboard (3)]
    ↳ Video Bus                                id=8 [slave  keyboard (3)]
    ↳ Power Button                            id=9 [slave  keyboard (3)]
    ↳ Sleep Button                            id=10 [slave  keyboard (3)]
    ↳ HP HD Camera: HP HD Camera              id=13 [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            id=16 [slave  keyboard (3)]
    ↳ HP Wireless hotkeys                      id=18 [slave  keyboard (3)]
    ↳ HP WMI hotkeys                          id=19 [slave  keyboard (3)]
    ↳ Logitech USB Receiver Consumer Control  id=20 [slave  keyboard (3)]

die Rückmeldung von xinput list bei deaktiviertem Touchpad::
kuehhe1@HP470:~$ xinput list
⎡ Virtual core pointer                    id=2 [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              id=4 [slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver                    id=11 [slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver Consumer Control  id=12 [slave  pointer  (2)]
⎜   ↳ SYNA3065:00 06CB:826F Mouse              id=14 [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad              id=17 [slave  pointer  (2)]
⎜   ↳ SYNA3065:00 06CB:826F Touchpad          id=15 [slave  pointer  (2)]
⎣ Virtual core keyboard                    id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard              id=5 [slave  keyboard (3)]
    ↳ Power Button                            id=6 [slave  keyboard (3)]
    ↳ Video Bus                                id=7 [slave  keyboard (3)]
    ↳ Video Bus                                id=8 [slave  keyboard (3)]
    ↳ Power Button                            id=9 [slave  keyboard (3)]
    ↳ Sleep Button                            id=10 [slave  keyboard (3)]
    ↳ HP HD Camera: HP HD Camera              id=13 [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            id=16 [slave  keyboard (3)]
    ↳ HP Wireless hotkeys                      id=18 [slave  keyboard (3)]
    ↳ HP WMI hotkeys                          id=19 [slave  keyboard (3)]
    ↳ Logitech USB Receiver Consumer Control  id=20 [slave  keyboard (3)]
« Letzte Änderung: 06.07.2020, 06:11:44 von kuehhe1 »

Re: Synaptics-Touchpad
« Antwort #9 am: 05.07.2020, 19:20:40 »
Hi, also ausschliesserietis:

Bisher funktioniert meine Maus über Bluetooth perfekt. Tut sie auch mit dem USB-Unifiying-Mini-Stick.
Keine Änderung im Verhalten.

Da geht nichts ohne meine MX Anywhere. Ausser manchmal. Möchte ich mich nach aller(dieser) Erfahrung aber nicht drauf verlassen. ::)

Und ja: Der Synaptics-Treiber ist definitiv installiert. Der "evdev" nicht.

Die "xinput list" liegt ja vor.

Frage: Warum wird das Synaptics-Modul ganz offensichtlich nach einem Umbooten von W10 nach LM20 geladen.
Ohne diese Umbooterei, sprich normalen Start mit LM 20 aber nicht bzw. nicht reproduzierbar oder nicht nachvollziehbar nur sporadisch?

Paketlisten werden gelesen... 0%                                                Paketlisten werden gelesen... Fertig                                         
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
xserver-xorg-input-synaptics ist schon die neueste Version (1.9.1-1ubuntu3).
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

Naja, mehr als Quatsch geht ja nicht und tut im Zweifel nicht weh:

$ sudo apt install xserver-xorg-input-evdev
[sudo] Passwort für xyz:           
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden NEUEN Pakete werden installiert:
  xserver-xorg-input-evdev
0 aktualisiert, 1 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen 31,9 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 106 kB Plattenplatz zusätzlich benutzt.
Holen:1 http://mirror.netcologne.de/ubuntu focal/universe amd64 xserver-xorg-input-evdev amd64 1:2.10.6-1 [31,9 kB]
Es wurden 31,9 kB in 0 s geholt (208 kB/s).   
Vormals nicht ausgewähltes Paket xserver-xorg-input-evdev wird gewählt.
(Lese Datenbank ... 306957 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../xserver-xorg-input-evdev_1%3a2.10.6-1_amd64.deb ...
Entpacken von xserver-xorg-input-evdev (1:2.10.6-1) ...
xserver-xorg-input-evdev (1:2.10.6-1) wird eingerichtet ...
Trigger für man-db (2.9.1-1) werden verarbeitet ...

Hat nach einem Neustart nicht geholfen. Also schnell wieder:

$ sudo apt remove xserver-xorg-input-evdev
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden Pakete werden ENTFERNT:
  xserver-xorg-input-evdev
0 aktualisiert, 0 neu installiert, 1 zu entfernen und 0 nicht aktualisiert.
Nach dieser Operation werden 106 kB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n] j
(Lese Datenbank ... 306964 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von xserver-xorg-input-evdev (1:2.10.6-1) ...
Trigger für man-db (2.9.1-1) werden verarbeitet ...

Man lernt ja dazu, wird jetzt aber mühsam und unergiebig, es sei denn, irgendwo lauert die ultimative Lösung.
Die dann sofortigen Einzug ins BS erhält.
Spätestens in "20.1" im Herbst.

Z.Zt. ist das wohl nicht lösbar.
Kein Grund, deswegen zu "Tricia" zurückzukehren.

"Gut Ding will Weile haben..." o.ä.

Grüsse und eine gesunde neue Woche

Wird schon...

Nachtrag:
Etwas habe ich vergessen ganz ohne Maus mit zufällig funktionierendem Touchpad:

xyz@A13B:~$ xinput list
⎡ Virtual core pointer                    id=2 [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              id=4 [slave  pointer  (2)]
⎜   ↳ SYNA3602:00 0911:5288 Touchpad          id=11 [slave  pointer  (2)]
⎜   ↳ SYNA3602:00 0911:5288 Mouse              id=10 [slave  pointer  (2)]
⎣ Virtual core keyboard                    id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard              id=5 [slave  keyboard (3)]
    ↳ Video Bus                                id=6 [slave  keyboard (3)]
    ↳ Power Button                            id=7 [slave  keyboard (3)]
    ↳ USB 2.0 Web Camera: USB 2.0 Web          id=9 [slave  keyboard (3)]
    ↳ SYNA3602:00 0911:5288 Keyboard          id=12 [slave  keyboard (3)]
    ↳ Intel HID events                        id=13 [slave  keyboard (3)]
    ↳ Intel HID 5 button array                id=14 [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            id=15 [slave  keyboard (3)]
xyzA13B:~$
« Letzte Änderung: 05.07.2020, 21:04:09 von wirdschon »

Re: Synaptics-Touchpad
« Antwort #10 am: 06.07.2020, 15:21:39 »
Hi :)
hab jetzt die ganze lange geschichte nicht ganz gelesen..
nur mal in den raum geworfen..
secure boot aus?

was passiert nach
trackpad / mousepad reset
modprobe -r psmouse
modprobe -v psmouse

Re: Synaptics-Touchpad
« Antwort #11 am: 06.07.2020, 16:09:34 »
@ehtron:

$ modprobe -r psmouse
$
$ modprobe -v psmouse
insmod /lib/modules/5.4.0-40-generic/kernel/drivers/input/mouse/psmouse.ko
modprobe: ERROR: could not insert 'psmouse': Operation not permitted

Fastboot und/oder Secureboot An und/oder Aus:

Hat keinen Einfluss auf das Verhalten des Touchpads...

Danke dennoch für den Tipp.

Grüsse

Re: Synaptics-Touchpad
« Antwort #12 am: 06.07.2020, 16:15:31 »
Hast du dir die Logdatei denn mal angesehen?

Re: Synaptics-Touchpad
« Antwort #13 am: 06.07.2020, 16:54:17 »
Hi :)
naja.. du siehst ja an der fehlermeldung... das ich die root rechte vergessen habe.. und mit
sudo geht es?

Re: Synaptics-Touchpad
« Antwort #14 am: 08.07.2020, 13:30:05 »
@tam; @ehtron:
...und diese Logdatei finde ich wo?

...auch ein vorangestelltes "sudo" ändert nichts.

$ sudo modprobe -r psmouse
$
[sudo] Passwort für xyz:           
$ sudo modprobe -v psmouse
insmod /lib/modules/5.4.0-40-generic/kernel/drivers/input/mouse/psmouse.ko
$

Heute morgen nach dem Start war das Touchpad wieder da, z.Zt. nach einem Neustart wieder nicht. Ich gebs erstmal drann, bringt ja offenbar im Moment nichts(mehr) sich mit diesem Pipifax seine Zeit zu vetreiben.
Ich vermute, dass das Notebook sich beim Booten gelegentlich und unreproduzierbar "Verschluckt". Ist dann halt so. Nutze ohnehin gewohnheitsmässig die Maus und unterwegs habe ich auch immerschon eine kleine, kabelgebundene Maus dabei.

Mache hier erstmal Schluss bis zur Wiedervorlage, wenn sich dieses Verhalten erledigt hat. Wird schon so werden nach aller Erfahrung und irgendeinem demnächst anstehenden grösseren Update.

Danke einstweilen allen für die Mithilfe...

Grüsse