Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
07.07.2020, 17:36:42

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 669258
  • Themen insgesamt: 54211
  • Heute online: 392
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Linux Mint 20, Kein Bild.  (Gelesen 487 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Linux Mint 20, Kein Bild.
« am: 28.06.2020, 12:12:43 »
hatte vor kurzem noch die Beta problemlos am laufen.
Bis vor kurzem, gab es ein Update seitdem nur ein schwarzes Bild nach dem Bootlogo.
Habe ich dann erstmal zur Seite gelegt.

Heute die Stable auf ein USB geflasht und auf ein neues probiert.
Da gibts schon ein schwarzes Bild wenn man die Live Sitzung startet. Ich sehe den Installer nicht einmal.

Mit 19.3 hatte ich auch keine Probleme, was hat sich geändert dass es auf einmal nichtmehr geht?
Andere Treiber?

Habe folgendes System:

CPU: i9-9900KF
Motherboard: Asus Strix Z390-F
RAM: 32GB Corsair Vengeance RGB DDR4-3200
GPU: MSI Nvidia GeForce GTX 1080 TI Gaming 11G
Für Linux eine dedizierte 250GB SSD.


Eine idee?

Re: Linux Mint 20, Kein Bild.
« Antwort #1 am: 28.06.2020, 12:23:16 »
Vielleicht abwarten, bis LM 20 hier erscheint.

Re: Linux Mint 20, Kein Bild.
« Antwort #2 am: 28.06.2020, 12:26:34 »
Erst mal LM-19.3 verwenden, wenn es damit keine Probleme gab.

Re: Linux Mint 20, Kein Bild.
« Antwort #3 am: 28.06.2020, 12:27:36 »
Vielleicht abwarten, bis LM 20 hier erscheint.

es ist heute offiziell erschienen...

Re: Linux Mint 20, Kein Bild.
« Antwort #4 am: 28.06.2020, 12:57:17 »
Lag am Nouveau Treiber.
Hab einfach den Nvidia Treiber installiert.

Re: Linux Mint 20, Kein Bild.
« Antwort #5 am: 04.07.2020, 10:30:29 »
@nexxus86

Hallo,
ich habe das gleiche Problem.
Das Livesystem kann ich nur abgesichert laden.
Wie bist du vorgegangen?
Im abgesicherten Livesystem mit dem Treibermanager auf den Nvidia-Treiber gewechselt?
Hat das über einen Reboot bestand?

Gruß Peter

Re: Linux Mint 20, Kein Bild.
« Antwort #6 am: 04.07.2020, 10:37:03 »
Im abgesicherten Livesystem mit dem Treibermanager auf den Nvidia-Treiber gewechselt?
Hat das über einen Reboot bestand?
Nein, im Livesystem kannst du nichts installieren, das musst du im installierten System machen.

Re: Linux Mint 20, Kein Bild.
« Antwort #7 am: 04.07.2020, 11:22:53 »
vor dem booten des Livesystems "e" drücken.
nomodeset am ende der Kernelparameter eingeben
Mit F10 booten.

Mint installieren.

dann beim Erstboot dasselbe nochmal für das Festinstallierte system.
Er wird melden dass der Grafiktreiber im Savemode ist bzw garnicht installiert ist.

Dann unter Treiber einfach den aktuellsten offiziellen Nvidia Treiber installieren (nicht den Nouveau!)

Dann normal neustarten ohne den nomodeset parameter.

Danach läufts, aber bin mit dem Compositor noch nicht zufrieden, Fenster ruckeln manchmal beim verschieben.
Cinnamon ist finde ich eine schlechte Wahl bei Nvidia Karten, Gnome 3 sollte da die bessere Wahl sein
« Letzte Änderung: 04.07.2020, 11:27:35 von nexxus86 »

Re: Linux Mint 20, Kein Bild.
« Antwort #8 am: 04.07.2020, 13:06:33 »
Danke für die raschen Antworten.
@toffifee - Das habe ich mir schon gedacht. Kann aber nur abgesichert booten und von dort installieren. Habe dann aber das Grafik-Problem und kann nichts ändern, weil ich nichts sehe.

@nexxus86 - Vielen Dank. Das hört sich vielversprechend an.
Nach dem "e" bekomme ich:

GNU GRUB  version 2.04
setparams  'Start Linux Mint 20Cinnamon 64-bit'
set gfxpayload=keep
linux    /casper/vmlinutz  file=cdrom/preseed/linuxmint.seed boot=casper iso-scan/filename=${iso_path} quiet splash --
initrd   /casper/initrd.lz

wo gebe ich nun "nomodeset" ein? Hinter ...splash --   oder hinter  ...initrd.lz?

Oder habe ich etwas falsch verstanden?

EDIT:
Ich muss wohl einfach eine neue Kommandozeile mit "nomodeset" eingeben.
Richtig?

EDIT:
Sorry. Ich glaube, ich habe es gefunden.
Ich muss quiet splash durch nomodeset ersetzen.

Ist das richtig?




« Letzte Änderung: 04.07.2020, 13:23:05 von Peter1956 »

Re: Linux Mint 20, Kein Bild.
« Antwort #9 am: Gestern um 11:23:31 »
Ich habe es geschafft!
Vielen Dank noch einmal für deine Hilfe nexxus86.

Eine Hürde musste ich noch nehmen.
Da ich LM20 als einziges Betriebssystem installiert habe, erscheint natürlich kein Bootmenü, wie beim booten des Livesystems.
Eine Bootmeldung erscheint bei mir auch nicht. LM startete und fuhr natürlich mit dem Nouveau-Treiber hoch und Ende!

Also noch einmal von vorn und neu installiert.
Dann beim boot des installieren Systems die (bei mir) Esc-Taste drücken, um in das Bootmenü zu gelangen.
Dann, wie von dir beschrieben, e drücken, "quiet splash" gegen "nomodeset" ersetzen und mit F10 booten,
den Treiber ändern und gut ist es.

Für mich ist das Thema gelöst.
Da ich mich aber frecherweise hier eingehängt habe, will ich das Thema nicht auf "gelöst" setzen.

Vielen Dank für die freundliche Hilfe

Gruß
Peter