Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
10.07.2020, 14:01:06

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24247
  • Letzte: tschirn
Statistiken
  • Beiträge insgesamt: 669801
  • Themen insgesamt: 54258
  • Heute online: 451
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  Chromium-Browser lässt sich nicht mehr installieren  (Gelesen 398 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Chromium-Browser lässt sich nicht mehr installieren
« am: 01.06.2020, 13:05:40 »
Liebe Linux Mint Gemeinde
mein System Linux Mint 18 Mate 64-bit.

Bei einer Deinstallation von Chromium-Browser vor ein paar Tagen blieb die Anwendungsverwaltung hängen und ich habe nach ca 10 min abgebrochen.

Nun brauche ich nächste Woche doch nochmals Chromium-Browser und wollte es wieder installieren.

(Da ich es für eine Videokonferenz mit Jitsi brauche, mit Chromium-Browser läuft Jitsi recht stabil.)

Doch das geht nun nicht mehr, da die Deinstallation missglückt ist.

Siehe Bild im Anhang.

sudo apt-get remove chromium

Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paket »chromium« ist nicht installiert, wird also auch nicht entfernt.
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 5 nicht aktualisiert.

Das liefert keinen Erfolg.

Kann mir jemand helfen?
« Letzte Änderung: 01.06.2020, 18:30:09 von Knurps »

Re: Chromium lässt sich nicht mehr installieren
« Antwort #1 am: 01.06.2020, 13:39:15 »
Die 3 mal im Terminal:
apt autoremoveapt install -fsudo dpkg --configure -aDanach nochmal versuchen zu installieren.

Re: Chromium lässt sich nicht mehr installieren
« Antwort #2 am: 01.06.2020, 14:02:24 »
Hallo toffifee,
hat leider nichts genützt. Gleiche Meldung wie im Bild im Anhang oben.

~ $ apt autoremove

Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 5 nicht aktualisiert.
 ~ $ apt install -f
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 5 nicht aktualisiert.

bei
 sudo dpkg --configure -a
scheint gar nichts zu passieren.


Ich habe eine Anleitung mit force gefunden, traue mich jedoch nicht!
https://www.schnatterente.net/software/apt-get-dpkg-kaputte-pakete-zwangs-entfernen

Ist das die richtige Methode wenn alles andere versagt?
# dpkg --remove --force-remove-reinstreq <package>

Oder macht das womöglich nich mehr kaputt??


Re: Chromium lässt sich nicht mehr installieren
« Antwort #3 am: 01.06.2020, 14:37:22 »
Sollte eigentlich nichts passieren.

Re: Chromium lässt sich nicht mehr installieren
« Antwort #4 am: 01.06.2020, 15:00:23 »
Hi :)
das es sich um
cromium-browser
dreht ist aufgefallen?

Re: Chromium-Browser lässt sich nicht mehr installieren
« Antwort #5 am: 01.06.2020, 15:14:31 »
Äh, ja das habe ich jetzt noch ergänzt, ich dachte das ist das einzige Programm das so heißt.
 :) ::)

Re: Chromium-Browser lässt sich nicht mehr installieren
« Antwort #6 am: 01.06.2020, 15:16:07 »
Hi :)
prima, dann solltest du das paket auch bearbeiten ;)

Re: Chromium-Browser lässt sich nicht mehr installieren
« Antwort #7 am: 01.06.2020, 15:28:30 »
Ja klar hab mich verschrieben;-)
Also das hier funktioniert nicht:
sudo apt-get --purge remove chromium-browser
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Die folgenden Pakete werden ENTFERNT:
  chromium-browser*
0 aktualisiert, 0 neu installiert, 1 zu entfernen und 5 nicht aktualisiert.
Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n] j
(Lese Datenbank ... 235111 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von chromium-browser (81.0.4044.138-0ubuntu0.16.04.1) ...
Löschen der Konfigurationsdateien von chromium-browser (81.0.4044.138-0ubuntu0.16.04.1) ...

Wenn ich danach über die Anwendungsverwaltung installieren versuche immer die selbe Fehlermeldung.
Traceback (most recent call last):
  File "/usr/lib/linuxmint/mintinstall/AptClient/AptClient.py", line 74, in _run
    cache.commit(acquire_progress_monitor, install_progress_monitor)
  File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 612, in commit
    raise SystemError("installArchives() failed")
SystemError: installArchives() failed

Siehe Bild oben!


Und bei Installationsversuch übers Terminal kommt das:
sudo apt-get install chromium-browser
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Vorgeschlagene Pakete:
  webaccounts-chromium-extension unity-chromium-extension
Empfohlene Pakete:
  chromium-browser-l10n
Die folgenden NEUEN Pakete werden installiert:
  chromium-browser
0 aktualisiert, 1 neu installiert, 0 zu entfernen und 5 nicht aktualisiert.
Es müssen noch 0 B von 63,9 MB an Archiven heruntergeladen werden.
Nach dieser Operation werden 229 MB Plattenplatz zusätzlich benutzt.
(Lese Datenbank ... 235109 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../chromium-browser_81.0.4044.138-0ubuntu0.16.04.1_amd64.deb ...
Entpacken von chromium-browser (81.0.4044.138-0ubuntu0.16.04.1) ...
dpkg-deb (Unterprozess): Archiv-Element wird dekomprimiert: lzma-Fehler: komprimierte Daten sind beschädigt
dpkg-deb: Fehler: Unterprozess <Dekompression> gab den Fehlerwert 2 zurück
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/chromium-browser_81.0.4044.138-0ubuntu0.16.04.1_amd64.deb (--unpack):
 Unterprozess dpkg-deb --fsys-tarfile gab den Fehlerwert 2 zurück
Trigger für man-db (2.7.5-1) werden verarbeitet ...
Trigger für desktop-file-utils (0.22-1ubuntu5.2) werden verarbeitet ...
Trigger für mime-support (3.59ubuntu1) werden verarbeitet ...
Trigger für hicolor-icon-theme (0.15-0ubuntu1.1) werden verarbeitet ...
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/chromium-browser_81.0.4044.138-0ubuntu0.16.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

klappt auch nicht.


Hat noch jemand eine Idee?
« Letzte Änderung: 01.06.2020, 15:33:05 von Knurps »

Re: Chromium-Browser lässt sich nicht mehr installieren
« Antwort #8 am: 01.06.2020, 15:34:42 »
noch vergessen:

das hier bringt auch nichts:

sudo dpkg --remove --force-remove-reinstreq chromium-browser
dpkg: Warnung: Die Anforderung, chromium-browser zu entfernen, wird ignoriert; es ist nicht installiert



Re: Chromium-Browser lässt sich nicht mehr installieren
« Antwort #9 am: 01.06.2020, 15:49:05 »
Und so?
apt clean
apt update
apt install chromium-browser

Re: Chromium-Browser lässt sich nicht mehr installieren
« Antwort #10 am: 01.06.2020, 16:41:46 »
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/chromium-browser_81.0.4044.138-0ubuntu0.16.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Probier mal, das Paket zu löschen
sudo rm /var/cache/apt/archives/chromium-browser_81.0.4044.138-0ubuntu0.16.04.1_amd64.deb
sudo apt autoremove
sudo apt clean
dann die Paketliste aktualisieren
sudo apt updateAbhängigkeiten korrigieren
sudo apt install -fund wenn alle Befehle ohne Fehlermeldungen durchlaufen, erst dann den Browser wieder installieren
sudo apt install chromium-browser

Re: Chromium-Browser lässt sich nicht mehr installieren
« Antwort #11 am: 01.06.2020, 18:29:57 »
Hallo janek-m

SUPER  :D es hat mit Deiner Anleitung geklappt

vielen herzlichen Dank, hipey!! ;D

rm und dann apt update

man lernt immer wieder dazu...

Danke an Euch alle, die Ihr Euch beteiligt habt, immer wieder schön zu sehen, was das hier für eine tolle Community ist!

Re: Chromium lässt sich nicht mehr installieren
« Antwort #12 am: 01.06.2020, 20:10:11 »
… Ist das die richtige Methode wenn alles andere versagt?
# dpkg --remove --force-remove-reinstreq <package>
Nein, „reinstreq“ steht für reinstallation required, d. h. die Paketverwaltung meldet von sich aus bswp.
Zitat
E: Das Paket xxx muss neu installiert werden, es kann jedoch kein Archiv dafür gefunden werden.
Dann kann man es neu installieren. Entfernen lässt es sich jedoch nur mit synatpic oder im Terminal mit diesem Schalter, aber ansonsten ist der unwirksam.